Patch for Test 8 segfault
This commit is contained in:
parent
5101607320
commit
3ad49b7a23
7
fmt.spec
7
fmt.spec
@ -1,6 +1,6 @@
|
|||||||
Name: fmt
|
Name: fmt
|
||||||
Version: 3.0.2
|
Version: 3.0.2
|
||||||
Release: 3%{?dist}
|
Release: 4%{?dist}
|
||||||
Summary: Small, safe and fast formatting library for C++
|
Summary: Small, safe and fast formatting library for C++
|
||||||
|
|
||||||
License: BSD
|
License: BSD
|
||||||
@ -8,6 +8,8 @@ URL: https://github.com/fmtlib/fmt
|
|||||||
Source0: https://github.com/fmtlib/fmt/archive/%{version}.tar.gz#/%{name}-%{version}.tar.gz
|
Source0: https://github.com/fmtlib/fmt/archive/%{version}.tar.gz#/%{name}-%{version}.tar.gz
|
||||||
# See https://github.com/fmtlib/fmt/issues/443 and https://lists.fedoraproject.org/archives/list/devel@lists.fedoraproject.org/message/LVKYLDLJVWAVJE4MQVKDO6PYZRD5MCP6/
|
# See https://github.com/fmtlib/fmt/issues/443 and https://lists.fedoraproject.org/archives/list/devel@lists.fedoraproject.org/message/LVKYLDLJVWAVJE4MQVKDO6PYZRD5MCP6/
|
||||||
Patch0: fmt_build_doc_system.patch
|
Patch0: fmt_build_doc_system.patch
|
||||||
|
# See https://github.com/fmtlib/fmt/issues/551
|
||||||
|
Patch1: fmt_test8_segfault.patch
|
||||||
|
|
||||||
%if 0%{?rhel}
|
%if 0%{?rhel}
|
||||||
BuildRequires: cmake3
|
BuildRequires: cmake3
|
||||||
@ -114,6 +116,9 @@ make -C build test
|
|||||||
%postun -p /sbin/ldconfig
|
%postun -p /sbin/ldconfig
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Aug 09 2017 Dave Johansen <davejohansen@gmail.com> - 3.0.2-4
|
||||||
|
- Patch for Test 8 segfault
|
||||||
|
|
||||||
* Wed Aug 02 2017 Fedora Release Engineering <releng@fedoraproject.org> - 3.0.2-3
|
* Wed Aug 02 2017 Fedora Release Engineering <releng@fedoraproject.org> - 3.0.2-3
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
|
||||||
|
|
||||||
|
23
fmt_test8_segfault.patch
Normal file
23
fmt_test8_segfault.patch
Normal file
@ -0,0 +1,23 @@
|
|||||||
|
From 6655e804c49f66b6c978fcdd01ef6b03b55208fa Mon Sep 17 00:00:00 2001
|
||||||
|
From: Victor Zverovich <victor.zverovich@gmail.com>
|
||||||
|
Date: Sun, 6 Aug 2017 20:18:04 -0700
|
||||||
|
Subject: [PATCH] Fix a segfault in test on glibc 2.26 #551
|
||||||
|
NOTE: Added ::internal so it would apply - DLJ
|
||||||
|
|
||||||
|
---
|
||||||
|
test/util-test.cc | 2 +-
|
||||||
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||||
|
|
||||||
|
diff --git a/test/util-test.cc b/test/util-test.cc
|
||||||
|
index a3882558..6cef7e81 100644
|
||||||
|
--- a/test/util-test.cc
|
||||||
|
+++ b/test/util-test.cc
|
||||||
|
@@ -838,7 +838,7 @@ TEST(UtilTest, FormatSystemError) {
|
||||||
|
EXPECT_EQ(fmt::format("test: {}", get_system_error(EDOM)), message.str());
|
||||||
|
message.clear();
|
||||||
|
fmt::internal::format_system_error(
|
||||||
|
- message, EDOM, fmt::StringRef(0, std::numeric_limits<size_t>::max()));
|
||||||
|
+ message, EDOM, fmt::StringRef(0, std::numeric_limits<ssize_t>::max()));
|
||||||
|
EXPECT_EQ(fmt::format("error {}", EDOM), message.str());
|
||||||
|
}
|
||||||
|
|
Loading…
Reference in New Issue
Block a user