Updated to version 6.2.0.
This commit is contained in:
parent
17f87c6afe
commit
160267329e
1
.gitignore
vendored
1
.gitignore
vendored
@ -5,3 +5,4 @@
|
||||
/5.2.1.tar.gz
|
||||
/5.3.0.tar.gz
|
||||
/6.1.2.tar.gz
|
||||
/6.2.0.tar.gz
|
||||
|
@ -20,5 +20,5 @@ index d5f4b70d..8ff160de 100644
|
||||
|
||||
{%- macro searchform(classes, button) %}
|
||||
--
|
||||
2.24.1
|
||||
2.25.1
|
||||
|
||||
|
@ -45,5 +45,5 @@ index 8ff160de..85eba08d 100644
|
||||
</div>
|
||||
{% endif %}
|
||||
--
|
||||
2.24.1
|
||||
2.25.1
|
||||
|
||||
|
@ -1,10 +1,10 @@
|
||||
diff --git a/doc/build.py b/doc/build.py
|
||||
index f46d483e..517d9f39 100755
|
||||
index 7df640bb..89af3fa7 100755
|
||||
--- a/doc/build.py
|
||||
+++ b/doc/build.py
|
||||
@@ -7,16 +7,6 @@ from subprocess import check_call, check_output, CalledProcessError, Popen, PIPE
|
||||
|
||||
versions = ['1.0.0', '1.1.0', '2.0.0', '3.0.2', '4.0.0', '4.1.0', '5.0.0', '5.1.0', '5.2.0', '5.2.1', '5.3.0', '6.0.0', '6.1.0', '6.1.1', '6.1.2']
|
||||
versions = ['1.0.0', '1.1.0', '2.0.0', '3.0.2', '4.0.0', '4.1.0', '5.0.0', '5.1.0', '5.2.0', '5.2.1', '5.3.0', '6.0.0', '6.1.0', '6.1.1', '6.1.2', '6.2.0']
|
||||
|
||||
-def create_build_env(dirname='virtualenv'):
|
||||
- # Create virtualenv.
|
||||
@ -26,5 +26,5 @@ index f46d483e..517d9f39 100755
|
||||
- create_build_env()
|
||||
build_docs(sys.argv[1])
|
||||
--
|
||||
2.24.1
|
||||
2.25.1
|
||||
|
||||
|
@ -1,5 +1,5 @@
|
||||
diff --git a/doc/build.py b/doc/build.py
|
||||
index 31049716..f46d483e 100755
|
||||
index a7bfcf73..7df640bb 100755
|
||||
--- a/doc/build.py
|
||||
+++ b/doc/build.py
|
||||
@@ -4,27 +4,9 @@
|
||||
@ -8,7 +8,7 @@ index 31049716..f46d483e 100755
|
||||
from subprocess import check_call, check_output, CalledProcessError, Popen, PIPE
|
||||
-from distutils.version import LooseVersion
|
||||
|
||||
versions = ['1.0.0', '1.1.0', '2.0.0', '3.0.2', '4.0.0', '4.1.0', '5.0.0', '5.1.0', '5.2.0', '5.2.1', '5.3.0', '6.0.0', '6.1.0', '6.1.1', '6.1.2']
|
||||
versions = ['1.0.0', '1.1.0', '2.0.0', '3.0.2', '4.0.0', '4.1.0', '5.0.0', '5.1.0', '5.2.0', '5.2.1', '5.3.0', '6.0.0', '6.1.0', '6.1.1', '6.1.2', '6.2.0']
|
||||
|
||||
-def pip_install(package, commit=None, **kwargs):
|
||||
- "Install package using pip."
|
||||
@ -62,5 +62,5 @@ index 31049716..f46d483e 100755
|
||||
def build_docs(version='dev', **kwargs):
|
||||
doc_dir = kwargs.get('doc_dir', os.path.dirname(os.path.realpath(__file__)))
|
||||
--
|
||||
2.24.1
|
||||
2.25.1
|
||||
|
||||
|
@ -18,5 +18,5 @@ index 2af32d53..0ad2d602 100644
|
||||
|
||||
install(DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}/html/
|
||||
--
|
||||
2.24.1
|
||||
2.25.1
|
||||
|
||||
|
@ -16,7 +16,7 @@ index f3dae606..2af32d53 100644
|
||||
|
||||
install(DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}/html/
|
||||
diff --git a/doc/build.py b/doc/build.py
|
||||
index 517d9f39..2c80ed5a 100755
|
||||
index 89af3fa7..88d26ec7 100755
|
||||
--- a/doc/build.py
|
||||
+++ b/doc/build.py
|
||||
@@ -49,7 +49,8 @@ def build_docs(version='dev', **kwargs):
|
||||
@ -30,5 +30,5 @@ index 517d9f39..2c80ed5a 100755
|
||||
'-Dversion=' + version, '-Drelease=' + version,
|
||||
'-Aversion=' + version, '-Aversions=' + ','.join(main_versions),
|
||||
--
|
||||
2.24.1
|
||||
2.25.1
|
||||
|
||||
|
@ -1,5 +1,5 @@
|
||||
diff --git a/doc/index.rst b/doc/index.rst
|
||||
index cbc9154d..b1782c3d 100644
|
||||
index d02ab0b0..a4d113d8 100644
|
||||
--- a/doc/index.rst
|
||||
+++ b/doc/index.rst
|
||||
@@ -191,12 +191,3 @@ Ease of Use
|
||||
@ -16,5 +16,5 @@ index cbc9154d..b1782c3d 100644
|
||||
- class="github-btn" width="100" height="20"></iframe>
|
||||
- </div>
|
||||
--
|
||||
2.24.1
|
||||
2.25.1
|
||||
|
||||
|
11
fmt.spec
11
fmt.spec
@ -1,11 +1,11 @@
|
||||
Name: fmt
|
||||
Version: 6.1.2
|
||||
Release: 2%{?dist}
|
||||
Version: 6.2.0
|
||||
Release: 1%{?dist}
|
||||
Summary: Small, safe and fast formatting library for C++
|
||||
|
||||
License: BSD
|
||||
URL: https://github.com/fmtlib/fmt
|
||||
Source0: https://github.com/fmtlib/fmt/archive/%{version}.tar.gz
|
||||
URL: https://github.com/fmtlib/%{name}
|
||||
Source0: %{url}/archive/%{version}.tar.gz
|
||||
# See https://github.com/fmtlib/fmt/issues/443 and https://lists.fedoraproject.org/archives/list/devel@lists.fedoraproject.org/message/LVKYLDLJVWAVJE4MQVKDO6PYZRD5MCP6/
|
||||
Patch1: doc-build-removed-all-pip-internet-stuff.patch
|
||||
Patch3: doc-build-do-not-create-virtual-environment.patch
|
||||
@ -110,6 +110,9 @@ popd
|
||||
%license doc/python-license.txt
|
||||
|
||||
%changelog
|
||||
* Mon Apr 06 2020 Vitaly Zaitsev <vitaly@easycoding.org> - 6.2.0-1
|
||||
- Updated to version 6.2.0.
|
||||
|
||||
* Tue Jan 28 2020 Fedora Release Engineering <releng@fedoraproject.org> - 6.1.2-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (6.1.2.tar.gz) = 8770bf4bd2bb6d938e75e0cf1e665c41930dbd9d2a6825274a5a43cd1d85b9c9ca621bb040ed099429f0e16bddbc3399361c453eb1bf3fc01376e6ad9dd875b7
|
||||
SHA512 (6.2.0.tar.gz) = 0003543f437bae416600a2b982eb133f65588bd36d7506fa7d883ae3133fcaf7ad825904af9b588ea22e5d91e56560aaf4243a6afa11ff6d8aace2e4bb1b0cee
|
||||
|
Loading…
Reference in New Issue
Block a user