1.3.6
Resolves: bz#1976712
This commit is contained in:
parent
089ff53023
commit
cf8d49388e
1
.gitignore
vendored
1
.gitignore
vendored
@ -1,2 +1,3 @@
|
||||
/fltk-1.3.4-1-source.tar.gz
|
||||
/fltk-1.3.5-source.tar.gz
|
||||
/fltk-1.3.6-source.tar.gz
|
||||
|
@ -1,7 +1,8 @@
|
||||
diff -up fltk-1.3.4-1/fltk-config.in.fltk_config fltk-1.3.4-1/fltk-config.in
|
||||
--- fltk-1.3.4-1/fltk-config.in.fltk_config 2016-01-30 20:49:56.000000000 -0600
|
||||
+++ fltk-1.3.4-1/fltk-config.in 2017-03-04 12:29:28.910316677 -0600
|
||||
@@ -44,8 +44,8 @@ CXX="@CXX@"
|
||||
Index: fltk-1.3.6/fltk-config.in
|
||||
===================================================================
|
||||
--- fltk-1.3.6.orig/fltk-config.in
|
||||
+++ fltk-1.3.6/fltk-config.in
|
||||
@@ -42,8 +42,8 @@ CXX="@CXX@"
|
||||
|
||||
# flags for C++ compiler:
|
||||
ARCHFLAGS="@ARCHFLAGS@"
|
||||
@ -12,7 +13,7 @@ diff -up fltk-1.3.4-1/fltk-config.in.fltk_config fltk-1.3.4-1/fltk-config.in
|
||||
LDFLAGS="@LDFLAGS@"
|
||||
LDLIBS="@LIBS@"
|
||||
OPTIM="@OPTIM@"
|
||||
@@ -228,7 +228,7 @@ if test "$BINARY_DIR" != ""; then
|
||||
@@ -226,7 +226,7 @@ if test "$BINARY_DIR" != ""; then
|
||||
includes="-I$BINARY_DIR $includes"
|
||||
fi
|
||||
|
||||
@ -21,7 +22,7 @@ diff -up fltk-1.3.4-1/fltk-config.in.fltk_config fltk-1.3.4-1/fltk-config.in
|
||||
libs=-L$libdir
|
||||
else
|
||||
libs=
|
||||
@@ -236,28 +236,28 @@ fi
|
||||
@@ -234,23 +234,23 @@ fi
|
||||
|
||||
# Calculate needed libraries
|
||||
LDSTATIC="$libdir/libfltk.a $LDLIBS"
|
||||
@ -33,9 +34,9 @@ diff -up fltk-1.3.4-1/fltk-config.in.fltk_config fltk-1.3.4-1/fltk-config.in
|
||||
LDSTATIC="$libdir/libfltk_forms.a $LDSTATIC"
|
||||
fi
|
||||
if test x$use_gl = xyes; then
|
||||
- LDLIBS="-lfltk_gl$SHAREDSUFFIX @GLLIB@ $LDLIBS"
|
||||
- LDLIBS="-lfltk_gl$SHAREDSUFFIX @GLLIBS@ $LDLIBS"
|
||||
+ LDLIBS="-lfltk_gl$SHAREDSUFFIX $LDLIBS"
|
||||
LDSTATIC="$libdir/libfltk_gl.a @GLLIB@ $LDSTATIC"
|
||||
LDSTATIC="$libdir/libfltk_gl.a @GLLIBS@ $LDSTATIC"
|
||||
fi
|
||||
if test x$use_images = xyes; then
|
||||
- LDLIBS="-lfltk_images$SHAREDSUFFIX $IMAGELIBS $LDLIBS"
|
||||
@ -49,10 +50,3 @@ diff -up fltk-1.3.4-1/fltk-config.in.fltk_config fltk-1.3.4-1/fltk-config.in
|
||||
LDSTATIC="$libdir/libfltk_cairo.a $CAIROLIBS $LDSTATIC"
|
||||
fi
|
||||
|
||||
-LDLIBS="$DSOLINK $LDFLAGS $libs $LDLIBS"
|
||||
-LDSTATIC="$LDFLAGS $LDSTATIC"
|
||||
+LDLIBS="$libs $LDLIBS"
|
||||
+#LDSTATIC="$LDFLAGS $LDSTATIC"
|
||||
|
||||
# Answer to user requests
|
||||
if test -n "$echo_help"; then
|
||||
|
@ -1,26 +1,13 @@
|
||||
Index: fltk-1.3.5/CMake/macros.cmake
|
||||
Index: fltk-1.3.6/CMake/setup.cmake
|
||||
===================================================================
|
||||
--- fltk-1.3.5.orig/CMake/macros.cmake
|
||||
+++ fltk-1.3.5/CMake/macros.cmake
|
||||
@@ -38,7 +38,7 @@ macro(FL_ADD_LIBRARY LIBNAME LIBTYPE LIB
|
||||
|
||||
set_target_properties(${LIBRARY_NAME}
|
||||
PROPERTIES
|
||||
- OUTPUT_NAME ${LIBRARY_NAME}
|
||||
+ OUTPUT_NAME ${LIBNAME}
|
||||
DEBUG_OUTPUT_NAME ${LIBRARY_NAME_DEBUG}
|
||||
CLEAN_DIRECT_OUTPUT TRUE
|
||||
COMPILE_DEFINITIONS "FL_LIBRARY"
|
||||
Index: fltk-1.3.5/CMake/setup.cmake
|
||||
===================================================================
|
||||
--- fltk-1.3.5.orig/CMake/setup.cmake
|
||||
+++ fltk-1.3.5/CMake/setup.cmake
|
||||
@@ -85,7 +85,7 @@ if(WIN32 AND NOT CYGWIN)
|
||||
elseif(APPLE AND NOT OPTION_APPLE_X11)
|
||||
set(FLTK_CONFIG_PATH FLTK/.framework/Resources/CMake)
|
||||
else()
|
||||
- set(FLTK_CONFIG_PATH ${FLTK_DATADIR}/fltk)
|
||||
+ set(FLTK_CONFIG_PATH ${FLTK_DATADIR}/fltk CACHE FILEPATH "Install location for cmake files.")
|
||||
endif(WIN32 AND NOT CYGWIN)
|
||||
--- fltk-1.3.6.orig/CMake/setup.cmake
|
||||
+++ fltk-1.3.6/CMake/setup.cmake
|
||||
@@ -62,7 +62,7 @@ if (WIN32 AND NOT CYGWIN)
|
||||
elseif (APPLE AND NOT OPTION_APPLE_X11)
|
||||
set (FLTK_CONFIG_PATH FLTK.framework/Resources/CMake)
|
||||
else ()
|
||||
- set (FLTK_CONFIG_PATH ${FLTK_DATADIR}/fltk)
|
||||
+ set (FLTK_CONFIG_PATH ${FLTK_DATADIR}/fltk CACHE FILEPATH "Install location for cmake files.")
|
||||
endif (WIN32 AND NOT CYGWIN)
|
||||
|
||||
include(TestBigEndian)
|
||||
|
16
fltk.spec
16
fltk.spec
@ -5,8 +5,8 @@
|
||||
|
||||
Summary: C++ user interface toolkit
|
||||
Name: fltk
|
||||
Version: 1.3.5
|
||||
Release: 11%{?dist}
|
||||
Version: 1.3.6
|
||||
Release: 1%{?dist}
|
||||
|
||||
# see COPYING (or http://www.fltk.org/COPYING.php ) for exceptions details
|
||||
License: LGPLv2+ with exceptions
|
||||
@ -31,7 +31,7 @@ BuildRequires: doxygen
|
||||
BuildRequires: texlive-latex
|
||||
# fltk bug with pdf generation, investigate later
|
||||
#BuildRequires: texlive-epstopdf
|
||||
BuildRequires: libjpeg-devel
|
||||
BuildRequires: pkgconfig(libjpeg)
|
||||
BuildRequires: pkgconfig(libpng)
|
||||
BuildRequires: pkgconfig(gl) pkgconfig(glu)
|
||||
BuildRequires: pkgconfig(ice)
|
||||
@ -39,7 +39,7 @@ BuildRequires: pkgconfig(sm)
|
||||
BuildRequires: pkgconfig(xext) pkgconfig(xinerama) pkgconfig(xft) pkgconfig(xt) pkgconfig(x11)
|
||||
BuildRequires: pkgconfig(xcursor)
|
||||
BuildRequires: pkgconfig(xproto)
|
||||
BuildRequires: zlib-devel
|
||||
BuildRequires: pkgconfig(zlib)
|
||||
BuildRequires: make
|
||||
|
||||
%description
|
||||
@ -52,9 +52,13 @@ It provides modern GUI functionality without the bloat, and supports
|
||||
Summary: Development files for %{name}
|
||||
Requires: %{name}%{?_isa} = %{version}-%{release}
|
||||
Requires: libstdc++-devel
|
||||
Requires: pkgconfig(fontconfig)
|
||||
Requires: pkgconfig(gl) pkgconfig(glu)
|
||||
Requires: pkgconfig(ice) pkgconfig(sm)
|
||||
Requires: pkgconfig(xft) pkgconfig(xt) pkgconfig(x11)
|
||||
Requires: pkgconfig(libjpeg)
|
||||
Requires: pkgconfig(libpng)
|
||||
Requires: pkgconfig(zlib)
|
||||
%description devel
|
||||
%{summary}.
|
||||
|
||||
@ -147,6 +151,10 @@ desktop-file-validate $RPM_BUILD_ROOT%{_datadir}/applications/fluid.desktop
|
||||
|
||||
|
||||
%changelog
|
||||
* Tue Jun 29 2021 Jan Grulich <jgrulich@redhat.com> - 1.3.6-1
|
||||
- 1.3.6
|
||||
Resolves: bz#1976712
|
||||
|
||||
* Thu Apr 15 2021 Mohan Boddu <mboddu@redhat.com> - 1.3.5-11
|
||||
- Rebuilt for RHEL 9 BETA on Apr 15th 2021. Related: rhbz#1947937
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (fltk-1.3.5-source.tar.gz) = db7ea7c5f3489195a48216037b9371a50f1119ae7692d66f71b6711e5ccf78814670581bae015e408dee15c4bba921728309372c1cffc90113cdc092e8540821
|
||||
SHA512 (fltk-1.3.6-source.tar.gz) = 7231cb733105e7b48ddd63aaa9fda241a625d8635615b331c63da2670dbef13da659fb4895111d2036c5fe5e7b0459873f6dccda4ef00f10c9f1a1d56c3615ba
|
||||
|
Loading…
Reference in New Issue
Block a user