- fltk-1.1.x-r5750 snapshot (1.1.8 pre-release)

- --enable-xinerama
- patch for undefined symbols in libfltk_gl
This commit is contained in:
Rex Dieter 2007-04-05 13:14:13 +00:00
parent 1dc4a20fcb
commit a90c0912d6
6 changed files with 56 additions and 31 deletions

View File

@ -1,2 +1,3 @@
fltk-1.1.7-source.tar.bz2
fltk-1.1.x-r5555.tar.bz2
fltk-1.1.x-r5750.tar.bz2

View File

@ -1,16 +0,0 @@
--- fltk-config.in.config 2007-04-04 15:31:31.000000000 -0400
+++ fltk-config.in 2007-04-04 15:31:45.000000000 -0400
@@ -52,13 +52,6 @@
# post-process command (only needed for MacOS)
POSTBUILD="@POSTBUILD@"
-# flags for C++ compiler:
-ARCHFLAGS="@ARCHFLAGS@"
-CFLAGS="@CFLAGS@ @LARGEFILE@"
-CXXFLAGS="@CXXFLAGS@ @LARGEFILE@"
-LDFLAGS="@LDFLAGS@"
-LDLIBS="@LIBS@"
-
# Check for local invocation, and update paths accordingly...
if test -f "$selfdir/FL/Fl_Window.H"; then
bindir="$selfdir/fluid"

View File

@ -0,0 +1,17 @@
--- fltk-1.1.x-r5750/fltk-config.in.199656 2007-03-06 14:00:04.000000000 -0600
+++ fltk-1.1.x-r5750/fltk-config.in 2007-04-05 07:36:57.000000000 -0500
@@ -54,10 +54,10 @@
# flags for C++ compiler:
ARCHFLAGS="@ARCHFLAGS@"
-CFLAGS="@CFLAGS@ @LARGEFILE@ @PTHREAD_FLAGS@"
-CXXFLAGS="@CXXFLAGS@ @LARGEFILE@ @PTHREAD_FLAGS@"
-LDFLAGS="@LDFLAGS@"
-LDLIBS="@LIBS@"
+#CFLAGS="@CFLAGS@ @LARGEFILE@ @PTHREAD_FLAGS@"
+#CXXFLAGS="@CXXFLAGS@ @LARGEFILE@ @PTHREAD_FLAGS@"
+#LDFLAGS="@LDFLAGS@"
+#LDLIBS="@LIBS@"
OPTIM="@OPTIM@"
# Check for local invocation, and update paths accordingly...

View File

@ -0,0 +1,11 @@
--- fltk-1.1.x-r5750/src/Makefile.undefined 2007-02-10 08:31:12.000000000 -0600
+++ fltk-1.1.x-r5750/src/Makefile 2007-04-05 07:51:31.000000000 -0500
@@ -282,7 +282,7 @@
libfltk_gl.so.1.1: $(GLOBJECTS) libfltk.so.1.1
echo $(DSOCOMMAND) $@ ...
- $(DSOCOMMAND) $@ $(GLOBJECTS) -L. -lfltk
+ $(DSOCOMMAND) $@ $(GLOBJECTS) -L. $(GLDLIBS) -lfltk
$(RM) libfltk_gl.so
$(LN) libfltk_gl.so.1.1 libfltk_gl.so

View File

@ -1,30 +1,32 @@
%define snap r5555
%define snap r5750
#define _disable_static --disable-static
Summary: C++ user interface toolkit
Name: fltk
Version: 1.1.7
Release: 9.%{snap}%{?dist}
Version: 1.1.8
Release: 0.1.%{snap}%{?dist}
License: LGPL with exceptions
Group: System Environment/Libraries
URL: http://www.fltk.org/
%if "%{?snap:1}" == "1"
Source0: ftp://ftp.easysw.com/pub/fltk/snapshots/fltk-1.1.x-%{snap}.tar.bz2
Source0: ftp://ftp3.easysw.com/pub/fltk/snapshots/fltk-1.1.x-%{snap}.tar.bz2
%else
Source0: http://ftp.easysw.com/pub/fltk/%{version}/%{name}-%{version}-source.tar.bz2
Source0: http://ftp3.easysw.com/pub/fltk/%{version}/%{name}-%{version}-source.tar.bz2
%endif
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
# See http://bugzilla.redhat.com/199656
Patch1: fltk-1.1.7-config.patch
# omit extraneous bits from fltk-config --cflags|--libs (http://bugzilla.redhat.com/199656)
Patch1: fltk-1.1.x-r5750-199656.patch
Patch2: fltk-1.1.7-test.patch
# libfltk_gl.so had undefined symbols
Patch3: fltk-1.1.x-r5750-undefined.patch
%if 0%{?rhel} > 4 || 0%{?fedora} > 4
BuildRequires: libICE-devel libSM-devel
BuildRequires: libXext-devel libXft-devel libXt-devel libX11-devel
BuildRequires: xorg-x11-proto-devel
BuildRequires: libXext-devel libXinerama-devel libXft-devel libXt-devel libX11-devel
BuildRequires: xorg-x11-proto-devel xorg-x11-utils
%else
BuildRequires: xorg-x11-devel
%endif
@ -72,19 +74,24 @@ Requires: %{name}-devel = %{version}-%{release}
%setup -q
%endif
%patch1 -p0 -b .199656
%patch1 -p1 -b .199656
%patch2 -p1 -b .test
%patch3 -p1 -b .undefined
%build
export CPPFLAGS="$(pkg-config xft --cflags)"
export LDFLAGS="$(pkg-config xft --libs)"
# using --with-optim, so unset CFLAGS/CXXFLAGS
export CFLAGS=" "
export CXXFLAGS=" "
%configure \
%{?_disable_static} \
--with-optim="%{optflags}" \
--enable-shared \
--enable-threads \
--enable-xdbe \
--enable-xinerama \
--enable-xft
make %{?_smp_mflags}
@ -122,8 +129,8 @@ mv $RPM_BUILD_ROOT%{_docdir}/fltk __docs
## unpackaged files
# errant docs
rm -rf $RPM_BUILD_ROOT%{_mandir}/cat*
%if "%{?_disable_static:1}" == "1"
# static libs
%if "%{?_disable_static:1}" == "1"
rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.a
%endif
# omit examples/games:
@ -186,12 +193,17 @@ update-desktop-database >& /dev/null ||:
%{_bindir}/fluid
%{_mandir}/man1/fluid.1*
%{_datadir}/applications/*fluid.desktop
%{_datadir}/icons/hicolor/*/*/*
# FIXME
%{_datadir}/mimelnk/*/*.desktop
%{_datadir}/icons/hicolor/*/*/*
%changelog
* Thu Apr 05 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 1.1.8-0.1.r5750
- fltk-1.1.x-r5750 snapshot (1.1.8 pre-release)
- --enable-xinerama
- patch for undefined symbols in libfltk_gl
* Wed Apr 4 2007 Thomas Fitzsimmons <fitzsim@redhat.com> - 1.1.7-9.r5555
- Always apply fltk-config patch (#199656)
- Update fltk-1.1.7-config.patch

View File

@ -1 +1 @@
4dea63e0e947950b446f955555cd47c9 fltk-1.1.x-r5555.tar.bz2
aa00ebba4fdec4ebab2881537b7d626f fltk-1.1.x-r5750.tar.bz2