don't build static fluid binary, should fix ftbfs/dso probs

This commit is contained in:
Rex Dieter 2010-12-07 12:57:20 -06:00
parent 82bdac2cb4
commit 4d6fd9fc99
2 changed files with 15 additions and 0 deletions

View File

@ -0,0 +1,12 @@
diff -up fltk-1.1.10/fluid/Makefile.fluid_target fltk-1.1.10/fluid/Makefile
--- fltk-1.1.10/fluid/Makefile.fluid_target 2008-12-29 14:21:29.000000000 -0600
+++ fltk-1.1.10/fluid/Makefile 2010-12-07 12:54:32.836737792 -0600
@@ -52,7 +52,7 @@ OBJECTS = $(CPPFILES:.cxx=.o)
include ../makeinclude
-all: $(FLUID) fluid$(EXEEXT)
+all: $(FLUID)
fluid$(EXEEXT): $(OBJECTS) $(LIBNAME) $(FLLIBNAME) \
$(IMGLIBNAME)

View File

@ -31,6 +31,8 @@ Patch5: fltk-1.1.8-fluid_desktop.patch
Patch7: fltk-1.1.9-scandir.patch
# use output of `pkg-config xft --libs` instead of just -lXft
Patch8: fltk-1.1.10-pkgconfig_xft.patch
# only build the fluid binary we intend to install/use (ie, don't build both fluid, fluid-shared)
Patch9: fltk-1.1.10-fluid_target.patch
%if 0%{?rhel} > 4 || 0%{?fedora} > 4
BuildRequires: libICE-devel libSM-devel
@ -99,6 +101,7 @@ Requires: %{name}-devel = %{version}-%{release}
%patch7 -p1 -b .gcc44
%endif
%patch8 -p1 -b .pkgconfig_xft
%patch9 -p1 -b .fluid_target
# verbose build output
sed -i.silent '\,^.SILENT:,d' makeinclude.in