- *really* fix --rpath issue, using non-empty patch this time (#238284)
This commit is contained in:
parent
a100c37482
commit
1c01bd4480
@ -0,0 +1,30 @@
|
|||||||
|
--- fltk-1.1.x-r5750/configure.in.rpath 2007-02-10 15:21:02.000000000 -0600
|
||||||
|
+++ fltk-1.1.x-r5750/configure.in 2007-04-29 12:47:29.000000000 -0500
|
||||||
|
@@ -180,9 +180,9 @@
|
||||||
|
GLDSONAME="libfltk_gl.so.$FL_API_VERSION"
|
||||||
|
IMGDSONAME="libfltk_images.so.$FL_API_VERSION"
|
||||||
|
DSOCOMMAND="\$(CXX) \$(DSOFLAGS) -Wl,-soname,\$@ \$(LDLIBS) -shared -fPIC $DEBUGFLAG -o"
|
||||||
|
- if test "x$libdir" != "x/usr/lib"; then
|
||||||
|
- DSOLINK="-Wl,-rpath,$libdir"
|
||||||
|
- fi
|
||||||
|
+# if test "x$libdir" != "x/usr/lib"; then
|
||||||
|
+# DSOLINK="-Wl,-rpath,$libdir"
|
||||||
|
+# fi
|
||||||
|
;;
|
||||||
|
AIX*)
|
||||||
|
DSONAME="libfltk_s.a"
|
||||||
|
--- fltk-1.1.x-r5750/configure.rpath 2007-03-23 00:00:35.000000000 -0500
|
||||||
|
+++ fltk-1.1.x-r5750/configure 2007-04-29 12:47:59.000000000 -0500
|
||||||
|
@@ -1482,9 +1482,9 @@
|
||||||
|
GLDSONAME="libfltk_gl.so.$FL_API_VERSION"
|
||||||
|
IMGDSONAME="libfltk_images.so.$FL_API_VERSION"
|
||||||
|
DSOCOMMAND="\$(CXX) \$(DSOFLAGS) -Wl,-soname,\$@ \$(LDLIBS) -shared -fPIC $DEBUGFLAG -o"
|
||||||
|
- if test "x$libdir" != "x/usr/lib"; then
|
||||||
|
- DSOLINK="-Wl,-rpath,$libdir"
|
||||||
|
- fi
|
||||||
|
+# if test "x$libdir" != "x/usr/lib"; then
|
||||||
|
+# DSOLINK="-Wl,-rpath,$libdir"
|
||||||
|
+# fi
|
||||||
|
;;
|
||||||
|
AIX*)
|
||||||
|
DSONAME="libfltk_s.a"
|
@ -5,7 +5,7 @@
|
|||||||
Summary: C++ user interface toolkit
|
Summary: C++ user interface toolkit
|
||||||
Name: fltk
|
Name: fltk
|
||||||
Version: 1.1.8
|
Version: 1.1.8
|
||||||
Release: 0.2.%{snap}%{?dist}
|
Release: 0.3.%{snap}%{?dist}
|
||||||
|
|
||||||
License: LGPL with exceptions
|
License: LGPL with exceptions
|
||||||
Group: System Environment/Libraries
|
Group: System Environment/Libraries
|
||||||
@ -79,6 +79,7 @@ Requires: %{name}-devel = %{version}-%{release}
|
|||||||
%patch1 -p1 -b .199656
|
%patch1 -p1 -b .199656
|
||||||
%patch2 -p1 -b .test
|
%patch2 -p1 -b .test
|
||||||
%patch3 -p1 -b .undefined
|
%patch3 -p1 -b .undefined
|
||||||
|
%patch4 -p1 -b .rpath
|
||||||
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
@ -201,6 +202,9 @@ update-desktop-database >& /dev/null ||:
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Sun Apr 29 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 1.1.8-0.3.r5750
|
||||||
|
- *really* fix --rpath issue, using non-empty patch this time (#238284)
|
||||||
|
|
||||||
* Sun Apr 29 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 1.1.8-0.2.r5750
|
* Sun Apr 29 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 1.1.8-0.2.r5750
|
||||||
- nuke --rpath (#238284)
|
- nuke --rpath (#238284)
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user