Fix annocheck bind-now problems

Resolves: rhbz#2044859
This commit is contained in:
Matej Mužila 2022-02-15 13:50:54 +01:00
parent f1ad7eb654
commit 57841c1388
2 changed files with 24 additions and 2 deletions

View File

@ -0,0 +1,14 @@
diff -up flexiblas-3.0.4/CMakeLists.txt.annocheck flexiblas-3.0.4/CMakeLists.txt
--- flexiblas-3.0.4/CMakeLists.txt.annocheck 2020-10-22 11:07:48.000000000 +0200
+++ flexiblas-3.0.4/CMakeLists.txt 2022-02-15 09:50:29.971016074 +0100
@@ -177,6 +177,10 @@ SET ( CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS
SET(CMAKE_INSTALL_RPATH_USE_LINK_PATH TRUE)
+IF(DEFINED ENV{LDFLAGS})
+ SET(CMAKE_SHARED_LINKER_FLAGS "${CMAKE_SHARED_LINKER_FLAGS} $ENV{LDFLAGS}")
+ENDIF()
+
#
# Check Some files
#

View File

@ -16,7 +16,7 @@
Name: flexiblas
Version: %{major_version}.%{minor_version}.%{patch_version}
Release: 5%{?dist}
Release: 6%{?dist}
Summary: A BLAS/LAPACK wrapper library with runtime exchangeable backends
# GPLv3 with an exception for the BLAS/LAPACK interface
@ -27,6 +27,8 @@ License: GPLv3 with exceptions and LGPLv2+ and BSD
URL: https://www.mpi-magdeburg.mpg.de/projects/%{name}
Source0: https://csc.mpi-magdeburg.mpg.de/mpcsc/software/%{name}/%{name}-%{version}.tar.xz
Patch1: flexiblas-3.0.4-annocheck.patch
BuildRequires: make, cmake, python
BuildRequires: gcc-fortran, gcc-c++
%if %{with system_lapack}
@ -204,7 +206,9 @@ threading support with a 64-integer interface.
%endif
%prep
%autosetup -p1
%setup -q
%patch1 -p1 -b .annocheck
%build
%if %{with system_lapack}
@ -395,6 +399,10 @@ make -C build64 test
%endif
%changelog
* Tue Feb 15 2022 Matej Mužila <mmuzila@redhat.com> - 3.0.4-6
- Fix annocheck bind-now problems
Resolves: rhbz#2044859
* Mon Aug 09 2021 Mohan Boddu <mboddu@redhat.com> - 3.0.4-5
- Rebuilt for IMA sigs, glibc 2.34, aarch64 flags
Related: rhbz#1991688