Resolves: #1281976
- Rebase to flex-2.6.0 - Add a patch to fix yy_less_macro_arg types.
This commit is contained in:
parent
c3a70b341f
commit
ffdaf36582
1
.gitignore
vendored
1
.gitignore
vendored
@ -4,3 +4,4 @@ flex-2.5.35.tar.bz2
|
|||||||
/flex-2.5.36.tar.bz2
|
/flex-2.5.36.tar.bz2
|
||||||
/flex-2.5.37.tar.bz2
|
/flex-2.5.37.tar.bz2
|
||||||
/flex-2.5.39.tar.bz2
|
/flex-2.5.39.tar.bz2
|
||||||
|
/flex-2.6.0.tar.bz2
|
||||||
|
30
flex-2.6.0-yyless.patch
Normal file
30
flex-2.6.0-yyless.patch
Normal file
@ -0,0 +1,30 @@
|
|||||||
|
diff -Nrup a/src/flex.skl b/src/flex.skl
|
||||||
|
--- a/src/flex.skl 2015-11-10 18:28:54.000000000 -0500
|
||||||
|
+++ b/src/flex.skl 2016-03-07 23:52:46.527139783 -0500
|
||||||
|
@@ -506,7 +506,7 @@ m4_ifdef( [[M4_YY_NOT_IN_HEADER]],
|
||||||
|
*/
|
||||||
|
#define YY_LESS_LINENO(n) \
|
||||||
|
do { \
|
||||||
|
- int yyl;\
|
||||||
|
+ yy_size_t yyl;\
|
||||||
|
for ( yyl = n; yyl < yyleng; ++yyl )\
|
||||||
|
if ( yytext[yyl] == '\n' )\
|
||||||
|
--yylineno;\
|
||||||
|
@@ -532,7 +532,7 @@ m4_ifdef( [[M4_YY_NOT_IN_HEADER]],
|
||||||
|
do \
|
||||||
|
{ \
|
||||||
|
/* Undo effects of setting up yytext. */ \
|
||||||
|
- int yyless_macro_arg = (n); \
|
||||||
|
+ yy_size_t yyless_macro_arg = (n); \
|
||||||
|
YY_LESS_LINENO(yyless_macro_arg);\
|
||||||
|
*yy_cp = YY_G(yy_hold_char); \
|
||||||
|
YY_RESTORE_YY_MORE_OFFSET \
|
||||||
|
@@ -2591,7 +2591,7 @@ void yyFlexLexer::LexerError( yyconst ch
|
||||||
|
do \
|
||||||
|
{ \
|
||||||
|
/* Undo effects of setting up yytext. */ \
|
||||||
|
- int yyless_macro_arg = (n); \
|
||||||
|
+ yy_size_t yyless_macro_arg = (n); \
|
||||||
|
YY_LESS_LINENO(yyless_macro_arg);\
|
||||||
|
yytext[yyleng] = YY_G(yy_hold_char); \
|
||||||
|
YY_G(yy_c_buf_p) = yytext + yyless_macro_arg; \
|
13
flex.spec
13
flex.spec
@ -2,8 +2,8 @@
|
|||||||
|
|
||||||
Summary: A tool for creating scanners (text pattern recognizers)
|
Summary: A tool for creating scanners (text pattern recognizers)
|
||||||
Name: flex
|
Name: flex
|
||||||
Version: 2.5.39
|
Version: 2.6.0
|
||||||
Release: 4%{?dist}
|
Release: 1%{?dist}
|
||||||
# parse.c and parse.h are under GPLv3+ with exception which allows
|
# parse.c and parse.h are under GPLv3+ with exception which allows
|
||||||
# relicensing. Since flex is shipped under BDS-style license,
|
# relicensing. Since flex is shipped under BDS-style license,
|
||||||
# let's assume that the relicensing was done.
|
# let's assume that the relicensing was done.
|
||||||
@ -13,12 +13,11 @@ Group: Development/Tools
|
|||||||
URL: http://flex.sourceforge.net/
|
URL: http://flex.sourceforge.net/
|
||||||
Source: http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.bz2
|
Source: http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.bz2
|
||||||
|
|
||||||
#fix test-bison-yylloc and test-bison-yylval test failures
|
Patch0: flex-2.6.0-yyless.patch
|
||||||
Patch0: 0001-bison-test-fixes-Do-not-use-obsolete-bison-construct.patch
|
|
||||||
|
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
Requires: m4
|
Requires: m4
|
||||||
BuildRequires: gettext bison m4
|
BuildRequires: gettext bison m4 help2man
|
||||||
Requires(post): /sbin/install-info
|
Requires(post): /sbin/install-info
|
||||||
Requires(preun): /sbin/install-info
|
Requires(preun): /sbin/install-info
|
||||||
|
|
||||||
@ -134,6 +133,10 @@ rm -rf ${RPM_BUILD_ROOT}
|
|||||||
%{_pkgdocdir}
|
%{_pkgdocdir}
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Mar 10 2016 Patsy Franklin <pfrankli@redhat.com> - 2.6.0-1
|
||||||
|
- Rebase to 2.6.0
|
||||||
|
- Pick up an additional patch requested in BZ #1281976
|
||||||
|
|
||||||
* Wed Feb 03 2016 Fedora Release Engineering <releng@fedoraproject.org> - 2.5.39-4
|
* Wed Feb 03 2016 Fedora Release Engineering <releng@fedoraproject.org> - 2.5.39-4
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user