- Add BR gawk

- Fix use of awk in one of the tests
This commit is contained in:
Petr Machata 2007-08-30 11:52:25 +00:00
parent 2459eb8dbe
commit f4cff0788c
2 changed files with 22 additions and 2 deletions

View File

@ -0,0 +1,14 @@
diff -rup flex-2.5.33/tests/test-linedir-r/Makefile.am flex-2.5.33-pm/tests/test-linedir-r/Makefile.am
--- flex-2.5.33/tests/test-linedir-r/Makefile.am 2003-03-26 19:29:45.000000000 +0100
+++ flex-2.5.33-pm/tests/test-linedir-r/Makefile.am 2007-08-30 12:28:09.000000000 +0200
@@ -46,8 +46,8 @@ $(testname)$(EXEEXT): $(OBJS)
test: $(testname)$(EXEEXT)
./$(testname)$(EXEEXT) < $(srcdir)/test.input
- cat -n scanner.c | grep '#line' | grep scanner.c | awk -f $(srcdir)/check-lines.awk
- cat -n scanner.h | grep '#line' | grep scanner.h | awk -f $(srcdir)/check-lines.awk
+ cat -n scanner.c | grep '#line' | grep scanner.c | $(AWK) -f $(srcdir)/check-lines.awk
+ cat -n scanner.h | grep '#line' | grep scanner.h | $(AWK) -f $(srcdir)/check-lines.awk
.c.o:
$(CC) -c -o $@ $(AM_CPPFLAGS) $(CPPFLAGS) $(CFLAGS) $<

View File

@ -1,7 +1,7 @@
Summary: A tool for creating scanners (text pattern recognizers)
Name: flex
Version: 2.5.33
Release: 10%{?dist}
Release: 11%{?dist}
License: BSD
Group: Development/Tools
URL: http://flex.sourceforge.net/
@ -10,9 +10,10 @@ Patch0: flex-2.5.33-pic.patch
Patch1: flex-2.5.33-yy.patch
Patch2: flex-2.5.33-opts.patch
Patch3: flex-2.5.33-includedir.patch
Patch4: flex-2.5.33-test-linedir-r.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
Requires: m4
BuildRequires: gettext bison m4
BuildRequires: gettext bison m4 gawk
Requires(post): /sbin/install-info
Requires(preun): /sbin/install-info
@ -36,6 +37,7 @@ application development.
%patch1 -p1
%patch2 -p1
%patch3 -p1
%patch4 -p1
%build
%configure --disable-dependency-tracking
@ -82,6 +84,10 @@ rm -rf ${RPM_BUILD_ROOT}
%{_infodir}/flex.info*
%changelog
* Thu Aug 30 2007 Petr Machata <pmachata@redhat.com> - 2.5.33-11
- Add BR gawk
- Fix use of awk in one of the tests
* Wed Aug 29 2007 Fedora Release Engineering <rel-eng at fedoraproject dot org> - 2.5.33-10
- Rebuild for selinux ppc32 issue.