Add a patch for "comparison between signed and unsigned" warnings
This commit is contained in:
parent
d39470d8a5
commit
a3088c99e8
41
flex-2.5.37-types.patch
Normal file
41
flex-2.5.37-types.patch
Normal file
@ -0,0 +1,41 @@
|
|||||||
|
From c53fd2db8c78fef5afd284c3e64da51bc71cf6c3 Mon Sep 17 00:00:00 2001
|
||||||
|
From: nomis52 <nomis52@users.sourceforge.net>
|
||||||
|
Date: Sat, 4 Aug 2012 15:03:31 -0400
|
||||||
|
Subject: [PATCH] Change variable types to silence compiler warnings; resolves
|
||||||
|
#3552806
|
||||||
|
|
||||||
|
Signed-off-by: Will Estes <westes575@gmail.com>
|
||||||
|
---
|
||||||
|
flex.skl | 2 +-
|
||||||
|
gen.c | 2 +-
|
||||||
|
2 files changed, 2 insertions(+), 2 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/flex.skl b/flex.skl
|
||||||
|
index 01d8204..7802f45 100644
|
||||||
|
--- a/flex.skl
|
||||||
|
+++ b/flex.skl
|
||||||
|
@@ -2360,7 +2360,7 @@ YY_BUFFER_STATE yy_scan_bytes YYFARGS2( yyconst char *,yybytes, yy_size_t ,_yyb
|
||||||
|
YY_BUFFER_STATE b;
|
||||||
|
char *buf;
|
||||||
|
yy_size_t n;
|
||||||
|
- int i;
|
||||||
|
+ yy_size_t i;
|
||||||
|
m4_dnl M4_YY_DECL_GUTS_VAR();
|
||||||
|
|
||||||
|
/* Get memory for full buffer, including space for trailing EOB's. */
|
||||||
|
diff --git a/gen.c b/gen.c
|
||||||
|
index 5a5daef..8d24a86 100644
|
||||||
|
--- a/gen.c
|
||||||
|
+++ b/gen.c
|
||||||
|
@@ -1972,7 +1972,7 @@ void make_tables ()
|
||||||
|
("if ( yy_act != YY_END_OF_BUFFER && yy_rule_can_match_eol[yy_act] )");
|
||||||
|
indent_up ();
|
||||||
|
indent_puts ("{");
|
||||||
|
- indent_puts ("int yyl;");
|
||||||
|
+ indent_puts ("yy_size_t yyl;");
|
||||||
|
do_indent ();
|
||||||
|
out_str ("for ( yyl = %s; yyl < yyleng; ++yyl )\n",
|
||||||
|
yymore_used ? (yytext_is_array ? "YY_G(yy_prev_more_offset)" :
|
||||||
|
--
|
||||||
|
1.7.6.5
|
||||||
|
|
11
flex.spec
11
flex.spec
@ -1,7 +1,7 @@
|
|||||||
Summary: A tool for creating scanners (text pattern recognizers)
|
Summary: A tool for creating scanners (text pattern recognizers)
|
||||||
Name: flex
|
Name: flex
|
||||||
Version: 2.5.37
|
Version: 2.5.37
|
||||||
Release: 3%{?dist}
|
Release: 4%{?dist}
|
||||||
# parse.c and parse.h are under GPLv3+ with exception which allows
|
# parse.c and parse.h are under GPLv3+ with exception which allows
|
||||||
# relicensing. Since flex is shipped under BDS-style license,
|
# relicensing. Since flex is shipped under BDS-style license,
|
||||||
# let's assume that the relicensing was done.
|
# let's assume that the relicensing was done.
|
||||||
@ -17,6 +17,9 @@ Patch0: flex-2.5.36-bison-2.6.1.patch
|
|||||||
# https://bugzilla.redhat.com/show_bug.cgi?id=925801
|
# https://bugzilla.redhat.com/show_bug.cgi?id=925801
|
||||||
Patch1: flex-2.5.37-aarch64.patch
|
Patch1: flex-2.5.37-aarch64.patch
|
||||||
|
|
||||||
|
# https://bugzilla.redhat.com/show_bug.cgi?id=993447
|
||||||
|
Patch2: flex-2.5.37-types.patch
|
||||||
|
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
Requires: m4
|
Requires: m4
|
||||||
BuildRequires: gettext bison m4
|
BuildRequires: gettext bison m4
|
||||||
@ -64,6 +67,7 @@ plain text and PDF formats.
|
|||||||
%setup -q
|
%setup -q
|
||||||
%patch0 -p1
|
%patch0 -p1
|
||||||
%patch1 -p1
|
%patch1 -p1
|
||||||
|
%patch2 -p1
|
||||||
|
|
||||||
%global flexdocdir %{_datadir}/doc/flex-doc-%{version}
|
%global flexdocdir %{_datadir}/doc/flex-doc-%{version}
|
||||||
|
|
||||||
@ -124,6 +128,11 @@ rm -rf ${RPM_BUILD_ROOT}
|
|||||||
%{_datadir}/doc/flex-doc-%{version}
|
%{_datadir}/doc/flex-doc-%{version}
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Sep 3 2013 Petr Machata <pmachata@redhat.com> - 2.5.37-4
|
||||||
|
- Add a patch for "comparison between signed and unsigned" warnings
|
||||||
|
that GCC produces when compiling flex-generated scanners
|
||||||
|
(flex-2.5.37-types.patch)
|
||||||
|
|
||||||
* Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.5.37-3
|
* Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.5.37-3
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user