- Patch with -fPIC only after the autogen.sh is run.
This commit is contained in:
parent
bbcb9d54ad
commit
356ece10f3
@ -1,12 +1,11 @@
|
|||||||
diff -urp flex-2.5.33/Makefile.in flex-2.5.33-pm/Makefile.in
|
diff -urp flex-2.5.33/Makefile.in flex-2.5.33-pm/Makefile.in
|
||||||
--- flex-2.5.33/Makefile.in 2007-05-30 10:57:18.000000000 +0200
|
--- flex-2.5.33/Makefile.in 2007-05-30 10:57:18.000000000 +0200
|
||||||
+++ flex-2.5.33-pm/Makefile.in 2007-05-30 10:57:11.000000000 +0200
|
+++ flex-2.5.33-pm/Makefile.in 2007-05-30 10:57:11.000000000 +0200
|
||||||
@@ -291,7 +291,7 @@ SUBDIRS = \
|
@@ -291,6 +291,6 @@ SUBDIRS = \
|
||||||
|
|
||||||
|
|
||||||
localedir = $(datadir)/locale
|
localedir = $(datadir)/locale
|
||||||
-AM_CPPFLAGS = -DLOCALEDIR=\"$(localedir)\" -I@includedir@ -I$(top_srcdir)/intl
|
-AM_CPPFLAGS = -DLOCALEDIR=\"$(localedir)\" -I@includedir@ -I$(top_srcdir)/intl
|
||||||
+AM_CPPFLAGS = -DLOCALEDIR=\"$(localedir)\" -I$(top_srcdir)/intl
|
+AM_CPPFLAGS = -DLOCALEDIR=\"$(localedir)\" -I$(top_srcdir)/intl
|
||||||
AM_CFLAGS = -fPIC
|
|
||||||
|
|
||||||
# Run GNU indent on sources. Don't run this unless all the sources compile cleanly.
|
# Run GNU indent on sources. Don't run this unless all the sources compile cleanly.
|
||||||
|
@ -1,13 +1,10 @@
|
|||||||
Only in flex-2.5.33-pm: flex-2.5.33
|
--- flex-2.5.33/Makefile.in 2008-01-08 16:09:52.000000000 +0100
|
||||||
diff -urp flex-2.5.33/Makefile.in flex-2.5.33-pm/Makefile.in
|
+++ flex-2.5.33-pm/Makefile.in 2008-01-08 16:10:22.000000000 +0100
|
||||||
--- flex-2.5.33/Makefile.in 2006-02-21 03:45:12.000000000 +0100
|
@@ -375,6 +375,7 @@ SUBDIRS = \
|
||||||
+++ flex-2.5.33-pm/Makefile.in 2007-01-31 15:06:32.000000000 +0100
|
tests
|
||||||
@@ -292,6 +292,7 @@ SUBDIRS = \
|
|
||||||
|
|
||||||
localedir = $(datadir)/locale
|
|
||||||
AM_CPPFLAGS = -DLOCALEDIR=\"$(localedir)\" -I@includedir@ -I$(top_srcdir)/intl
|
AM_CPPFLAGS = -DLOCALEDIR=\"$(localedir)\" -I@includedir@ -I$(top_srcdir)/intl
|
||||||
+AM_CFLAGS = -fPIC
|
+AM_CFLAGS = -fPIC
|
||||||
|
|
||||||
# Run GNU indent on sources. Don't run this unless all the sources compile cleanly.
|
# Run GNU indent on sources. Don't run this unless all the sources compile cleanly.
|
||||||
#
|
#
|
||||||
Only in flex-2.5.33-pm: Makefile.in~
|
|
||||||
|
13
flex.spec
13
flex.spec
@ -1,16 +1,16 @@
|
|||||||
Summary: A tool for creating scanners (text pattern recognizers)
|
Summary: A tool for creating scanners (text pattern recognizers)
|
||||||
Name: flex
|
Name: flex
|
||||||
Version: 2.5.33
|
Version: 2.5.33
|
||||||
Release: 12%{?dist}
|
Release: 13%{?dist}
|
||||||
License: BSD
|
License: BSD
|
||||||
Group: Development/Tools
|
Group: Development/Tools
|
||||||
URL: http://flex.sourceforge.net/
|
URL: http://flex.sourceforge.net/
|
||||||
Source: flex-%{version}.tar.bz2
|
Source: flex-%{version}.tar.bz2
|
||||||
Patch0: flex-2.5.33-pic.patch
|
|
||||||
Patch1: flex-2.5.33-yy.patch
|
Patch1: flex-2.5.33-yy.patch
|
||||||
Patch2: flex-2.5.33-opts.patch
|
Patch2: flex-2.5.33-opts.patch
|
||||||
Patch3: flex-2.5.33-includedir.patch
|
Patch3: flex-2.5.33-includedir.patch
|
||||||
Patch4: flex-2.5.33-test-linedir-r.patch
|
Patch4: flex-2.5.33-test-linedir-r.patch
|
||||||
|
Patch5: flex-2.5.33-pic.patch
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
Requires: m4
|
Requires: m4
|
||||||
BuildRequires: gettext bison m4 gawk autoconf automake gettext-devel
|
BuildRequires: gettext bison m4 gawk autoconf automake gettext-devel
|
||||||
@ -33,14 +33,16 @@ application development.
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
%patch0 -p1
|
|
||||||
%patch1 -p1
|
%patch1 -p1
|
||||||
%patch2 -p1
|
%patch2 -p1
|
||||||
%patch3 -p1
|
%patch3 -p1
|
||||||
%patch4 -p1
|
%patch4 -p1
|
||||||
|
./autogen.sh
|
||||||
|
# The -fPIC patch has to be applied after the build system is
|
||||||
|
# re-generated.
|
||||||
|
%patch5 -p1
|
||||||
|
|
||||||
%build
|
%build
|
||||||
./autogen.sh
|
|
||||||
%configure --disable-dependency-tracking
|
%configure --disable-dependency-tracking
|
||||||
make %{?_smp_mflags}
|
make %{?_smp_mflags}
|
||||||
|
|
||||||
@ -85,6 +87,9 @@ rm -rf ${RPM_BUILD_ROOT}
|
|||||||
%{_infodir}/flex.info*
|
%{_infodir}/flex.info*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Jan 8 2008 Petr Machata <pmachata@redhat.com> - 2.5.33-13
|
||||||
|
- Patch with -fPIC only after the autogen.sh is run.
|
||||||
|
|
||||||
* Thu Jan 3 2008 Petr Machata <pmachata@redhat.com> - 2.5.33-12
|
* Thu Jan 3 2008 Petr Machata <pmachata@redhat.com> - 2.5.33-12
|
||||||
- Run autogen.sh before the rest of the build.
|
- Run autogen.sh before the rest of the build.
|
||||||
- Add BR autoconf automake gettext-devel.
|
- Add BR autoconf automake gettext-devel.
|
||||||
|
Loading…
Reference in New Issue
Block a user