Update to 0.8.0
This commit is contained in:
parent
1928f4f1fa
commit
a64b7f9fef
1
.gitignore
vendored
1
.gitignore
vendored
@ -11,3 +11,4 @@
|
|||||||
/flatpak-0.6.12.tar.xz
|
/flatpak-0.6.12.tar.xz
|
||||||
/flatpak-0.6.13.tar.xz
|
/flatpak-0.6.13.tar.xz
|
||||||
/flatpak-0.6.14.tar.xz
|
/flatpak-0.6.14.tar.xz
|
||||||
|
/flatpak-0.8.0.tar.xz
|
||||||
|
@ -1,30 +0,0 @@
|
|||||||
From 31ca19eb99dbd588a1995898ab1baf6cef2180d6 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Alexander Larsson <alexl@redhat.com>
|
|
||||||
Date: Tue, 29 Nov 2016 16:59:48 +0100
|
|
||||||
Subject: [PATCH] pull: Exit early on error without aborting transaction
|
|
||||||
|
|
||||||
At this point we have not set up repo yet, so aborting would crash.
|
|
||||||
---
|
|
||||||
common/flatpak-dir.c | 4 ++--
|
|
||||||
1 file changed, 2 insertions(+), 2 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/common/flatpak-dir.c b/common/flatpak-dir.c
|
|
||||||
index 8213440..1094cf4 100644
|
|
||||||
--- a/common/flatpak-dir.c
|
|
||||||
+++ b/common/flatpak-dir.c
|
|
||||||
@@ -1563,13 +1563,13 @@ flatpak_dir_pull (FlatpakDir *self,
|
|
||||||
g_autoptr(GPtrArray) subdirs_arg = NULL;
|
|
||||||
|
|
||||||
if (!flatpak_dir_ensure_repo (self, cancellable, error))
|
|
||||||
- goto out;
|
|
||||||
+ return FALSE;
|
|
||||||
|
|
||||||
if (!ostree_repo_remote_get_url (self->repo,
|
|
||||||
repository,
|
|
||||||
&url,
|
|
||||||
error))
|
|
||||||
- goto out;
|
|
||||||
+ return FALSE;
|
|
||||||
|
|
||||||
if (*url == 0)
|
|
||||||
return TRUE; /* Empty url, silently disables updates */
|
|
13
flatpak.spec
13
flatpak.spec
@ -1,18 +1,15 @@
|
|||||||
# Although technically 0.1.2 satisfies configure, 0.1.3 has a security fix.
|
%global bubblewrap_version 0.1.5
|
||||||
%global bubblewrap_version 0.1.3
|
|
||||||
%global ostree_version 2016.14
|
%global ostree_version 2016.14
|
||||||
|
|
||||||
Name: flatpak
|
Name: flatpak
|
||||||
Version: 0.6.14
|
Version: 0.8.0
|
||||||
Release: 2%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: Application deployment framework for desktop apps
|
Summary: Application deployment framework for desktop apps
|
||||||
|
|
||||||
Group: Development/Tools
|
Group: Development/Tools
|
||||||
License: LGPLv2+
|
License: LGPLv2+
|
||||||
URL: http://flatpak.org/
|
URL: http://flatpak.org/
|
||||||
Source0: https://github.com/flatpak/flatpak/releases/download/%{version}/%{name}-%{version}.tar.xz
|
Source0: https://github.com/flatpak/flatpak/releases/download/%{version}/%{name}-%{version}.tar.xz
|
||||||
# Fix a GNOME Software crash.
|
|
||||||
Patch0: flatpak-0.6.14-fix-gnome-software-crash.patch
|
|
||||||
|
|
||||||
BuildRequires: pkgconfig(fuse)
|
BuildRequires: pkgconfig(fuse)
|
||||||
BuildRequires: pkgconfig(gio-unix-2.0)
|
BuildRequires: pkgconfig(gio-unix-2.0)
|
||||||
@ -103,7 +100,6 @@ This package contains libflatpak.
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
%patch0 -p1
|
|
||||||
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
@ -192,6 +188,9 @@ flatpak remote-list --system &> /dev/null || :
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Dec 20 2016 Kalev Lember <klember@redhat.com> - 0.8.0-1
|
||||||
|
- Update to 0.8.0
|
||||||
|
|
||||||
* Tue Nov 29 2016 David King <amigadave@amigadave.com> - 0.6.14-2
|
* Tue Nov 29 2016 David King <amigadave@amigadave.com> - 0.6.14-2
|
||||||
- Add a patch to fix a GNOME Software crash
|
- Add a patch to fix a GNOME Software crash
|
||||||
- Silence repository listing during post
|
- Silence repository listing during post
|
||||||
|
Loading…
Reference in New Issue
Block a user