Rebase backported upstream patches to updated versions
Resolves: RHEL-26066
This commit is contained in:
parent
34285389a4
commit
9200959671
File diff suppressed because it is too large
Load Diff
File diff suppressed because it is too large
Load Diff
@ -1,14 +1,15 @@
|
||||
From cec97aac1c9fad9b5bc18d1166b63edb13ca2bcc Mon Sep 17 00:00:00 2001
|
||||
From: "Owen W. Taylor" <otaylor@fishsoup.net>
|
||||
Date: Tue, 17 Dec 2024 15:35:21 +0100
|
||||
Subject: [PATCH 1/9] tests/oci-registry-client.py: Drop python2 compatibility
|
||||
Subject: [PATCH 01/09] tests/oci-registry-client.py: Drop python2
|
||||
compatibility
|
||||
|
||||
---
|
||||
tests/oci-registry-client.py | 15 ++++++---------
|
||||
1 file changed, 6 insertions(+), 9 deletions(-)
|
||||
|
||||
diff --git a/tests/oci-registry-client.py b/tests/oci-registry-client.py
|
||||
index 7f1eeb5453..b9ca63d70d 100644
|
||||
index 7f1eeb54..b9ca63d7 100644
|
||||
--- a/tests/oci-registry-client.py
|
||||
+++ b/tests/oci-registry-client.py
|
||||
@@ -2,12 +2,9 @@
|
||||
@ -27,7 +28,7 @@ index 7f1eeb5453..b9ca63d70d 100644
|
||||
|
||||
if sys.argv[2] == 'add':
|
||||
detach_icons = '--detach-icons' in sys.argv
|
||||
@@ -16,8 +13,8 @@
|
||||
@@ -16,8 +13,8 @@ if sys.argv[2] == 'add':
|
||||
params = {'d': sys.argv[5]}
|
||||
if detach_icons:
|
||||
params['detach-icons'] = 1
|
||||
@ -38,7 +39,7 @@ index 7f1eeb5453..b9ca63d70d 100644
|
||||
path = "/testing/{repo}/{tag}?{query}".format(repo=sys.argv[3],
|
||||
tag=sys.argv[4],
|
||||
query=query)
|
||||
@@ -28,7 +25,7 @@
|
||||
@@ -28,7 +25,7 @@ if sys.argv[2] == 'add':
|
||||
print("Failed: status={}".format(response.status), file=sys.stderr)
|
||||
sys.exit(1)
|
||||
elif sys.argv[2] == 'delete':
|
||||
@ -47,11 +48,13 @@ index 7f1eeb5453..b9ca63d70d 100644
|
||||
path = "/testing/{repo}/{ref}".format(repo=sys.argv[3],
|
||||
ref=sys.argv[4])
|
||||
conn.request("DELETE", path)
|
||||
--
|
||||
2.47.1
|
||||
|
||||
From d8ce35c9d1c0b1c83127b07abe9b3479170cc8f6 Mon Sep 17 00:00:00 2001
|
||||
From: "Owen W. Taylor" <otaylor@fishsoup.net>
|
||||
Date: Tue, 17 Dec 2024 15:41:53 +0100
|
||||
Subject: [PATCH 2/9] tests/oci-registry-client.py: Parse URL parameter
|
||||
Subject: [PATCH 02/09] tests/oci-registry-client.py: Parse URL parameter
|
||||
|
||||
---
|
||||
tests/oci-registry-client.py | 9 +++++++--
|
||||
@ -59,10 +62,10 @@ Subject: [PATCH 2/9] tests/oci-registry-client.py: Parse URL parameter
|
||||
2 files changed, 8 insertions(+), 3 deletions(-)
|
||||
|
||||
diff --git a/tests/oci-registry-client.py b/tests/oci-registry-client.py
|
||||
index b9ca63d70d..cd835609ad 100644
|
||||
index b9ca63d7..cd835609 100644
|
||||
--- a/tests/oci-registry-client.py
|
||||
+++ b/tests/oci-registry-client.py
|
||||
@@ -6,6 +6,11 @@
|
||||
@@ -6,6 +6,11 @@ import http.client
|
||||
import urllib.parse
|
||||
|
||||
|
||||
@ -74,7 +77,7 @@ index b9ca63d70d..cd835609ad 100644
|
||||
if sys.argv[2] == 'add':
|
||||
detach_icons = '--detach-icons' in sys.argv
|
||||
if detach_icons:
|
||||
@@ -14,7 +19,7 @@
|
||||
@@ -14,7 +19,7 @@ if sys.argv[2] == 'add':
|
||||
if detach_icons:
|
||||
params['detach-icons'] = 1
|
||||
query = urllib.parse.urlencode(params)
|
||||
@ -83,7 +86,7 @@ index b9ca63d70d..cd835609ad 100644
|
||||
path = "/testing/{repo}/{tag}?{query}".format(repo=sys.argv[3],
|
||||
tag=sys.argv[4],
|
||||
query=query)
|
||||
@@ -25,7 +30,7 @@
|
||||
@@ -25,7 +30,7 @@ if sys.argv[2] == 'add':
|
||||
print("Failed: status={}".format(response.status), file=sys.stderr)
|
||||
sys.exit(1)
|
||||
elif sys.argv[2] == 'delete':
|
||||
@ -93,7 +96,7 @@ index b9ca63d70d..cd835609ad 100644
|
||||
ref=sys.argv[4])
|
||||
conn.request("DELETE", path)
|
||||
diff --git a/tests/test-oci-registry.sh b/tests/test-oci-registry.sh
|
||||
index 8eb154f5ea..51a6142fe8 100755
|
||||
index 8eb154f5..51a6142f 100755
|
||||
--- a/tests/test-oci-registry.sh
|
||||
+++ b/tests/test-oci-registry.sh
|
||||
@@ -29,7 +29,7 @@ echo "1..14"
|
||||
@ -105,11 +108,13 @@ index 8eb154f5ea..51a6142fe8 100755
|
||||
|
||||
setup_repo_no_add oci
|
||||
|
||||
--
|
||||
2.47.1
|
||||
|
||||
From 0757171aa07f3b8d390881e0765de09ed77d4825 Mon Sep 17 00:00:00 2001
|
||||
From: "Owen W. Taylor" <otaylor@fishsoup.net>
|
||||
Date: Tue, 17 Dec 2024 15:47:07 +0100
|
||||
Subject: [PATCH 3/9] tests/oci-registry-client.py: Convert to argparse
|
||||
Subject: [PATCH 03/09] tests/oci-registry-client.py: Convert to argparse
|
||||
|
||||
---
|
||||
tests/oci-registry-client.py | 57 +++++++++++++++++++++++-------------
|
||||
@ -120,7 +125,7 @@ Subject: [PATCH 3/9] tests/oci-registry-client.py: Convert to argparse
|
||||
diff --git a/tests/oci-registry-client.py b/tests/oci-registry-client.py
|
||||
old mode 100644
|
||||
new mode 100755
|
||||
index cd835609ad..5654062bec
|
||||
index cd835609..5654062b
|
||||
--- a/tests/oci-registry-client.py
|
||||
+++ b/tests/oci-registry-client.py
|
||||
@@ -1,45 +1,62 @@
|
||||
@ -207,7 +212,7 @@ index cd835609ad..5654062bec
|
||||
+args = parser.parse_args()
|
||||
+args.func(args)
|
||||
diff --git a/tests/test-oci-registry.sh b/tests/test-oci-registry.sh
|
||||
index 51a6142fe8..bc2f138b96 100755
|
||||
index 51a6142f..bc2f138b 100755
|
||||
--- a/tests/test-oci-registry.sh
|
||||
+++ b/tests/test-oci-registry.sh
|
||||
@@ -29,7 +29,7 @@ echo "1..14"
|
||||
@ -219,11 +224,13 @@ index 51a6142fe8..bc2f138b96 100755
|
||||
|
||||
setup_repo_no_add oci
|
||||
|
||||
--
|
||||
2.47.1
|
||||
|
||||
From f38197c03dc77b9192c6dbc59e175b3cb640614a Mon Sep 17 00:00:00 2001
|
||||
From: Sebastian Wick <sebastian.wick@redhat.com>
|
||||
Date: Thu, 22 Aug 2024 02:43:13 -0400
|
||||
Subject: [PATCH 4/9] tests/oci-registry-server.py: Clean up Python style
|
||||
Subject: [PATCH 04/09] tests/oci-registry-server.py: Clean up Python style
|
||||
|
||||
---
|
||||
.flake8 | 2 +
|
||||
@ -233,17 +240,17 @@ Subject: [PATCH 4/9] tests/oci-registry-server.py: Clean up Python style
|
||||
|
||||
diff --git a/.flake8 b/.flake8
|
||||
new file mode 100644
|
||||
index 0000000000..7da1f9608e
|
||||
index 00000000..7da1f960
|
||||
--- /dev/null
|
||||
+++ b/.flake8
|
||||
@@ -0,0 +1,2 @@
|
||||
+[flake8]
|
||||
+max-line-length = 100
|
||||
diff --git a/tests/oci-registry-server.py b/tests/oci-registry-server.py
|
||||
index 33c3b646b0..3050a88358 100755
|
||||
index 33c3b646..3050a883 100755
|
||||
--- a/tests/oci-registry-server.py
|
||||
+++ b/tests/oci-registry-server.py
|
||||
@@ -13,65 +13,61 @@
|
||||
@@ -13,65 +13,61 @@ import http.server as http_server
|
||||
repositories = {}
|
||||
icons = {}
|
||||
|
||||
@ -331,7 +338,7 @@ index 33c3b646b0..3050a88358 100755
|
||||
matches[route_path[i][1:]] = path[i]
|
||||
elif route_path[i] != path[i]:
|
||||
return False
|
||||
@@ -92,24 +88,25 @@ def do_GET(self):
|
||||
@@ -92,24 +88,25 @@ class RequestHandler(http_server.BaseHTTPRequestHandler):
|
||||
|
||||
add_headers = {}
|
||||
|
||||
@ -370,7 +377,7 @@ index 33c3b646b0..3050a88358 100755
|
||||
else:
|
||||
response = 404
|
||||
|
||||
@@ -121,86 +118,89 @@ def do_GET(self):
|
||||
@@ -121,86 +118,89 @@ class RequestHandler(http_server.BaseHTTPRequestHandler):
|
||||
self.send_header("Content-Type", response_content_type)
|
||||
|
||||
if response == 200 or response == 304:
|
||||
@ -490,7 +497,7 @@ index 33c3b646b0..3050a88358 100755
|
||||
|
||||
images.append(image)
|
||||
|
||||
@@ -214,26 +214,26 @@ def do_POST(self):
|
||||
@@ -214,26 +214,26 @@ class RequestHandler(http_server.BaseHTTPRequestHandler):
|
||||
return
|
||||
|
||||
def do_DELETE(self):
|
||||
@ -526,7 +533,7 @@ index 33c3b646b0..3050a88358 100755
|
||||
del manifests[t]
|
||||
|
||||
modified()
|
||||
@@ -245,22 +245,24 @@ def do_DELETE(self):
|
||||
@@ -245,22 +245,24 @@ class RequestHandler(http_server.BaseHTTPRequestHandler):
|
||||
self.end_headers()
|
||||
return
|
||||
|
||||
@ -557,11 +564,13 @@ index 33c3b646b0..3050a88358 100755
|
||||
dir = None
|
||||
if len(sys.argv) >= 2 and len(sys.argv[1]) > 0:
|
||||
dir = sys.argv[1]
|
||||
--
|
||||
2.47.1
|
||||
|
||||
From 47ff75860097afe0b07758b2457a52f0e6b94bd7 Mon Sep 17 00:00:00 2001
|
||||
From: "Owen W. Taylor" <otaylor@fishsoup.net>
|
||||
Date: Thu, 22 Aug 2024 02:47:19 -0400
|
||||
Subject: [PATCH 5/9] tests/oci-registry-server.py: Convert to argparse
|
||||
Subject: [PATCH 05/09] tests/oci-registry-server.py: Convert to argparse
|
||||
|
||||
---
|
||||
tests/oci-registry-server.py | 15 ++++++++-------
|
||||
@ -569,7 +578,7 @@ Subject: [PATCH 5/9] tests/oci-registry-server.py: Convert to argparse
|
||||
2 files changed, 9 insertions(+), 8 deletions(-)
|
||||
|
||||
diff --git a/tests/oci-registry-server.py b/tests/oci-registry-server.py
|
||||
index 3050a88358..65421f34c9 100755
|
||||
index 3050a883..65421f34 100755
|
||||
--- a/tests/oci-registry-server.py
|
||||
+++ b/tests/oci-registry-server.py
|
||||
@@ -1,5 +1,6 @@
|
||||
@ -579,7 +588,7 @@ index 3050a88358..65421f34c9 100755
|
||||
import base64
|
||||
import hashlib
|
||||
import json
|
||||
@@ -246,7 +247,7 @@ def do_DELETE(self):
|
||||
@@ -246,7 +247,7 @@ class RequestHandler(http_server.BaseHTTPRequestHandler):
|
||||
return
|
||||
|
||||
|
||||
@ -610,7 +619,7 @@ index 3050a88358..65421f34c9 100755
|
||||
- run(dir)
|
||||
+ run(args)
|
||||
diff --git a/tests/test-oci-registry.sh b/tests/test-oci-registry.sh
|
||||
index bc2f138b96..12036358fa 100755
|
||||
index bc2f138b..12036358 100755
|
||||
--- a/tests/test-oci-registry.sh
|
||||
+++ b/tests/test-oci-registry.sh
|
||||
@@ -27,7 +27,7 @@ echo "1..14"
|
||||
@ -622,11 +631,13 @@ index bc2f138b96..12036358fa 100755
|
||||
port=$(cat httpd-port)
|
||||
client="python3 $test_srcdir/oci-registry-client.py --url=http://127.0.0.1:$port"
|
||||
|
||||
--
|
||||
2.47.1
|
||||
|
||||
From c2c2f3679608a32339dadb233dc11633f22b0793 Mon Sep 17 00:00:00 2001
|
||||
From: Sebastian Wick <sebastian.wick@redhat.com>
|
||||
Date: Tue, 17 Dec 2024 16:39:16 +0100
|
||||
Subject: [PATCH 6/9] tests/oci-registry-server.py: Always get bytes for the
|
||||
Subject: [PATCH 06/09] tests/oci-registry-server.py: Always get bytes for the
|
||||
response
|
||||
|
||||
And sent the Content-Length header.
|
||||
@ -635,10 +646,10 @@ And sent the Content-Length header.
|
||||
1 file changed, 24 insertions(+), 22 deletions(-)
|
||||
|
||||
diff --git a/tests/oci-registry-server.py b/tests/oci-registry-server.py
|
||||
index 65421f34c9..13bf50b367 100755
|
||||
index 65421f34..13bf50b3 100755
|
||||
--- a/tests/oci-registry-server.py
|
||||
+++ b/tests/oci-registry-server.py
|
||||
@@ -5,7 +5,6 @@
|
||||
@@ -5,7 +5,6 @@ import base64
|
||||
import hashlib
|
||||
import json
|
||||
import os
|
||||
@ -655,7 +666,7 @@ index 65421f34c9..13bf50b367 100755
|
||||
|
||||
|
||||
def cache_icon(data_uri):
|
||||
@@ -62,7 +61,6 @@ def check_route(self, route):
|
||||
@@ -62,7 +61,6 @@ class RequestHandler(http_server.BaseHTTPRequestHandler):
|
||||
path = parts[0].split("/")
|
||||
|
||||
route_path = route.split("/")
|
||||
@ -663,7 +674,7 @@ index 65421f34c9..13bf50b367 100755
|
||||
if len(route_path) != len(path):
|
||||
return False
|
||||
|
||||
@@ -82,34 +80,47 @@ def check_route(self, route):
|
||||
@@ -82,34 +80,47 @@ class RequestHandler(http_server.BaseHTTPRequestHandler):
|
||||
return True
|
||||
|
||||
def do_GET(self):
|
||||
@ -720,7 +731,7 @@ index 65421f34c9..13bf50b367 100755
|
||||
|
||||
self.send_response(response)
|
||||
for k, v in list(add_headers.items()):
|
||||
@@ -123,16 +134,7 @@ def do_GET(self):
|
||||
@@ -123,16 +134,7 @@ class RequestHandler(http_server.BaseHTTPRequestHandler):
|
||||
|
||||
self.end_headers()
|
||||
|
||||
@ -738,11 +749,13 @@ index 65421f34c9..13bf50b367 100755
|
||||
|
||||
def do_HEAD(self):
|
||||
return self.do_GET()
|
||||
--
|
||||
2.47.1
|
||||
|
||||
From 85379a0fe6b79d216a29497980ce2c8e0ab46997 Mon Sep 17 00:00:00 2001
|
||||
From: "Owen W. Taylor" <otaylor@fishsoup.net>
|
||||
Date: Tue, 17 Dec 2024 16:41:38 +0100
|
||||
Subject: [PATCH 7/9] tests/oci-registry: Add support for SSL to client and
|
||||
Subject: [PATCH 07/09] tests/oci-registry: Add support for SSL to client and
|
||||
server
|
||||
|
||||
---
|
||||
@ -751,7 +764,7 @@ Subject: [PATCH 7/9] tests/oci-registry: Add support for SSL to client and
|
||||
2 files changed, 39 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/tests/oci-registry-client.py b/tests/oci-registry-client.py
|
||||
index 5654062bec..c4707c07ec 100755
|
||||
index 5654062b..c4707c07 100755
|
||||
--- a/tests/oci-registry-client.py
|
||||
+++ b/tests/oci-registry-client.py
|
||||
@@ -1,6 +1,7 @@
|
||||
@ -762,7 +775,7 @@ index 5654062bec..c4707c07ec 100755
|
||||
import sys
|
||||
|
||||
import http.client
|
||||
@@ -9,7 +10,20 @@
|
||||
@@ -9,7 +10,20 @@ import urllib.parse
|
||||
|
||||
def get_conn(args):
|
||||
parsed = urllib.parse.urlparse(args.url)
|
||||
@ -795,10 +808,10 @@ index 5654062bec..c4707c07ec 100755
|
||||
subparsers = parser.add_subparsers()
|
||||
subparsers.required = True
|
||||
diff --git a/tests/oci-registry-server.py b/tests/oci-registry-server.py
|
||||
index 13bf50b367..2bbe8c6e8a 100755
|
||||
index 13bf50b3..2bbe8c6e 100755
|
||||
--- a/tests/oci-registry-server.py
|
||||
+++ b/tests/oci-registry-server.py
|
||||
@@ -5,6 +5,7 @@
|
||||
@@ -5,6 +5,7 @@ import base64
|
||||
import hashlib
|
||||
import json
|
||||
import os
|
||||
@ -806,7 +819,7 @@ index 13bf50b367..2bbe8c6e8a 100755
|
||||
import time
|
||||
|
||||
from urllib.parse import parse_qs
|
||||
@@ -252,6 +253,19 @@ def do_DELETE(self):
|
||||
@@ -252,6 +253,19 @@ class RequestHandler(http_server.BaseHTTPRequestHandler):
|
||||
def run(args):
|
||||
RequestHandler.protocol_version = "HTTP/1.0"
|
||||
httpd = http_server.HTTPServer(("127.0.0.1", 0), RequestHandler)
|
||||
@ -848,11 +861,13 @@ index 13bf50b367..2bbe8c6e8a 100755
|
||||
args = parser.parse_args()
|
||||
|
||||
run(args)
|
||||
--
|
||||
2.47.1
|
||||
|
||||
From 68b3fdcc0b00ee1080a1a3cd15dff33f1de6c0bf Mon Sep 17 00:00:00 2001
|
||||
From: "Owen W. Taylor" <otaylor@fishsoup.net>
|
||||
Date: Fri, 23 Aug 2024 09:48:26 -0400
|
||||
Subject: [PATCH 8/9] common: Implement /etc/containers/certs.d for OCI
|
||||
Subject: [PATCH 08/09] common: Implement /etc/containers/certs.d for OCI
|
||||
registries
|
||||
|
||||
Docker and podman can be configured to use mutual TLS authentication
|
||||
@ -882,7 +897,7 @@ Co-authored-by: Sebastian Wick <sebastian.wick@redhat.com>
|
||||
6 files changed, 440 insertions(+), 36 deletions(-)
|
||||
|
||||
diff --git a/.github/workflows/check.yml b/.github/workflows/check.yml
|
||||
index dbf44c1d4f..6cce2a6f57 100644
|
||||
index dbf44c1d..6cce2a6f 100644
|
||||
--- a/.github/workflows/check.yml
|
||||
+++ b/.github/workflows/check.yml
|
||||
@@ -52,7 +52,7 @@ jobs:
|
||||
@ -895,7 +910,7 @@ index dbf44c1d4f..6cce2a6f57 100644
|
||||
sudo mkdir /tmp/flatpak-com.example.App-OwnedByRoot
|
||||
- name: Check out flatpak
|
||||
diff --git a/common/flatpak-oci-registry.c b/common/flatpak-oci-registry.c
|
||||
index ad595e53f9..6d36de2a16 100644
|
||||
index ad595e53..6d36de2a 100644
|
||||
--- a/common/flatpak-oci-registry.c
|
||||
+++ b/common/flatpak-oci-registry.c
|
||||
@@ -76,7 +76,8 @@ struct FlatpakOciRegistry
|
||||
@ -1137,7 +1152,7 @@ index ad595e53f9..6d36de2a16 100644
|
||||
r, image,
|
||||
cancellable);
|
||||
diff --git a/common/flatpak-utils-http-private.h b/common/flatpak-utils-http-private.h
|
||||
index 2c89ba4032..a930ee793b 100644
|
||||
index 2c89ba40..a930ee79 100644
|
||||
--- a/common/flatpak-utils-http-private.h
|
||||
+++ b/common/flatpak-utils-http-private.h
|
||||
@@ -39,6 +39,15 @@ void flatpak_http_session_free (FlatpakHttpSession* http_session);
|
||||
@ -1181,7 +1196,7 @@ index 2c89ba4032..a930ee793b 100644
|
||||
int dest_dfd,
|
||||
const char *dest_subpath,
|
||||
diff --git a/common/flatpak-utils-http.c b/common/flatpak-utils-http.c
|
||||
index 27de9c7a87..e8d5d724bd 100644
|
||||
index 27de9c7a..e8d5d724 100644
|
||||
--- a/common/flatpak-utils-http.c
|
||||
+++ b/common/flatpak-utils-http.c
|
||||
@@ -73,6 +73,17 @@ G_DEFINE_AUTOPTR_CLEANUP_FUNC (SoupURI, soup_uri_free)
|
||||
@ -1680,7 +1695,7 @@ index 27de9c7a87..e8d5d724bd 100644
|
||||
data.cache_data = cache_data;
|
||||
|
||||
diff --git a/doc/flatpak-remote.xml b/doc/flatpak-remote.xml
|
||||
index 798f5c392c..47a5a42ac4 100644
|
||||
index 798f5c39..47a5a42a 100644
|
||||
--- a/doc/flatpak-remote.xml
|
||||
+++ b/doc/flatpak-remote.xml
|
||||
@@ -80,6 +80,12 @@
|
||||
@ -1697,7 +1712,7 @@ index 798f5c392c..47a5a42ac4 100644
|
||||
</varlistentry>
|
||||
<varlistentry>
|
||||
diff --git a/tests/httpcache.c b/tests/httpcache.c
|
||||
index a4550fb038..f6f9de6461 100644
|
||||
index a4550fb0..f6f9de64 100644
|
||||
--- a/tests/httpcache.c
|
||||
+++ b/tests/httpcache.c
|
||||
@@ -32,7 +32,7 @@ main (int argc, char *argv[])
|
||||
@ -1709,11 +1724,13 @@ index a4550fb038..f6f9de6461 100644
|
||||
flags,
|
||||
AT_FDCWD, dest,
|
||||
NULL, NULL, NULL, &error))
|
||||
--
|
||||
2.47.1
|
||||
|
||||
From cf555f02fcc1cf410fdad7607ff83a6764864a14 Mon Sep 17 00:00:00 2001
|
||||
From: "Owen W. Taylor" <otaylor@fishsoup.net>
|
||||
Date: Tue, 17 Dec 2024 17:47:35 +0100
|
||||
Subject: [PATCH 9/9] tests: Add tests for https OCI remotes
|
||||
Subject: [PATCH 09/09] tests: Add tests for https OCI remotes
|
||||
|
||||
---
|
||||
tests/libtest.sh | 17 +++++--
|
||||
@ -1724,7 +1741,7 @@ Subject: [PATCH 9/9] tests: Add tests for https OCI remotes
|
||||
5 files changed, 101 insertions(+), 20 deletions(-)
|
||||
|
||||
diff --git a/tests/libtest.sh b/tests/libtest.sh
|
||||
index d63810e1b7..7dad594fd2 100644
|
||||
index d63810e1..7dad594f 100644
|
||||
--- a/tests/libtest.sh
|
||||
+++ b/tests/libtest.sh
|
||||
@@ -332,12 +332,16 @@ make_runtime () {
|
||||
@ -1765,7 +1782,7 @@ index d63810e1b7..7dad594fd2 100644
|
||||
|
||||
if ! /bin/kill -0 "$DBUS_SESSION_BUS_PID"; then
|
||||
diff --git a/tests/test-matrix/meson.build b/tests/test-matrix/meson.build
|
||||
index 151760484d..fd0b50345c 100644
|
||||
index 15176048..fd0b5034 100644
|
||||
--- a/tests/test-matrix/meson.build
|
||||
+++ b/tests/test-matrix/meson.build
|
||||
@@ -17,8 +17,10 @@ wrapped_tests += {'name' : 'test-sideload@system.wrap', 'script' : 'test-sideloa
|
||||
@ -1782,7 +1799,7 @@ index 151760484d..fd0b50345c 100644
|
||||
wrapped_tests += {'name' : 'test-update-remote-configuration@oldsummary.wrap', 'script' : 'test-update-remote-configuration.sh'}
|
||||
wrapped_tests += {'name' : 'test-update-portal@user.wrap', 'script' : 'test-update-portal.sh'}
|
||||
diff --git a/tests/test-oci-registry.sh b/tests/test-oci-registry.sh
|
||||
index 12036358fa..da234ded59 100755
|
||||
index 12036358..da234ded 100755
|
||||
--- a/tests/test-oci-registry.sh
|
||||
+++ b/tests/test-oci-registry.sh
|
||||
@@ -27,9 +27,73 @@ echo "1..14"
|
||||
@ -1952,7 +1969,7 @@ index 12036358fa..da234ded59 100755
|
||||
assert_not_has_file $base/oci/hello-origin.index.gz
|
||||
|
||||
diff --git a/tests/test-wrapper.sh b/tests/test-wrapper.sh
|
||||
index be6242562b..2dacc1bc0a 100755
|
||||
index be624256..2dacc1bc 100755
|
||||
--- a/tests/test-wrapper.sh
|
||||
+++ b/tests/test-wrapper.sh
|
||||
@@ -30,6 +30,12 @@ for feature in $(echo $1 | sed "s/^.*@\(.*\).wrap/\1/" | tr "," "\n"); do
|
||||
@ -1969,7 +1986,7 @@ index be6242562b..2dacc1bc0a 100755
|
||||
echo unsupported test feature $feature
|
||||
exit 1
|
||||
diff --git a/tests/update-test-matrix b/tests/update-test-matrix
|
||||
index 2aff6f0029..3a51d0ba6b 100755
|
||||
index 2aff6f00..3a51d0ba 100755
|
||||
--- a/tests/update-test-matrix
|
||||
+++ b/tests/update-test-matrix
|
||||
@@ -23,7 +23,7 @@ TEST_MATRIX_SOURCE=(
|
||||
@ -1981,3 +1998,6 @@ index 2aff6f0029..3a51d0ba6b 100755
|
||||
'tests/test-update-remote-configuration.sh{newsummary+oldsummary}' \
|
||||
'tests/test-override.sh' \
|
||||
'tests/test-update-portal.sh{user+system}' \
|
||||
--
|
||||
2.47.1
|
||||
|
||||
|
@ -1,7 +1,7 @@
|
||||
From 7a2f04dcefd069f4f2086bbd00fc3a1fb98aa921 Mon Sep 17 00:00:00 2001
|
||||
From 74c8d6ee0bf170fbd4accda2d422afde14712408 Mon Sep 17 00:00:00 2001
|
||||
From: "Owen W. Taylor" <otaylor@fishsoup.net>
|
||||
Date: Tue, 29 Oct 2024 17:16:08 -0400
|
||||
Subject: [PATCH 1/2] Don't return a VarRefInfoRef from
|
||||
Subject: [PATCH 01/02] Don't return a VarRefInfoRef from
|
||||
flatpak_remote_state_lookup_ref()
|
||||
|
||||
The memory management of returning a VarRefInfoRef is tricky - it
|
||||
@ -9,10 +9,10 @@ points to data owned by the summary or the sideload repo. External
|
||||
consumers were always retrieving a copy of the summary metadata,
|
||||
so make the public function do that.
|
||||
---
|
||||
common/flatpak-dir-private.h | 14 ++++----
|
||||
common/flatpak-dir.c | 63 ++++++++++++++++++++++++++++--------
|
||||
common/flatpak-transaction.c | 14 +++-----
|
||||
3 files changed, 62 insertions(+), 29 deletions(-)
|
||||
common/flatpak-dir-private.h | 14 ++++-----
|
||||
common/flatpak-dir.c | 61 +++++++++++++++++++++++++++++-------
|
||||
common/flatpak-transaction.c | 14 +++------
|
||||
3 files changed, 61 insertions(+), 28 deletions(-)
|
||||
|
||||
diff --git a/common/flatpak-dir-private.h b/common/flatpak-dir-private.h
|
||||
index 539476b8..3456660b 100644
|
||||
@ -40,7 +40,7 @@ index 539476b8..3456660b 100644
|
||||
FlatpakDecomposed *ref);
|
||||
GFile *flatpak_remote_state_lookup_sideload_checksum (FlatpakRemoteState *self,
|
||||
diff --git a/common/flatpak-dir.c b/common/flatpak-dir.c
|
||||
index 9f398252..583aaccb 100644
|
||||
index 9f398252..99889aa5 100644
|
||||
--- a/common/flatpak-dir.c
|
||||
+++ b/common/flatpak-dir.c
|
||||
@@ -755,14 +755,14 @@ get_summary_for_ref (FlatpakRemoteState *self,
|
||||
@ -66,12 +66,7 @@ index 9f398252..583aaccb 100644
|
||||
{
|
||||
if (!flatpak_remote_state_allow_ref (self, ref))
|
||||
{
|
||||
@@ -818,16 +818,54 @@ flatpak_remote_state_lookup_ref (FlatpakRemoteState *self,
|
||||
{
|
||||
FlatpakSideloadState *ss = NULL;
|
||||
|
||||
- if (!flatpak_remote_state_resolve_sideloaded_ref (self, ref, out_checksum, out_timestamp, out_info, &ss, error))
|
||||
+ if (!flatpak_remote_state_resolve_sideloaded_ref (self, ref, out_checksum, out_timestamp, out_info, &ss, out_image_source, error))
|
||||
@@ -822,12 +822,50 @@ flatpak_remote_state_lookup_ref (FlatpakRemoteState *self,
|
||||
return FALSE;
|
||||
|
||||
if (out_sideload_path)
|
||||
@ -193,10 +188,10 @@ index 1aba1daa..2dd35f53 100644
|
||||
--
|
||||
2.47.1
|
||||
|
||||
From 126a8b7587f9adb55243620fa652489d49ee9e1b Mon Sep 17 00:00:00 2001
|
||||
From 751944405e027daf968741a3fbeec188ccf07ab1 Mon Sep 17 00:00:00 2001
|
||||
From: "Owen W. Taylor" <otaylor@fishsoup.net>
|
||||
Date: Tue, 29 Oct 2024 17:19:38 -0400
|
||||
Subject: [PATCH 2/2] Support sideload repositories for OCI remotes
|
||||
Subject: [PATCH 02/02] Support sideload repositories for OCI remotes
|
||||
|
||||
For OCI remotes, the existing sideload repository system doesn't
|
||||
work: identity for OCI remotes is done by manifest digest (disguised
|
||||
@ -229,7 +224,7 @@ FlatpakImageSource loaded from the image sideload repository.
|
||||
app/flatpak-builtins-utils.h | 6 +
|
||||
common/flatpak-common-types-private.h | 13 +-
|
||||
common/flatpak-dir-private.h | 12 +-
|
||||
common/flatpak-dir.c | 360 +++++++++++++++++-----
|
||||
common/flatpak-dir.c | 362 +++++++++++++++++-----
|
||||
common/flatpak-image-collection-private.h | 50 +++
|
||||
common/flatpak-image-collection.c | 154 +++++++++
|
||||
common/flatpak-image-source-private.h | 7 +
|
||||
@ -240,7 +235,7 @@ FlatpakImageSource loaded from the image sideload repository.
|
||||
doc/flatpak-install.xml | 9 +
|
||||
doc/flatpak-update.xml | 9 +
|
||||
doc/reference/meson.build | 1 +
|
||||
18 files changed, 666 insertions(+), 116 deletions(-)
|
||||
18 files changed, 667 insertions(+), 117 deletions(-)
|
||||
create mode 100644 common/flatpak-image-collection-private.h
|
||||
create mode 100644 common/flatpak-image-collection.c
|
||||
|
||||
@ -476,7 +471,7 @@ index 3456660b..ffcff5ff 100644
|
||||
GError **error);
|
||||
FlatpakDecomposed * flatpak_dir_get_remote_auto_install_authenticator_ref (FlatpakDir *self,
|
||||
diff --git a/common/flatpak-dir.c b/common/flatpak-dir.c
|
||||
index 583aaccb..1c304525 100644
|
||||
index 99889aa5..1c304525 100644
|
||||
--- a/common/flatpak-dir.c
|
||||
+++ b/common/flatpak-dir.c
|
||||
@@ -52,6 +52,7 @@
|
||||
@ -716,6 +711,15 @@ index 583aaccb..1c304525 100644
|
||||
|
||||
if (out_info)
|
||||
*out_info = info;
|
||||
@@ -818,7 +908,7 @@ flatpak_remote_state_lookup_ref_internal (FlatpakRemoteState *self,
|
||||
{
|
||||
FlatpakSideloadState *ss = NULL;
|
||||
|
||||
- if (!flatpak_remote_state_resolve_sideloaded_ref (self, ref, out_checksum, out_timestamp, out_info, &ss, error))
|
||||
+ if (!flatpak_remote_state_resolve_sideloaded_ref (self, ref, out_checksum, out_timestamp, out_info, &ss, out_image_source, error))
|
||||
return FALSE;
|
||||
|
||||
if (out_sideload_path)
|
||||
@@ -843,17 +933,26 @@ flatpak_remote_state_lookup_ref (FlatpakRemoteState *self,
|
||||
guint64 *out_timestamp,
|
||||
GVariant **out_summary_metadata,
|
||||
|
18
flatpak.spec
18
flatpak.spec
@ -12,7 +12,7 @@
|
||||
|
||||
Name: flatpak
|
||||
Version: 1.16.0
|
||||
Release: 1%{?dist}
|
||||
Release: 2%{?dist}
|
||||
Summary: Application deployment framework for desktop apps
|
||||
|
||||
License: LGPL-2.1-or-later
|
||||
@ -28,18 +28,18 @@ Source1: flatpak-add-fedora-repos.service
|
||||
# with the config from upstream sources.
|
||||
Source2: flatpak.sysusers.conf
|
||||
|
||||
# Add support for preinstalling flatpaks
|
||||
# https://github.com/flatpak/flatpak/pull/5832
|
||||
Patch0: flatpak-add-support-for-preinstalling-flatpaks.patch
|
||||
# Implement /etc/containers/certs.d for OCI registries
|
||||
# https://github.com/flatpak/flatpak/pull/5916
|
||||
Patch1: flatpak-implement-etc-containers-certs-for-oci-registries.patch
|
||||
Patch0: flatpak-implement-etc-containers-certs-for-oci-registries.patch
|
||||
# Allow direct installation from OCI images
|
||||
# https://github.com/flatpak/flatpak/pull/5972
|
||||
Patch2: flatpak-allow-direct-installation-from-oci-images.patch
|
||||
Patch1: flatpak-allow-direct-installation-from-oci-images.patch
|
||||
# Support sideload repositories for OCI remotes
|
||||
# https://github.com/owtaylor/flatpak/commits/oci-sideload
|
||||
Patch3: flatpak-support-sideload-repositories-for-oci-remotes.patch
|
||||
Patch2: flatpak-support-sideload-repositories-for-oci-remotes.patch
|
||||
# Add support for preinstalling flatpaks
|
||||
# https://github.com/flatpak/flatpak/pull/5832
|
||||
Patch3: flatpak-add-support-for-preinstalling-flatpaks.patch
|
||||
|
||||
# ostree not on i686 for RHEL 10
|
||||
# https://github.com/containers/composefs/pull/229#issuecomment-1838735764
|
||||
@ -309,6 +309,10 @@ fi
|
||||
|
||||
|
||||
%changelog
|
||||
* Fri Jan 17 2025 Jan Grulich <jgrulich@redhat.com> - 1.16.0-2
|
||||
- Rebase backported upstream patches to updated versions
|
||||
Resolves: RHEL-26066
|
||||
|
||||
* Mon Jan 13 2025 Jan Grulich <jgrulich@redhat.com> - 1.16.0-1
|
||||
- Update to 1.16.0
|
||||
Resolves: RHEL-72779
|
||||
|
Loading…
Reference in New Issue
Block a user