Update to 0.6.10
This commit is contained in:
parent
1291526305
commit
9007b2ca02
1
.gitignore
vendored
1
.gitignore
vendored
@ -6,3 +6,4 @@
|
|||||||
/flatpak-0.6.7.tar.xz
|
/flatpak-0.6.7.tar.xz
|
||||||
/flatpak-0.6.8.tar.xz
|
/flatpak-0.6.8.tar.xz
|
||||||
/flatpak-0.6.9.tar.xz
|
/flatpak-0.6.9.tar.xz
|
||||||
|
/flatpak-0.6.10.tar.xz
|
||||||
|
@ -1,24 +0,0 @@
|
|||||||
From 983b2a5db124a44d86f8e6577763df8544d73838 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Alexander Larsson <alexl@redhat.com>
|
|
||||||
Date: Tue, 6 Sep 2016 15:28:26 +0200
|
|
||||||
Subject: [PATCH] lib: Look for "bwrap" in PATH when launching from libflatpak
|
|
||||||
|
|
||||||
We forgot to look in the path, which made it fail when using
|
|
||||||
the system bwrap and not passing a full path.
|
|
||||||
---
|
|
||||||
common/flatpak-run.c | 2 +-
|
|
||||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
||||||
|
|
||||||
diff --git a/common/flatpak-run.c b/common/flatpak-run.c
|
|
||||||
index 1c06574..8e63a62 100644
|
|
||||||
--- a/common/flatpak-run.c
|
|
||||||
+++ b/common/flatpak-run.c
|
|
||||||
@@ -3413,7 +3413,7 @@ flatpak_run_app (const char *app_ref,
|
|
||||||
if (!g_spawn_async (NULL,
|
|
||||||
(char **) real_argv_array->pdata,
|
|
||||||
envp,
|
|
||||||
- G_SPAWN_DEFAULT,
|
|
||||||
+ G_SPAWN_SEARCH_PATH,
|
|
||||||
child_setup, fd_array,
|
|
||||||
NULL,
|
|
||||||
error))
|
|
16
flatpak.spec
16
flatpak.spec
@ -1,14 +1,12 @@
|
|||||||
Name: flatpak
|
Name: flatpak
|
||||||
Version: 0.6.9
|
Version: 0.6.10
|
||||||
Release: 2%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: Application deployment framework for desktop apps
|
Summary: Application deployment framework for desktop apps
|
||||||
|
|
||||||
Group: Development/Tools
|
Group: Development/Tools
|
||||||
License: LGPLv2+
|
License: LGPLv2+
|
||||||
URL: http://flatpak.org/
|
URL: http://flatpak.org/
|
||||||
Source0: https://github.com/flatpak/flatpak/releases/download/%{version}/%{name}-%{version}.tar.xz
|
Source0: https://github.com/flatpak/flatpak/releases/download/%{version}/%{name}-%{version}.tar.xz
|
||||||
# Taken from upstream git.
|
|
||||||
Patch0: flatpak-0.6.9-look-up-bwrap-in-path.patch
|
|
||||||
|
|
||||||
BuildRequires: pkgconfig(fuse)
|
BuildRequires: pkgconfig(fuse)
|
||||||
BuildRequires: pkgconfig(gio-unix-2.0)
|
BuildRequires: pkgconfig(gio-unix-2.0)
|
||||||
@ -17,7 +15,7 @@ BuildRequires: pkgconfig(json-glib-1.0)
|
|||||||
BuildRequires: pkgconfig(libarchive) >= 2.8.0
|
BuildRequires: pkgconfig(libarchive) >= 2.8.0
|
||||||
BuildRequires: pkgconfig(libelf) >= 0.8.12
|
BuildRequires: pkgconfig(libelf) >= 0.8.12
|
||||||
BuildRequires: pkgconfig(libsoup-2.4)
|
BuildRequires: pkgconfig(libsoup-2.4)
|
||||||
BuildRequires: pkgconfig(ostree-1) >= 2016.7
|
BuildRequires: pkgconfig(ostree-1) >= 2016.10
|
||||||
BuildRequires: pkgconfig(polkit-gobject-1)
|
BuildRequires: pkgconfig(polkit-gobject-1)
|
||||||
BuildRequires: pkgconfig(libseccomp)
|
BuildRequires: pkgconfig(libseccomp)
|
||||||
BuildRequires: pkgconfig(xau)
|
BuildRequires: pkgconfig(xau)
|
||||||
@ -39,7 +37,7 @@ Requires: kernel >= 4.0.4-202
|
|||||||
# Needed for the document portal.
|
# Needed for the document portal.
|
||||||
Requires: /usr/bin/fusermount
|
Requires: /usr/bin/fusermount
|
||||||
|
|
||||||
Requires: /usr/bin/bwrap
|
Requires: bubblewrap >= 0.1.2
|
||||||
|
|
||||||
# Remove in F27.
|
# Remove in F27.
|
||||||
Provides: xdg-app = %{version}-%{release}
|
Provides: xdg-app = %{version}-%{release}
|
||||||
@ -86,7 +84,7 @@ This package contains the pkg-config file and development headers for %{name}.
|
|||||||
Summary: Libraries for %{name}
|
Summary: Libraries for %{name}
|
||||||
Group: Development/Libraries
|
Group: Development/Libraries
|
||||||
License: LGPLv2+
|
License: LGPLv2+
|
||||||
Requires: /usr/bin/bwrap
|
Requires: bubblewrap >= 0.1.2
|
||||||
# Remove in F27.
|
# Remove in F27.
|
||||||
Provides: xdg-app-libs%{?_isa} = %{version}-%{release}
|
Provides: xdg-app-libs%{?_isa} = %{version}-%{release}
|
||||||
Obsoletes: xdg-app-libs <= 0.5.2-2
|
Obsoletes: xdg-app-libs <= 0.5.2-2
|
||||||
@ -97,7 +95,6 @@ This package contains libflatpak.
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
%patch0 -p1
|
|
||||||
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
@ -182,6 +179,9 @@ flatpak remote-list --system
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Sep 12 2016 David King <amigadave@amigadave.com> - 0.6.10-1
|
||||||
|
- Update to 0.6.10
|
||||||
|
|
||||||
* Tue Sep 06 2016 David King <amigadave@amigadave.com> - 0.6.9-2
|
* Tue Sep 06 2016 David King <amigadave@amigadave.com> - 0.6.9-2
|
||||||
- Look for bwrap in PATH
|
- Look for bwrap in PATH
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user