Update to 0.9.8
This commit is contained in:
parent
d4f89b08dd
commit
8645083bf6
1
.gitignore
vendored
1
.gitignore
vendored
@ -22,3 +22,4 @@
|
||||
/flatpak-0.9.5.tar.xz
|
||||
/flatpak-0.9.6.tar.xz
|
||||
/flatpak-0.9.7.tar.xz
|
||||
/flatpak-0.9.8.tar.xz
|
||||
|
@ -1,64 +0,0 @@
|
||||
From 0853089457a3e2ca343ea467dfc703bf99c416b9 Mon Sep 17 00:00:00 2001
|
||||
From: "Owen W. Taylor" <otaylor@fishsoup.net>
|
||||
Date: Thu, 6 Jul 2017 17:07:08 -0400
|
||||
Subject: [PATCH] OCI: Update org.opencontainers.ref.name to
|
||||
org.opencontainers.image.ref.name
|
||||
|
||||
This annotation was changed in later versions of the OCI Image specification.
|
||||
(See https://github.com/projectatomic/skopeo/issues/369#issuecomment-310158211)
|
||||
---
|
||||
common/flatpak-json-oci.c | 10 +++++-----
|
||||
1 file changed, 5 insertions(+), 5 deletions(-)
|
||||
|
||||
diff --git a/common/flatpak-json-oci.c b/common/flatpak-json-oci.c
|
||||
index a64a0e0..718e0dc 100644
|
||||
--- a/common/flatpak-json-oci.c
|
||||
+++ b/common/flatpak-json-oci.c
|
||||
@@ -426,7 +426,7 @@ flatpak_oci_index_add_manifest (FlatpakOciIndex *self,
|
||||
int count;
|
||||
|
||||
if (desc->annotations != NULL)
|
||||
- m_ref = g_hash_table_lookup (desc->annotations, "org.opencontainers.ref.name");
|
||||
+ m_ref = g_hash_table_lookup (desc->annotations, "org.opencontainers.image.ref.name");
|
||||
|
||||
if (m_ref != NULL)
|
||||
flatpak_oci_index_remove_manifest (self, m_ref);
|
||||
@@ -449,7 +449,7 @@ flatpak_oci_manifest_descriptor_get_ref (FlatpakOciManifestDescriptor *m)
|
||||
if (m->parent.annotations == NULL)
|
||||
return NULL;
|
||||
|
||||
- return g_hash_table_lookup (m->parent.annotations, "org.opencontainers.ref.name");
|
||||
+ return g_hash_table_lookup (m->parent.annotations, "org.opencontainers.image.ref.name");
|
||||
}
|
||||
|
||||
static int
|
||||
@@ -703,7 +703,7 @@ flatpak_oci_export_annotations (GHashTable *source,
|
||||
GHashTable *dest)
|
||||
{
|
||||
const char *keys[] = {
|
||||
- "org.opencontainers.ref.name",
|
||||
+ "org.opencontainers.image.ref.name",
|
||||
"org.flatpak.installed-size",
|
||||
"org.flatpak.download-size",
|
||||
"org.flatpak.metadata",
|
||||
@@ -750,7 +750,7 @@ flatpak_oci_add_annotations_for_commit (GHashTable *annotations,
|
||||
GVariant *commit_data)
|
||||
{
|
||||
if (ref)
|
||||
- add_annotation (annotations,"org.opencontainers.ref.name", ref);
|
||||
+ add_annotation (annotations,"org.opencontainers.image.ref.name", ref);
|
||||
|
||||
if (commit)
|
||||
add_annotation (annotations,"org.flatpak.commit", commit);
|
||||
@@ -809,7 +809,7 @@ flatpak_oci_parse_commit_annotations (GHashTable *annotations,
|
||||
GHashTableIter iter;
|
||||
gpointer _key, _value;
|
||||
|
||||
- oci_ref = g_hash_table_lookup (annotations, "org.opencontainers.ref.name");
|
||||
+ oci_ref = g_hash_table_lookup (annotations, "org.opencontainers.image.ref.name");
|
||||
if (oci_ref != NULL && out_ref != NULL && *out_ref == NULL)
|
||||
*out_ref = g_strdup (oci_ref);
|
||||
|
||||
--
|
||||
2.13.0
|
||||
|
24
flatpak.spec
24
flatpak.spec
@ -1,9 +1,9 @@
|
||||
%global bubblewrap_version 0.1.8
|
||||
%global ostree_version 2017.7
|
||||
%global ostree_version 2017.10
|
||||
|
||||
Name: flatpak
|
||||
Version: 0.9.7
|
||||
Release: 5%{?dist}
|
||||
Version: 0.9.8
|
||||
Release: 1%{?dist}
|
||||
Summary: Application deployment framework for desktop apps
|
||||
|
||||
Group: Development/Tools
|
||||
@ -11,8 +11,6 @@ License: LGPLv2+
|
||||
URL: http://flatpak.org/
|
||||
Source0: https://github.com/flatpak/flatpak/releases/download/%{version}/%{name}-%{version}.tar.xz
|
||||
|
||||
Patch0: OCI-Update-org.opencontainers.ref.name-to-org.openco.patch
|
||||
|
||||
BuildRequires: pkgconfig(fuse)
|
||||
BuildRequires: pkgconfig(gio-unix-2.0)
|
||||
BuildRequires: pkgconfig(gobject-introspection-1.0) >= 1.40.0
|
||||
@ -47,10 +45,6 @@ Requires: /usr/bin/fusermount
|
||||
Requires: bubblewrap >= %{bubblewrap_version}
|
||||
Requires: ostree-libs%{?_isa} >= %{ostree_version}
|
||||
|
||||
# Remove in F27.
|
||||
Provides: xdg-app = %{version}-%{release}
|
||||
Obsoletes: xdg-app <= 0.5.2-2
|
||||
|
||||
%description
|
||||
flatpak is a system for building, distributing and running sandboxed desktop
|
||||
applications on Linux. See https://wiki.gnome.org/Projects/SandboxedApps for
|
||||
@ -70,9 +64,6 @@ Requires: /usr/bin/tar
|
||||
Requires: /usr/bin/unzip
|
||||
# For debuginfo.
|
||||
Requires: /usr/bin/eu-strip
|
||||
# Remove in F27.
|
||||
Provides: xdg-app-builder = %{version}-%{release}
|
||||
Obsoletes: xdg-app-builder <= 0.5.2-2
|
||||
|
||||
%description builder
|
||||
flatpak-builder is a tool that makes it easy to build applications and their
|
||||
@ -84,9 +75,6 @@ Group: Development/Libraries
|
||||
License: LGPLv2+
|
||||
Requires: %{name}%{?_isa} = %{version}-%{release}
|
||||
Requires: %{name}-libs%{?_isa} = %{version}-%{release}
|
||||
# Remove in F27.
|
||||
Provides: xdg-app-devel%{?_isa} = %{version}-%{release}
|
||||
Obsoletes: xdg-app-devel <= 0.5.2-2
|
||||
|
||||
%description devel
|
||||
This package contains the pkg-config file and development headers for %{name}.
|
||||
@ -97,9 +85,6 @@ Group: Development/Libraries
|
||||
License: LGPLv2+
|
||||
Requires: bubblewrap >= %{bubblewrap_version}
|
||||
Requires: ostree%{?_isa} >= %{ostree_version}
|
||||
# Remove in F27.
|
||||
Provides: xdg-app-libs%{?_isa} = %{version}-%{release}
|
||||
Obsoletes: xdg-app-libs <= 0.5.2-2
|
||||
|
||||
%description libs
|
||||
This package contains libflatpak.
|
||||
@ -199,6 +184,9 @@ flatpak remote-list --system &> /dev/null || :
|
||||
|
||||
|
||||
%changelog
|
||||
* Mon Aug 21 2017 David King <amigadave@amigadave.com> - 0.9.8-1
|
||||
- Update to 0.9.8
|
||||
|
||||
* Wed Aug 02 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.9.7-5
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (flatpak-0.9.7.tar.xz) = 0510e3b58bd3b4239c2eafa9f6776e1489bc0def3e27a8dd1c1aa4f8244e82431b4448cd9e980bbb04dd6c04a1880a97f4913929eb3b73679865e2f5fdb65706
|
||||
SHA512 (flatpak-0.9.8.tar.xz) = c371a919f33c2b09a4d0b5de52d79a62e0c49113ac21c5c284887febc9f878eb7c4eb1f2513989f85e2b4e2f28cac1747401d93599d0fdc61eafe6432f6bd815
|
||||
|
Loading…
Reference in New Issue
Block a user