Update to 1.4.1
This commit is contained in:
parent
842e7bdf8a
commit
6d5bdff69b
1
.gitignore
vendored
1
.gitignore
vendored
@ -69,3 +69,4 @@
|
|||||||
/flatpak-1.3.3.tar.xz
|
/flatpak-1.3.3.tar.xz
|
||||||
/flatpak-1.3.4.tar.xz
|
/flatpak-1.3.4.tar.xz
|
||||||
/flatpak-1.4.0.tar.xz
|
/flatpak-1.4.0.tar.xz
|
||||||
|
/flatpak-1.4.1.tar.xz
|
||||||
|
@ -1,68 +0,0 @@
|
|||||||
From 1029f2b1d05bf96eb6083b5879c31997fd1d53be Mon Sep 17 00:00:00 2001
|
|
||||||
From: Alexander Larsson <alexl@redhat.com>
|
|
||||||
Date: Wed, 12 Jun 2019 08:15:37 +0200
|
|
||||||
Subject: [PATCH] transaction: Add back support for file: uris in RuntimeRepo
|
|
||||||
keys
|
|
||||||
|
|
||||||
This used to work, and the gnome-software test suite relies on it,
|
|
||||||
so add it back. I believe it regressed in
|
|
||||||
https://github.com/flatpak/flatpak/pull/2740
|
|
||||||
|
|
||||||
This fixes https://github.com/flatpak/flatpak/issues/2955
|
|
||||||
|
|
||||||
Closes: #2956
|
|
||||||
Approved by: alexlarsson
|
|
||||||
---
|
|
||||||
common/flatpak-transaction.c | 34 +++++++++++++++++++++++++++-------
|
|
||||||
1 file changed, 27 insertions(+), 7 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/common/flatpak-transaction.c b/common/flatpak-transaction.c
|
|
||||||
index 849455ca..e4a42dfc 100644
|
|
||||||
--- a/common/flatpak-transaction.c
|
|
||||||
+++ b/common/flatpak-transaction.c
|
|
||||||
@@ -2618,15 +2618,35 @@ handle_runtime_repo_deps (FlatpakTransaction *self,
|
|
||||||
if (priv->disable_deps)
|
|
||||||
return TRUE;
|
|
||||||
|
|
||||||
- if (!g_str_has_prefix (dep_url, "http:") && !g_str_has_prefix (dep_url, "https:"))
|
|
||||||
- return flatpak_fail_error (error, FLATPAK_ERROR_INVALID_DATA, _("Flatpakrepo URL %s not HTTP or HTTPS"), dep_url);
|
|
||||||
|
|
||||||
- soup_session = flatpak_create_soup_session (PACKAGE_STRING);
|
|
||||||
- dep_data = flatpak_load_http_uri (soup_session, dep_url, 0, NULL, NULL, cancellable, error);
|
|
||||||
- if (dep_data == NULL)
|
|
||||||
+ if (g_str_has_prefix (dep_url, "file:"))
|
|
||||||
{
|
|
||||||
- g_prefix_error (error, "Can't load dependent file %s", dep_url);
|
|
||||||
- return FALSE;
|
|
||||||
+ g_autoptr(GFile) file = NULL;
|
|
||||||
+ g_autofree char *data = NULL;
|
|
||||||
+ gsize data_len;
|
|
||||||
+
|
|
||||||
+ file = g_file_new_for_uri (dep_url);
|
|
||||||
+
|
|
||||||
+ if (!g_file_load_contents (file, cancellable, &data, &data_len, NULL, error))
|
|
||||||
+ {
|
|
||||||
+ g_prefix_error (error, "Can't load dependent file %s", dep_url);
|
|
||||||
+ return FALSE;
|
|
||||||
+ }
|
|
||||||
+
|
|
||||||
+ dep_data = g_bytes_new_take (g_steal_pointer (&data), data_len);
|
|
||||||
+ }
|
|
||||||
+ else
|
|
||||||
+ {
|
|
||||||
+ if (!g_str_has_prefix (dep_url, "http:") && !g_str_has_prefix (dep_url, "https:"))
|
|
||||||
+ return flatpak_fail_error (error, FLATPAK_ERROR_INVALID_DATA, _("Flatpakrepo URL %s not HTTP or HTTPS"), dep_url);
|
|
||||||
+
|
|
||||||
+ soup_session = flatpak_create_soup_session (PACKAGE_STRING);
|
|
||||||
+ dep_data = flatpak_load_http_uri (soup_session, dep_url, 0, NULL, NULL, cancellable, error);
|
|
||||||
+ if (dep_data == NULL)
|
|
||||||
+ {
|
|
||||||
+ g_prefix_error (error, "Can't load dependent file %s", dep_url);
|
|
||||||
+ return FALSE;
|
|
||||||
+ }
|
|
||||||
}
|
|
||||||
|
|
||||||
if (!g_key_file_load_from_data (dep_keyfile,
|
|
||||||
--
|
|
||||||
2.21.0
|
|
||||||
|
|
10
flatpak.spec
10
flatpak.spec
@ -2,8 +2,8 @@
|
|||||||
%global ostree_version 2018.9
|
%global ostree_version 2018.9
|
||||||
|
|
||||||
Name: flatpak
|
Name: flatpak
|
||||||
Version: 1.4.0
|
Version: 1.4.1
|
||||||
Release: 2%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: Application deployment framework for desktop apps
|
Summary: Application deployment framework for desktop apps
|
||||||
|
|
||||||
License: LGPLv2+
|
License: LGPLv2+
|
||||||
@ -12,9 +12,6 @@ Source0: https://github.com/flatpak/flatpak/releases/download/%{version}/
|
|||||||
# Add Fedora flatpak repositories
|
# Add Fedora flatpak repositories
|
||||||
Source1: flatpak-add-fedora-repos.service
|
Source1: flatpak-add-fedora-repos.service
|
||||||
|
|
||||||
# Backported from upstream
|
|
||||||
Patch0: 0001-transaction-Add-back-support-for-file-uris-in-Runtim.patch
|
|
||||||
|
|
||||||
BuildRequires: pkgconfig(appstream-glib)
|
BuildRequires: pkgconfig(appstream-glib)
|
||||||
BuildRequires: pkgconfig(dconf)
|
BuildRequires: pkgconfig(dconf)
|
||||||
BuildRequires: pkgconfig(fuse)
|
BuildRequires: pkgconfig(fuse)
|
||||||
@ -249,6 +246,9 @@ fi
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Jun 13 2019 Kalev Lember <klember@redhat.com> - 1.4.1-1
|
||||||
|
- Update to 1.4.1
|
||||||
|
|
||||||
* Wed Jun 12 2019 Kalev Lember <klember@redhat.com> - 1.4.0-2
|
* Wed Jun 12 2019 Kalev Lember <klember@redhat.com> - 1.4.0-2
|
||||||
- Backport an upstream patch to fix gnome-software CI
|
- Backport an upstream patch to fix gnome-software CI
|
||||||
|
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (flatpak-1.4.0.tar.xz) = 13348da9975dd4c5d354330919ca5076862d02ceb4e3ea1f5fdfc3af3b4f6cab025821f35d255a1ab773c7bc4adc27a194bd330adf853108ec6c963d597a9296
|
SHA512 (flatpak-1.4.1.tar.xz) = a3638e72e7ae3af914786be31e3be9fca7289e31201d29dea3161f41aa0fb696702e1ba002508eefbae2276c3c1478efc65d9a3c82e12747f7e1865968e19f9f
|
||||||
|
Loading…
Reference in New Issue
Block a user