Update to 1.11.1 (#1953833)
This commit is contained in:
parent
89da895a64
commit
3f2d8c56c2
1
.gitignore
vendored
1
.gitignore
vendored
@ -92,3 +92,4 @@
|
||||
/flatpak-1.10.0.tar.xz
|
||||
/flatpak-1.10.1.tar.xz
|
||||
/flatpak-1.10.2.tar.xz
|
||||
/flatpak-1.11.1.tar.xz
|
||||
|
@ -1,34 +0,0 @@
|
||||
From adbd286cef9a4c4bed76eb95337d5d6f5e42dd45 Mon Sep 17 00:00:00 2001
|
||||
From: Kalev Lember <klember@redhat.com>
|
||||
Date: Mon, 5 Apr 2021 10:40:26 +0200
|
||||
Subject: [PATCH] OCI: Switch to pax format for tar archives
|
||||
|
||||
For reasons unknown, libarchive appears to generate broken gnutar format
|
||||
tar archives when the archive contains files that are larger than 2 GB.
|
||||
This commit switches to the pax format to work this around.
|
||||
|
||||
This should be a better default as it also removes 256 char filename
|
||||
length limitation and matches what other libraries are doing, e.g.
|
||||
Python 3.8 switched to the pax format by default as well.
|
||||
|
||||
See https://pagure.io/fedora-infrastructure/issue/9840
|
||||
---
|
||||
common/flatpak-oci-registry.c | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/common/flatpak-oci-registry.c b/common/flatpak-oci-registry.c
|
||||
index 6aa68c27..2a7f3ba1 100644
|
||||
--- a/common/flatpak-oci-registry.c
|
||||
+++ b/common/flatpak-oci-registry.c
|
||||
@@ -1476,7 +1476,7 @@ flatpak_oci_registry_write_layer (FlatpakOciRegistry *self,
|
||||
}
|
||||
|
||||
a = archive_write_new ();
|
||||
- if (archive_write_set_format_gnutar (a) != ARCHIVE_OK ||
|
||||
+ if (archive_write_set_format_pax (a) != ARCHIVE_OK ||
|
||||
archive_write_add_filter_none (a) != ARCHIVE_OK)
|
||||
{
|
||||
propagate_libarchive_error (error, a);
|
||||
--
|
||||
2.30.2
|
||||
|
11
flatpak.spec
11
flatpak.spec
@ -2,8 +2,8 @@
|
||||
%global ostree_version 2020.8
|
||||
|
||||
Name: flatpak
|
||||
Version: 1.10.2
|
||||
Release: 3%{?dist}
|
||||
Version: 1.11.1
|
||||
Release: 1%{?dist}
|
||||
Summary: Application deployment framework for desktop apps
|
||||
|
||||
License: LGPLv2+
|
||||
@ -12,10 +12,6 @@ Source0: https://github.com/flatpak/flatpak/releases/download/%{version}/
|
||||
# Add Fedora flatpak repositories
|
||||
Source1: flatpak-add-fedora-repos.service
|
||||
|
||||
# https://github.com/flatpak/flatpak/pull/4210
|
||||
# https://pagure.io/fedora-infrastructure/issue/9840
|
||||
Patch0: 0001-OCI-Switch-to-pax-format-for-tar-archives.patch
|
||||
|
||||
BuildRequires: pkgconfig(appstream-glib)
|
||||
BuildRequires: pkgconfig(dconf)
|
||||
BuildRequires: pkgconfig(fuse)
|
||||
@ -268,6 +264,9 @@ fi
|
||||
|
||||
|
||||
%changelog
|
||||
* Tue Apr 27 2021 David King <amigadave@amigadave.com> - 1.11.1-1
|
||||
- Update to 1.11.1 (#1953833)
|
||||
|
||||
* Wed Apr 14 2021 Kalev Lember <klember@redhat.com> - 1.10.2-3
|
||||
- Disable system env generator to work around selinux denials (#1947214)
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (flatpak-1.10.2.tar.xz) = c932b9aa2803aa5b453917174bf282d82924aca7341d72555e2557fc588ccefa0eaf32b956f75752c17cd8f73b687d4a688ebd64df36680b80b5ff5750468597
|
||||
SHA512 (flatpak-1.11.1.tar.xz) = 0121b4fcf159311c7480d1be29cd169a39ae61fcea9532f25b266b585038a07a930ff418a9c5b9645aab2510de78ad32c8ae8556991c8d2d7c08ab1e3cc819d1
|
||||
|
Loading…
Reference in New Issue
Block a user