Update to 0.9.10
- Split out flatpak-builder to a separate source package
This commit is contained in:
parent
e31ddd3479
commit
2e0b49bebf
1
.gitignore
vendored
1
.gitignore
vendored
@ -23,3 +23,4 @@
|
|||||||
/flatpak-0.9.6.tar.xz
|
/flatpak-0.9.6.tar.xz
|
||||||
/flatpak-0.9.7.tar.xz
|
/flatpak-0.9.7.tar.xz
|
||||||
/flatpak-0.9.8.tar.xz
|
/flatpak-0.9.8.tar.xz
|
||||||
|
/flatpak-0.9.10.tar.xz
|
||||||
|
@ -1,27 +0,0 @@
|
|||||||
From 2a661fd448a153992e07904b666ef4fb748810a3 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Alexander Larsson <alexl@redhat.com>
|
|
||||||
Date: Fri, 25 Aug 2017 14:37:57 +0200
|
|
||||||
Subject: [PATCH] Fix regression in --devel
|
|
||||||
|
|
||||||
Commit 489bfddfb mistakenly ended a line with a comma instead of a semicolon which
|
|
||||||
caused --devel to break.
|
|
||||||
---
|
|
||||||
common/flatpak-run.c | 2 +-
|
|
||||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
||||||
|
|
||||||
diff --git a/common/flatpak-run.c b/common/flatpak-run.c
|
|
||||||
index 390a7751..a36c2e98 100644
|
|
||||||
--- a/common/flatpak-run.c
|
|
||||||
+++ b/common/flatpak-run.c
|
|
||||||
@@ -4641,7 +4641,7 @@ flatpak_run_app (const char *app_ref,
|
|
||||||
if ((flags & FLATPAK_RUN_FLAG_DEVEL) != 0)
|
|
||||||
key = FLATPAK_METADATA_KEY_SDK;
|
|
||||||
else
|
|
||||||
- key = FLATPAK_METADATA_KEY_RUNTIME,
|
|
||||||
+ key = FLATPAK_METADATA_KEY_RUNTIME;
|
|
||||||
|
|
||||||
metakey = flatpak_deploy_get_metadata (app_deploy);
|
|
||||||
default_runtime = g_key_file_get_string (metakey,
|
|
||||||
--
|
|
||||||
2.13.0
|
|
||||||
|
|
43
flatpak.spec
43
flatpak.spec
@ -2,8 +2,8 @@
|
|||||||
%global ostree_version 2017.10
|
%global ostree_version 2017.10
|
||||||
|
|
||||||
Name: flatpak
|
Name: flatpak
|
||||||
Version: 0.9.8
|
Version: 0.9.10
|
||||||
Release: 2%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: Application deployment framework for desktop apps
|
Summary: Application deployment framework for desktop apps
|
||||||
|
|
||||||
Group: Development/Tools
|
Group: Development/Tools
|
||||||
@ -11,15 +11,11 @@ License: LGPLv2+
|
|||||||
URL: http://flatpak.org/
|
URL: http://flatpak.org/
|
||||||
Source0: https://github.com/flatpak/flatpak/releases/download/%{version}/%{name}-%{version}.tar.xz
|
Source0: https://github.com/flatpak/flatpak/releases/download/%{version}/%{name}-%{version}.tar.xz
|
||||||
|
|
||||||
# Backported from upstream
|
|
||||||
Patch0: 0001-Fix-regression-in-devel.patch
|
|
||||||
|
|
||||||
BuildRequires: pkgconfig(fuse)
|
BuildRequires: pkgconfig(fuse)
|
||||||
BuildRequires: pkgconfig(gio-unix-2.0)
|
BuildRequires: pkgconfig(gio-unix-2.0)
|
||||||
BuildRequires: pkgconfig(gobject-introspection-1.0) >= 1.40.0
|
BuildRequires: pkgconfig(gobject-introspection-1.0) >= 1.40.0
|
||||||
BuildRequires: pkgconfig(json-glib-1.0)
|
BuildRequires: pkgconfig(json-glib-1.0)
|
||||||
BuildRequires: pkgconfig(libarchive) >= 2.8.0
|
BuildRequires: pkgconfig(libarchive) >= 2.8.0
|
||||||
BuildRequires: pkgconfig(libelf) >= 0.8.12
|
|
||||||
BuildRequires: pkgconfig(libsoup-2.4)
|
BuildRequires: pkgconfig(libsoup-2.4)
|
||||||
BuildRequires: pkgconfig(libxml-2.0) >= 2.4
|
BuildRequires: pkgconfig(libxml-2.0) >= 2.4
|
||||||
BuildRequires: pkgconfig(ostree-1) >= %{ostree_version}
|
BuildRequires: pkgconfig(ostree-1) >= %{ostree_version}
|
||||||
@ -29,11 +25,9 @@ BuildRequires: pkgconfig(xau)
|
|||||||
BuildRequires: bubblewrap >= %{bubblewrap_version}
|
BuildRequires: bubblewrap >= %{bubblewrap_version}
|
||||||
BuildRequires: docbook-dtds
|
BuildRequires: docbook-dtds
|
||||||
BuildRequires: docbook-style-xsl
|
BuildRequires: docbook-style-xsl
|
||||||
|
BuildRequires: gettext
|
||||||
BuildRequires: gpgme-devel
|
BuildRequires: gpgme-devel
|
||||||
BuildRequires: intltool
|
|
||||||
BuildRequires: libattr-devel
|
|
||||||
BuildRequires: libcap-devel
|
BuildRequires: libcap-devel
|
||||||
BuildRequires: libdwarf-devel
|
|
||||||
BuildRequires: systemd
|
BuildRequires: systemd
|
||||||
BuildRequires: /usr/bin/xmlto
|
BuildRequires: /usr/bin/xmlto
|
||||||
BuildRequires: /usr/bin/xsltproc
|
BuildRequires: /usr/bin/xsltproc
|
||||||
@ -53,25 +47,6 @@ flatpak is a system for building, distributing and running sandboxed desktop
|
|||||||
applications on Linux. See https://wiki.gnome.org/Projects/SandboxedApps for
|
applications on Linux. See https://wiki.gnome.org/Projects/SandboxedApps for
|
||||||
more information.
|
more information.
|
||||||
|
|
||||||
%package builder
|
|
||||||
Summary: Build helper for %{name}
|
|
||||||
Group: Development/Tools
|
|
||||||
License: LGPLv2+
|
|
||||||
Requires: %{name}%{?_isa} = %{version}-%{release}
|
|
||||||
Requires: /usr/bin/bzip2
|
|
||||||
Requires: /usr/bin/bzr
|
|
||||||
Requires: /usr/bin/git
|
|
||||||
Requires: /usr/bin/patch
|
|
||||||
Requires: /usr/bin/strip
|
|
||||||
Requires: /usr/bin/tar
|
|
||||||
Requires: /usr/bin/unzip
|
|
||||||
# For debuginfo.
|
|
||||||
Requires: /usr/bin/eu-strip
|
|
||||||
|
|
||||||
%description builder
|
|
||||||
flatpak-builder is a tool that makes it easy to build applications and their
|
|
||||||
dependencies by automating the configure && make && make install steps.
|
|
||||||
|
|
||||||
%package devel
|
%package devel
|
||||||
Summary: Development files for %{name}
|
Summary: Development files for %{name}
|
||||||
Group: Development/Libraries
|
Group: Development/Libraries
|
||||||
@ -100,7 +75,7 @@ This package contains libflatpak.
|
|||||||
%build
|
%build
|
||||||
(if ! test -x configure; then NOCONFIGURE=1 ./autogen.sh; CONFIGFLAGS=--enable-gtk-doc; fi;
|
(if ! test -x configure; then NOCONFIGURE=1 ./autogen.sh; CONFIGFLAGS=--enable-gtk-doc; fi;
|
||||||
# User namespace support is sufficient.
|
# User namespace support is sufficient.
|
||||||
%configure --with-dwarf-header=%{_includedir}/libdwarf --with-priv-mode=none \
|
%configure --with-priv-mode=none \
|
||||||
--with-system-bubblewrap --enable-docbook-docs $CONFIGFLAGS)
|
--with-system-bubblewrap --enable-docbook-docs $CONFIGFLAGS)
|
||||||
%make_build V=1
|
%make_build V=1
|
||||||
|
|
||||||
@ -156,9 +131,7 @@ flatpak remote-list --system &> /dev/null || :
|
|||||||
%{_mandir}/man5/flatpak-flatpakref.5*
|
%{_mandir}/man5/flatpak-flatpakref.5*
|
||||||
%{_mandir}/man5/flatpak-flatpakrepo.5*
|
%{_mandir}/man5/flatpak-flatpakrepo.5*
|
||||||
%{_mandir}/man5/flatpak-installation.5*
|
%{_mandir}/man5/flatpak-installation.5*
|
||||||
%{_mandir}/man5/flatpak-manifest.5*
|
|
||||||
%{_mandir}/man5/flatpak-remote.5*
|
%{_mandir}/man5/flatpak-remote.5*
|
||||||
%exclude %{_mandir}/man1/flatpak-builder.1*
|
|
||||||
%{_sysconfdir}/dbus-1/system.d/org.freedesktop.Flatpak.SystemHelper.conf
|
%{_sysconfdir}/dbus-1/system.d/org.freedesktop.Flatpak.SystemHelper.conf
|
||||||
%{_sysconfdir}/flatpak/remotes.d
|
%{_sysconfdir}/flatpak/remotes.d
|
||||||
%{_sysconfdir}/profile.d/flatpak.sh
|
%{_sysconfdir}/profile.d/flatpak.sh
|
||||||
@ -169,10 +142,6 @@ flatpak remote-list --system &> /dev/null || :
|
|||||||
# Co-own directory.
|
# Co-own directory.
|
||||||
%{_userunitdir}/dbus.service.d
|
%{_userunitdir}/dbus.service.d
|
||||||
|
|
||||||
%files builder
|
|
||||||
%{_bindir}/flatpak-builder
|
|
||||||
%{_mandir}/man1/flatpak-builder.1*
|
|
||||||
|
|
||||||
%files devel
|
%files devel
|
||||||
%{_datadir}/gir-1.0/Flatpak-1.0.gir
|
%{_datadir}/gir-1.0/Flatpak-1.0.gir
|
||||||
%{_datadir}/gtk-doc/
|
%{_datadir}/gtk-doc/
|
||||||
@ -187,6 +156,10 @@ flatpak remote-list --system &> /dev/null || :
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Sep 04 2017 Kalev Lember <klember@redhat.com> - 0.9.10-1
|
||||||
|
- Update to 0.9.10
|
||||||
|
- Split out flatpak-builder to a separate source package
|
||||||
|
|
||||||
* Fri Aug 25 2017 Kalev Lember <klember@redhat.com> - 0.9.8-2
|
* Fri Aug 25 2017 Kalev Lember <klember@redhat.com> - 0.9.8-2
|
||||||
- Backport a patch to fix regression in --devel
|
- Backport a patch to fix regression in --devel
|
||||||
|
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (flatpak-0.9.8.tar.xz) = c371a919f33c2b09a4d0b5de52d79a62e0c49113ac21c5c284887febc9f878eb7c4eb1f2513989f85e2b4e2f28cac1747401d93599d0fdc61eafe6432f6bd815
|
SHA512 (flatpak-0.9.10.tar.xz) = 34ed0280b33375fbbfd19afa84543620e40fdc646d6c5dccadc8e1d6706e0e2e2c51a753edf157350cc9e6705f12e5f7568cea82a56f18ed9a052e0ac7d6d34f
|
||||||
|
Loading…
Reference in New Issue
Block a user