Update to 1.0.0
This commit is contained in:
parent
9b483e7baf
commit
0fc3aa8f7e
1
.gitignore
vendored
1
.gitignore
vendored
@ -49,3 +49,4 @@
|
|||||||
/flatpak-0.99.1.tar.xz
|
/flatpak-0.99.1.tar.xz
|
||||||
/flatpak-0.99.2.tar.xz
|
/flatpak-0.99.2.tar.xz
|
||||||
/flatpak-0.99.3.tar.xz
|
/flatpak-0.99.3.tar.xz
|
||||||
|
/flatpak-1.0.0.tar.xz
|
||||||
|
@ -1,29 +0,0 @@
|
|||||||
From 7be25521cf639acc77ad8f968eb6c918533e94ec Mon Sep 17 00:00:00 2001
|
|
||||||
From: Colin Walters <walters@verbum.org>
|
|
||||||
Date: Wed, 11 Jul 2018 14:56:32 -0400
|
|
||||||
Subject: [PATCH] libglnx.m4: Include stdio.h for renameat2
|
|
||||||
|
|
||||||
glibc added it upstream:
|
|
||||||
https://sourceware.org/git/?p=glibc.git;a=commit;h=d6da5cb6a8e0e8a9ce92b7d951a254cf325248d7
|
|
||||||
|
|
||||||
But we need the right header.
|
|
||||||
Ref: https://github.com/flatpak/flatpak/issues/1890
|
|
||||||
---
|
|
||||||
libglnx.m4 | 1 +
|
|
||||||
1 file changed, 1 insertion(+)
|
|
||||||
|
|
||||||
diff --git a/libglnx/libglnx.m4 b/libglnx.m4
|
|
||||||
index 34caf20..5922805 100644
|
|
||||||
--- a/libglnx/libglnx.m4
|
|
||||||
+++ b/libglnx/libglnx.m4
|
|
||||||
@@ -7,6 +7,7 @@ AC_CHECK_DECLS([
|
|
||||||
[], [], [[
|
|
||||||
#include <sys/types.h>
|
|
||||||
#include <unistd.h>
|
|
||||||
+#include <stdio.h>
|
|
||||||
#include <sys/mount.h>
|
|
||||||
#include <fcntl.h>
|
|
||||||
#include <sched.h>
|
|
||||||
--
|
|
||||||
2.17.1
|
|
||||||
|
|
17
flatpak.spec
17
flatpak.spec
@ -2,17 +2,14 @@
|
|||||||
%global ostree_version 2018.6
|
%global ostree_version 2018.6
|
||||||
|
|
||||||
Name: flatpak
|
Name: flatpak
|
||||||
Version: 0.99.3
|
Version: 1.0.0
|
||||||
Release: 2%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: Application deployment framework for desktop apps
|
Summary: Application deployment framework for desktop apps
|
||||||
|
|
||||||
License: LGPLv2+
|
License: LGPLv2+
|
||||||
URL: http://flatpak.org/
|
URL: http://flatpak.org/
|
||||||
Source0: https://github.com/flatpak/flatpak/releases/download/%{version}/%{name}-%{version}.tar.xz
|
Source0: https://github.com/flatpak/flatpak/releases/download/%{version}/%{name}-%{version}.tar.xz
|
||||||
|
|
||||||
# https://github.com/flatpak/flatpak/pull/1914
|
|
||||||
Patch0: 0001-libglnx.m4-Include-stdio.h-for-renameat2.patch
|
|
||||||
|
|
||||||
BuildRequires: pkgconfig(appstream-glib)
|
BuildRequires: pkgconfig(appstream-glib)
|
||||||
BuildRequires: pkgconfig(gio-unix-2.0)
|
BuildRequires: pkgconfig(gio-unix-2.0)
|
||||||
BuildRequires: pkgconfig(gobject-introspection-1.0) >= 1.40.0
|
BuildRequires: pkgconfig(gobject-introspection-1.0) >= 1.40.0
|
||||||
@ -34,10 +31,6 @@ BuildRequires: libcap-devel
|
|||||||
BuildRequires: systemd
|
BuildRequires: systemd
|
||||||
BuildRequires: /usr/bin/xmlto
|
BuildRequires: /usr/bin/xmlto
|
||||||
BuildRequires: /usr/bin/xsltproc
|
BuildRequires: /usr/bin/xsltproc
|
||||||
# For patch0
|
|
||||||
BuildRequires: automake autoconf libtool
|
|
||||||
BuildRequires: gettext-devel
|
|
||||||
BuildRequires: gtk-doc
|
|
||||||
|
|
||||||
Requires: bubblewrap >= %{bubblewrap_version}
|
Requires: bubblewrap >= %{bubblewrap_version}
|
||||||
Requires: ostree-libs%{?_isa} >= %{ostree_version}
|
Requires: ostree-libs%{?_isa} >= %{ostree_version}
|
||||||
@ -76,9 +69,6 @@ This package contains libflatpak.
|
|||||||
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
# For patch0
|
|
||||||
autoreconf -fi
|
|
||||||
|
|
||||||
(if ! test -x configure; then NOCONFIGURE=1 ./autogen.sh; CONFIGFLAGS=--enable-gtk-doc; fi;
|
(if ! test -x configure; then NOCONFIGURE=1 ./autogen.sh; CONFIGFLAGS=--enable-gtk-doc; fi;
|
||||||
# User namespace support is sufficient.
|
# User namespace support is sufficient.
|
||||||
%configure --with-priv-mode=none \
|
%configure --with-priv-mode=none \
|
||||||
@ -158,6 +148,9 @@ flatpak remote-list --system &> /dev/null || :
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Aug 20 2018 David King <amigadave@amigadave.com> - 1.0.0-1
|
||||||
|
- Update to 1.0.0
|
||||||
|
|
||||||
* Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.99.3-2
|
* Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.99.3-2
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
|
||||||
|
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (flatpak-0.99.3.tar.xz) = 8018a1450f5b90d97dfa24e876e6c7d20b5dac4399d78e8544ba8f0ae613b1aa6ee0ae7842477d00a24d7f59d273ee7b52b10fa284c48b5e11474187da183b6c
|
SHA512 (flatpak-1.0.0.tar.xz) = 7bf03787f8d318b00eaaff8b9955b45cd1b7570ebf735e234d9b652e8686c7b2386078a727ac9fbc862aea1ef3fd36787584c3bcc948d594a5a9d9b3cbe46cbd
|
||||||
|
Loading…
Reference in New Issue
Block a user