Svn rev. 1705

Signed-off-by: Peter Lemenkov <lemenkov@gmail.com>
This commit is contained in:
Peter Lemenkov 2013-07-30 17:07:08 +04:00
parent e626e6dfe8
commit 075c56fd4e
9 changed files with 91 additions and 54 deletions

View File

@ -1,24 +1,24 @@
From 7ff2cdbd539a5b341fc27efc51cc0fb9c4797c14 Mon Sep 17 00:00:00 2001
From b3d958119dea5580df83370d0c0bec5d581f5ea8 Mon Sep 17 00:00:00 2001
From: Peter Lemenkov <lemenkov@gmail.com>
Date: Fri, 17 Sep 2010 18:58:28 +0400
Subject: [PATCH 1/7] Initial commit of autotools-related files
Signed-off-by: Peter Lemenkov <lemenkov@gmail.com>
---
Makefile.am | 224 +++++++++++++++++++++++++++++++++++++
Makefile.am | 225 +++++++++++++++++++++++++++++++++++++
bootstrap.sh | 4 +
configure.ac | 355 +++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
3 files changed, 583 insertions(+)
configure.ac | 361 +++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
3 files changed, 590 insertions(+)
create mode 100644 Makefile.am
create mode 100755 bootstrap.sh
create mode 100644 configure.ac
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 0000000..3a34908
index 0000000..fb07af2
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,224 @@
@@ -0,0 +1,225 @@
+sbin_PROGRAMS = flashrom
+
+man_MANS = flashrom.8
@ -44,6 +44,7 @@ index 0000000..3a34908
+ processor_enable.c
+if HAVE_X86_ONLY_INTERNAL
+internal_x86_only_SOURCES = \
+ amd_imc.c \
+ ich_descriptors.c \
+ ich_descriptors.h \
+ ichspi.c \
@ -255,11 +256,11 @@ index 0000000..0213288
+automake --add-missing --copy --force-missing
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..2971103
index 0000000..69044a1
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,355 @@
+AC_INIT([flashrom], [0.9.6.1-r1673], [flashrom@flashrom.org], [flashrom], [http://www.flashrom.org/])
@@ -0,0 +1,361 @@
+AC_INIT([flashrom], [0.9.6.1-r1705], [flashrom@flashrom.org], [flashrom], [http://www.flashrom.org/])
+
+AC_PREREQ(2.59)
+
@ -441,11 +442,17 @@ index 0000000..2971103
+ ;;
+ mingw*)
+ linux_spi="n/a"
+ # TODO
+ # MinGW doesn't have the ffs() function, but we can use gcc's __builtin_ffs().
+ CFLAGS="$CFLAGS -Dffs=__builtin_ffs"
+ # Some functions provided by Microsoft do not work as described in C99 specifications. This macro fixes that
+ # for MinGW. See http://sourceforge.net/apps/trac/mingw-w64/wiki/printf%20and%20scanf%20family */
+ CFLAGS="$CFLAGS -D__USE_MINGW_ANSI_STDIO=1"
+ ;;
+ *djgpp*)
+ linux_spi="n/a"
+ AC_CHECK_HEADERS([pc.h])
+ # DJGPP has odd uint*_t definitions which cause lots of format string warnings.
+ CFLAGS="$CFLAGS -Wno-format"
+ ;;
+ *)
+ AC_MSG_ERROR([No support for this OS ($target_os) yet])
@ -615,5 +622,5 @@ index 0000000..2971103
+------------------------------------------------------------------------
+])
--
1.8.2.1
1.8.3.1

View File

@ -1,4 +1,4 @@
From 5a1299bc8df91871916409744daff283fb2897e0 Mon Sep 17 00:00:00 2001
From e8b036673ed701e08391260009ca458acd494343 Mon Sep 17 00:00:00 2001
From: Peter Lemenkov <lemenkov@gmail.com>
Date: Sat, 12 Jun 2010 22:13:53 +0400
Subject: [PATCH 2/7] Use dmidecode path defined at configure stage
@ -22,5 +22,5 @@ index 242889f..a10fc4f 100644
static char *dmistrings[ARRAY_SIZE(dmidecode_names)];
--
1.8.2.1
1.8.3.1

View File

@ -1,4 +1,4 @@
From 2c6aa71fcdca430e6fd830fd2dfa95752d4beee3 Mon Sep 17 00:00:00 2001
From 7b2370b38bacb4103857232c17baad7d66522744 Mon Sep 17 00:00:00 2001
From: Peter Lemenkov <lemenkov@gmail.com>
Date: Sat, 18 Sep 2010 09:05:43 +0400
Subject: [PATCH 3/7] Use macros from configure stage instead of HAVE_UTSNAME
@ -9,7 +9,7 @@ Signed-off-by: Peter Lemenkov <lemenkov@gmail.com>
1 file changed, 3 insertions(+), 2 deletions(-)
diff --git a/flashrom.c b/flashrom.c
index c11f723..7c45119 100644
index db5b1c7..bdd4aa6 100644
--- a/flashrom.c
+++ b/flashrom.c
@@ -32,7 +32,8 @@
@ -22,7 +22,7 @@ index c11f723..7c45119 100644
#include <sys/utsname.h>
#endif
#include "flash.h"
@@ -1588,7 +1589,7 @@ void print_sysinfo(void)
@@ -1603,7 +1604,7 @@ void print_sysinfo(void)
msg_ginfo(" (unknown arch)");
break;
}
@ -32,5 +32,5 @@ index c11f723..7c45119 100644
uname(&osinfo);
--
1.8.2.1
1.8.3.1

View File

@ -1,4 +1,4 @@
From bbcd9c2fe41b937c13486cd1b252425b11cf37b4 Mon Sep 17 00:00:00 2001
From 87752ba22d3dbeedb93e2f8a299bf6377c6ba491 Mon Sep 17 00:00:00 2001
From: Peter Lemenkov <lemenkov@gmail.com>
Date: Sat, 18 Sep 2010 09:40:01 +0400
Subject: [PATCH 4/7] Kill some x86-related ifdefs in code - this is now
@ -6,6 +6,7 @@ Subject: [PATCH 4/7] Kill some x86-related ifdefs in code - this is now
Signed-off-by: Peter Lemenkov <lemenkov@gmail.com>
---
amd_imc.c | 4 ----
atahpt.c | 6 ------
ich_descriptors.c | 3 ---
ich_descriptors.h | 2 --
@ -20,8 +21,27 @@ Signed-off-by: Peter Lemenkov <lemenkov@gmail.com>
satamv.c | 5 -----
sb600spi.c | 4 ----
wbsio_spi.c | 4 ----
14 files changed, 63 deletions(-)
15 files changed, 67 deletions(-)
diff --git a/amd_imc.c b/amd_imc.c
index b05390c..9aabe3f 100644
--- a/amd_imc.c
+++ b/amd_imc.c
@@ -19,8 +19,6 @@
* Foundation, Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-1301 USA
*/
-#if defined(__i386__) || defined(__x86_64__)
-
#include "flash.h"
#include "programmer.h"
#include "hwaccess.h"
@@ -155,5 +153,3 @@ int amd_imc_shutdown(struct pci_dev *dev)
return ret;
}
-
-#endif
diff --git a/atahpt.c b/atahpt.c
index f8be8c4..aa98711 100644
--- a/atahpt.c
@ -44,7 +64,7 @@ index f8be8c4..aa98711 100644
-#error PCI port I/O access is not supported on this architecture yet.
-#endif
diff --git a/ich_descriptors.c b/ich_descriptors.c
index e5ca87a..c6e1a4b 100644
index 528717b..b479b6a 100644
--- a/ich_descriptors.c
+++ b/ich_descriptors.c
@@ -19,8 +19,6 @@
@ -79,7 +99,7 @@ index 3a44740..3af4fe7 100644
#endif /* __ICH_DESCRIPTORS_H__ */
-#endif /* defined(__i386__) || defined(__x86_64__) */
diff --git a/ichspi.c b/ichspi.c
index 12f4584..5067342 100644
index 4f6a1b1..71a715b 100644
--- a/ichspi.c
+++ b/ichspi.c
@@ -23,8 +23,6 @@
@ -91,7 +111,7 @@ index 12f4584..5067342 100644
#include <string.h>
#include <stdlib.h>
#include "flash.h"
@@ -1888,5 +1886,3 @@ int via_init_spi(struct pci_dev *dev, uint32_t mmio_base)
@@ -1887,5 +1885,3 @@ int via_init_spi(struct pci_dev *dev, uint32_t mmio_base)
return 0;
}
@ -258,7 +278,7 @@ index c3f27e7..b8f175b 100644
-#error PCI port I/O access is not supported on this architecture yet.
-#endif
diff --git a/sb600spi.c b/sb600spi.c
index fe60aa9..d691cb6 100644
index e76c04a..0514acd 100644
--- a/sb600spi.c
+++ b/sb600spi.c
@@ -21,8 +21,6 @@
@ -267,10 +287,10 @@ index fe60aa9..d691cb6 100644
-#if defined(__i386__) || defined(__x86_64__)
-
#include <string.h>
#include <stdlib.h>
#include "flash.h"
#include "programmer.h"
#include "hwaccess.h"
@@ -323,5 +321,3 @@ int sb600_probe_spi(struct pci_dev *dev)
@@ -359,5 +357,3 @@ int sb600_probe_spi(struct pci_dev *dev)
register_spi_programmer(&spi_programmer_sb600);
return 0;
}
@ -296,5 +316,5 @@ index 7d4bb2a..6e6eec1 100644
-
-#endif
--
1.8.2.1
1.8.3.1

View File

@ -1,4 +1,4 @@
From 6bdd32ea19039f71b1a2d45f86fa6c2fc17b6322 Mon Sep 17 00:00:00 2001
From d34343e1f47a6760d4145789ee8fb27db4b25445 Mon Sep 17 00:00:00 2001
From: Peter Lemenkov <lemenkov@gmail.com>
Date: Sun, 26 Sep 2010 18:25:31 +0400
Subject: [PATCH 5/7] Use endiannes determined at the configure stage
@ -9,7 +9,7 @@ Signed-off-by: Peter Lemenkov <lemenkov@gmail.com>
1 file changed, 2 insertions(+), 58 deletions(-)
diff --git a/hwaccess.h b/hwaccess.h
index 714a660..f6f7c4c 100644
index fd6eb12..f76043d 100644
--- a/hwaccess.h
+++ b/hwaccess.h
@@ -41,58 +41,6 @@
@ -94,5 +94,5 @@ index 714a660..f6f7c4c 100644
#define be_to_cpu8 cpu_to_be8
#define be_to_cpu16 cpu_to_be16
--
1.8.2.1
1.8.3.1

View File

@ -1,15 +1,15 @@
From adf493f60525cdb813a4b8d65731f1a73215e55e Mon Sep 17 00:00:00 2001
From a366f2b127d40411066a431004999ecb41b6af7b Mon Sep 17 00:00:00 2001
From: Peter Lemenkov <lemenkov@gmail.com>
Date: Sun, 26 Sep 2010 21:05:50 +0400
Subject: [PATCH 6/7] Use HAVE_*_H macro for detecting includes
Signed-off-by: Peter Lemenkov <lemenkov@gmail.com>
---
hwaccess.h | 71 +++++++++++++++++++++++++++++++++++++++++++++++++-------------
1 file changed, 56 insertions(+), 15 deletions(-)
hwaccess.h | 69 ++++++++++++++++++++++++++++++++++++++++++++++++++------------
1 file changed, 56 insertions(+), 13 deletions(-)
diff --git a/hwaccess.h b/hwaccess.h
index f6f7c4c..4e820f0 100644
index f76043d..12ea46c 100644
--- a/hwaccess.h
+++ b/hwaccess.h
@@ -24,11 +24,9 @@
@ -110,16 +110,7 @@ index f6f7c4c..4e820f0 100644
#define OUTB(x,y) outportb(y, x)
#define OUTW(x,y) outportw(y, x)
#define OUTL(x,y) outportl(y, x)
@@ -182,8 +224,6 @@ cpu_to_be(64)
#if defined(__NetBSD__) || defined (__OpenBSD__)
#if defined(__i386__) || defined(__x86_64__)
- #include <sys/types.h>
- #include <machine/sysarch.h>
#if defined(__NetBSD__)
#if defined(__i386__)
#define iopl i386_iopl
@@ -240,7 +280,7 @@ static inline uint32_t inl(uint16_t port)
@@ -240,7 +282,7 @@ static inline uint32_t inl(uint16_t port)
typedef struct { uint32_t hi, lo; } msr_t;
msr_t rdmsr(int addr);
int wrmsr(int addr, msr_t msr);
@ -128,7 +119,7 @@ index f6f7c4c..4e820f0 100644
#if defined(__FreeBSD__) || defined(__FreeBSD_kernel__) || defined(__DragonFly__)
/* FreeBSD already has conflicting definitions for wrmsr/rdmsr. */
#undef rdmsr
@@ -250,7 +290,8 @@ int wrmsr(int addr, msr_t msr);
@@ -250,7 +292,8 @@ int wrmsr(int addr, msr_t msr);
typedef struct { uint32_t hi, lo; } msr_t;
msr_t freebsd_rdmsr(int addr);
int freebsd_wrmsr(int addr, msr_t msr);
@ -139,5 +130,5 @@ index f6f7c4c..4e820f0 100644
#include <arch/io.h>
#include <arch/msr.h>
--
1.8.2.1
1.8.3.1

View File

@ -1,4 +1,4 @@
From 1f2e7a71454e1d1cb58a13d680a52c58ebe6b097 Mon Sep 17 00:00:00 2001
From 726ed55ebf1dbfe4a70a864331f36c3824421727 Mon Sep 17 00:00:00 2001
From: Mattias Mattsson <vitplister@gmail.com>
Date: Wed, 27 Jul 2011 21:02:50 +0400
Subject: [PATCH 7/7] ppc hack
@ -9,10 +9,10 @@ Subject: [PATCH 7/7] ppc hack
2 files changed, 3 insertions(+), 1 deletion(-)
diff --git a/internal.c b/internal.c
index 5af74cd..bb8d91c 100644
index ab3c81f..1bad0ea 100644
--- a/internal.c
+++ b/internal.c
@@ -348,6 +348,8 @@ int internal_init(void)
@@ -352,6 +352,8 @@ int internal_init(void)
"Aborting.\n");
return 1;
#endif
@ -35,5 +35,5 @@ index 1361dd5..49d4006 100644
* AMD Elan SC520, AMD Geode and maybe other SoC-style CPUs.
* FIXME: Move enable_flash_cs5536 and get_flashbase_sc520 here.
--
1.8.2.1
1.8.3.1

View File

@ -1,13 +1,13 @@
Summary: Simple program for reading/writing BIOS chips content
Name: flashrom
Version: 0.9.6.1
Release: 4.svn1673%{?dist}
Release: 5.svn1705%{?dist}
License: GPLv2
Group: Applications/System
URL: http://flashrom.org
#Source0: http://qa.coreboot.org/releases/%{name}-%{version}.tar.bz2
#Source1: http://qa.coreboot.org/releases/%{name}-%{version}.tar.bz2.asc
## svn -r 1673 export svn://coreboot.org/flashrom/trunk flashrom-0.9.6.1
## svn -r 1705 export svn://coreboot.org/flashrom/trunk flashrom-0.9.6.1
## tar -cjvf flashrom-0.9.6.1.tar.bz2 flashrom-0.9.6.1
Source0: %{name}-%{version}.tar.bz2
Patch1: flashrom-0001-Initial-commit-of-autotools-related-files.patch
@ -85,7 +85,26 @@ rm -rf %{buildroot}
%changelog
* Tue May 21 2013 Peter Lemenkov <lemenkov@gmail.com> - 0.9.6.1-4.svn1673
* Tue Jul 30 2013 Peter Lemenkov <lemenkov@gmail.com> - 0.9.6.1-5.svn1705
- Handle active IMCs in AMD chipsets
- Rename Numonyx and ST (SGS/Thomson) chips to Micron
- Various cross-platform fixes
- Add support for remaining Numonyx (Micron) N25Q chips
- Add support for Spansion S25FL...S chips
- Add support for Spansion S25FL2 chips
- Add support for Micron/Numonyx/ST M25PX80
- Add support for AMIC A25LQ16 and A25LQ64
- Add support for more Eon EN25QH chips
- Add support for Eon EN25S series
- Add support for Numonyx M45PE series
- Add support for some GigaDevice GD25* chips
- Add support for all Sanyo LE25FW chips
- Add support for Nantronics N25 series
- Fix unlocking function for most Atmel AT2[56]D* chips
- Add W25Q...W series
- dediprog: fix SPI clock setting
* Tue May 21 2013 Peter Lemenkov <lemenkov@gmail.com> - 0.9.6.1-4.svn1673
- dediprog: add support for chip select
- Add support for PMC Pm25LD series flash chips
- Add Altera USB-Blaster SPI programmer

View File

@ -1 +1 @@
13f99fd53cb466d4ea048097606c1cfc flashrom-0.9.6.1.tar.bz2
116357a2f31575b15ee7f379493969a7 flashrom-0.9.6.1.tar.bz2