update to 1.3.2
This commit is contained in:
parent
ea4db547ed
commit
fcc40c1e3f
2
.gitignore
vendored
2
.gitignore
vendored
@ -1 +1 @@
|
|||||||
/flac-1.3.1.tar.xz
|
/flac-1.3.2.tar.xz
|
||||||
|
@ -1,26 +1,25 @@
|
|||||||
diff -up flac-1.3.1/configure.ac.cflags flac-1.3.1/configure.ac
|
diff -up flac-1.3.2/configure.ac.cflags flac-1.3.2/configure.ac
|
||||||
--- flac-1.3.1/configure.ac.cflags 2014-11-27 03:45:33.598155763 +0100
|
--- flac-1.3.2/configure.ac.cflags 2017-01-02 14:02:15.663046237 +0100
|
||||||
+++ flac-1.3.1/configure.ac 2014-11-27 13:45:18.092749862 +0100
|
+++ flac-1.3.2/configure.ac 2017-01-02 14:04:20.718046015 +0100
|
||||||
@@ -352,8 +352,7 @@ if test "x$debug" = xtrue; then
|
@@ -390,7 +390,7 @@ if test "x$debug" = xtrue; then
|
||||||
CFLAGS="-g $CFLAGS"
|
|
||||||
else
|
else
|
||||||
CPPFLAGS="-DNDEBUG $CPPFLAGS"
|
CPPFLAGS="-DNDEBUG $CPPFLAGS"
|
||||||
- CFLAGS=$(echo "$CFLAGS" | sed 's/-O2//;s/-g//')
|
CFLAGS=$(echo "$CFLAGS" | sed 's/-O2//')
|
||||||
- CFLAGS="-O3 -funroll-loops $CFLAGS"
|
- CFLAGS="-O3 -funroll-loops $CFLAGS"
|
||||||
+ CFLAGS="$user_cflags"
|
+ CFLAGS="$user_cflags"
|
||||||
fi
|
fi
|
||||||
|
|
||||||
XIPH_GCC_VERSION
|
XIPH_GCC_VERSION
|
||||||
@@ -363,7 +362,6 @@ if test x$ac_cv_c_compiler_gnu = xyes ;
|
@@ -400,7 +400,6 @@ if test x$ac_cv_c_compiler_gnu = xyes ;
|
||||||
CXXFLAGS="$CXXFLAGS -Wall -Wextra -Wcast-align -Wshadow -Wwrite-strings -Wctor-dtor-privacy -Wnon-virtual-dtor -Wreorder -Wsign-promo -Wundef -Wunreachable-code " # -Wcast-qual -Wbad-function-cast -Wwrite-strings -Woverloaded-virtual -Wmissing-declarations
|
CXXFLAGS="$CXXFLAGS -Wall -Wextra -Wcast-align -Wshadow -Wwrite-strings -Wctor-dtor-privacy -Wnon-virtual-dtor -Wreorder -Wsign-promo -Wundef " # -Wcast-qual -Wbad-function-cast -Wwrite-strings -Woverloaded-virtual -Wmissing-declarations
|
||||||
|
|
||||||
XIPH_ADD_CFLAGS([-Wdeclaration-after-statement])
|
XIPH_ADD_CFLAGS([-Wdeclaration-after-statement])
|
||||||
- XIPH_ADD_CFLAGS([-D_FORTIFY_SOURCE=2])
|
- XIPH_ADD_CFLAGS([-D_FORTIFY_SOURCE=2])
|
||||||
|
|
||||||
AC_LANG_PUSH([C++])
|
AC_LANG_PUSH([C++])
|
||||||
XIPH_ADD_CXXFLAGS([-Weffc++])
|
XIPH_ADD_CXXFLAGS([-Weffc++])
|
||||||
@@ -385,10 +383,6 @@ if test x$ac_cv_c_compiler_gnu = xyes ;
|
@@ -426,10 +425,6 @@ if test x$ac_cv_c_compiler_gnu = xyes ;
|
||||||
XIPH_ADD_CFLAGS([-fgnu89-inline])
|
XIPH_ADD_CFLAGS([-fno-inline-small-functions])
|
||||||
fi
|
fi
|
||||||
|
|
||||||
- if test "x$asm_optimisation$sse_os" = "xyesyes" ; then
|
- if test "x$asm_optimisation$sse_os" = "xyesyes" ; then
|
||||||
@ -29,4 +28,4 @@ diff -up flac-1.3.1/configure.ac.cflags flac-1.3.1/configure.ac
|
|||||||
-
|
-
|
||||||
fi
|
fi
|
||||||
|
|
||||||
XIPH_ADD_CFLAGS([-Wextra])
|
case "$host_os" in
|
||||||
|
9
flac-testsuite.patch
Normal file
9
flac-testsuite.patch
Normal file
@ -0,0 +1,9 @@
|
|||||||
|
diff -up flac-1.3.2/test/metaflac-test-files/case07-expect.meta.testsuite flac-1.3.2/test/metaflac-test-files/case07-expect.meta
|
||||||
|
--- flac-1.3.2/test/metaflac-test-files/case07-expect.meta.testsuite 2017-01-01 01:52:09.366371726 +0100
|
||||||
|
+++ flac-1.3.2/test/metaflac-test-files/case07-expect.meta 2017-01-02 14:10:47.659045330 +0100
|
||||||
|
@@ -1,4 +1,4 @@
|
||||||
|
-reference libFLAC 1.3.1 20141125
|
||||||
|
+reference libFLAC 1.3.2 20170101
|
||||||
|
ARTIST=The_artist_formerly_known_as_the_artist...
|
||||||
|
ARTIST=Chuck_Woolery
|
||||||
|
ARTIST=Vern
|
@ -7,7 +7,7 @@
|
|||||||
|
|
||||||
Summary: An encoder/decoder for the Free Lossless Audio Codec
|
Summary: An encoder/decoder for the Free Lossless Audio Codec
|
||||||
Name: flac
|
Name: flac
|
||||||
Version: 1.3.1
|
Version: 1.3.2
|
||||||
Release: 6%{?dist}
|
Release: 6%{?dist}
|
||||||
License: BSD and GPLv2+ and GFDL
|
License: BSD and GPLv2+ and GFDL
|
||||||
Group: Applications/Multimedia
|
Group: Applications/Multimedia
|
||||||
@ -15,6 +15,8 @@ Source0: http://downloads.xiph.org/releases/flac/flac-%{version}.tar.xz
|
|||||||
URL: http://www.xiph.org/flac/
|
URL: http://www.xiph.org/flac/
|
||||||
# use our CFLAGS and don't force SSE intrinsics
|
# use our CFLAGS and don't force SSE intrinsics
|
||||||
Patch1: flac-cflags.patch
|
Patch1: flac-cflags.patch
|
||||||
|
# fix testing
|
||||||
|
Patch2: flac-testsuite.patch
|
||||||
Requires: %{name}-libs%{?_isa} = %{version}-%{release}
|
Requires: %{name}-libs%{?_isa} = %{version}-%{release}
|
||||||
BuildRequires: libogg-devel
|
BuildRequires: libogg-devel
|
||||||
BuildRequires: automake autoconf libtool gettext-devel doxygen
|
BuildRequires: automake autoconf libtool gettext-devel doxygen
|
||||||
@ -79,6 +81,7 @@ This is the input plugin for XMMS to be able to read FLAC files.
|
|||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
%patch1 -p1 -b .cflags
|
%patch1 -p1 -b .cflags
|
||||||
|
%patch2 -p1 -b .testsuite
|
||||||
|
|
||||||
%build
|
%build
|
||||||
# use our libtool to avoid problems with RPATH
|
# use our libtool to avoid problems with RPATH
|
||||||
|
Loading…
Reference in New Issue
Block a user