- Update for 1.20 and drop obsolete patches (#285161)
This commit is contained in:
parent
25ab8228bb
commit
a2cc44e452
@ -1,4 +1 @@
|
||||
flac-1.1.0.tar.gz
|
||||
flac-1.1.2.tar.gz
|
||||
flac-1.1.3.tar.gz
|
||||
flac-1.1.4.tar.gz
|
||||
flac-1.2.0.tar.gz
|
||||
|
@ -1,29 +0,0 @@
|
||||
--- flac-1.1.3/configure.in.noxmms 2006-11-20 16:29:34.000000000 -0500
|
||||
+++ flac-1.1.3/configure.in 2007-02-01 19:20:39.000000000 -0500
|
||||
@@ -196,25 +196,7 @@
|
||||
fi
|
||||
AM_CONDITIONAL(FLaC__HAS_DOXYGEN, test -n "$DOXYGEN")
|
||||
|
||||
-AC_ARG_ENABLE(local-xmms-plugin,
|
||||
-AC_HELP_STRING([--enable-local-xmms-plugin], [Install XMMS plugin to ~/.xmms/Plugins instead of system location]),
|
||||
-[case "${enableval}" in
|
||||
- yes) install_xmms_plugin_locally=true ;;
|
||||
- no) install_xmms_plugin_locally=false ;;
|
||||
- *) AC_MSG_ERROR(bad value ${enableval} for --enable-local-xmms-plugin) ;;
|
||||
-esac],[install_xmms_plugin_locally=false])
|
||||
-AM_CONDITIONAL(FLaC__INSTALL_XMMS_PLUGIN_LOCALLY, test "x$install_xmms_plugin_locally" = xtrue)
|
||||
-
|
||||
-AC_ARG_ENABLE(xmms-plugin,
|
||||
-AC_HELP_STRING([--disable-xmms-plugin], [Do not build XMMS plugin]),
|
||||
-[case "${enableval}" in
|
||||
- yes) enable_xmms_plugin=true ;;
|
||||
- no) enable_xmms_plugin=false ;;
|
||||
- *) AC_MSG_ERROR(bad value ${enableval} for --enable-xmms-plugin) ;;
|
||||
-esac],[enable_xmms_plugin=true])
|
||||
-if test "x$enable_xmms_plugin" != xfalse ; then
|
||||
- AM_PATH_XMMS(0.9.5.1, , AC_MSG_WARN([*** XMMS >= 0.9.5.1 not installed - XMMS support will not be built]))
|
||||
-fi
|
||||
+AM_CONDITIONAL(FLaC__INSTALL_XMMS_PLUGIN_LOCALLY, test x$install_xmms_plugin_locally = xtrue)
|
||||
AM_CONDITIONAL(FLaC__HAS_XMMS, test -n "$XMMS_INPUT_PLUGIN_DIR")
|
||||
|
||||
dnl check for ogg library
|
@ -1,10 +0,0 @@
|
||||
--- flac-1.1.4/src/libFLAC/md5.c 2006-11-11 22:56:47.000000000 +0000
|
||||
+++ flac-1.1.4.new/src/libFLAC/md5.c 2007-04-12 13:41:01.000000000 +0100
|
||||
@@ -143,6 +143,7 @@ FLAC__MD5Transform(FLAC__uint32 buf[4],
|
||||
|
||||
#endif
|
||||
|
||||
+static
|
||||
FLaC__INLINE
|
||||
void
|
||||
byteSwap(FLAC__uint32 *buf, unsigned words)
|
@ -1,14 +0,0 @@
|
||||
--- flac-1.1.4/src/libFLAC/Makefile.am.link-ogg 2007-02-07 01:13:45.000000000 +0000
|
||||
+++ flac-1.1.4/src/libFLAC/Makefile.am 2007-02-14 12:09:23.000000000 +0000
|
||||
@@ -92,9 +92,10 @@ extra_ogg_sources = \
|
||||
ogg_encoder_aspect.c \
|
||||
ogg_helper.c \
|
||||
ogg_mapping.c
|
||||
+OGG_LIBS=-logg
|
||||
endif
|
||||
# see 'http://www.gnu.org/software/libtool/manual.html#Libtool-versioning' for numbering convention
|
||||
-libFLAC_la_LDFLAGS = -version-info 8:1:0 -lm $(LOCAL_EXTRA_LDFLAGS)
|
||||
+libFLAC_la_LDFLAGS = -version-info 8:1:0 -lm $(OGG_LIBS) $(LOCAL_EXTRA_LDFLAGS)
|
||||
libFLAC_la_SOURCES = \
|
||||
bitmath.c \
|
||||
bitreader.c \
|
23
flac.spec
23
flac.spec
@ -1,18 +1,15 @@
|
||||
Summary: An encoder/decoder for the Free Lossless Audio Codec
|
||||
Name: flac
|
||||
Version: 1.1.4
|
||||
Release: 5%{?dist}
|
||||
Version: 1.2.0
|
||||
Release: 1%{?dist}
|
||||
License: LGPL/GPL
|
||||
Group: Applications/Multimedia
|
||||
Source: http://prdownloads.sourceforge.net/flac/flac-%{version}.tar.gz
|
||||
Patch2: flac-1.1.4-hide-byteswap.patch
|
||||
Patch3: flac-1.1.3-gnu-stack.patch
|
||||
Patch4: flac-1.1.3-noxmms.patch
|
||||
Patch5: flac-1.1.4-link-ogg.patch
|
||||
Patch1: flac-1.1.3-gnu-stack.patch
|
||||
URL: http://flac.sourceforge.net/
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
BuildRequires: glib2-devel, libogg-devel, doxygen, nasm
|
||||
BuildRequires: libtool, gettext-devel
|
||||
BuildRequires: gettext-devel
|
||||
Obsoletes: flac-libs
|
||||
Provides: flac-libs
|
||||
|
||||
@ -36,16 +33,11 @@ will use the Free Lossless Audio Codec.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch2 -p1 -b .extra-sym
|
||||
%patch3 -p1 -b .gnu-stack
|
||||
%patch4 -p1 -b .noxmms
|
||||
%patch5 -p1 -b .link-ogg
|
||||
|
||||
autoreconf -i -f
|
||||
%patch1 -p1 -b .gnu-stack
|
||||
|
||||
%build
|
||||
export XMMS_CONFIG=no # Disable XMMS
|
||||
%configure --with-pic
|
||||
%configure --with-pic --disable-xmms-plugin
|
||||
|
||||
make %{?_smp_mflags}
|
||||
|
||||
@ -80,6 +72,9 @@ rm -rf %{buildroot}
|
||||
%{_datadir}/aclocal/*.m4
|
||||
|
||||
%changelog
|
||||
* Mon Sep 10 2007 - Bastien Nocera <bnocera@redhat.com> - 1.2.0
|
||||
- Update for 1.20 and drop obsolete patches (#285161)
|
||||
|
||||
* Fri Aug 24 2007 Adam Jackson <ajax@redhat.com> - 1.1.4-5
|
||||
- Rebuild for build ID
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user