update to 1.3.3
This commit is contained in:
parent
8a48df9df3
commit
9d82258c3f
2
.gitignore
vendored
2
.gitignore
vendored
@ -1 +1 @@
|
||||
/flac-1.3.2.tar.xz
|
||||
/flac-1.3.3.tar.xz
|
||||
|
@ -1,31 +0,0 @@
|
||||
diff -up flac-1.3.2/configure.ac.cflags flac-1.3.2/configure.ac
|
||||
--- flac-1.3.2/configure.ac.cflags 2017-01-02 14:02:15.663046237 +0100
|
||||
+++ flac-1.3.2/configure.ac 2017-01-02 14:04:20.718046015 +0100
|
||||
@@ -390,7 +390,7 @@ if test "x$debug" = xtrue; then
|
||||
else
|
||||
CPPFLAGS="-DNDEBUG $CPPFLAGS"
|
||||
CFLAGS=$(echo "$CFLAGS" | sed 's/-O2//')
|
||||
- CFLAGS="-O3 -funroll-loops $CFLAGS"
|
||||
+ CFLAGS="$user_cflags"
|
||||
fi
|
||||
|
||||
XIPH_GCC_VERSION
|
||||
@@ -400,7 +400,6 @@ if test x$ac_cv_c_compiler_gnu = xyes ;
|
||||
CXXFLAGS="$CXXFLAGS -Wall -Wextra -Wcast-align -Wshadow -Wwrite-strings -Wctor-dtor-privacy -Wnon-virtual-dtor -Wreorder -Wsign-promo -Wundef " # -Wcast-qual -Wbad-function-cast -Wwrite-strings -Woverloaded-virtual -Wmissing-declarations
|
||||
|
||||
XIPH_ADD_CFLAGS([-Wdeclaration-after-statement])
|
||||
- XIPH_ADD_CFLAGS([-D_FORTIFY_SOURCE=2])
|
||||
|
||||
AC_LANG_PUSH([C++])
|
||||
XIPH_ADD_CXXFLAGS([-Weffc++])
|
||||
@@ -426,10 +425,6 @@ if test x$ac_cv_c_compiler_gnu = xyes ;
|
||||
XIPH_ADD_CFLAGS([-fno-inline-small-functions])
|
||||
fi
|
||||
|
||||
- if test "x$asm_optimisation$sse_os" = "xyesyes" ; then
|
||||
- XIPH_ADD_CFLAGS([-msse2])
|
||||
- fi
|
||||
-
|
||||
fi
|
||||
|
||||
case "$host_os" in
|
@ -1,22 +0,0 @@
|
||||
commit 4f47b63e9c971e6391590caf00a0f2a5ed612e67
|
||||
Author: Erik de Castro Lopo <erikd@mega-nerd.com>
|
||||
Date: Sat Apr 8 18:34:49 2017 +1000
|
||||
|
||||
stream_decoder.c: Fix a memory leak
|
||||
|
||||
Leak reported by Secunia Research.
|
||||
|
||||
diff --git a/src/libFLAC/stream_decoder.c b/src/libFLAC/stream_decoder.c
|
||||
index 14d5fe7f..a5527511 100644
|
||||
--- a/src/libFLAC/stream_decoder.c
|
||||
+++ b/src/libFLAC/stream_decoder.c
|
||||
@@ -1753,6 +1753,9 @@ FLAC__bool read_metadata_vorbiscomment_(FLAC__StreamDecoder *decoder, FLAC__Stre
|
||||
}
|
||||
memset (obj->comments[i].entry, 0, obj->comments[i].length) ;
|
||||
if (!FLAC__bitreader_read_byte_block_aligned_no_crc(decoder->private_->input, obj->comments[i].entry, obj->comments[i].length)) {
|
||||
+ /* Current i-th entry is bad, so we delete it. */
|
||||
+ free (obj->comments[i].entry) ;
|
||||
+ obj->comments[i].entry = NULL ;
|
||||
obj->num_comments = i;
|
||||
goto skip;
|
||||
}
|
15
flac.spec
15
flac.spec
@ -7,15 +7,11 @@
|
||||
|
||||
Summary: An encoder/decoder for the Free Lossless Audio Codec
|
||||
Name: flac
|
||||
Version: 1.3.2
|
||||
Version: 1.3.3
|
||||
Release: 12%{?dist}
|
||||
License: BSD and GPLv2+ and GFDL
|
||||
Source0: http://downloads.xiph.org/releases/flac/flac-%{version}.tar.xz
|
||||
URL: http://www.xiph.org/flac/
|
||||
# use our CFLAGS and don't force SSE intrinsics
|
||||
Patch1: flac-cflags.patch
|
||||
# fix memory leak in parsing of vorbis comments
|
||||
Patch2: flac-memleak.patch
|
||||
Source0: https://downloads.xiph.org/releases/flac/flac-%{version}.tar.xz
|
||||
URL: https://www.xiph.org/flac/
|
||||
Requires: %{name}-libs%{?_isa} = %{version}-%{release}
|
||||
BuildRequires: libogg-devel
|
||||
BuildRequires: gcc gcc-c++ automake autoconf libtool gettext-devel doxygen
|
||||
@ -75,8 +71,6 @@ This is the input plugin for XMMS to be able to read FLAC files.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch1 -p1 -b .cflags
|
||||
%patch2 -p1 -b .memleak
|
||||
|
||||
%build
|
||||
# use our libtool to avoid problems with RPATH
|
||||
@ -85,6 +79,7 @@ This is the input plugin for XMMS to be able to read FLAC files.
|
||||
# -funroll-loops makes encoding about 10% faster
|
||||
export CFLAGS="%{optflags} -funroll-loops"
|
||||
%configure \
|
||||
--htmldir=%{_docdir}/flac/html \
|
||||
%if %{with_xmms}
|
||||
--enable-xmms-plugin \
|
||||
%else
|
||||
@ -114,7 +109,7 @@ rm %{buildroot}%{xmms_inputdir}/*.la
|
||||
%endif
|
||||
|
||||
%check
|
||||
make -C test check FLAC__TEST_LEVEL=0 &> /dev/null
|
||||
make check
|
||||
|
||||
%ldconfig_scriptlets libs
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (flac-1.3.2.tar.xz) = 63910e8ebbe508316d446ffc9eb6d02efbd5f47d29d2ea7864da9371843c8e671854db6e89ba043fe08aef1845b8ece70db80f1cce853f591ca30d56ef7c3a15
|
||||
SHA512 (flac-1.3.3.tar.xz) = d6417e14fab0c41b2df369e5e39ce62a5f588e491af4d465b0162f74e171e5549b2f061867f344bfbf8aaccd246bf5f2acd697e532a2c7901c920c69429b1a28
|
||||
|
Loading…
Reference in New Issue
Block a user