Auto sync2gitlab import of flac-1.3.2-9.el8.src.rpm
This commit is contained in:
parent
472e8ce45e
commit
1e204bb928
1
.gitignore
vendored
Normal file
1
.gitignore
vendored
Normal file
@ -0,0 +1 @@
|
||||
/flac-1.3.2.tar.xz
|
31
flac-cflags.patch
Normal file
31
flac-cflags.patch
Normal file
@ -0,0 +1,31 @@
|
||||
diff -up flac-1.3.2/configure.ac.cflags flac-1.3.2/configure.ac
|
||||
--- flac-1.3.2/configure.ac.cflags 2017-01-02 14:02:15.663046237 +0100
|
||||
+++ flac-1.3.2/configure.ac 2017-01-02 14:04:20.718046015 +0100
|
||||
@@ -390,7 +390,7 @@ if test "x$debug" = xtrue; then
|
||||
else
|
||||
CPPFLAGS="-DNDEBUG $CPPFLAGS"
|
||||
CFLAGS=$(echo "$CFLAGS" | sed 's/-O2//')
|
||||
- CFLAGS="-O3 -funroll-loops $CFLAGS"
|
||||
+ CFLAGS="$user_cflags"
|
||||
fi
|
||||
|
||||
XIPH_GCC_VERSION
|
||||
@@ -400,7 +400,6 @@ if test x$ac_cv_c_compiler_gnu = xyes ;
|
||||
CXXFLAGS="$CXXFLAGS -Wall -Wextra -Wcast-align -Wshadow -Wwrite-strings -Wctor-dtor-privacy -Wnon-virtual-dtor -Wreorder -Wsign-promo -Wundef " # -Wcast-qual -Wbad-function-cast -Wwrite-strings -Woverloaded-virtual -Wmissing-declarations
|
||||
|
||||
XIPH_ADD_CFLAGS([-Wdeclaration-after-statement])
|
||||
- XIPH_ADD_CFLAGS([-D_FORTIFY_SOURCE=2])
|
||||
|
||||
AC_LANG_PUSH([C++])
|
||||
XIPH_ADD_CXXFLAGS([-Weffc++])
|
||||
@@ -426,10 +425,6 @@ if test x$ac_cv_c_compiler_gnu = xyes ;
|
||||
XIPH_ADD_CFLAGS([-fno-inline-small-functions])
|
||||
fi
|
||||
|
||||
- if test "x$asm_optimisation$sse_os" = "xyesyes" ; then
|
||||
- XIPH_ADD_CFLAGS([-msse2])
|
||||
- fi
|
||||
-
|
||||
fi
|
||||
|
||||
case "$host_os" in
|
22
flac-memleak.patch
Normal file
22
flac-memleak.patch
Normal file
@ -0,0 +1,22 @@
|
||||
commit 4f47b63e9c971e6391590caf00a0f2a5ed612e67
|
||||
Author: Erik de Castro Lopo <erikd@mega-nerd.com>
|
||||
Date: Sat Apr 8 18:34:49 2017 +1000
|
||||
|
||||
stream_decoder.c: Fix a memory leak
|
||||
|
||||
Leak reported by Secunia Research.
|
||||
|
||||
diff --git a/src/libFLAC/stream_decoder.c b/src/libFLAC/stream_decoder.c
|
||||
index 14d5fe7f..a5527511 100644
|
||||
--- a/src/libFLAC/stream_decoder.c
|
||||
+++ b/src/libFLAC/stream_decoder.c
|
||||
@@ -1753,6 +1753,9 @@ FLAC__bool read_metadata_vorbiscomment_(FLAC__StreamDecoder *decoder, FLAC__Stre
|
||||
}
|
||||
memset (obj->comments[i].entry, 0, obj->comments[i].length) ;
|
||||
if (!FLAC__bitreader_read_byte_block_aligned_no_crc(decoder->private_->input, obj->comments[i].entry, obj->comments[i].length)) {
|
||||
+ /* Current i-th entry is bad, so we delete it. */
|
||||
+ free (obj->comments[i].entry) ;
|
||||
+ obj->comments[i].entry = NULL ;
|
||||
obj->num_comments = i;
|
||||
goto skip;
|
||||
}
|
12
flac-nonasm.patch
Normal file
12
flac-nonasm.patch
Normal file
@ -0,0 +1,12 @@
|
||||
diff -up flac-1.3.2/configure.ac.nonasm flac-1.3.2/configure.ac
|
||||
--- flac-1.3.2/configure.ac.nonasm 2018-09-20 18:07:24.511716480 +0200
|
||||
+++ flac-1.3.2/configure.ac 2018-09-20 18:21:18.727824763 +0200
|
||||
@@ -377,7 +377,7 @@ if test x$have_clock_gettime = xyes; the
|
||||
fi
|
||||
|
||||
# only matters for x86
|
||||
-AC_CHECK_PROGS(NASM, nasm)
|
||||
+#AC_CHECK_PROGS(NASM, nasm)
|
||||
AM_CONDITIONAL(FLaC__HAS_NASM, test -n "$NASM")
|
||||
if test -n "$NASM" ; then
|
||||
AC_DEFINE(FLAC__HAS_NASM)
|
324
flac.spec
Normal file
324
flac.spec
Normal file
@ -0,0 +1,324 @@
|
||||
Summary: An encoder/decoder for the Free Lossless Audio Codec
|
||||
Name: flac
|
||||
Version: 1.3.2
|
||||
Release: 9%{?dist}
|
||||
License: BSD and GPLv2+ and GFDL
|
||||
Group: Applications/Multimedia
|
||||
Source0: http://downloads.xiph.org/releases/flac/flac-%{version}.tar.xz
|
||||
URL: http://www.xiph.org/flac/
|
||||
# use our CFLAGS and don't force SSE intrinsics
|
||||
Patch1: flac-cflags.patch
|
||||
# fix memory leak in parsing of vorbis comments
|
||||
Patch2: flac-memleak.patch
|
||||
# disable nasm detection
|
||||
Patch3: flac-nonasm.patch
|
||||
Requires: %{name}-libs%{?_isa} = %{version}-%{release}
|
||||
BuildRequires: libogg-devel
|
||||
BuildRequires: gcc automake autoconf libtool gettext-devel doxygen
|
||||
# xmms-flac subpackage was dropped in 1.3.2-8
|
||||
Obsoletes: xmms-%{name} < 1.3.2-8
|
||||
|
||||
%description
|
||||
FLAC stands for Free Lossless Audio Codec. Grossly oversimplified, FLAC
|
||||
is similar to Ogg Vorbis, but lossless. The FLAC project consists of
|
||||
the stream format, reference encoders and decoders in library form,
|
||||
flac, a command-line program to encode and decode FLAC files, metaflac,
|
||||
a command-line metadata editor for FLAC files and input plugins for
|
||||
various music players.
|
||||
|
||||
This package contains the command-line tools and documentation.
|
||||
|
||||
%package libs
|
||||
Summary: Libraries for the Free Lossless Audio Codec
|
||||
Group: System Environment/Libraries
|
||||
Obsoletes: flac < 1.2.1-11
|
||||
|
||||
%description libs
|
||||
FLAC stands for Free Lossless Audio Codec. Grossly oversimplified, FLAC
|
||||
is similar to Ogg Vorbis, but lossless. The FLAC project consists of
|
||||
the stream format, reference encoders and decoders in library form,
|
||||
flac, a command-line program to encode and decode FLAC files, metaflac,
|
||||
a command-line metadata editor for FLAC files and input plugins for
|
||||
various music players.
|
||||
This package contains the FLAC libraries.
|
||||
|
||||
%package devel
|
||||
Summary: Development libraries and header files from FLAC
|
||||
Group: Development/Libraries
|
||||
Requires: %{name}-libs%{?_isa} = %{version}-%{release}
|
||||
Requires: pkgconfig
|
||||
|
||||
%description devel
|
||||
This package contains all the files needed to develop applications that
|
||||
will use the Free Lossless Audio Codec.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch1 -p1 -b .cflags
|
||||
%patch2 -p1 -b .memleak
|
||||
%patch3 -p1 -b .nonasm
|
||||
|
||||
%build
|
||||
# use our libtool to avoid problems with RPATH
|
||||
./autogen.sh -V
|
||||
|
||||
# -funroll-loops makes encoding about 10% faster
|
||||
export CFLAGS="%{optflags} -funroll-loops"
|
||||
%configure \
|
||||
--disable-xmms-plugin \
|
||||
--disable-silent-rules \
|
||||
--disable-thorough-tests
|
||||
|
||||
make %{?_smp_mflags}
|
||||
|
||||
%install
|
||||
make install DESTDIR=%{buildroot}
|
||||
|
||||
# split documentation
|
||||
mv %{buildroot}%{_docdir}/flac* ./flac-doc
|
||||
mkdir -p flac-doc-devel
|
||||
mv flac-doc{/html/api,-devel}
|
||||
rm flac-doc/FLAC.tag
|
||||
|
||||
rm %{buildroot}%{_libdir}/*.la
|
||||
|
||||
%check
|
||||
make -C test check FLAC__TEST_LEVEL=0 &> /dev/null
|
||||
|
||||
%ldconfig_scriptlets libs
|
||||
|
||||
%files
|
||||
%doc flac-doc/*
|
||||
%{_bindir}/flac
|
||||
%{_bindir}/metaflac
|
||||
%{_mandir}/man1/*
|
||||
|
||||
%files libs
|
||||
%doc AUTHORS COPYING* README
|
||||
%{_libdir}/*.so.*
|
||||
|
||||
%files devel
|
||||
%doc flac-doc-devel/*
|
||||
%{_includedir}/*
|
||||
%{_libdir}/*.so
|
||||
%{_libdir}/pkgconfig/*
|
||||
%{_datadir}/aclocal/*.m4
|
||||
|
||||
%changelog
|
||||
* Thu Sep 20 2018 Miroslav Lichvar <mlichvar@redhat.com> 1.3.2-9
|
||||
- disable nasm to avoid gaps in annobin coverage (#1630561)
|
||||
|
||||
* Wed May 16 2018 Miroslav Lichvar <mlichvar@redhat.com> 1.3.2-8
|
||||
- drop xmms-flac subpackage (#1578806)
|
||||
|
||||
* Wed May 02 2018 Miroslav Lichvar <mlichvar@redhat.com> 1.3.2-7
|
||||
- fix memory leak in parsing of vorbis comments (CVE-2017-6888)
|
||||
- add gcc to build requirements
|
||||
|
||||
* Wed Feb 07 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.3.2-6
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
|
||||
|
||||
* Sat Feb 03 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 1.3.2-5
|
||||
- Switch to %%ldconfig_scriptlets
|
||||
|
||||
* Wed Aug 02 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.3.2-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
|
||||
|
||||
* Wed Jul 26 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.3.2-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
|
||||
|
||||
* Fri Feb 10 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.3.2-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
|
||||
|
||||
* Mon Jan 02 2017 Miroslav Lichvar <mlichvar@redhat.com> 1.3.2-1
|
||||
- update to 1.3.2
|
||||
|
||||
* Wed Feb 03 2016 Fedora Release Engineering <releng@fedoraproject.org> - 1.3.1-6
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
|
||||
|
||||
* Mon Aug 10 2015 Tom Callaway <spot@fedoraproject.org> - 1.3.1-5
|
||||
- add xmms-flac plugin as a conditionalized subpackage
|
||||
|
||||
* Wed Jun 17 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3.1-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
|
||||
|
||||
* Sat May 02 2015 Kalev Lember <kalevlember@gmail.com> - 1.3.1-3
|
||||
- Rebuilt for GCC 5 C++11 ABI change
|
||||
|
||||
* Sat Feb 21 2015 Till Maas <opensource@till.name> - 1.3.1-2
|
||||
- Rebuilt for Fedora 23 Change
|
||||
https://fedoraproject.org/wiki/Changes/Harden_all_packages_with_position-independent_code
|
||||
|
||||
* Thu Nov 27 2014 Miroslav Lichvar <mlichvar@redhat.com> 1.3.1-1
|
||||
- update to 1.3.1 (CVE-2014-8962, CVE-2014-9028)
|
||||
|
||||
* Sat Aug 16 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3.0-5
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
|
||||
|
||||
* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3.0-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
|
||||
|
||||
* Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3.0-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
|
||||
|
||||
* Mon Jun 03 2013 Miroslav Lichvar <mlichvar@redhat.com> 1.3.0-2
|
||||
- fix memory corruption in metaflac (#969259)
|
||||
- disable slower assembly code
|
||||
|
||||
* Tue May 28 2013 Miroslav Lichvar <mlichvar@redhat.com> 1.3.0-1
|
||||
- update to 1.3.0
|
||||
|
||||
* Tue Apr 02 2013 Miroslav Lichvar <mlichvar@redhat.com> 1.3.0-0.2.pre3
|
||||
- update to 1.3.0pre3
|
||||
|
||||
* Tue Mar 05 2013 Miroslav Lichvar <mlichvar@redhat.com> 1.3.0-0.1.pre1
|
||||
- update to 1.3.0pre1
|
||||
- make some dependencies arch-specific
|
||||
|
||||
* Wed Feb 13 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2.1-13.20121204gita43f56
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
|
||||
|
||||
* Thu Dec 06 2012 Kalev Lember <kalevlember@gmail.com> - 1.2.1-12.20121204gita43f56
|
||||
- Added self-obsoletes to help multilib upgrades
|
||||
|
||||
* Tue Dec 04 2012 Miroslav Lichvar <mlichvar@redhat.com> 1.2.1-11.20121204gita43f56
|
||||
- update to 20121204gita43f56
|
||||
- create libs subpackage
|
||||
- split documentation to base and devel subpackages
|
||||
- drop defattr macros
|
||||
- add GFDL to License tag
|
||||
|
||||
* Thu Jul 19 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2.1-10
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
|
||||
|
||||
* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2.1-9
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
|
||||
|
||||
* Fri Dec 9 2011 Peter Robinson <pbrobinson@fedoraproject.org> - 1.2.1-8
|
||||
- Rebuild to fix FTBFS
|
||||
|
||||
* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2.1-7
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
|
||||
|
||||
* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2.1-6
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
|
||||
|
||||
* Tue Feb 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2.1-5
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
|
||||
|
||||
* Mon Mar 17 2008 Miroslav Lichvar <mlichvar@redhat.com> 1.2.1-4
|
||||
- speed up decoding
|
||||
- CFLAGS cleanup
|
||||
|
||||
* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.2.1-3
|
||||
- Autorebuild for GCC 4.3
|
||||
|
||||
* Tue Jan 29 2008 Miroslav Lichvar <mlichvar@redhat.com> 1.2.1-2
|
||||
- fix building with gcc-4.3
|
||||
- reenable some assembly optimizations
|
||||
- hide private libFLAC symbols (#285961)
|
||||
- update license tag
|
||||
- add %%check
|
||||
- remove -maltivec from CFLAGS
|
||||
|
||||
* Mon Sep 17 2007 - Bastien Nocera <bnocera@redhat.com> - 1.2.1-1
|
||||
- Update to 1.2.1
|
||||
|
||||
* Wed Sep 12 2007 - Bastien Nocera <bnocera@redhat.com> - 1.2.0-3
|
||||
- Make a few functions hidden, to try and avoid textrels
|
||||
- Disable optimisations on x86 for the same reason
|
||||
(#285961)
|
||||
|
||||
* Tue Sep 11 2007 - Bastien Nocera <bnocera@redhat.com> - 1.2.0-2
|
||||
- Update GNU stack patch to cover all the NASM sources used
|
||||
|
||||
* Mon Sep 10 2007 - Bastien Nocera <bnocera@redhat.com> - 1.2.0-1
|
||||
- Update for 1.20 and drop obsolete patches (#285161)
|
||||
|
||||
* Fri Aug 24 2007 Adam Jackson <ajax@redhat.com> - 1.1.4-5
|
||||
- Rebuild for build ID
|
||||
|
||||
* Thu Apr 12 2007 - Bastien Nocera <bnocera@redhat.com> - 1.1.4-4
|
||||
- The byteSwap symbol shouldn't be global, reported by Joe Orton
|
||||
<jorton@redhat.com> (#215920)
|
||||
|
||||
* Wed Feb 14 2007 - Bastien Nocera <bnocera@redhat.com> - 1.1.4-3
|
||||
- Also include the new pkgconfig files
|
||||
|
||||
* Wed Feb 14 2007 - Bastien Nocera <bnocera@redhat.com> - 1.1.4-2
|
||||
- Update link-ogg patch for 1.1.4
|
||||
|
||||
* Wed Feb 14 2007 - Bastien Nocera <bnocera@redhat.com> - 1.1.4-1
|
||||
- Update to upstream 1.1.4
|
||||
|
||||
* Tue Feb 13 2007 - Bastien Nocera <bnocera@redhat.com> - 1.1.3-2
|
||||
- A few fixes from the the Fedora merge review
|
||||
- Remove the static library
|
||||
|
||||
* Tue Feb 13 2007 - Bastien Nocera <bnocera@redhat.com> - 1.1.3-1
|
||||
- Update with work from Matthias Clasen <mclasen@redhat.com> up
|
||||
to upstream 1.1.3 (#229462)
|
||||
- Remove xmmx-flac Obsolete, as we don't ship the xmms plugin
|
||||
|
||||
* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 1.1.2-27
|
||||
- rebuild
|
||||
- Try building w/ glib2-devel
|
||||
|
||||
* Wed Jun 7 2006 Jeremy Katz <katzj@redhat.com> - 1.1.2-26
|
||||
- rebuild for -devel deps
|
||||
|
||||
* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 1.1.2-25.2.1
|
||||
- bump again for double-long bug on ppc(64)
|
||||
|
||||
* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 1.1.2-25.2
|
||||
- rebuilt for new gcc4.1 snapshot and glibc changes
|
||||
|
||||
* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
|
||||
- rebuilt
|
||||
|
||||
* Thu Apr 21 2005 Warren Togami <wtogami@redhat.com> - 1.1.2-25
|
||||
- Fix buildreqs (#154649 thias)
|
||||
- obsolete older xmms-flac
|
||||
|
||||
* Mon Apr 4 2005 Elliot Lee <sopwith@redhat.com> - 1.1.2-24
|
||||
- Removed xmms-flac subpackage
|
||||
|
||||
* Tue Mar 29 2005 John (J5) Palmieri <johnp@redhat.com> 1.1.2-2
|
||||
- Rebuild (flac picked up a dependancy on it's older version)
|
||||
|
||||
* Mon Mar 28 2005 John (J5) Palmieri <johnp@redhat.com> 1.1.2-1
|
||||
- Update to upstream version 1.1.2
|
||||
- Replace flac-1.1.0-libtool.patch with flac-1.1.2-libtool.patch
|
||||
|
||||
* Wed Mar 02 2005 John (J5) Palmieri <johnp@redhat.com> 1.1.0-9
|
||||
- rebuild for gcc 4.0
|
||||
|
||||
* Wed Feb 23 2005 Colin Walters <walters@redhat.com> 1.1.0-8
|
||||
- New patch flac-1.1.0-gnu-stack.patch from Ulrich Drepper to mark asm
|
||||
as not requiring an executable stack
|
||||
|
||||
* Thu Jul 15 2004 Tim Waugh <twaugh@redhat.com> 1.1.0-7
|
||||
- Fixed warnings in shipped m4 file.
|
||||
|
||||
* Mon Jun 21 2004 Colin Walters <walters@redhat.com> 1.1.0-6
|
||||
- BuildRequire glib-devel for xmms plugin
|
||||
- BuildRequire nasm
|
||||
|
||||
* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
|
||||
- rebuilt
|
||||
|
||||
* Sun Apr 04 2004 Warren Togami <wtogami@redhat.com> 1.1.0-4
|
||||
- #119551 flac-xmms -> xmms-flac to match fedora.us and freshrpms.net
|
||||
- Obsoletes flac-libs to upgrade smoothly from fedora.us
|
||||
|
||||
* Thu Mar 11 2004 Bill Nottingham <notting@redhat.com> 1.1.0-3
|
||||
- fix x86_64 linkage (#117893)
|
||||
|
||||
* Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
|
||||
- rebuilt
|
||||
|
||||
* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
|
||||
- rebuilt
|
||||
|
||||
* Wed Aug 6 2003 Bill Nottingham <notting@redhat.com> 1.1.0-1
|
||||
- initial build
|
Loading…
Reference in New Issue
Block a user