feat(service): add OpenTelemetry (OTLP) service
Resolves: RHEL-5973
This commit is contained in:
parent
dcf3c6db03
commit
3092542327
@ -0,0 +1,53 @@
|
|||||||
|
From a27f6afa21de35aa98e5309430dbcab9e6056f9c Mon Sep 17 00:00:00 2001
|
||||||
|
From: Pat Riehecky <riehecky@fnal.gov>
|
||||||
|
Date: Wed, 1 Feb 2023 09:52:43 -0600
|
||||||
|
Subject: [PATCH 05/22] v2.0.0: feat(service): add OpenTelemetry (OTLP) service
|
||||||
|
|
||||||
|
(cherry picked from commit 77c7061cc191bec6d8a36d2666c2d3c3e0ccbb4a)
|
||||||
|
---
|
||||||
|
config/Makefile.am | 1 +
|
||||||
|
config/services/opentelemetry.xml | 7 +++++++
|
||||||
|
po/POTFILES.in | 1 +
|
||||||
|
3 files changed, 9 insertions(+)
|
||||||
|
create mode 100644 config/services/opentelemetry.xml
|
||||||
|
|
||||||
|
diff --git a/config/Makefile.am b/config/Makefile.am
|
||||||
|
index d66398563ff2..47f30c1566e0 100644
|
||||||
|
--- a/config/Makefile.am
|
||||||
|
+++ b/config/Makefile.am
|
||||||
|
@@ -247,6 +247,7 @@ CONFIG_FILES = \
|
||||||
|
services/ntp.xml \
|
||||||
|
services/nut.xml \
|
||||||
|
services/openvpn.xml \
|
||||||
|
+ services/opentelemetry.xml \
|
||||||
|
services/ovirt-imageio.xml \
|
||||||
|
services/ovirt-storageconsole.xml \
|
||||||
|
services/ovirt-vmconsole.xml \
|
||||||
|
diff --git a/config/services/opentelemetry.xml b/config/services/opentelemetry.xml
|
||||||
|
new file mode 100644
|
||||||
|
index 000000000000..46c0e5258957
|
||||||
|
--- /dev/null
|
||||||
|
+++ b/config/services/opentelemetry.xml
|
||||||
|
@@ -0,0 +1,7 @@
|
||||||
|
+<?xml version="1.0" encoding="utf-8"?>
|
||||||
|
+<service>
|
||||||
|
+ <short>OTLP</short>
|
||||||
|
+ <description>OpenTelemetry Protocol (OTLP) specification describes the encoding, transport, and delivery mechanism of telemetry data between telemetry sources, intermediate nodes such as collectors and telemetry backends.</description>
|
||||||
|
+ <port protocol="tcp" port="4317"/>
|
||||||
|
+ <port protocol="tcp" port="4318"/>
|
||||||
|
+</service>
|
||||||
|
diff --git a/po/POTFILES.in b/po/POTFILES.in
|
||||||
|
index f3c0595980f9..1c990542ac4d 100644
|
||||||
|
--- a/po/POTFILES.in
|
||||||
|
+++ b/po/POTFILES.in
|
||||||
|
@@ -180,6 +180,7 @@ config/services/nrpe.xml
|
||||||
|
config/services/ntp.xml
|
||||||
|
config/services/nut.xml
|
||||||
|
config/services/openvpn.xml
|
||||||
|
+config/services/opentelemetry.xml
|
||||||
|
config/services/ovirt-imageio.xml
|
||||||
|
config/services/ovirt-storageconsole.xml
|
||||||
|
config/services/ovirt-vmconsole.xml
|
||||||
|
--
|
||||||
|
2.43.5
|
||||||
|
|
@ -1,7 +1,7 @@
|
|||||||
Summary: A firewall daemon with D-Bus interface providing a dynamic firewall
|
Summary: A firewall daemon with D-Bus interface providing a dynamic firewall
|
||||||
Name: firewalld
|
Name: firewalld
|
||||||
Version: 1.3.4
|
Version: 1.3.4
|
||||||
Release: 1%{?dist}
|
Release: 2%{?dist}
|
||||||
URL: http://www.firewalld.org
|
URL: http://www.firewalld.org
|
||||||
License: GPLv2+
|
License: GPLv2+
|
||||||
Source0: https://github.com/firewalld/firewalld/releases/download/v%{version}/firewalld-%{version}.tar.bz2
|
Source0: https://github.com/firewalld/firewalld/releases/download/v%{version}/firewalld-%{version}.tar.bz2
|
||||||
@ -9,6 +9,7 @@ Patch1: 0001-RHEL-only-Add-cockpit-by-default-to-some-zones.patch
|
|||||||
Patch2: 0002-v1.4.0-test-atlocal-pass-EBTABLES-to-testsuite.patch
|
Patch2: 0002-v1.4.0-test-atlocal-pass-EBTABLES-to-testsuite.patch
|
||||||
Patch3: 0003-v1.4.0-feat-direct-avoid-iptables-flush-if-using-nft.patch
|
Patch3: 0003-v1.4.0-feat-direct-avoid-iptables-flush-if-using-nft.patch
|
||||||
Patch4: 0004-v1.4.0-test-direct-avoid-iptables-flush-if-using-nft.patch
|
Patch4: 0004-v1.4.0-test-direct-avoid-iptables-flush-if-using-nft.patch
|
||||||
|
Patch5: 0005-v2.0.0-feat-service-add-OpenTelemetry-OTLP-service.patch
|
||||||
BuildArch: noarch
|
BuildArch: noarch
|
||||||
BuildRequires: autoconf
|
BuildRequires: autoconf
|
||||||
BuildRequires: automake
|
BuildRequires: automake
|
||||||
@ -111,6 +112,8 @@ end
|
|||||||
%autosetup -p1
|
%autosetup -p1
|
||||||
|
|
||||||
%build
|
%build
|
||||||
|
# must run automake since patches touch .am files
|
||||||
|
./autogen.sh
|
||||||
%configure --enable-sysconfig --enable-rpmmacros PYTHON="%{__python3} %{py3_shbang_opts}"
|
%configure --enable-sysconfig --enable-rpmmacros PYTHON="%{__python3} %{py3_shbang_opts}"
|
||||||
make %{?_smp_mflags}
|
make %{?_smp_mflags}
|
||||||
|
|
||||||
@ -230,6 +233,9 @@ rm -rf %{buildroot}%{_datadir}/firewalld/testsuite
|
|||||||
%{_mandir}/man1/firewall-config*.1*
|
%{_mandir}/man1/firewall-config*.1*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Jul 01 2024 Eric Garver <egarver@redhat.com> - 1.3.4-2
|
||||||
|
- feat(service): add OpenTelemetry (OTLP) service
|
||||||
|
|
||||||
* Thu Oct 26 2023 Eric Garver <egarver@redhat.com> - 1.3.4-1
|
* Thu Oct 26 2023 Eric Garver <egarver@redhat.com> - 1.3.4-1
|
||||||
- package rebase to v1.3.4
|
- package rebase to v1.3.4
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user