diff --git a/firefox.spec b/firefox.spec
index 5d3ed44..4a6bbcc 100644
--- a/firefox.spec
+++ b/firefox.spec
@@ -1207,7 +1207,9 @@ echo "--------------------------------------------"
 %endif
 %patch -P9 -p1 -b .rhbz-2131158-webrtc-nss-fix
 %patch -P10 -p1 -b .build-ffvpx
+%if 0%{?rhel} == 10
 %patch -P12 -p1 -b .system-nss-replace-xyber-with-mlkem
+%endif
 
 # We need to create the wasi.patch with the correct path to the wasm libclang_rt.
 %if %{with wasi_sdk}
@@ -1247,6 +1249,7 @@ export LIBCLANG_RT=`pwd`/wasi-sdk-20/build/compiler-rt/lib/wasi/libclang_rt.buil
 %endif
 
 # --- Upstream PipeWire camera and screencast fixes ----
+%if %{?use_pipewire_camera}
 %patch -P250 -p1 -b .pipewire-screencast-hide-cursor-when-goes-off-screen-or-is-invisible
 %patch -P251 -p1 -b .pipewire-camera-support-additional-formats-and-fix-rgb-bgr-mapping
 %patch -P252 -p1 -b .pipewire-camera-filter-out-devices-without-capabilities
@@ -1257,6 +1260,7 @@ export LIBCLANG_RT=`pwd`/wasi-sdk-20/build/compiler-rt/lib/wasi/libclang_rt.buil
 %patch -P257 -p1 -b .pipewire-camera-get-max-fps-for-each-format-when-specified-as-list
 %patch -P258 -p1 -b .pipewire-camera-use-exact-stream-parameters-specified-by-capability
 %patch -P259 -p1 -b .pipewire-camera-use-better-unique-device-name-for-camera-devices
+%endif
 
 # ---- Security patches ----