diff --git a/.gitignore b/.gitignore
index 914c049..2a2c136 100644
--- a/.gitignore
+++ b/.gitignore
@@ -606,3 +606,5 @@ firefox-3.6.4.source.tar.bz2
 /dump_syms-vendor.tar.xz
 /firefox-langpacks-119.0.1-20231110.tar.xz
 /firefox-119.0.1.source.tar.xz
+/firefox-120.0.source.tar.xz
+/firefox-langpacks-120.0-20231114.tar.xz
diff --git a/fedora-customization.patch b/fedora-customization.patch
index 2bcb335..e1d54b0 100644
--- a/fedora-customization.patch
+++ b/fedora-customization.patch
@@ -1,7 +1,7 @@
-diff --git a/toolkit/xre/nsAppRunner.cpp b/toolkit/xre/nsAppRunner.cpp
---- a/toolkit/xre/nsAppRunner.cpp
-+++ b/toolkit/xre/nsAppRunner.cpp
-@@ -5762,6 +5762,12 @@ int XREMain::XRE_main(int argc, char* ar
+diff -up firefox-120.0/toolkit/xre/nsAppRunner.cpp.fedora-customization firefox-120.0/toolkit/xre/nsAppRunner.cpp
+--- firefox-120.0/toolkit/xre/nsAppRunner.cpp.fedora-customization	2023-11-13 21:48:38.000000000 +0100
++++ firefox-120.0/toolkit/xre/nsAppRunner.cpp	2023-11-14 10:39:13.001603081 +0100
+@@ -5765,6 +5765,12 @@ int XREMain::XRE_main(int argc, char* ar
    if (!mAppData->remotingName) {
      mAppData->remotingName = mAppData->name;
    }
@@ -14,21 +14,18 @@ diff --git a/toolkit/xre/nsAppRunner.cpp b/toolkit/xre/nsAppRunner.cpp
    // used throughout this file
    gAppData = mAppData.get();
  
-diff --git a/widget/gtk/nsWindow.cpp b/widget/gtk/nsWindow.cpp
---- a/widget/gtk/nsWindow.cpp
-+++ b/widget/gtk/nsWindow.cpp
-@@ -3448,7 +3448,13 @@ void* nsWindow::GetNativeData(uint32_t a
+diff -up firefox-120.0/widget/gtk/nsWindow.cpp.fedora-customization firefox-120.0/widget/gtk/nsWindow.cpp
+--- firefox-120.0/widget/gtk/nsWindow.cpp.fedora-customization	2023-11-14 10:39:13.003603150 +0100
++++ firefox-120.0/widget/gtk/nsWindow.cpp	2023-11-14 10:41:06.339532735 +0100
+@@ -3457,6 +3457,11 @@ void* nsWindow::GetNativeData(uint32_t a
  nsresult nsWindow::SetTitle(const nsAString& aTitle) {
    if (!mShell) return NS_OK;
  
--    // convert the string into utf8 and set the title.
 +  const char* appTitle = getenv("MOZ_APP_TITLE");
 +  if (appTitle) {
 +    gtk_window_set_title(GTK_WINDOW(mShell), appTitle);
 +    return NS_OK;
 +  }
-+
-+  // convert the string into utf8 and set the title.
- #define UTF8_FOLLOWBYTE(ch) (((ch)&0xC0) == 0x80)
+     // convert the string into utf8 and set the title.
+ #define UTF8_FOLLOWBYTE(ch) (((ch) & 0xC0) == 0x80)
    NS_ConvertUTF16toUTF8 titleUTF8(aTitle);
-   if (titleUTF8.Length() > NS_WINDOW_TITLE_MAX_LENGTH) {
diff --git a/firefox.spec b/firefox.spec
index 8d1209d..c125071 100644
--- a/firefox.spec
+++ b/firefox.spec
@@ -168,13 +168,13 @@ ExcludeArch: i686
 
 Summary:        Mozilla Firefox Web browser
 Name:           firefox
-Version:        119.0.1
+Version:        120.0
 Release:        1%{?pre_tag}%{?dist}
 URL:            https://www.mozilla.org/firefox/
 License:        MPLv1.1 or GPLv2+ or LGPLv2+
 Source0:        https://archive.mozilla.org/pub/firefox/releases/%{version}%{?pre_version}/source/firefox-%{version}%{?pre_version}.source.tar.xz
 %if %{with langpacks}
-Source1:        firefox-langpacks-%{version}%{?pre_version}-20231110.tar.xz
+Source1:        firefox-langpacks-%{version}%{?pre_version}-20231114.tar.xz
 %endif
 Source2:        cbindgen-vendor.tar.xz
 Source3:        dump_syms-vendor.tar.xz
@@ -248,8 +248,6 @@ Patch242:        0026-Add-KDE-integration-to-Firefox.patch
 Patch402:        mozilla-1196777.patch
 Patch407:        mozilla-1667096.patch
 Patch408:        D167159.diff
-Patch409:        D192061.1699444912.diff
-Patch410:        D192208.1699444906.diff
 Patch411:        mozilla-1762816.patch
 
 # PGO/LTO patches
@@ -522,7 +520,7 @@ This package contains results of tests executed during build.
 # Test patches
 #%patch100 -p1 -b .firefox-tests-xpcshell
 #%patch101 -p1 -b .firefox-tests-reftest
-%patch102 -p1 -b .firefox-tests-xpcshell-freeze
+#%patch102 -p1 -b .firefox-tests-xpcshell-freeze
 
 # Fedora patches
 %patch215 -p1 -b .addons
@@ -542,8 +540,6 @@ This package contains results of tests executed during build.
 %patch402 -p1 -b .1196777
 %patch407 -p1 -b .1667096
 %patch408 -p1 -b .D167159
-%patch409 -p1 -b .D192061
-%patch410 -p1 -b .D192208
 %patch411 -p1 -b .mozilla-1762816
 
 # PGO patches
@@ -1153,6 +1149,9 @@ fi
 #---------------------------------------------------------------------
 
 %changelog
+* Tue Nov 14 2023 Martin Stransky <stransky@redhat.com>- 120.0-1
+- Updated to 120.0
+
 * Fri Nov 10 2023 Martin Stransky <stransky@redhat.com>- 119.0.1-1
 - Updated to 119.0.1
 
diff --git a/sources b/sources
index 99133cf..081f4b1 100644
--- a/sources
+++ b/sources
@@ -1,5 +1,5 @@
 SHA512 (mochitest-python.tar.gz) = 089b1593068b76f4572af0086eaccf52a6a1299bfffb58593206d19bf021ae381f2380bbfeb4371586cd53706ff6dde3d240238b2caf19b96c57dfc2f4524e36
 SHA512 (cbindgen-vendor.tar.xz) = 3e7eaff088db918e95f5505e5feeb06e8b7b95cc62042a6d163a708fc76baea43d21bf49cf7e02bc64fdfc61e8d7704057dbb225098de56e110783104d166c54
 SHA512 (dump_syms-vendor.tar.xz) = 5769c052fa874a965eb8837776b01fb097e8930f45d0d0d2a93997c4fae8726184a192aee52302bde62e62897801b1463cae9283563d9d60e8b8ee80a250f2a3
-SHA512 (firefox-langpacks-119.0.1-20231110.tar.xz) = e1afd9529a4584c553bbd0def42b24a7aeed5c8dba6c3cc8965608a7aa90c1cf053e6b8ea885b9f2ee3d56351e9970d3ed5e0ee551bbbac441c00798c8d217ca
-SHA512 (firefox-119.0.1.source.tar.xz) = 4f3201aee10e7b831cc384b2c7430a24f4de81f703115a917f9eb7acecb2ae1725f11af56c41257a056bb9d7a4d749d590cc9baffcd6e13852be45aaecf8163a
+SHA512 (firefox-120.0.source.tar.xz) = 3c6f7de5e3b79883b6f92bbc5c0ad36e2e7961981d59ce8495e92cdf310a74b94bfa1dae80737970d15eeaafbe886e53bd7bfd99a71ae0ec4a7175f12079529f
+SHA512 (firefox-langpacks-120.0-20231114.tar.xz) = 61e52b3f21f8f66ed08b87d4093987e9459830702c622be63bb94e1148d8daa9bdbfe68a5f4c67b9a2b199290f4f48418cfdd893ad1dba78c7825008a6bf4259