patch out definition of gettid now that glibc has it
This commit is contained in:
parent
03ffbea6c0
commit
9a4af46fa2
14
fio-3.14-no-redef-gettid.patch
Normal file
14
fio-3.14-no-redef-gettid.patch
Normal file
@ -0,0 +1,14 @@
|
|||||||
|
--- fio-3.14/os/os-linux.h.orig 2019-05-22 17:29:16.413054806 -0500
|
||||||
|
+++ fio-3.14/os/os-linux.h 2019-05-22 17:29:20.977241736 -0500
|
||||||
|
@@ -124,11 +124,6 @@
|
||||||
|
return syscall(__NR_ioprio_set, which, who, ioprio);
|
||||||
|
}
|
||||||
|
|
||||||
|
-static inline int gettid(void)
|
||||||
|
-{
|
||||||
|
- return syscall(__NR_gettid);
|
||||||
|
-}
|
||||||
|
-
|
||||||
|
#define SPLICE_DEF_SIZE (64*1024)
|
||||||
|
|
||||||
|
#ifndef BLKGETSIZE64
|
4
fio.spec
4
fio.spec
@ -7,6 +7,8 @@ License: GPLv2
|
|||||||
URL: http://git.kernel.dk/?p=fio.git;a=summary
|
URL: http://git.kernel.dk/?p=fio.git;a=summary
|
||||||
Source: http://brick.kernel.dk/snaps/%{name}-%{version}.tar.bz2
|
Source: http://brick.kernel.dk/snaps/%{name}-%{version}.tar.bz2
|
||||||
|
|
||||||
|
Patch0: fio-3.14-no-redef-gettid.patch
|
||||||
|
|
||||||
BuildRequires: gcc
|
BuildRequires: gcc
|
||||||
BuildRequires: libaio-devel
|
BuildRequires: libaio-devel
|
||||||
BuildRequires: zlib-devel
|
BuildRequires: zlib-devel
|
||||||
@ -35,6 +37,8 @@ one wants to simulate.
|
|||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
|
|
||||||
|
%patch0 -p1
|
||||||
|
|
||||||
%build
|
%build
|
||||||
./configure --disable-optimizations
|
./configure --disable-optimizations
|
||||||
EXTFLAGS="$RPM_OPT_FLAGS" LDFLAGS="$RPM_LD_FLAGS" make V=1 %{?_smp_mflags}
|
EXTFLAGS="$RPM_OPT_FLAGS" LDFLAGS="$RPM_LD_FLAGS" make V=1 %{?_smp_mflags}
|
||||||
|
Loading…
Reference in New Issue
Block a user