Use LDFLAGS when linking dynamic engines
Resolves: rhbz#2044858
This commit is contained in:
parent
dda6fbc526
commit
212d1fbc82
30
0001-fio-use-LDFLAGS-when-linking-dynamic-engines.patch
Normal file
30
0001-fio-use-LDFLAGS-when-linking-dynamic-engines.patch
Normal file
@ -0,0 +1,30 @@
|
|||||||
|
From 2b3d4a6a924e0aa82654d3b96fb134085af7a98a Mon Sep 17 00:00:00 2001
|
||||||
|
From: Eric Sandeen <esandeen@redhat.com>
|
||||||
|
Date: Wed, 26 Jan 2022 08:49:45 -0600
|
||||||
|
Subject: [PATCH] fio: use LDFLAGS when linking dynamic engines
|
||||||
|
|
||||||
|
Without this, locally defined LDFLAGS won't be applied when
|
||||||
|
linking the dynamically loaded IO engines.
|
||||||
|
|
||||||
|
Signed-off-by: Eric Sandeen <sandeen@redhat.com>
|
||||||
|
Signed-off-by: Jens Axboe <axboe@kernel.dk>
|
||||||
|
---
|
||||||
|
Makefile | 2 +-
|
||||||
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||||
|
|
||||||
|
diff --git a/Makefile b/Makefile
|
||||||
|
index 76eb0d7d..00e79539 100644
|
||||||
|
--- a/Makefile
|
||||||
|
+++ b/Makefile
|
||||||
|
@@ -295,7 +295,7 @@ define engine_template =
|
||||||
|
$(1)_OBJS := $$($(1)_SRCS:.c=.o)
|
||||||
|
$$($(1)_OBJS): CFLAGS := -fPIC $$($(1)_CFLAGS) $(CFLAGS)
|
||||||
|
engines/fio-$(1).so: $$($(1)_OBJS)
|
||||||
|
- $$(QUIET_LINK)$(CC) -shared -rdynamic -fPIC -Wl,-soname,fio-$(1).so.1 -o $$@ $$< $$($(1)_LIBS)
|
||||||
|
+ $$(QUIET_LINK)$(CC) $(DYNAMIC) -shared -rdynamic -fPIC -Wl,-soname,fio-$(1).so.1 -o $$@ $$< $$($(1)_LIBS)
|
||||||
|
ENGS_OBJS += engines/fio-$(1).so
|
||||||
|
endef
|
||||||
|
else # !CONFIG_DYNAMIC_ENGINES
|
||||||
|
--
|
||||||
|
2.31.1
|
||||||
|
|
7
fio.spec
7
fio.spec
@ -1,6 +1,6 @@
|
|||||||
Name: fio
|
Name: fio
|
||||||
Version: 3.27
|
Version: 3.27
|
||||||
Release: 5%{?dist}
|
Release: 6%{?dist}
|
||||||
Summary: Multithreaded IO generation tool
|
Summary: Multithreaded IO generation tool
|
||||||
|
|
||||||
License: GPLv2
|
License: GPLv2
|
||||||
@ -9,6 +9,7 @@ Source: http://brick.kernel.dk/snaps/%{name}-%{version}.tar.bz2
|
|||||||
|
|
||||||
Patch0: 0001-ioengines-fix-crash-with-enghelp-option.patch
|
Patch0: 0001-ioengines-fix-crash-with-enghelp-option.patch
|
||||||
Patch1: 0001-fio-remove-raw-device-support.patch
|
Patch1: 0001-fio-remove-raw-device-support.patch
|
||||||
|
Patch2: 0001-fio-use-LDFLAGS-when-linking-dynamic-engines.patch
|
||||||
|
|
||||||
BuildRequires: gcc
|
BuildRequires: gcc
|
||||||
BuildRequires: libaio-devel
|
BuildRequires: libaio-devel
|
||||||
@ -210,6 +211,10 @@ make install prefix=%{_prefix} mandir=%{_mandir} libdir=%{_libdir}/fio DESTDIR=$
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Feb 04 2022 Eric Sandeen <sandeen@redhat.com> - 3.27.6
|
||||||
|
- Use LDFLAGS when linking dynamic engines
|
||||||
|
Related: rhbz#2044858
|
||||||
|
|
||||||
* Tue Aug 10 2021 Eric Sandeen <sandeen@redhat.com> - 3.27.5
|
* Tue Aug 10 2021 Eric Sandeen <sandeen@redhat.com> - 3.27.5
|
||||||
- Add gating CI yaml file
|
- Add gating CI yaml file
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user