2.0.13
This commit is contained in:
parent
8bfefa51ab
commit
1b9d30af8c
1
.gitignore
vendored
1
.gitignore
vendored
@ -1 +1,2 @@
|
||||
/fio-2.*.tar.bz2
|
||||
/fio-2.0.13.tar.gz
|
||||
|
@ -1,40 +0,0 @@
|
||||
From 4de98eb0e68314ba36fcfc2722a1c9b3bc5d3318 Mon Sep 17 00:00:00 2001
|
||||
From: Jens Axboe <axboe@kernel.dk>
|
||||
Date: Tue, 1 Jan 2013 10:59:04 +0100
|
||||
Subject: [PATCH] Move 'tsc_reliable' outside of ARCH_HAVE_CPU_CLOCK
|
||||
MIME-Version: 1.0
|
||||
Content-Type: text/plain; charset=UTF-8
|
||||
Content-Transfer-Encoding: 8bit
|
||||
|
||||
Otherwise we fail building on architectures that do not define
|
||||
it, as reported by Dan:
|
||||
|
||||
cc -o gettime.o -c -std=gnu99 -Wwrite-strings -Wall -O3 -g -O2 -g -pipe
|
||||
-Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector
|
||||
--param=ssp-buffer-size=4 -m31 -march=z9-109 -mtune=z10
|
||||
-DFIO_VERSION='"fio-2.0.12.2"' -D_GNU_SOURCE -D_LARGEFILE_SOURCE
|
||||
-D_FILE_OFFSET_BITS=64 -D_FORTIFY_SOURCE=2 -DFIO_INC_DEBUG gettime.c
|
||||
gettime.c: In function 'fio_clock_init':
|
||||
gettime.c:317:6: error: 'tsc_reliable' undeclared (first use in this function)
|
||||
gettime.c:317:6: note: each undeclared identifier is reported only once for each function it appears in
|
||||
make: *** [gettime.o] Error 1
|
||||
|
||||
Reported-by: Dan Horák <dan@danny.cz>
|
||||
Signed-off-by: Jens Axboe <axboe@kernel.dk>
|
||||
---
|
||||
gettime.c | 2 +-
|
||||
1 files changed, 1 insertions(+), 1 deletions(-)
|
||||
|
||||
diff -up fio-2.0.12.2/gettime.c.no-arch-cpu-clock fio-2.0.12.2/gettime.c
|
||||
--- fio-2.0.12.2/gettime.c.no-arch-cpu-clock 2012-12-20 15:19:57.000000000 +0100
|
||||
+++ fio-2.0.12.2/gettime.c 2013-01-01 11:40:29.000000000 +0100
|
||||
@@ -15,8 +15,8 @@
|
||||
|
||||
#ifdef ARCH_HAVE_CPU_CLOCK
|
||||
static unsigned long cycles_per_usec;
|
||||
-int tsc_reliable = 0;
|
||||
#endif
|
||||
+int tsc_reliable = 0;
|
||||
|
||||
struct tv_valid {
|
||||
struct timeval last_tv;
|
8
fio.spec
8
fio.spec
@ -1,6 +1,6 @@
|
||||
Name: fio
|
||||
Version: 2.0.12.2
|
||||
Release: 2%{?dist}
|
||||
Version: 2.0.13
|
||||
Release: 1%{?dist}
|
||||
Summary: Multithreaded IO generation tool
|
||||
|
||||
Group: Applications/System
|
||||
@ -24,7 +24,6 @@ one wants to simulate.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1 -b .no-arch-cpu-clock
|
||||
|
||||
%build
|
||||
EXTFLAGS="$RPM_OPT_FLAGS" make V=1 %{?_smp_mflags}
|
||||
@ -43,6 +42,9 @@ rm -rf $RPM_BUILD_ROOT
|
||||
%{_mandir}/man1/*
|
||||
|
||||
%changelog
|
||||
* Wed Jan 9 2013 Peter Robinson <pbrobinson@fedoraproject.org> 2.0.13-1
|
||||
- New upstream 2.0.13 release
|
||||
|
||||
* Tue Jan 01 2013 Dan Horák <dan[at]danny.cz> - 2.0.12.2-2
|
||||
- fix build on arches without ARCH_HAVE_CPU_CLOCK (arm, s390)
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user