auto-import changelog data from findutils-4.1.20-1.src.rpm
Fri Jun 25 2004 Tim Waugh <twaugh@redhat.com> 4.1.20-1 - Clarify find man page (bug #126098). - Apply changes by Robert Scheck <redhat@linuxnetz.de> (bug #126352): - Upgrade to 4.1.20 and some specfile cleanup
This commit is contained in:
parent
356b0df496
commit
d34d182f51
@ -1 +1 @@
|
||||
findutils-4.1.7.tar.gz
|
||||
findutils-4.1.20.tar.gz
|
||||
|
@ -1,19 +1,19 @@
|
||||
--- findutils-4.1.7/find/Makefile.am.selinux 2000-04-05 03:34:33.000000000 -0400
|
||||
+++ findutils-4.1.7/find/Makefile.am 2003-10-10 13:06:11.450070637 -0400
|
||||
--- findutils-4.1.20/find/Makefile.am.selinux 2003-05-26 19:02:34.000000000 +0100
|
||||
+++ findutils-4.1.20/find/Makefile.am 2004-06-25 15:41:32.551569936 +0100
|
||||
@@ -3,8 +3,9 @@
|
||||
bin_PROGRAMS = find
|
||||
find_SOURCES = find.c fstype.c parser.c pred.c tree.c util.c version.c
|
||||
EXTRA_DIST = defs.h $(man_MANS)
|
||||
+DEFS = @DEFS@ -I. -I$(srcdir) -I.. -DWITH_SELINUX
|
||||
INCLUDES = -I$(top_srcdir)/lib -I../intl -DLOCALEDIR=\"$(localedir)\"
|
||||
-LDADD = ../lib/libfind.a @INTLLIBS@
|
||||
+LDADD = ../lib/libfind.a @INTLLIBS@ -lselinux
|
||||
INCLUDES = -I../gnulib/lib -I$(top_srcdir)/lib -I$(top_srcdir)/gnulib/lib -I../intl -DLOCALEDIR=\"$(localedir)\"
|
||||
-LDADD = ../lib/libfind.a ../gnulib/lib/libgnulib.a @INTLLIBS@
|
||||
+LDADD = ../lib/libfind.a ../gnulib/lib/libgnulib.a @INTLLIBS@ -lselinux
|
||||
man_MANS = find.1
|
||||
SUBDIRS = testsuite
|
||||
|
||||
--- findutils-4.1.7/find/defs.h.selinux 2001-05-20 16:39:37.000000000 -0400
|
||||
+++ findutils-4.1.7/find/defs.h 2003-10-10 13:06:11.451070520 -0400
|
||||
@@ -118,6 +118,10 @@
|
||||
--- findutils-4.1.20/find/defs.h.selinux 2004-06-25 15:39:56.115013659 +0100
|
||||
+++ findutils-4.1.20/find/defs.h 2004-06-25 15:39:56.209995493 +0100
|
||||
@@ -127,6 +127,10 @@
|
||||
#define MODE_RWX (S_IXUSR | S_IXGRP | S_IXOTH | MODE_RW)
|
||||
#define MODE_ALL (S_ISUID | S_ISGID | S_ISVTX | MODE_RWX)
|
||||
|
||||
@ -24,7 +24,7 @@
|
||||
/* Not char because of type promotion; NeXT gcc can't handle it. */
|
||||
typedef int boolean;
|
||||
#define true 1
|
||||
@@ -265,6 +269,9 @@
|
||||
@@ -278,6 +282,9 @@
|
||||
struct perm_val perm; /* perm */
|
||||
mode_t type; /* type */
|
||||
FILE *stream; /* fprint fprint0 */
|
||||
@ -34,7 +34,7 @@
|
||||
struct format_val printf_vec; /* printf fprintf */
|
||||
} args;
|
||||
|
||||
@@ -310,6 +317,11 @@
|
||||
@@ -323,6 +330,11 @@
|
||||
VOID *xmalloc PARAMS((size_t n));
|
||||
VOID *xrealloc PARAMS((VOID *p, size_t n));
|
||||
|
||||
@ -46,8 +46,8 @@
|
||||
/* xstrdup.c */
|
||||
char *xstrdup PARAMS((char *string));
|
||||
|
||||
--- findutils-4.1.7/find/find.1.selinux 2003-10-10 13:06:11.334084221 -0400
|
||||
+++ findutils-4.1.7/find/find.1 2003-10-10 13:06:11.555058342 -0400
|
||||
--- findutils-4.1.20/find/find.1.selinux 2004-06-25 15:39:56.087019013 +0100
|
||||
+++ findutils-4.1.20/find/find.1 2004-06-25 15:39:56.211995111 +0100
|
||||
@@ -230,6 +230,9 @@
|
||||
file of type \fIc\fR; if \-follow has been given, true if \fIc\fR is
|
||||
`l'. In other words, for symbolic links, \-xtype checks the type of
|
||||
@ -67,9 +67,9 @@
|
||||
.PP
|
||||
A `%' character followed by any other character is discarded (but the
|
||||
other character is printed).
|
||||
--- findutils-4.1.7/find/find.c.selinux 2001-05-20 16:39:37.000000000 -0400
|
||||
+++ findutils-4.1.7/find/find.c 2003-10-10 13:06:11.556058225 -0400
|
||||
@@ -135,6 +135,9 @@
|
||||
--- findutils-4.1.20/find/find.c.selinux 2004-06-25 15:39:56.123012130 +0100
|
||||
+++ findutils-4.1.20/find/find.c 2004-06-25 15:39:56.213994729 +0100
|
||||
@@ -154,6 +154,9 @@
|
||||
|
||||
/* Pointer to the function used to stat files. */
|
||||
int (*xstat) ();
|
||||
@ -79,7 +79,7 @@
|
||||
|
||||
/* Status value to return to system. */
|
||||
int exit_status;
|
||||
@@ -181,6 +184,10 @@
|
||||
@@ -200,6 +203,10 @@
|
||||
xstat = debug_stat;
|
||||
#else /* !DEBUG_STAT */
|
||||
xstat = lstat;
|
||||
@ -90,7 +90,7 @@
|
||||
#endif /* !DEBUG_STAT */
|
||||
|
||||
human_block_size (getenv ("FIND_BLOCK_SIZE"), 0, &output_block_size);
|
||||
@@ -202,6 +209,14 @@
|
||||
@@ -221,6 +228,14 @@
|
||||
if (strchr ("-!(),", argv[i][0]) == NULL)
|
||||
usage (_("paths must precede expression"));
|
||||
predicate_name = argv[i];
|
||||
@ -105,9 +105,9 @@
|
||||
parse_function = find_parser (predicate_name);
|
||||
if (parse_function == NULL)
|
||||
/* Command line option not recognized */
|
||||
--- findutils-4.1.7/find/parser.c.selinux 2001-05-20 16:39:37.000000000 -0400
|
||||
+++ findutils-4.1.7/find/parser.c 2003-10-10 13:06:11.558057991 -0400
|
||||
@@ -23,6 +23,10 @@
|
||||
--- findutils-4.1.20/find/parser.c.selinux 2004-06-25 15:39:56.130010791 +0100
|
||||
+++ findutils-4.1.20/find/parser.c 2004-06-25 15:39:56.218993772 +0100
|
||||
@@ -25,6 +25,10 @@
|
||||
#include "modetype.h"
|
||||
#include "xstrtol.h"
|
||||
|
||||
@ -118,7 +118,7 @@
|
||||
#if ENABLE_NLS
|
||||
# include <libintl.h>
|
||||
# define _(Text) gettext (Text)
|
||||
@@ -113,6 +117,9 @@
|
||||
@@ -115,6 +119,9 @@
|
||||
static boolean parse_version PARAMS((char *argv[], int *arg_ptr));
|
||||
static boolean parse_xdev PARAMS((char *argv[], int *arg_ptr));
|
||||
static boolean parse_xtype PARAMS((char *argv[], int *arg_ptr));
|
||||
@ -128,7 +128,7 @@
|
||||
|
||||
static boolean insert_regex PARAMS((char *argv[], int *arg_ptr, boolean ignore_case));
|
||||
static boolean insert_type PARAMS((char *argv[], int *arg_ptr, boolean (*which_pred )()));
|
||||
@@ -215,7 +222,11 @@
|
||||
@@ -217,7 +224,11 @@
|
||||
{"-version", parse_version}, /* GNU */
|
||||
{"xdev", parse_xdev},
|
||||
{"xtype", parse_xtype}, /* GNU */
|
||||
@ -141,7 +141,7 @@
|
||||
};
|
||||
|
||||
/* Return a pointer to the parser function to invoke for predicate
|
||||
@@ -465,7 +476,10 @@
|
||||
@@ -467,7 +478,10 @@
|
||||
{
|
||||
dereference = true;
|
||||
xstat = stat;
|
||||
@ -153,7 +153,7 @@
|
||||
return (true);
|
||||
}
|
||||
|
||||
@@ -570,6 +584,10 @@
|
||||
@@ -572,6 +586,10 @@
|
||||
-nouser -nogroup -path PATTERN -perm [+-]MODE -regex PATTERN\n\
|
||||
-size N[bckw] -true -type [bcdpfls] -uid N -used N -user NAME\n\
|
||||
-xtype [bcdpfls]\n"));
|
||||
@ -164,7 +164,7 @@
|
||||
puts (_("\
|
||||
actions: -exec COMMAND ; -fprint FILE -fprint0 FILE -fprintf FILE FORMAT\n\
|
||||
-ok COMMAND ; -print -print0 -printf FORMAT -prune -ls\n"));
|
||||
@@ -1200,6 +1218,32 @@
|
||||
@@ -1204,6 +1222,32 @@
|
||||
return true;
|
||||
}
|
||||
|
||||
@ -197,7 +197,7 @@
|
||||
static boolean
|
||||
parse_xtype (char **argv, int *arg_ptr)
|
||||
{
|
||||
@@ -1358,7 +1402,11 @@
|
||||
@@ -1363,7 +1407,11 @@
|
||||
if (*scan2 == '.')
|
||||
for (scan2++; ISDIGIT (*scan2); scan2++)
|
||||
/* Do nothing. */ ;
|
||||
@ -210,9 +210,9 @@
|
||||
{
|
||||
segmentp = make_segment (segmentp, format, scan2 - format,
|
||||
(int) *scan2);
|
||||
--- findutils-4.1.7/find/pred.c.selinux 2001-05-20 16:39:37.000000000 -0400
|
||||
+++ findutils-4.1.7/find/pred.c 2003-10-10 13:15:13.752422594 -0400
|
||||
@@ -27,6 +27,14 @@
|
||||
--- findutils-4.1.20/find/pred.c.selinux 2004-06-25 15:39:56.120012703 +0100
|
||||
+++ findutils-4.1.20/find/pred.c 2004-06-25 15:39:56.222993008 +0100
|
||||
@@ -29,6 +29,14 @@
|
||||
#include "modetype.h"
|
||||
#include "wait.h"
|
||||
|
||||
@ -227,7 +227,7 @@
|
||||
#if ENABLE_NLS
|
||||
# include <libintl.h>
|
||||
# define _(Text) gettext (Text)
|
||||
@@ -69,7 +77,6 @@
|
||||
@@ -71,7 +79,6 @@
|
||||
|
||||
extern int yesno ();
|
||||
|
||||
@ -235,7 +235,7 @@
|
||||
/* Get or fake the disk device blocksize.
|
||||
Usually defined by sys/param.h (if at all). */
|
||||
#ifndef DEV_BSIZE
|
||||
@@ -196,6 +203,9 @@
|
||||
@@ -198,6 +205,9 @@
|
||||
{pred_used, "used "},
|
||||
{pred_user, "user "},
|
||||
{pred_xtype, "xtype "},
|
||||
@ -245,7 +245,7 @@
|
||||
{0, "none "}
|
||||
};
|
||||
|
||||
@@ -719,6 +729,26 @@
|
||||
@@ -723,6 +733,26 @@
|
||||
fprintf (fp, segment->text,
|
||||
human_readable ((uintmax_t) stat_buf->st_uid, hbuf, 1, 1));
|
||||
break;
|
||||
@ -272,7 +272,7 @@
|
||||
}
|
||||
}
|
||||
return (true);
|
||||
@@ -1220,6 +1250,34 @@
|
||||
@@ -1231,6 +1261,34 @@
|
||||
}
|
||||
return (pred_type (pathname, &sbuf, pred_ptr));
|
||||
}
|
||||
@ -307,29 +307,29 @@
|
||||
|
||||
/* 1) fork to get a child; parent remembers the child pid
|
||||
2) child execs the command requested
|
||||
--- findutils-4.1.7/find/Makefile.in.selinux 2001-05-20 17:16:36.000000000 -0400
|
||||
+++ findutils-4.1.7/find/Makefile.in 2003-10-10 13:06:11.560057756 -0400
|
||||
@@ -110,7 +110,7 @@
|
||||
--- findutils-4.1.20/find/Makefile.in.selinux 2003-05-26 19:18:11.000000000 +0100
|
||||
+++ findutils-4.1.20/find/Makefile.in 2004-06-25 15:42:30.881421141 +0100
|
||||
@@ -54,7 +54,7 @@
|
||||
CPPFLAGS = @CPPFLAGS@
|
||||
CYGPATH_W = @CYGPATH_W@
|
||||
DATADIRNAME = @DATADIRNAME@
|
||||
-DEFS = @DEFS@
|
||||
+DEFS = @DEFS@ -DWITH_SELINUX
|
||||
DEPDIR = @DEPDIR@
|
||||
ECHO_C = @ECHO_C@
|
||||
ECHO_N = @ECHO_N@
|
||||
@@ -145,7 +145,7 @@
|
||||
bin_PROGRAMS = find
|
||||
find_SOURCES = find.c fstype.c parser.c pred.c tree.c util.c version.c
|
||||
EXTRA_DIST = defs.h $(man_MANS)
|
||||
INCLUDES = -I$(top_srcdir)/lib -I../intl -DLOCALEDIR=\"$(localedir)\"
|
||||
-LDADD = ../lib/libfind.a @INTLLIBS@
|
||||
+LDADD = ../lib/libfind.a @INTLLIBS@ -lselinux
|
||||
-LDADD = ../lib/libfind.a ../gnulib/lib/libgnulib.a @INTLLIBS@
|
||||
+LDADD = ../lib/libfind.a ../gnulib/lib/libgnulib.a @INTLLIBS@ -lselinux
|
||||
man_MANS = find.1
|
||||
SUBDIRS = testsuite
|
||||
subdir = find
|
||||
@@ -120,7 +120,7 @@
|
||||
PROGRAMS = $(bin_PROGRAMS)
|
||||
|
||||
|
||||
-DEFS = @DEFS@ -I. -I$(srcdir) -I..
|
||||
+DEFS = @DEFS@ -I. -I$(srcdir) -I.. -DWITH_SELINUX
|
||||
CPPFLAGS = @CPPFLAGS@
|
||||
LDFLAGS = @LDFLAGS@
|
||||
LIBS = @LIBS@
|
||||
--- findutils-4.1.7/find/util.c.selinux 2001-05-20 16:39:37.000000000 -0400
|
||||
+++ findutils-4.1.7/find/util.c 2003-10-10 13:19:10.869534272 -0400
|
||||
@@ -65,6 +65,9 @@
|
||||
--- findutils-4.1.20/find/util.c.selinux 2004-06-25 15:39:56.124011938 +0100
|
||||
+++ findutils-4.1.20/find/util.c 2004-06-25 15:39:56.228991860 +0100
|
||||
@@ -67,6 +67,9 @@
|
||||
last_pred->no_default_print = false;
|
||||
last_pred->need_stat = PRED_NEED_STAT;
|
||||
last_pred->args.str = NULL;
|
||||
|
@ -3,8 +3,8 @@
|
||||
%endif
|
||||
Summary: The GNU versions of find utilities (find and xargs).
|
||||
Name: findutils
|
||||
Version: 4.1.7
|
||||
Release: 27
|
||||
Version: 4.1.20
|
||||
Release: 1
|
||||
Epoch: 1
|
||||
License: GPL
|
||||
Group: Applications/File
|
||||
@ -12,15 +12,17 @@ Source0: ftp://alpha.gnu.org/gnu/findutils/%{name}-%{version}.tar.gz
|
||||
Patch0: findutils-53857.patch
|
||||
Patch1: findutils-4.1.7-usage.patch
|
||||
Patch2: findutils-4.1.7-i.patch
|
||||
Patch3: findutils-4.1.7-d_type.patch
|
||||
Patch3: findutils-d_type.patch
|
||||
Patch4: findutils-4.1.7-xargs-EIL.patch
|
||||
Patch5: findutils-install.patch
|
||||
Patch6: findutils-size.patch
|
||||
%if %{WITH_SELINUX}
|
||||
BuildRequires: libselinux-devel
|
||||
Patch5: findutils-selinux.patch
|
||||
Patch7: findutils-selinux.patch
|
||||
%endif
|
||||
Prereq: /sbin/install-info
|
||||
Buildroot: %{_tmppath}/%{name}-%{version}-root
|
||||
BuildRequires: libtool
|
||||
BuildRequires: libtool, automake17, autoconf
|
||||
BuildRequires: dejagnu
|
||||
|
||||
%description
|
||||
@ -41,13 +43,26 @@ useful for finding things on your system.
|
||||
%patch2 -p1 -b .i
|
||||
%patch3 -p1 -b .d_type
|
||||
%patch4 -p1 -b .xargs-EIL
|
||||
%patch5 -p1 -b .install
|
||||
%patch6 -p1 -b .size
|
||||
%if %{WITH_SELINUX}
|
||||
#SELinux
|
||||
%patch5 -p1 -b .selinux
|
||||
%patch7 -p1 -b .selinux
|
||||
%endif
|
||||
|
||||
rm -f config.guess config.sub
|
||||
libtoolize --force
|
||||
autoheader
|
||||
aclocal-1.7
|
||||
automake-1.7
|
||||
autoconf
|
||||
|
||||
cd gnulib
|
||||
libtoolize --force
|
||||
autoheader
|
||||
aclocal-1.7 -I m4
|
||||
automake-1.7
|
||||
autoconf
|
||||
|
||||
%build
|
||||
%define optflags $RPM_OPT_FLAGS -D_GNU_SOURCE
|
||||
@ -99,6 +114,11 @@ rm -rf %{buildroot}
|
||||
%{_infodir}/find.info*
|
||||
|
||||
%changelog
|
||||
* Fri Jun 25 2004 Tim Waugh <twaugh@redhat.com> 4.1.20-1
|
||||
- Clarify find man page (bug #126098).
|
||||
- Apply changes by Robert Scheck <redhat@linuxnetz.de> (bug #126352):
|
||||
- Upgrade to 4.1.20 and some specfile cleanup
|
||||
|
||||
* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
|
||||
- rebuilt
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user