- 4.2.18.

This commit is contained in:
Tim Waugh 2005-02-21 12:28:18 +00:00
parent da48862cec
commit be816a7329
4 changed files with 45 additions and 45 deletions

View File

@ -1,2 +1,3 @@
findutils-4.1.20.tar.gz findutils-4.1.20.tar.gz
findutils-4.2.15.tar.gz findutils-4.2.15.tar.gz
findutils-4.2.18.tar.gz

View File

@ -1,5 +1,5 @@
--- findutils-4.2.15/find/util.c.selinux 2005-01-23 18:04:45.000000000 +0000 --- findutils-4.2.18/find/util.c.selinux 2005-01-23 18:04:45.000000000 +0000
+++ findutils-4.2.15/find/util.c 2005-01-31 13:57:16.155474378 +0000 +++ findutils-4.2.18/find/util.c 2005-02-21 12:10:19.662700028 +0000
@@ -70,6 +70,9 @@ @@ -70,6 +70,9 @@
last_pred->need_stat = true; last_pred->need_stat = true;
last_pred->need_type = true; last_pred->need_type = true;
@ -10,9 +10,9 @@
last_pred->pred_next = NULL; last_pred->pred_next = NULL;
last_pred->pred_left = NULL; last_pred->pred_left = NULL;
last_pred->pred_right = NULL; last_pred->pred_right = NULL;
--- findutils-4.2.15/find/find.c.selinux 2005-01-25 00:30:40.000000000 +0000 --- findutils-4.2.18/find/find.c.selinux 2005-02-16 09:51:08.000000000 +0000
+++ findutils-4.2.15/find/find.c 2005-01-31 14:02:01.060964738 +0000 +++ findutils-4.2.18/find/find.c 2005-02-21 12:10:19.667699072 +0000
@@ -217,6 +217,93 @@ @@ -228,6 +228,93 @@
{ {
return lstat(name, p); return lstat(name, p);
} }
@ -106,7 +106,7 @@
#ifdef DEBUG_STAT #ifdef DEBUG_STAT
static uintmax_t stat_count = 0u; static uintmax_t stat_count = 0u;
@@ -245,11 +332,17 @@ @@ -256,11 +343,17 @@
{ {
case SYMLINK_ALWAYS_DEREF: /* -L */ case SYMLINK_ALWAYS_DEREF: /* -L */
options.xstat = optionl_stat; options.xstat = optionl_stat;
@ -124,7 +124,7 @@
/* Can't turn no_leaf_check off because the user might have specified /* Can't turn no_leaf_check off because the user might have specified
* -noleaf anyway * -noleaf anyway
*/ */
@@ -257,6 +350,9 @@ @@ -268,6 +361,9 @@
case SYMLINK_DEREF_ARGSONLY: /* -H */ case SYMLINK_DEREF_ARGSONLY: /* -H */
options.xstat = optionh_stat; options.xstat = optionh_stat;
@ -134,7 +134,7 @@
options.no_leaf_check = true; options.no_leaf_check = true;
} }
@@ -330,6 +426,9 @@ @@ -373,6 +469,9 @@
int int
main (int argc, char **argv) main (int argc, char **argv)
{ {
@ -144,7 +144,7 @@
int i; int i;
PFB parse_function; /* Pointer to the function which parses. */ PFB parse_function; /* Pointer to the function which parses. */
struct predicate *cur_pred; struct predicate *cur_pred;
@@ -447,6 +546,14 @@ @@ -509,6 +608,14 @@
if (strchr ("-!(),", argv[i][0]) == NULL) if (strchr ("-!(),", argv[i][0]) == NULL)
usage (_("paths must precede expression")); usage (_("paths must precede expression"));
predicate_name = argv[i]; predicate_name = argv[i];
@ -159,9 +159,9 @@
parse_function = find_parser (predicate_name); parse_function = find_parser (predicate_name);
if (parse_function == NULL) if (parse_function == NULL)
/* Command line option not recognized */ /* Command line option not recognized */
--- findutils-4.2.15/find/find.1.selinux 2005-01-23 18:29:25.000000000 +0000 --- findutils-4.2.18/find/find.1.selinux 2005-02-15 09:32:24.000000000 +0000
+++ findutils-4.2.15/find/find.1 2005-01-31 13:57:16.233459455 +0000 +++ findutils-4.2.18/find/find.1 2005-02-21 12:10:19.671698307 +0000
@@ -433,6 +433,9 @@ @@ -441,6 +441,9 @@
link to a file of type \fIc\fR; if the \-L option has been given, true link to a file of type \fIc\fR; if the \-L option has been given, true
if \fIc\fR is `l'. In other words, for symbolic links, \-xtype checks if \fIc\fR is `l'. In other words, for symbolic links, \-xtype checks
the type of the file that \-type does not check. the type of the file that \-type does not check.
@ -171,7 +171,7 @@
.SS ACTIONS .SS ACTIONS
.IP "\-delete\fR" .IP "\-delete\fR"
@@ -703,6 +706,8 @@ @@ -711,6 +714,8 @@
File's type (like in ls \-l), U=unknown type (shouldn't happen) File's type (like in ls \-l), U=unknown type (shouldn't happen)
.IP %Y .IP %Y
File's type (like %y), plus follow symlinks: L=loop, N=nonexistent File's type (like %y), plus follow symlinks: L=loop, N=nonexistent
@ -180,8 +180,8 @@
.PP .PP
A `%' character followed by any other character is discarded (but the A `%' character followed by any other character is discarded (but the
other character is printed). other character is printed).
--- findutils-4.2.15/find/Makefile.in.selinux 2005-01-29 00:50:23.000000000 +0000 --- findutils-4.2.18/find/Makefile.in.selinux 2005-02-16 10:26:56.000000000 +0000
+++ findutils-4.2.15/find/Makefile.in 2005-01-31 13:58:31.031147041 +0000 +++ findutils-4.2.18/find/Makefile.in 2005-02-21 12:10:19.674697733 +0000
@@ -1,4 +1,4 @@ @@ -1,4 +1,4 @@
-# Makefile.in generated by automake 1.9.4 from Makefile.am. -# Makefile.in generated by automake 1.9.4 from Makefile.am.
+# Makefile.in generated by automake 1.9.3 from Makefile.am. +# Makefile.in generated by automake 1.9.3 from Makefile.am.
@ -228,8 +228,8 @@
&& test -n "`cat c$${pid}_.out`" \ && test -n "`cat c$${pid}_.out`" \
&& test -z "`cat c$${pid}_.err`"; then :; \ && test -z "`cat c$${pid}_.err`"; then :; \
else echo "$$f does not support $$opt" 1>&2; bad=1; fi; \ else echo "$$f does not support $$opt" 1>&2; bad=1; fi; \
--- findutils-4.2.15/find/defs.h.selinux 2005-01-25 00:30:40.000000000 +0000 --- findutils-4.2.18/find/defs.h.selinux 2005-02-12 10:36:03.000000000 +0000
+++ findutils-4.2.15/find/defs.h 2005-01-31 13:57:16.244457351 +0000 +++ findutils-4.2.18/find/defs.h 2005-02-21 12:10:58.729228360 +0000
@@ -130,6 +130,10 @@ @@ -130,6 +130,10 @@
#define MODE_RWX (S_IXUSR | S_IXGRP | S_IXOTH | MODE_RW) #define MODE_RWX (S_IXUSR | S_IXGRP | S_IXOTH | MODE_RW)
#define MODE_ALL (S_ISUID | S_ISGID | S_ISVTX | MODE_RWX) #define MODE_ALL (S_ISUID | S_ISGID | S_ISVTX | MODE_RWX)
@ -261,18 +261,18 @@
int launch PARAMS((const struct buildcmd_control *ctl, int launch PARAMS((const struct buildcmd_control *ctl,
struct buildcmd_state *buildstate)); struct buildcmd_state *buildstate));
@@ -518,6 +528,9 @@ @@ -524,6 +534,9 @@
* flag to open(2).
/* Pointer to the function used to stat files. */ */
int (*xstat) (const char *name, struct stat *statbuf); boolean open_nofollow_available;
+#ifdef WITH_SELINUX +#ifdef WITH_SELINUX
+ int (*x_getfilecon) (); + int (*x_getfilecon) ();
+#endif /* WITH_SELINUX */ +#endif /* WITH_SELINUX */
}; };
extern struct options options; extern struct options options;
--- findutils-4.2.15/find/Makefile.am.selinux 2004-11-21 13:37:47.000000000 +0000 --- findutils-4.2.18/find/Makefile.am.selinux 2004-11-21 13:37:47.000000000 +0000
+++ findutils-4.2.15/find/Makefile.am 2005-01-31 13:57:16.245457159 +0000 +++ findutils-4.2.18/find/Makefile.am 2005-02-21 12:10:19.682696203 +0000
@@ -3,8 +3,9 @@ @@ -3,8 +3,9 @@
bin_PROGRAMS = find bin_PROGRAMS = find
find_SOURCES = find.c fstype.c parser.c pred.c tree.c util.c version.c find_SOURCES = find.c fstype.c parser.c pred.c tree.c util.c version.c
@ -284,11 +284,11 @@
man_MANS = find.1 man_MANS = find.1
SUBDIRS = testsuite SUBDIRS = testsuite
--- findutils-4.2.15/find/parser.c.selinux 2005-01-31 13:57:16.145476291 +0000 --- findutils-4.2.18/find/parser.c.selinux 2005-02-21 12:10:19.652701940 +0000
+++ findutils-4.2.15/find/parser.c 2005-01-31 13:57:16.251456012 +0000 +++ findutils-4.2.18/find/parser.c 2005-02-21 12:10:19.691694482 +0000
@@ -31,6 +31,10 @@ @@ -36,6 +36,10 @@
#include "nextelem.h" #include <sys/file.h>
#endif
+#ifdef WITH_SELINUX +#ifdef WITH_SELINUX
+#include <selinux/selinux.h> +#include <selinux/selinux.h>
@ -297,7 +297,7 @@
#if ENABLE_NLS #if ENABLE_NLS
# include <libintl.h> # include <libintl.h>
# define _(Text) gettext (Text) # define _(Text) gettext (Text)
@@ -134,6 +138,9 @@ @@ -139,6 +143,9 @@
static boolean parse_warn PARAMS((char *argv[], int *arg_ptr)); static boolean parse_warn PARAMS((char *argv[], int *arg_ptr));
static boolean parse_xtype PARAMS((char *argv[], int *arg_ptr)); static boolean parse_xtype PARAMS((char *argv[], int *arg_ptr));
static boolean parse_quit PARAMS((char *argv[], int *arg_ptr)); static boolean parse_quit PARAMS((char *argv[], int *arg_ptr));
@ -307,7 +307,7 @@
static boolean insert_regex PARAMS((char *argv[], int *arg_ptr, boolean ignore_case)); static boolean insert_regex PARAMS((char *argv[], int *arg_ptr, boolean ignore_case));
static boolean insert_type PARAMS((char *argv[], int *arg_ptr, boolean (*which_pred )())); static boolean insert_type PARAMS((char *argv[], int *arg_ptr, boolean (*which_pred )()));
@@ -261,6 +268,8 @@ @@ -266,6 +273,8 @@
{ARG_TEST, "wholename", parse_wholename}, /* GNU, replaces -path */ {ARG_TEST, "wholename", parse_wholename}, /* GNU, replaces -path */
{ARG_OPTION, "xdev", parse_xdev}, {ARG_OPTION, "xdev", parse_xdev},
{ARG_TEST, "xtype", parse_xtype}, /* GNU */ {ARG_TEST, "xtype", parse_xtype}, /* GNU */
@ -316,7 +316,7 @@
{0, 0, 0} {0, 0, 0}
}; };
@@ -739,6 +748,10 @@ @@ -744,6 +753,10 @@
-nouser -nogroup -path PATTERN -perm [+-]MODE -regex PATTERN\n\ -nouser -nogroup -path PATTERN -perm [+-]MODE -regex PATTERN\n\
-wholename PATTERN -size N[bcwkMG] -true -type [bcdpflsD] -uid N\n\ -wholename PATTERN -size N[bcwkMG] -true -type [bcdpflsD] -uid N\n\
-used N -user NAME -xtype [bcdpfls]\n")); -used N -user NAME -xtype [bcdpfls]\n"));
@ -327,7 +327,7 @@
puts (_("\ puts (_("\
actions: -exec COMMAND ; -fprint FILE -fprint0 FILE -fprintf FILE FORMAT\n\ actions: -exec COMMAND ; -fprint FILE -fprint0 FILE -fprintf FILE FORMAT\n\
-fls FILE -ok COMMAND ; -print -print0 -printf FORMAT -prune -ls -delete\n\ -fls FILE -ok COMMAND ; -print -print0 -printf FORMAT -prune -ls -delete\n\
@@ -1591,6 +1604,32 @@ @@ -1602,6 +1615,32 @@
return true; return true;
} }
@ -360,7 +360,7 @@
static boolean static boolean
parse_xtype (char **argv, int *arg_ptr) parse_xtype (char **argv, int *arg_ptr)
{ {
@@ -1766,7 +1805,11 @@ @@ -1777,7 +1816,11 @@
if (*scan2 == '.') if (*scan2 == '.')
for (scan2++; ISDIGIT (*scan2); scan2++) for (scan2++; ISDIGIT (*scan2); scan2++)
/* Do nothing. */ ; /* Do nothing. */ ;
@ -372,8 +372,8 @@
{ {
segmentp = make_segment (segmentp, format, scan2 - format, segmentp = make_segment (segmentp, format, scan2 - format,
(int) *scan2); (int) *scan2);
--- findutils-4.2.15/find/pred.c.selinux 2005-01-25 00:30:40.000000000 +0000 --- findutils-4.2.18/find/pred.c.selinux 2005-02-07 23:49:45.000000000 +0000
+++ findutils-4.2.15/find/pred.c 2005-01-31 14:37:23.724774302 +0000 +++ findutils-4.2.18/find/pred.c 2005-02-21 12:10:19.696693526 +0000
@@ -35,6 +35,14 @@ @@ -35,6 +35,14 @@
#include "wait.h" #include "wait.h"
#include "buildcmd.h" #include "buildcmd.h"
@ -407,7 +407,7 @@
{0, "none "} {0, "none "}
}; };
@@ -874,6 +884,26 @@ @@ -828,6 +838,26 @@
} }
break; break;
@ -434,7 +434,7 @@
} }
} }
return (true); return (true);
@@ -1477,6 +1507,34 @@ @@ -1398,6 +1428,34 @@
*/ */
return (pred_type (pathname, &sbuf, pred_ptr)); return (pred_type (pathname, &sbuf, pred_ptr));
} }

View File

@ -3,17 +3,15 @@
%endif %endif
Summary: The GNU versions of find utilities (find and xargs). Summary: The GNU versions of find utilities (find and xargs).
Name: findutils Name: findutils
Version: 4.2.15 Version: 4.2.18
Release: 2 Release: 1
Epoch: 1 Epoch: 1
License: GPL License: GPL
Group: Applications/File Group: Applications/File
Source0: ftp://alpha.gnu.org/gnu/findutils/%{name}-%{version}.tar.gz Source0: ftp://ftp.gnu.org/gnu/findutils/%{name}-%{version}.tar.gz
Patch1: findutils-no-locate.patch Patch1: findutils-no-locate.patch
Patch2: findutils-regex.patch Patch2: findutils-regex.patch
Patch3: findutils-testsuite.patch
Patch4: findutils-selinux.patch Patch4: findutils-selinux.patch
Patch5: findutils-nofollow.patch
Prereq: /sbin/install-info Prereq: /sbin/install-info
Buildroot: %{_tmppath}/%{name}-%{version}-root Buildroot: %{_tmppath}/%{name}-%{version}-root
@ -38,12 +36,10 @@ useful for finding things on your system.
%setup -q %setup -q
%patch1 -p1 -b .no-locate %patch1 -p1 -b .no-locate
%patch2 -p1 -b .regex %patch2 -p1 -b .regex
%patch3 -p1 -b .testsuite
%if %{WITH_SELINUX} %if %{WITH_SELINUX}
#SELinux #SELinux
%patch4 -p1 -b .selinux %patch4 -p1 -b .selinux
%endif %endif
%patch5 -p1 -b .nofollow
autoreconf autoreconf
@ -97,6 +93,9 @@ rm -rf %{buildroot}
%{_infodir}/find.info* %{_infodir}/find.info*
%changelog %changelog
* Mon Feb 21 2005 Tim Waugh <twaugh@redhat.com> 1:4.2.18-1
- 4.2.18.
* Mon Feb 14 2005 Tim Waugh <twaugh@redhat.com> 1:4.2.15-2 * Mon Feb 14 2005 Tim Waugh <twaugh@redhat.com> 1:4.2.15-2
- Added nofollow patch from upstream. - Added nofollow patch from upstream.

View File

@ -1 +1 @@
a881b15aa7170aea045bf35cc92d48e7 findutils-4.2.15.tar.gz 8aac2498435f3f1882678fb9ebda5c34 findutils-4.2.18.tar.gz