- Don't use uninitialized memory in -printf %%Z (#174485)
- Ship more documentation files - Clean up the spec file a bit
This commit is contained in:
parent
fb1403d548
commit
75c031dd05
@ -1,18 +1,5 @@
|
||||
--- findutils-4.2.25/find/Makefile.am.selinux 2005-07-03 12:07:16.000000000 -0400
|
||||
+++ findutils-4.2.25/find/Makefile.am 2005-10-11 17:03:51.000000000 -0400
|
||||
@@ -5,8 +5,9 @@
|
||||
# regexprops_SOURCES = regexprops.c
|
||||
find_SOURCES = find.c fstype.c parser.c pred.c tree.c util.c version.c
|
||||
EXTRA_DIST = defs.h $(man_MANS)
|
||||
+DEFS = @DEFS@ -I. -I$(srcdir) -I.. -DWITH_SELINUX
|
||||
INCLUDES = -I../gnulib/lib -I$(top_srcdir)/lib -I$(top_srcdir)/gnulib/lib -I../intl -DLOCALEDIR=\"$(localedir)\"
|
||||
-LDADD = ../lib/libfind.a ../gnulib/lib/libgnulib.a @INTLLIBS@
|
||||
+LDADD = ../lib/libfind.a ../gnulib/lib/libgnulib.a @INTLLIBS@ -lselinux
|
||||
man_MANS = find.1
|
||||
SUBDIRS = testsuite
|
||||
|
||||
--- findutils-4.2.25/find/parser.c.selinux 2005-07-31 17:01:54.000000000 -0400
|
||||
+++ findutils-4.2.25/find/parser.c 2005-10-11 17:38:06.000000000 -0400
|
||||
--- findutils-4.2.27/find/parser.c.selinux 2005-12-04 03:07:52.000000000 +0100
|
||||
+++ findutils-4.2.27/find/parser.c 2006-01-12 07:36:36.000000000 +0100
|
||||
@@ -47,6 +47,10 @@
|
||||
/* We need <unistd.h> for isatty(). */
|
||||
#include <unistd.h>
|
||||
@ -54,7 +41,7 @@
|
||||
puts (_("\
|
||||
actions: -delete -print0 -printf FORMAT -fprintf FILE FORMAT -print \n\
|
||||
-fprint0 FILE -fprint FILE -ls -fls FILE -prune -quit\n\
|
||||
@@ -1712,6 +1725,29 @@
|
||||
@@ -1727,6 +1740,29 @@
|
||||
exit (0);
|
||||
}
|
||||
|
||||
@ -84,7 +71,7 @@
|
||||
static boolean
|
||||
parse_xdev (const struct parser_table* entry, char **argv, int *arg_ptr)
|
||||
{
|
||||
@@ -1949,7 +1985,11 @@
|
||||
@@ -1964,7 +2000,11 @@
|
||||
if (*scan2 == '.')
|
||||
for (scan2++; ISDIGIT (*scan2); scan2++)
|
||||
/* Do nothing. */ ;
|
||||
@ -96,41 +83,76 @@
|
||||
{
|
||||
segmentp = make_segment (segmentp, format, scan2 - format,
|
||||
(int) *scan2);
|
||||
--- findutils-4.2.25/find/Makefile.in.selinux 2005-09-03 07:17:59.000000000 -0400
|
||||
+++ findutils-4.2.25/find/Makefile.in 2005-10-11 17:04:12.000000000 -0400
|
||||
@@ -175,7 +175,7 @@
|
||||
CROSS_COMPILING_FALSE = @CROSS_COMPILING_FALSE@
|
||||
CROSS_COMPILING_TRUE = @CROSS_COMPILING_TRUE@
|
||||
CYGPATH_W = @CYGPATH_W@
|
||||
-DEFS = @DEFS@
|
||||
+DEFS = @DEFS@ -I. -I$(srcdir) -I.. -DWITH_SELINUX
|
||||
DEPDIR = @DEPDIR@
|
||||
ECHO_C = @ECHO_C@
|
||||
ECHO_N = @ECHO_N@
|
||||
@@ -270,7 +270,7 @@
|
||||
@@ -2046,6 +2086,9 @@
|
||||
case 'H': /* ARGV element file was found under */
|
||||
case 'p': /* pathname */
|
||||
case 'P': /* pathname with ARGV element stripped */
|
||||
+#ifdef WITH_SELINUX
|
||||
+ case 'Z': /* SELinux security context */
|
||||
+#endif /* WITH_SELINUX */
|
||||
*fmt++ = 's';
|
||||
break;
|
||||
|
||||
--- findutils-4.2.27/find/defs.h.selinux 2005-09-04 19:59:34.000000000 +0200
|
||||
+++ findutils-4.2.27/find/defs.h 2006-01-12 07:36:19.000000000 +0100
|
||||
@@ -131,6 +131,10 @@
|
||||
#define MODE_RWX (S_IXUSR | S_IXGRP | S_IXOTH | MODE_RW)
|
||||
#define MODE_ALL (S_ISUID | S_ISGID | S_ISVTX | MODE_RWX)
|
||||
|
||||
+#ifdef WITH_SELINUX
|
||||
+#include <selinux/selinux.h>
|
||||
+#endif /*WITH_SELINUX*/
|
||||
+
|
||||
#if 1
|
||||
#include <stdbool.h>
|
||||
typedef bool boolean;
|
||||
@@ -320,6 +324,9 @@
|
||||
struct dir_id fileid; /* samefile */
|
||||
mode_t type; /* type */
|
||||
FILE *stream; /* ls fls fprint0 */
|
||||
+#ifdef WITH_SELINUX
|
||||
+ security_context_t scontext; /* scontext */
|
||||
+#endif /*WITH_SELINUX*/
|
||||
struct format_val printf_vec; /* printf fprintf fprint */
|
||||
} args;
|
||||
|
||||
@@ -479,6 +486,9 @@
|
||||
boolean pred_used PARAMS((char *pathname, struct stat *stat_buf, struct predicate *pred_ptr));
|
||||
boolean pred_user PARAMS((char *pathname, struct stat *stat_buf, struct predicate *pred_ptr));
|
||||
boolean pred_xtype PARAMS((char *pathname, struct stat *stat_buf, struct predicate *pred_ptr));
|
||||
+#ifdef WITH_SELINUX
|
||||
+boolean pred_scontext PARAMS((char *pathname, struct stat *stat_buf, struct predicate *pred_ptr));
|
||||
+#endif /* WITH_SELINUX */
|
||||
|
||||
|
||||
|
||||
@@ -568,6 +578,10 @@
|
||||
* can be changed with the positional option, -regextype.
|
||||
*/
|
||||
int regex_options;
|
||||
+
|
||||
+#ifdef WITH_SELINUX
|
||||
+ int (*x_getfilecon) ();
|
||||
+#endif /* WITH_SELINUX */
|
||||
};
|
||||
extern struct options options;
|
||||
|
||||
--- findutils-4.2.27/find/Makefile.am.selinux 2005-07-03 18:07:08.000000000 +0200
|
||||
+++ findutils-4.2.27/find/Makefile.am 2006-01-12 07:36:19.000000000 +0100
|
||||
@@ -5,8 +5,9 @@
|
||||
# regexprops_SOURCES = regexprops.c
|
||||
find_SOURCES = find.c fstype.c parser.c pred.c tree.c util.c version.c
|
||||
EXTRA_DIST = defs.h $(man_MANS)
|
||||
+DEFS = @DEFS@ -I. -I$(srcdir) -I.. -DWITH_SELINUX
|
||||
INCLUDES = -I../gnulib/lib -I$(top_srcdir)/lib -I$(top_srcdir)/gnulib/lib -I../intl -DLOCALEDIR=\"$(localedir)\"
|
||||
-LDADD = ../lib/libfind.a ../gnulib/lib/libgnulib.a @INTLLIBS@
|
||||
+LDADD = ../lib/libfind.a ../gnulib/lib/libgnulib.a @INTLLIBS@ -lselinux
|
||||
man_MANS = find.1
|
||||
SUBDIRS = testsuite
|
||||
all: all-recursive
|
||||
@@ -286,9 +286,9 @@
|
||||
exit 1;; \
|
||||
esac; \
|
||||
done; \
|
||||
- echo ' cd $(top_srcdir) && $(AUTOMAKE) --gnits find/Makefile'; \
|
||||
+ echo ' cd $(top_srcdir) && $(AUTOMAKE) --gnu find/Makefile'; \
|
||||
cd $(top_srcdir) && \
|
||||
- $(AUTOMAKE) --gnits find/Makefile
|
||||
+ $(AUTOMAKE) --gnu find/Makefile
|
||||
.PRECIOUS: Makefile
|
||||
Makefile: $(srcdir)/Makefile.in $(top_builddir)/config.status
|
||||
@case '$?' in \
|
||||
--- findutils-4.2.25/find/find.1.selinux 2005-09-02 16:46:48.000000000 -0400
|
||||
+++ findutils-4.2.25/find/find.1 2005-10-11 17:03:51.000000000 -0400
|
||||
@@ -455,6 +455,9 @@
|
||||
|
||||
--- findutils-4.2.27/find/find.1.selinux 2005-12-05 18:05:02.000000000 +0100
|
||||
+++ findutils-4.2.27/find/find.1 2006-01-12 07:36:19.000000000 +0100
|
||||
@@ -483,6 +483,9 @@
|
||||
link to a file of type \fIc\fR; if the \-L option has been given, true
|
||||
if \fIc\fR is `l'. In other words, for symbolic links, \-xtype checks
|
||||
the type of the file that \-type does not check.
|
||||
@ -140,7 +162,7 @@
|
||||
|
||||
.SS ACTIONS
|
||||
.IP "\-delete\fR"
|
||||
@@ -753,6 +756,8 @@
|
||||
@@ -785,6 +788,8 @@
|
||||
File's type (like in ls \-l), U=unknown type (shouldn't happen)
|
||||
.IP %Y
|
||||
File's type (like %y), plus follow symlinks: L=loop, N=nonexistent
|
||||
@ -149,8 +171,8 @@
|
||||
.PP
|
||||
A `%' character followed by any other character is discarded (but the
|
||||
other character is printed).
|
||||
--- findutils-4.2.25/find/find.c.selinux 2005-08-30 03:40:03.000000000 -0400
|
||||
+++ findutils-4.2.25/find/find.c 2005-10-11 17:14:28.000000000 -0400
|
||||
--- findutils-4.2.27/find/find.c.selinux 2005-11-11 08:41:37.000000000 +0100
|
||||
+++ findutils-4.2.27/find/find.c 2006-01-12 07:36:19.000000000 +0100
|
||||
@@ -244,6 +244,93 @@
|
||||
{
|
||||
return lstat(name, p);
|
||||
@ -281,9 +303,9 @@
|
||||
+ int is_selinux_enabled_flag = is_selinux_enabled()>0;
|
||||
+#endif /* WITH_SELINUX */
|
||||
int i;
|
||||
const struct parser_table *entry_close, *entry_print, *entry_open;
|
||||
const struct parser_table *parse_entry; /* Pointer to the parsing table entry for this expression. */
|
||||
struct predicate *cur_pred;
|
||||
@@ -537,6 +636,14 @@
|
||||
@@ -538,6 +637,14 @@
|
||||
if (strchr ("-!(),", argv[i][0]) == NULL)
|
||||
usage (_("paths must precede expression"));
|
||||
predicate_name = argv[i];
|
||||
@ -298,7 +320,7 @@
|
||||
parse_entry = find_parser (predicate_name);
|
||||
if (parse_entry == NULL)
|
||||
{
|
||||
@@ -1802,7 +1909,7 @@
|
||||
@@ -1807,7 +1914,7 @@
|
||||
static void
|
||||
process_dir (char *pathname, char *name, int pathlen, struct stat *statp, char *parent)
|
||||
{
|
||||
@ -307,8 +329,20 @@
|
||||
boolean subdirs_unreliable; /* if true, cannot use dir link count as subdir limif (if false, it may STILL be unreliable) */
|
||||
int idx; /* Which entry are we on? */
|
||||
struct stat stat_buf;
|
||||
--- findutils-4.2.25/find/pred.c.selinux 2005-09-01 16:57:49.000000000 -0400
|
||||
+++ findutils-4.2.25/find/pred.c 2005-10-11 17:03:51.000000000 -0400
|
||||
--- findutils-4.2.27/find/util.c.selinux 2005-07-01 23:45:18.000000000 +0200
|
||||
+++ findutils-4.2.27/find/util.c 2006-01-12 07:36:19.000000000 +0100
|
||||
@@ -78,6 +78,9 @@
|
||||
last_pred->need_stat = true;
|
||||
last_pred->need_type = true;
|
||||
last_pred->args.str = NULL;
|
||||
+#ifdef WITH_SELINUX
|
||||
+ last_pred->args.scontext = NULL;
|
||||
+#endif
|
||||
last_pred->pred_next = NULL;
|
||||
last_pred->pred_left = NULL;
|
||||
last_pred->pred_right = NULL;
|
||||
--- findutils-4.2.27/find/pred.c.selinux 2005-11-30 07:17:15.000000000 +0100
|
||||
+++ findutils-4.2.27/find/pred.c 2006-01-12 07:36:28.000000000 +0100
|
||||
@@ -38,6 +38,14 @@
|
||||
#include "buildcmd.h"
|
||||
#include "yesno.h"
|
||||
@ -342,7 +376,7 @@
|
||||
{0, "none "}
|
||||
};
|
||||
|
||||
@@ -903,6 +913,26 @@
|
||||
@@ -903,6 +913,25 @@
|
||||
mode_to_filetype(stat_buf->st_mode & S_IFMT));
|
||||
}
|
||||
break;
|
||||
@ -359,7 +393,6 @@
|
||||
+ (void) fflush(stderr);
|
||||
+ }
|
||||
+ else {
|
||||
+ segment->text[segment->text_len] = 's';
|
||||
+ (void) fprintf (fp, segment->text, scontext);
|
||||
+ freecon(scontext);
|
||||
+ }
|
||||
@ -369,7 +402,7 @@
|
||||
}
|
||||
}
|
||||
return true;
|
||||
@@ -1480,6 +1510,34 @@
|
||||
@@ -1493,6 +1522,34 @@
|
||||
*/
|
||||
return (pred_type (pathname, &sbuf, pred_ptr));
|
||||
}
|
||||
@ -404,59 +437,3 @@
|
||||
|
||||
/* 1) fork to get a child; parent remembers the child pid
|
||||
2) child execs the command requested
|
||||
--- findutils-4.2.25/find/util.c.selinux 2005-06-19 16:01:58.000000000 -0400
|
||||
+++ findutils-4.2.25/find/util.c 2005-10-11 17:03:51.000000000 -0400
|
||||
@@ -78,6 +78,9 @@
|
||||
last_pred->need_stat = true;
|
||||
last_pred->need_type = true;
|
||||
last_pred->args.str = NULL;
|
||||
+#ifdef WITH_SELINUX
|
||||
+ last_pred->args.scontext = NULL;
|
||||
+#endif
|
||||
last_pred->pred_next = NULL;
|
||||
last_pred->pred_left = NULL;
|
||||
last_pred->pred_right = NULL;
|
||||
--- findutils-4.2.25/find/defs.h.selinux 2005-08-30 03:36:24.000000000 -0400
|
||||
+++ findutils-4.2.25/find/defs.h 2005-10-11 17:03:51.000000000 -0400
|
||||
@@ -131,6 +131,10 @@
|
||||
#define MODE_RWX (S_IXUSR | S_IXGRP | S_IXOTH | MODE_RW)
|
||||
#define MODE_ALL (S_ISUID | S_ISGID | S_ISVTX | MODE_RWX)
|
||||
|
||||
+#ifdef WITH_SELINUX
|
||||
+#include <selinux/selinux.h>
|
||||
+#endif /*WITH_SELINUX*/
|
||||
+
|
||||
#if 1
|
||||
#include <stdbool.h>
|
||||
typedef bool boolean;
|
||||
@@ -320,6 +324,9 @@
|
||||
struct dir_id fileid; /* samefile */
|
||||
mode_t type; /* type */
|
||||
FILE *stream; /* ls fls fprint0 */
|
||||
+#ifdef WITH_SELINUX
|
||||
+ security_context_t scontext; /* scontext */
|
||||
+#endif /*WITH_SELINUX*/
|
||||
struct format_val printf_vec; /* printf fprintf fprint */
|
||||
} args;
|
||||
|
||||
@@ -479,6 +486,9 @@
|
||||
boolean pred_used PARAMS((char *pathname, struct stat *stat_buf, struct predicate *pred_ptr));
|
||||
boolean pred_user PARAMS((char *pathname, struct stat *stat_buf, struct predicate *pred_ptr));
|
||||
boolean pred_xtype PARAMS((char *pathname, struct stat *stat_buf, struct predicate *pred_ptr));
|
||||
+#ifdef WITH_SELINUX
|
||||
+boolean pred_scontext PARAMS((char *pathname, struct stat *stat_buf, struct predicate *pred_ptr));
|
||||
+#endif /* WITH_SELINUX */
|
||||
|
||||
|
||||
|
||||
@@ -568,6 +578,10 @@
|
||||
* can be changed with the positional option, -regextype.
|
||||
*/
|
||||
int regex_options;
|
||||
+
|
||||
+#ifdef WITH_SELINUX
|
||||
+ int (*x_getfilecon) ();
|
||||
+#endif /* WITH_SELINUX */
|
||||
};
|
||||
extern struct options options;
|
||||
|
||||
|
@ -1,11 +1,11 @@
|
||||
%define WITH_SELINUX 1
|
||||
Summary: The GNU versions of find utilities (find and xargs).
|
||||
Name: findutils
|
||||
Version: 4.2.27
|
||||
Release: 1.1
|
||||
Release: 2
|
||||
Epoch: 1
|
||||
License: GPL
|
||||
Group: Applications/File
|
||||
URL: http://www.gnu.org/software/findutils/
|
||||
Source0: ftp://ftp.gnu.org/gnu/findutils/%{name}-%{version}.tar.gz
|
||||
Patch1: findutils-no-locate.patch
|
||||
Patch2: findutils-selinux.patch
|
||||
@ -44,22 +44,7 @@ make check
|
||||
|
||||
%install
|
||||
rm -rf %{buildroot}
|
||||
%makeinstall
|
||||
|
||||
( cd %{buildroot}
|
||||
gzip -9fn .%{_infodir}/find.info*
|
||||
)
|
||||
|
||||
rm -f $RPM_BUILD_ROOT%{_bindir}/locate \
|
||||
$RPM_BUILD_ROOT%{_bindir}/updatedb \
|
||||
$RPM_BUILD_ROOT%{_libexecdir}/bigram \
|
||||
$RPM_BUILD_ROOT%{_libexecdir}/code \
|
||||
$RPM_BUILD_ROOT%{_libexecdir}/frcode \
|
||||
$RPM_BUILD_ROOT%{_mandir}/man1/locate.1* \
|
||||
$RPM_BUILD_ROOT%{_mandir}/man1/updatedb.1* \
|
||||
$RPM_BUILD_ROOT%{_mandir}/man5/locatedb.5*
|
||||
|
||||
rm -f $RPM_BUILD_ROOT%{_infodir}/dir
|
||||
make install DESTDIR=$RPM_BUILD_ROOT
|
||||
|
||||
%find_lang %{name}
|
||||
|
||||
@ -76,7 +61,7 @@ rm -rf %{buildroot}
|
||||
|
||||
%files -f %{name}.lang
|
||||
%defattr(-,root,root)
|
||||
%doc NEWS README
|
||||
%doc AUTHORS COPYING NEWS README THANKS TODO
|
||||
%{_bindir}/find
|
||||
%{_bindir}/xargs
|
||||
%{_mandir}/man1/find.1*
|
||||
@ -84,6 +69,11 @@ rm -rf %{buildroot}
|
||||
%{_infodir}/find.info*
|
||||
|
||||
%changelog
|
||||
* Thu Jan 12 2006 Miloslav Trmac <mitr@redhat.com> - 1:4.2.27-2
|
||||
- Don't use uninitialized memory in -printf %%Z (#174485)
|
||||
- Ship more documentation files
|
||||
- Clean up the spec file a bit
|
||||
|
||||
* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
|
||||
- rebuilt
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user