- 4.2.20.
This commit is contained in:
parent
459833a109
commit
24ec15e80c
@ -1,3 +1,4 @@
|
||||
findutils-4.1.20.tar.gz
|
||||
findutils-4.2.15.tar.gz
|
||||
findutils-4.2.18.tar.gz
|
||||
findutils-4.2.20.tar.gz
|
||||
|
@ -1,5 +1,5 @@
|
||||
--- findutils-4.2.15/Makefile.am.no-locate 2005-01-25 00:30:39.000000000 +0000
|
||||
+++ findutils-4.2.15/Makefile.am 2005-01-31 13:50:24.246315747 +0000
|
||||
--- findutils-4.2.20/Makefile.am.no-locate 2005-03-02 22:36:19.000000000 +0000
|
||||
+++ findutils-4.2.20/Makefile.am 2005-03-17 13:13:22.000000000 +0000
|
||||
@@ -2,7 +2,7 @@
|
||||
|
||||
EXTRA_DIST = COPYING ChangeLog TODO install-sh config.h.in stamp-h.in \
|
||||
@ -9,14 +9,14 @@
|
||||
|
||||
ACLOCAL_AMFLAGS = -I gnulib/m4 -I m4
|
||||
|
||||
--- findutils-4.2.15/Makefile.in.no-locate 2005-01-31 13:50:39.130466141 +0000
|
||||
+++ findutils-4.2.15/Makefile.in 2005-01-31 13:50:47.220917226 +0000
|
||||
@@ -260,7 +260,7 @@
|
||||
--- findutils-4.2.20/Makefile.in.no-locate 2005-03-17 12:11:29.000000000 +0000
|
||||
+++ findutils-4.2.20/Makefile.in 2005-03-17 13:13:52.000000000 +0000
|
||||
@@ -142,7 +142,7 @@
|
||||
EXTRA_DIST = COPYING ChangeLog TODO install-sh config.h.in stamp-h.in \
|
||||
THANKS config.rpath
|
||||
|
||||
-SUBDIRS = gnulib lib find xargs locate doc po m4
|
||||
+SUBDIRS = gnulib lib find xargs doc po m4
|
||||
|
||||
ACLOCAL_AMFLAGS = -I gnulib/m4 -I m4
|
||||
CONFIG_CLEAN_FILES = gnulib/lib/regex.c
|
||||
all: config.h
|
||||
subdir = .
|
||||
|
@ -1,5 +1,5 @@
|
||||
--- findutils-4.2.18/find/util.c.selinux 2005-01-23 18:04:45.000000000 +0000
|
||||
+++ findutils-4.2.18/find/util.c 2005-02-21 12:10:19.662700028 +0000
|
||||
--- findutils-4.2.20/find/util.c.selinux 2005-01-24 16:12:31.000000000 +0000
|
||||
+++ findutils-4.2.20/find/util.c 2005-03-17 13:14:11.000000000 +0000
|
||||
@@ -70,6 +70,9 @@
|
||||
last_pred->need_stat = true;
|
||||
last_pred->need_type = true;
|
||||
@ -10,9 +10,9 @@
|
||||
last_pred->pred_next = NULL;
|
||||
last_pred->pred_left = NULL;
|
||||
last_pred->pred_right = NULL;
|
||||
--- findutils-4.2.18/find/find.c.selinux 2005-02-16 09:51:08.000000000 +0000
|
||||
+++ findutils-4.2.18/find/find.c 2005-02-21 12:10:19.667699072 +0000
|
||||
@@ -228,6 +228,93 @@
|
||||
--- findutils-4.2.20/find/find.c.selinux 2005-03-03 22:30:10.000000000 +0000
|
||||
+++ findutils-4.2.20/find/find.c 2005-03-17 13:14:11.000000000 +0000
|
||||
@@ -239,6 +239,93 @@
|
||||
{
|
||||
return lstat(name, p);
|
||||
}
|
||||
@ -106,7 +106,7 @@
|
||||
|
||||
#ifdef DEBUG_STAT
|
||||
static uintmax_t stat_count = 0u;
|
||||
@@ -256,11 +343,17 @@
|
||||
@@ -267,11 +354,17 @@
|
||||
{
|
||||
case SYMLINK_ALWAYS_DEREF: /* -L */
|
||||
options.xstat = optionl_stat;
|
||||
@ -124,7 +124,7 @@
|
||||
/* Can't turn no_leaf_check off because the user might have specified
|
||||
* -noleaf anyway
|
||||
*/
|
||||
@@ -268,6 +361,9 @@
|
||||
@@ -279,6 +372,9 @@
|
||||
|
||||
case SYMLINK_DEREF_ARGSONLY: /* -H */
|
||||
options.xstat = optionh_stat;
|
||||
@ -134,7 +134,7 @@
|
||||
options.no_leaf_check = true;
|
||||
}
|
||||
|
||||
@@ -373,6 +469,9 @@
|
||||
@@ -384,6 +480,9 @@
|
||||
int
|
||||
main (int argc, char **argv)
|
||||
{
|
||||
@ -144,7 +144,7 @@
|
||||
int i;
|
||||
PFB parse_function; /* Pointer to the function which parses. */
|
||||
struct predicate *cur_pred;
|
||||
@@ -509,6 +608,14 @@
|
||||
@@ -512,6 +611,14 @@
|
||||
if (strchr ("-!(),", argv[i][0]) == NULL)
|
||||
usage (_("paths must precede expression"));
|
||||
predicate_name = argv[i];
|
||||
@ -159,8 +159,8 @@
|
||||
parse_function = find_parser (predicate_name);
|
||||
if (parse_function == NULL)
|
||||
/* Command line option not recognized */
|
||||
--- findutils-4.2.18/find/find.1.selinux 2005-02-15 09:32:24.000000000 +0000
|
||||
+++ findutils-4.2.18/find/find.1 2005-02-21 12:10:19.671698307 +0000
|
||||
--- findutils-4.2.20/find/find.1.selinux 2005-03-02 22:36:20.000000000 +0000
|
||||
+++ findutils-4.2.20/find/find.1 2005-03-17 13:14:11.000000000 +0000
|
||||
@@ -441,6 +441,9 @@
|
||||
link to a file of type \fIc\fR; if the \-L option has been given, true
|
||||
if \fIc\fR is `l'. In other words, for symbolic links, \-xtype checks
|
||||
@ -171,7 +171,7 @@
|
||||
|
||||
.SS ACTIONS
|
||||
.IP "\-delete\fR"
|
||||
@@ -711,6 +714,8 @@
|
||||
@@ -713,6 +716,8 @@
|
||||
File's type (like in ls \-l), U=unknown type (shouldn't happen)
|
||||
.IP %Y
|
||||
File's type (like %y), plus follow symlinks: L=loop, N=nonexistent
|
||||
@ -180,15 +180,9 @@
|
||||
.PP
|
||||
A `%' character followed by any other character is discarded (but the
|
||||
other character is printed).
|
||||
--- findutils-4.2.18/find/Makefile.in.selinux 2005-02-16 10:26:56.000000000 +0000
|
||||
+++ findutils-4.2.18/find/Makefile.in 2005-02-21 12:10:19.674697733 +0000
|
||||
@@ -1,4 +1,4 @@
|
||||
-# Makefile.in generated by automake 1.9.4 from Makefile.am.
|
||||
+# Makefile.in generated by automake 1.9.3 from Makefile.am.
|
||||
# @configure_input@
|
||||
|
||||
# Copyright (C) 1994, 1995, 1996, 1997, 1998, 1999, 2000, 2001, 2002,
|
||||
@@ -174,7 +174,7 @@
|
||||
--- findutils-4.2.20/find/Makefile.in.selinux 2005-03-17 12:11:50.000000000 +0000
|
||||
+++ findutils-4.2.20/find/Makefile.in 2005-03-17 13:14:11.000000000 +0000
|
||||
@@ -52,7 +52,7 @@
|
||||
CPP = @CPP@
|
||||
CPPFLAGS = @CPPFLAGS@
|
||||
CYGPATH_W = @CYGPATH_W@
|
||||
@ -197,39 +191,17 @@
|
||||
DEPDIR = @DEPDIR@
|
||||
ECHO_C = @ECHO_C@
|
||||
ECHO_N = @ECHO_N@
|
||||
@@ -266,7 +266,7 @@
|
||||
localedir = $(datadir)/locale
|
||||
@@ -142,7 +142,7 @@
|
||||
bin_PROGRAMS = find
|
||||
find_SOURCES = find.c fstype.c parser.c pred.c tree.c util.c version.c
|
||||
EXTRA_DIST = defs.h $(man_MANS)
|
||||
-LDADD = ../lib/libfind.a ../gnulib/lib/libgnulib.a @INTLLIBS@
|
||||
+LDADD = ../lib/libfind.a ../gnulib/lib/libgnulib.a @INTLLIBS@ -lselinux
|
||||
man_MANS = find.1
|
||||
SUBDIRS = testsuite
|
||||
all: all-recursive
|
||||
@@ -282,9 +282,9 @@
|
||||
exit 1;; \
|
||||
esac; \
|
||||
done; \
|
||||
- echo ' cd $(top_srcdir) && $(AUTOMAKE) --gnits find/Makefile'; \
|
||||
+ echo ' cd $(top_srcdir) && $(AUTOMAKE) --gnu find/Makefile'; \
|
||||
cd $(top_srcdir) && \
|
||||
- $(AUTOMAKE) --gnits find/Makefile
|
||||
+ $(AUTOMAKE) --gnu find/Makefile
|
||||
.PRECIOUS: Makefile
|
||||
Makefile: $(srcdir)/Makefile.in $(top_builddir)/config.status
|
||||
@case '$?' in \
|
||||
@@ -334,8 +334,7 @@
|
||||
f=`echo "$$p" | \
|
||||
sed 's,^.*/,,;s/$(EXEEXT)$$//;$(transform);s/$$/$(EXEEXT)/'`; \
|
||||
for opt in --help --version; do \
|
||||
- if "$(DESTDIR)$(bindir)/$$f" $$opt >c$${pid}_.out \
|
||||
- 2>c$${pid}_.err </dev/null \
|
||||
+ if "$(DESTDIR)$(bindir)/$$f" $$opt > c$${pid}_.out 2> c$${pid}_.err \
|
||||
&& test -n "`cat c$${pid}_.out`" \
|
||||
&& test -z "`cat c$${pid}_.err`"; then :; \
|
||||
else echo "$$f does not support $$opt" 1>&2; bad=1; fi; \
|
||||
--- findutils-4.2.18/find/defs.h.selinux 2005-02-12 10:36:03.000000000 +0000
|
||||
+++ findutils-4.2.18/find/defs.h 2005-02-21 12:10:58.729228360 +0000
|
||||
subdir = find
|
||||
--- findutils-4.2.20/find/defs.h.selinux 2005-03-04 09:58:29.000000000 +0000
|
||||
+++ findutils-4.2.20/find/defs.h 2005-03-17 13:14:11.000000000 +0000
|
||||
@@ -130,6 +130,10 @@
|
||||
#define MODE_RWX (S_IXUSR | S_IXGRP | S_IXOTH | MODE_RW)
|
||||
#define MODE_ALL (S_ISUID | S_ISGID | S_ISVTX | MODE_RWX)
|
||||
@ -271,8 +243,8 @@
|
||||
};
|
||||
extern struct options options;
|
||||
|
||||
--- findutils-4.2.18/find/Makefile.am.selinux 2004-11-21 13:37:47.000000000 +0000
|
||||
+++ findutils-4.2.18/find/Makefile.am 2005-02-21 12:10:19.682696203 +0000
|
||||
--- findutils-4.2.20/find/Makefile.am.selinux 2004-11-23 00:10:40.000000000 +0000
|
||||
+++ findutils-4.2.20/find/Makefile.am 2005-03-17 13:14:11.000000000 +0000
|
||||
@@ -3,8 +3,9 @@
|
||||
bin_PROGRAMS = find
|
||||
find_SOURCES = find.c fstype.c parser.c pred.c tree.c util.c version.c
|
||||
@ -284,8 +256,8 @@
|
||||
man_MANS = find.1
|
||||
SUBDIRS = testsuite
|
||||
|
||||
--- findutils-4.2.18/find/parser.c.selinux 2005-02-21 12:10:19.652701940 +0000
|
||||
+++ findutils-4.2.18/find/parser.c 2005-02-21 12:10:19.691694482 +0000
|
||||
--- findutils-4.2.20/find/parser.c.selinux 2005-03-17 13:14:11.000000000 +0000
|
||||
+++ findutils-4.2.20/find/parser.c 2005-03-17 13:14:11.000000000 +0000
|
||||
@@ -36,6 +36,10 @@
|
||||
#include <sys/file.h>
|
||||
#endif
|
||||
@ -372,8 +344,8 @@
|
||||
{
|
||||
segmentp = make_segment (segmentp, format, scan2 - format,
|
||||
(int) *scan2);
|
||||
--- findutils-4.2.18/find/pred.c.selinux 2005-02-07 23:49:45.000000000 +0000
|
||||
+++ findutils-4.2.18/find/pred.c 2005-02-21 12:10:19.696693526 +0000
|
||||
--- findutils-4.2.20/find/pred.c.selinux 2005-03-04 10:33:39.000000000 +0000
|
||||
+++ findutils-4.2.20/find/pred.c 2005-03-17 13:14:11.000000000 +0000
|
||||
@@ -35,6 +35,14 @@
|
||||
#include "wait.h"
|
||||
#include "buildcmd.h"
|
||||
@ -407,7 +379,7 @@
|
||||
{0, "none "}
|
||||
};
|
||||
|
||||
@@ -828,6 +838,26 @@
|
||||
@@ -839,6 +849,26 @@
|
||||
|
||||
}
|
||||
break;
|
||||
@ -434,7 +406,7 @@
|
||||
}
|
||||
}
|
||||
return (true);
|
||||
@@ -1398,6 +1428,34 @@
|
||||
@@ -1411,6 +1441,34 @@
|
||||
*/
|
||||
return (pred_type (pathname, &sbuf, pred_ptr));
|
||||
}
|
||||
|
@ -3,8 +3,8 @@
|
||||
%endif
|
||||
Summary: The GNU versions of find utilities (find and xargs).
|
||||
Name: findutils
|
||||
Version: 4.2.18
|
||||
Release: 3
|
||||
Version: 4.2.20
|
||||
Release: 1
|
||||
Epoch: 1
|
||||
License: GPL
|
||||
Group: Applications/File
|
||||
@ -95,6 +95,9 @@ rm -rf %{buildroot}
|
||||
%{_infodir}/find.info*
|
||||
|
||||
%changelog
|
||||
* Thu Mar 17 2005 Tim Waugh <twaugh@redhat.com> 1:4.2.20-1
|
||||
- 4.2.20.
|
||||
|
||||
* Mon Mar 14 2005 Tim Waugh <twaugh@redhat.com> 1:4.2.18-3
|
||||
- Applied patch from Robert Scheck to fix compilation with GCC 4 (bug #151031).
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user