update the gio patch
This commit is contained in:
parent
914720913e
commit
a1aa9a4458
@ -1,6 +1,6 @@
|
||||
Index: configure.in
|
||||
===================================================================
|
||||
--- configure.in (revision 2182)
|
||||
--- configure.in (revision 2210)
|
||||
+++ configure.in (working copy)
|
||||
@@ -18,13 +18,13 @@
|
||||
dnl
|
||||
@ -14,7 +14,7 @@ Index: configure.in
|
||||
GNOME_VFS_REQUIRED=2.10.0
|
||||
LIBGLADE_REQUIRED=2.4.0
|
||||
-NAUTILUS_REQUIRED=2.10.0
|
||||
+NAUTILUS_REQUIRED=2.21.0
|
||||
+NAUTILUS_REQUIRED=2.22.1
|
||||
|
||||
AC_SUBST(GLIB_REQUIRED)
|
||||
AC_SUBST(GTK_REQUIRED)
|
||||
@ -26,9 +26,20 @@ Index: configure.in
|
||||
gthread-2.0 \
|
||||
gtk+-2.0 >= $GTK_REQUIRED \
|
||||
libgnome-2.0 >= $LIBGNOME_REQUIRED \
|
||||
@@ -56,8 +57,8 @@
|
||||
|
||||
if test x"$enable_nautilus_actions" != xno; then
|
||||
if pkg-config --atleast-version=$NAUTILUS_REQUIRED libnautilus-extension; then
|
||||
- NAUTILUS_CFLAGS=`pkg-config --cflags libnautilus-extension glib-2.0 gnome-vfs-2.0`
|
||||
- NAUTILUS_LIBS=`pkg-config --libs libnautilus-extension glib-2.0 gnome-vfs-2.0`
|
||||
+ NAUTILUS_CFLAGS=`pkg-config --cflags libnautilus-extension glib-2.0 gio-2.0`
|
||||
+ NAUTILUS_LIBS=`pkg-config --libs libnautilus-extension glib-2.0 gio-2.0`
|
||||
build_nautilus_actions=yes
|
||||
fi
|
||||
fi
|
||||
Index: nautilus/nautilus-fileroller.c
|
||||
===================================================================
|
||||
--- nautilus/nautilus-fileroller.c (revision 2182)
|
||||
--- nautilus/nautilus-fileroller.c (revision 2210)
|
||||
+++ nautilus/nautilus-fileroller.c (working copy)
|
||||
@@ -24,9 +24,7 @@
|
||||
#include <config.h>
|
||||
@ -41,7 +52,7 @@ Index: nautilus/nautilus-fileroller.c
|
||||
#include <libnautilus-extension/nautilus-extension-types.h>
|
||||
#include <libnautilus-extension/nautilus-file-info.h>
|
||||
#include <libnautilus-extension/nautilus-menu-provider.h>
|
||||
@@ -204,34 +202,31 @@
|
||||
@@ -204,34 +202,19 @@
|
||||
return NULL;
|
||||
|
||||
for (scan = files; scan; scan = scan->next) {
|
||||
@ -51,33 +62,20 @@ Index: nautilus/nautilus-fileroller.c
|
||||
- if (all_archives && ! is_archive (file))
|
||||
- all_archives = FALSE;
|
||||
+ if ((all_archives = is_archive (file)) == FALSE)
|
||||
+ break;
|
||||
+ break;
|
||||
|
||||
+ /* FIXME: Here we should get the parent of the current
|
||||
+ * file and check if it is the same parent as for the
|
||||
+ * other files and then check if the parent is writable
|
||||
+ *
|
||||
+ * We *MUST NOT* do that synchronous since this function
|
||||
+ * gets called very often (every time a selection changed)
|
||||
+ * and it could be a remote location. MUST NOT DO SYNC IO.
|
||||
+ *
|
||||
+ * Nautilus actually already has stat'ed the parent and
|
||||
+ * knows if the parent is writable or not. The API is
|
||||
+ * just missing. This is filed under bug #521612. Once that
|
||||
+ * bug is fixed we can actually implement the funcionality.
|
||||
+ * Until then we just set can_write to TRUE. If that is an
|
||||
+ * lie we will find out once the user tries to really extract
|
||||
+ * stuff.
|
||||
+ *
|
||||
+ * Christian Kellner
|
||||
+ * */
|
||||
+ }
|
||||
+ if (can_write) {
|
||||
+ NautilusFileInfo *parent;
|
||||
|
||||
- if (can_write) {
|
||||
- char *parent_uri;
|
||||
- GnomeVFSFileInfo *info;
|
||||
- GnomeVFSResult result;
|
||||
-
|
||||
+ parent = nautilus_file_info_get_parent_info (file);
|
||||
+ can_write = nautilus_file_info_can_write (parent);
|
||||
+ }
|
||||
+ }
|
||||
|
||||
- parent_uri = nautilus_file_info_get_parent_uri (file);
|
||||
- info = gnome_vfs_file_info_new ();
|
||||
-
|
||||
|
@ -5,13 +5,13 @@
|
||||
%define libgnomeprint_version 2.2.0
|
||||
%define libgnomeprintui_version 2.2.0
|
||||
%define desktop_file_utils_version 0.9
|
||||
%define nautilus_version 2.9.0
|
||||
%define nautilus_version 2.22.1
|
||||
%define gnome_doc_utils_version 0.3.2
|
||||
|
||||
Summary: File Roller is a tool for viewing and creating archives
|
||||
Name: file-roller
|
||||
Version: 2.22.0
|
||||
Release: 1%{?dist}
|
||||
Release: 2%{?dist}
|
||||
License: GPLv2+
|
||||
Group: Applications/Archiving
|
||||
URL: http://download.gnome.org/sources/file-roller/
|
||||
@ -54,6 +54,8 @@ such as tar files.
|
||||
%setup -q
|
||||
%patch0 -p0 -b .gio
|
||||
|
||||
autoreconf
|
||||
|
||||
%build
|
||||
%configure --disable-scrollkeeper --disable-static
|
||||
export tagname=CC
|
||||
@ -129,6 +131,9 @@ fi
|
||||
%{_datadir}/icons/hicolor/scalable/apps/file-roller.svg
|
||||
|
||||
%changelog
|
||||
* Fri Apr 4 2008 Matthias Clasen <mclasen@redhat.com> - 2.22.0-2
|
||||
- Update the gio patch
|
||||
|
||||
* Tue Mar 11 2008 Matthias Clasen <mclasen@redhat.com> - 2.22.0-1
|
||||
- Update to 2.22.0
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user