- Update to 2.29.92
This commit is contained in:
parent
bfa93eda3c
commit
80641f3aad
@ -1,31 +0,0 @@
|
|||||||
From 84c17b017f258c0394973ac05c044c33b81d42e6 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Bastien Nocera <hadess@hadess.net>
|
|
||||||
Date: Wed, 10 Feb 2010 17:47:08 +0000
|
|
||||||
Subject: [PATCH] Fix libm linking
|
|
||||||
|
|
||||||
Otherwise we fail to link against libm:
|
|
||||||
/usr/bin/ld: dlg-batch-add.o: undefined reference to symbol 'floor@@GLIBC_2.2.5'
|
|
||||||
/usr/bin/ld: note: 'floor@@GLIBC_2.2.5' is defined in DSO /lib64/libm.so.6 so try adding it to the linker command line
|
|
||||||
/lib64/libm.so.6: could not read symbols: Invalid operation
|
|
||||||
|
|
||||||
https://bugzilla.gnome.org/show_bug.cgi?id=609565
|
|
||||||
---
|
|
||||||
configure.ac | 2 ++
|
|
||||||
1 files changed, 2 insertions(+), 0 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/configure.ac b/configure.ac
|
|
||||||
index 9a0de5a..37bffc7 100644
|
|
||||||
--- a/configure.ac
|
|
||||||
+++ b/configure.ac
|
|
||||||
@@ -91,6 +91,8 @@ AC_CHECK_FUNC(mkdtemp,
|
|
||||||
mkdtemp_missing=true)
|
|
||||||
AM_CONDITIONAL(MKDTEMP_MISSING, test x$mkdtemp_missing = xtrue)
|
|
||||||
|
|
||||||
+AC_CHECK_LIB(m, floor)
|
|
||||||
+
|
|
||||||
dnl ==========================================================================
|
|
||||||
|
|
||||||
AC_ARG_ENABLE(packagekit,
|
|
||||||
--
|
|
||||||
1.6.6
|
|
||||||
|
|
@ -1,16 +1,16 @@
|
|||||||
%define glib2_version 2.6.0
|
%define glib2_version 2.16.0
|
||||||
%define pango_version 1.8.0
|
%define pango_version 1.8.0
|
||||||
%define gtk2_version 2.6.0
|
%define gtk2_version 2.16.0
|
||||||
%define libgnomeui_version 2.6.0
|
%define libgnomeui_version 2.6.0
|
||||||
%define libgnomeprint_version 2.2.0
|
%define libgnomeprint_version 2.2.0
|
||||||
%define libgnomeprintui_version 2.2.0
|
%define libgnomeprintui_version 2.2.0
|
||||||
%define desktop_file_utils_version 0.9
|
%define desktop_file_utils_version 0.9
|
||||||
%define nautilus_version 2.22.1
|
%define nautilus_version 2.22.2
|
||||||
%define gnome_doc_utils_version 0.3.2
|
%define gnome_doc_utils_version 0.3.2
|
||||||
|
|
||||||
Summary: Tool for viewing and creating archives
|
Summary: Tool for viewing and creating archives
|
||||||
Name: file-roller
|
Name: file-roller
|
||||||
Version: 2.29.91
|
Version: 2.29.92
|
||||||
Release: 1%{?dist}
|
Release: 1%{?dist}
|
||||||
License: GPLv2+
|
License: GPLv2+
|
||||||
Group: Applications/Archiving
|
Group: Applications/Archiving
|
||||||
@ -122,6 +122,9 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
|
|||||||
%{_datadir}/icons/hicolor/scalable/apps/file-roller.svg
|
%{_datadir}/icons/hicolor/scalable/apps/file-roller.svg
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Mar 9 2010 Tomas Bzatek <tbzatek@redhat.com> 2.29.92-1
|
||||||
|
- Update to 2.29.92
|
||||||
|
|
||||||
* Mon Feb 22 2010 Matthias Clasen <mclasen@redhat.com> 2.29.91-1
|
* Mon Feb 22 2010 Matthias Clasen <mclasen@redhat.com> 2.29.91-1
|
||||||
- Update to 2.29.91
|
- Update to 2.29.91
|
||||||
|
|
||||||
|
@ -1,24 +0,0 @@
|
|||||||
diff -up file-roller-2.28.1/src/fr-window.c.property-get file-roller-2.28.1/src/fr-window.c
|
|
||||||
--- file-roller-2.28.1/src/fr-window.c.property-get 2009-12-14 00:59:59.792797354 -0500
|
|
||||||
+++ file-roller-2.28.1/src/fr-window.c 2009-12-14 01:01:49.141546600 -0500
|
|
||||||
@@ -4138,13 +4138,14 @@ get_xds_atom_value (GdkDragContext *cont
|
|
||||||
g_return_val_if_fail (context != NULL, NULL);
|
|
||||||
g_return_val_if_fail (context->source_window != NULL, NULL);
|
|
||||||
|
|
||||||
- gdk_property_get (context->source_window,
|
|
||||||
- XDS_ATOM, TEXT_ATOM,
|
|
||||||
- 0, MAX_XDS_ATOM_VAL_LEN,
|
|
||||||
- FALSE, NULL, NULL, NULL,
|
|
||||||
- (unsigned char **) &ret);
|
|
||||||
+ if (gdk_property_get (context->source_window,
|
|
||||||
+ XDS_ATOM, TEXT_ATOM,
|
|
||||||
+ 0, MAX_XDS_ATOM_VAL_LEN,
|
|
||||||
+ FALSE, NULL, NULL, NULL,
|
|
||||||
+ (unsigned char **) &ret))
|
|
||||||
+ return ret;
|
|
||||||
|
|
||||||
- return ret;
|
|
||||||
+ return NULL;
|
|
||||||
}
|
|
||||||
|
|
||||||
|
|
Loading…
Reference in New Issue
Block a user