fido-device-onboard/0001-chore-update-libcryptsetup-rs-to-0.8.patch
Peter Robinson 7e25c6bb2d 0.4.10
2023-06-23 15:08:25 +01:00

65 lines
2.4 KiB
Diff

From 5e57b7fc4afc170c65e4b9a283da2f59fb3f127e Mon Sep 17 00:00:00 2001
From: Irene Diez <idiez@redhat.com>
Date: Tue, 13 Jun 2023 17:40:05 +0200
Subject: [PATCH] chore: update libcryptsetup to 0.8.0 and fix API changes
Signed-off-by: Irene Diez <idiez@redhat.com>
---
Cargo.lock | 4 ++--
client-linuxapp/Cargo.toml | 2 +-
client-linuxapp/src/reencrypt/rebind.rs | 4 ++--
3 files changed, 5 insertions(+), 5 deletions(-)
diff --git a/client-linuxapp/Cargo.toml b/client-linuxapp/Cargo.toml
index f97a649d..cbd132b8 100644
--- a/client-linuxapp/Cargo.toml
+++ b/client-linuxapp/Cargo.toml
@@ -17,7 +17,7 @@ rand = "0.8.4"
nix = "0.26"
uuid = "1.3"
thiserror = "1"
-libcryptsetup-rs = { version = "0.7.0", features = ["mutex"] }
+libcryptsetup-rs = { version = "0.8.0", features = ["mutex"] }
secrecy = "0.8"
devicemapper = "0.33"
diff --git a/client-linuxapp/src/reencrypt/mod.rs b/client-linuxapp/src/reencrypt/mod.rs
index da2b7d38..1e38d35a 100644
--- a/client-linuxapp/src/reencrypt/mod.rs
+++ b/client-linuxapp/src/reencrypt/mod.rs
@@ -64,7 +64,7 @@ fn perform_reencrypt(dev_name: &str) -> Result<()> {
.context("Error opening device")?;
dev.context_handle()
- .load::<libcryptsetup_rs::CryptParamsLuks2>(None, None)
+ .load::<()>(None, None)
.context("Error loading device context")?;
let status = dev
diff --git a/client-linuxapp/src/reencrypt/rebind.rs b/client-linuxapp/src/reencrypt/rebind.rs
index 0c35a71c..693beb1f 100644
--- a/client-linuxapp/src/reencrypt/rebind.rs
+++ b/client-linuxapp/src/reencrypt/rebind.rs
@@ -154,7 +154,7 @@ fn clevis_bind(
log::trace!("Clevis bind successful");
dev.context_handle()
- .load::<libcryptsetup_rs::CryptParamsLuks2>(None, None)
+ .load::<()>(None, None)
.context("Error re-loading device context")?;
log::trace!("Reloaded device context");
diff --git a/client-linuxapp/src/serviceinfo.rs b/client-linuxapp/src/serviceinfo.rs
index 43c60302..89ce7e6b 100644
--- a/client-linuxapp/src/serviceinfo.rs
+++ b/client-linuxapp/src/serviceinfo.rs
@@ -253,7 +253,7 @@ impl DiskEncryptionInProgress {
log::debug!("Device initiated");
dev.context_handle()
- .load::<libcryptsetup_rs::CryptParamsLuks2>(None, None)
+ .load::<()>(None, None)
.context("Error loading device context")?;
log::debug!("Device information loaded");