Updates for eln/c9s building
This commit is contained in:
parent
7e25c6bb2d
commit
fc0d38c450
1
.gitignore
vendored
1
.gitignore
vendored
@ -1 +1,2 @@
|
|||||||
/fido-device-onboard-rs-*.tar.gz
|
/fido-device-onboard-rs-*.tar.gz
|
||||||
|
/fido-device-onboard-rs-0.4.10-vendor-patched.tar.xz
|
||||||
|
22
fdo-fix-tss-esapi-features.patch
Normal file
22
fdo-fix-tss-esapi-features.patch
Normal file
@ -0,0 +1,22 @@
|
|||||||
|
--- fido-device-onboard-rs-0.4.10/manufacturing-client/Cargo.toml.orig 2023-07-03 15:24:05.020575397 +0100
|
||||||
|
+++ fido-device-onboard-rs-0.4.10/manufacturing-client/Cargo.toml 2023-07-03 15:24:26.381717418 +0100
|
||||||
|
@@ -16,7 +16,7 @@
|
||||||
|
sys-info = "0.9"
|
||||||
|
passwd = "0.0.1"
|
||||||
|
rand = "0.8.4"
|
||||||
|
-tss-esapi = "7.2"
|
||||||
|
+tss-esapi = { version = "7.2", features = ["generate-bindings"] }
|
||||||
|
regex = "1.3.7"
|
||||||
|
|
||||||
|
fdo-data-formats = { path = "../data-formats", version = "0.4.10" }
|
||||||
|
--- fido-device-onboard-rs-0.4.10/owner-tool/Cargo.toml.orig 2023-07-03 15:22:27.024923885 +0100
|
||||||
|
+++ fido-device-onboard-rs-0.4.10/owner-tool/Cargo.toml 2023-07-03 15:23:31.955355563 +0100
|
||||||
|
@@ -14,7 +14,7 @@
|
||||||
|
serde = { version = "1", features = ["derive"] }
|
||||||
|
serde_yaml = "0.9"
|
||||||
|
tokio = { version = "1", features = ["full"] }
|
||||||
|
-tss-esapi = "7.2"
|
||||||
|
+tss-esapi = { version = "7.2", features = ["generate-bindings"] }
|
||||||
|
|
||||||
|
fdo-util = { path = "../util", version = "0.4.10" }
|
||||||
|
fdo-data-formats = { path = "../data-formats", version = "0.4.10" }
|
@ -4,17 +4,22 @@
|
|||||||
|
|
||||||
Name: fido-device-onboard
|
Name: fido-device-onboard
|
||||||
Version: 0.4.10
|
Version: 0.4.10
|
||||||
Release: 1%{?dist}
|
Release: 2%{?dist}
|
||||||
Summary: A rust implementation of the FIDO Device Onboard Specification
|
Summary: A rust implementation of the FIDO Device Onboard Specification
|
||||||
License: BSD-3-Clause
|
License: BSD-3-Clause
|
||||||
|
|
||||||
|
|
||||||
URL: https://github.com/fedora-iot/fido-device-onboard-rs
|
URL: https://github.com/fedora-iot/fido-device-onboard-rs
|
||||||
Source0: %{url}/archive/v%{version}/%{name}-rs-%{version}.tar.gz
|
Source0: %{url}/archive/v%{version}/%{name}-rs-%{version}.tar.gz
|
||||||
|
# See make-vendored-tarfile.sh in upstream repo
|
||||||
|
Source1: %{name}-rs-%{version}-vendor-patched.tar.xz
|
||||||
# From upstream
|
# From upstream
|
||||||
Patch0: 0001-chore-update-libcryptsetup-rs-to-0.8.patch
|
Patch0: 0001-chore-update-libcryptsetup-rs-to-0.8.patch
|
||||||
|
Patch1: fdo-fix-tss-esapi-features.patch
|
||||||
|
|
||||||
%if 0%{?rhel} && !0%{?eln}
|
# Because nobody cares
|
||||||
|
ExcludeArch: %{ix86}
|
||||||
|
|
||||||
|
%if 0%{?rhel}
|
||||||
BuildRequires: rust-toolset
|
BuildRequires: rust-toolset
|
||||||
%else
|
%else
|
||||||
BuildRequires: rust-packaging
|
BuildRequires: rust-packaging
|
||||||
@ -33,17 +38,20 @@ BuildRequires: tpm2-tss-devel
|
|||||||
%prep
|
%prep
|
||||||
%autosetup -p1 -n %{name}-rs-%{version}
|
%autosetup -p1 -n %{name}-rs-%{version}
|
||||||
|
|
||||||
|
%if 0%{?rhel}
|
||||||
|
%cargo_prep -V 1
|
||||||
|
%else
|
||||||
%cargo_prep
|
%cargo_prep
|
||||||
|
|
||||||
%generate_buildrequires
|
%generate_buildrequires
|
||||||
%cargo_generate_buildrequires -a
|
%cargo_generate_buildrequires -a
|
||||||
|
%endif
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%cargo_build \
|
%cargo_build \
|
||||||
-F openssl-kdf/deny_custom
|
-F openssl-kdf/deny_custom
|
||||||
|
|
||||||
%cargo_license_summary
|
%{?cargo_license_summary}
|
||||||
%{cargo_license} > LICENSE.dependencies
|
%{?cargo_license} > LICENSE.dependencies
|
||||||
|
|
||||||
%install
|
%install
|
||||||
install -D -m 0755 -t %{buildroot}%{_libexecdir}/fdo target/release/fdo-client-linuxapp
|
install -D -m 0755 -t %{buildroot}%{_libexecdir}/fdo target/release/fdo-client-linuxapp
|
||||||
@ -219,6 +227,9 @@ Requires: fdo-owner-cli = %{version}-%{release}
|
|||||||
%systemd_postun_with_restart fdo-aio.service
|
%systemd_postun_with_restart fdo-aio.service
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Jul 03 2023 Peter Robinson <pbrobinson@fedoraproject.org> - 0.4.10-2
|
||||||
|
- Updates for eln/c9s building
|
||||||
|
|
||||||
* Fri Jun 23 2023 Peter Robinson <pbrobinson@fedoraproject.org> - 0.4.10-1
|
* Fri Jun 23 2023 Peter Robinson <pbrobinson@fedoraproject.org> - 0.4.10-1
|
||||||
- Update to 0.4.10
|
- Update to 0.4.10
|
||||||
|
|
||||||
|
1
sources
1
sources
@ -1 +1,2 @@
|
|||||||
|
SHA512 (fido-device-onboard-rs-0.4.10-vendor-patched.tar.xz) = e8a272e186be04d5937ed32d33bd9d968150cbe84c7cfa9fe5dc53055d7fc61c2198d42e38ee31fb56aaec75c27098e14af15964c6524fa7e396cd05081e337a
|
||||||
SHA512 (fido-device-onboard-rs-0.4.10.tar.gz) = 7b8b082b845f6af269adaff9608075da43d884edd2ed39ec7b613c368d95b0083a8edbf160479d5effb7c19ce5049a2da3e5806dfbe7addcbc34bd3658367731
|
SHA512 (fido-device-onboard-rs-0.4.10.tar.gz) = 7b8b082b845f6af269adaff9608075da43d884edd2ed39ec7b613c368d95b0083a8edbf160479d5effb7c19ce5049a2da3e5806dfbe7addcbc34bd3658367731
|
||||||
|
Loading…
Reference in New Issue
Block a user