import CS fido-device-onboard-0.5.1-1.el9
This commit is contained in:
parent
4c0a229d7f
commit
ba4ae0855c
@ -1,2 +1,2 @@
|
||||
46520f8fc83e17f4f308e56e464413df14b0a30e SOURCES/fido-device-onboard-rs-0.4.7-vendor-patched.tar.xz
|
||||
7a56d23875101202a44ad2a35d928be29263cf4d SOURCES/fido-device-onboard-rs-0.4.7.tar.gz
|
||||
68573f4be1bf03ecb813adb38eed51de2293b0e0 SOURCES/fido-device-onboard-rs-0.5.1-vendor-patched.tar.xz
|
||||
2bd391405b20379e4237439ca78c67823e1e017d SOURCES/fido-device-onboard-rs-0.5.1.tar.gz
|
||||
|
4
.gitignore
vendored
4
.gitignore
vendored
@ -1,2 +1,2 @@
|
||||
SOURCES/fido-device-onboard-rs-0.4.7-vendor-patched.tar.xz
|
||||
SOURCES/fido-device-onboard-rs-0.4.7.tar.gz
|
||||
SOURCES/fido-device-onboard-rs-0.5.1-vendor-patched.tar.xz
|
||||
SOURCES/fido-device-onboard-rs-0.5.1.tar.gz
|
||||
|
@ -0,0 +1,40 @@
|
||||
From f1b53d4bdac4ab889eb084111f395d418945ed07 Mon Sep 17 00:00:00 2001
|
||||
From: Antonio Murdaca <amurdaca@redhat.com>
|
||||
Date: Mon, 25 Nov 2024 12:30:52 +0100
|
||||
Subject: [PATCH] Revert "chore: use git fork for aws-nitro-enclaves-cose"
|
||||
|
||||
This reverts commit 1ea09e88baee3c47cdc76902f0034d553207d515.
|
||||
---
|
||||
data-formats/Cargo.toml | 2 +-
|
||||
http-wrapper/Cargo.toml | 2 +-
|
||||
2 files changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/data-formats/Cargo.toml b/data-formats/Cargo.toml
|
||||
index 83979e1..c8ae80f 100644
|
||||
--- a/data-formats/Cargo.toml
|
||||
+++ b/data-formats/Cargo.toml
|
||||
@@ -17,7 +17,7 @@ serde_cbor = "0.11"
|
||||
serde_repr = "0.1.6"
|
||||
serde_tuple = "0.5"
|
||||
thiserror = "1"
|
||||
-aws-nitro-enclaves-cose = { git = "https://github.com/nullr0ute/aws-nitro-enclaves-cose/", rev = "e3938e60d9051690569d1e4fcbe1c0c99d2fafa8" }
|
||||
+aws-nitro-enclaves-cose = "0.4.0"
|
||||
uuid = "1.3"
|
||||
num-traits = "0.2"
|
||||
num-derive = "0.3"
|
||||
diff --git a/http-wrapper/Cargo.toml b/http-wrapper/Cargo.toml
|
||||
index 0decb0c..70fcf41 100644
|
||||
--- a/http-wrapper/Cargo.toml
|
||||
+++ b/http-wrapper/Cargo.toml
|
||||
@@ -20,7 +20,7 @@ openssl = "0.10.66"
|
||||
|
||||
fdo-data-formats = { path = "../data-formats", version = "0.5.1" }
|
||||
fdo-store = { path = "../store", version = "0.5.1" }
|
||||
-aws-nitro-enclaves-cose = { git = "https://github.com/nullr0ute/aws-nitro-enclaves-cose/", rev = "e3938e60d9051690569d1e4fcbe1c0c99d2fafa8" }
|
||||
+aws-nitro-enclaves-cose = "0.4.0"
|
||||
|
||||
# Server-side
|
||||
uuid = { version = "1.3", features = ["v4"], optional = true }
|
||||
--
|
||||
2.47.0
|
||||
|
@ -1,14 +0,0 @@
|
||||
#/bin/bash
|
||||
set -x
|
||||
ver=$1
|
||||
cargo vendor
|
||||
# Various vendor cleanups
|
||||
pushd vendor
|
||||
# cleanup windows files
|
||||
rm -rf winapi/src/*
|
||||
touch winapi/src/lib.rs
|
||||
rm -rf winapi-x86_64-pc-windows-gnu/lib/*
|
||||
rm -rf winapi-i686-pc-windows-gnu/lib/*
|
||||
rm -rf vcpkg/test-data
|
||||
popd #vendor
|
||||
tar cjf fido-device-onboard-rs-$ver-vendor-patched.tar.xz vendor/
|
@ -1,84 +1,69 @@
|
||||
%global debug_package %{nil}
|
||||
%define dracutlibdir %{_prefix}/lib/dracut
|
||||
%global dracutlibdir %{_prefix}/lib/dracut
|
||||
%bcond_without check
|
||||
%global forgeurl https://github.com/fedora-iot/fido-device-onboard-rs
|
||||
|
||||
Version: 0.4.7
|
||||
|
||||
%forgemeta
|
||||
%global combined_license Apache-2.0 AND (Apache-2.0 OR BSL-1.0) AND (Apache-2.0 OR ISC OR MIT) AND (Apache-2.0 OR MIT) AND ((Apache-2.0 OR MIT) AND BSD-3-Clause) AND (Apache-2.0 WITH LLVM-exception OR Apache-2.0 OR MIT) AND BSD-2-Clause AND BSD-3-Clause AND (CC0-1.0 OR Apache-2.0) AND (CC0-1.0 OR MIT-0 OR Apache-2.0) AND ISC AND MIT AND ((MIT OR Apache-2.0) AND Unicode-DFS-2016) AND (Apache-2.0 OR MIT OR Zlib) AND MPL-2.0 AND (Unlicense OR MIT)
|
||||
|
||||
Name: fido-device-onboard
|
||||
Release: 3%{?dist}
|
||||
Version: 0.5.1
|
||||
Release: 1%{?dist}
|
||||
Summary: A rust implementation of the FIDO Device Onboard Specification
|
||||
License: BSD-3-Clause
|
||||
|
||||
# Apache-2.0
|
||||
# Apache-2.0 OR BSL-1.0
|
||||
# Apache-2.0 OR ISC OR MIT
|
||||
# Apache-2.0 OR MIT
|
||||
# (Apache-2.0 OR MIT) AND BSD-3-Clause
|
||||
# Apache-2.0 WITH LLVM-exception OR Apache-2.0 OR MIT
|
||||
# BSD-2-Clause
|
||||
# BSD-3-Clause
|
||||
# CC0-1.0
|
||||
# CC0-1.0 OR Apache-2.0
|
||||
# ISC
|
||||
# MIT
|
||||
# MIT OR Apache-2.0
|
||||
# MIT OR Apache-2.0 OR Zlib
|
||||
# MPL-2.0
|
||||
# Unlicense OR MIT
|
||||
# Zlib OR Apache-2.0 OR MIT
|
||||
URL: https://github.com/fdo-rs/fido-device-onboard-rs
|
||||
Source0: %{url}/archive/v%{version}/%{name}-rs-%{version}.tar.gz
|
||||
# See make-vendored-tarfile.sh in upstream repo
|
||||
Source1: %{name}-rs-%{version}-vendor-patched.tar.xz
|
||||
Patch1: 0001-Revert-chore-use-git-fork-for-aws-nitro-enclaves-cos.patch
|
||||
|
||||
License: Apache-2.0 and BSD and MIT
|
||||
URL: %{forgeurl}
|
||||
# Because nobody cares
|
||||
ExcludeArch: %{ix86}
|
||||
|
||||
Source0: %{forgesource}
|
||||
# this is a basic script to generate the vendor tarfile.
|
||||
Source1: make-vendored-tarfile.sh
|
||||
%if "%{?commit}" != ""
|
||||
Source2: %{name}-rs-%{commit}-vendor-patched.tar.xz
|
||||
%else
|
||||
Source2: %{name}-rs-%{version}-vendor-patched.tar.xz
|
||||
%endif
|
||||
|
||||
ExclusiveArch: %{rust_arches}
|
||||
# Needs, at least, tss bindings regen
|
||||
ExcludeArch: s390x i686 %{power64}
|
||||
|
||||
%if 0%{?rhel} && !0%{?eln}
|
||||
%if 0%{?rhel}
|
||||
BuildRequires: rust-toolset
|
||||
%else
|
||||
BuildRequires: rust-packaging
|
||||
%endif
|
||||
BuildRequires: clang-devel
|
||||
BuildRequires: cryptsetup-devel
|
||||
BuildRequires: device-mapper-devel
|
||||
BuildRequires: golang
|
||||
BuildRequires: openssl-devel >= 3.0.1-12
|
||||
BuildRequires: systemd-rpm-macros
|
||||
BuildRequires: tpm2-tss-devel
|
||||
BuildRequires: sqlite-devel
|
||||
BuildRequires: libpq-devel
|
||||
|
||||
%description
|
||||
%{summary}.
|
||||
|
||||
%prep
|
||||
%forgesetup
|
||||
|
||||
%if 0%{?rhel}
|
||||
%autosetup -p1 -a1 -n %{name}-rs-%{version}
|
||||
rm -f Cargo.lock
|
||||
%if 0%{?rhel} >= 10
|
||||
%cargo_prep -v vendor
|
||||
%else
|
||||
%cargo_prep -V 1
|
||||
%endif
|
||||
%endif
|
||||
|
||||
%if 0%{?fedora}
|
||||
%autosetup -p1 -n %{name}-rs-%{version}
|
||||
%cargo_prep
|
||||
|
||||
# Vendored crates
|
||||
tar xf %{SOURCE2}
|
||||
mkdir -p .cargo
|
||||
cat >.cargo/config << EOF
|
||||
[source.crates-io]
|
||||
replace-with = "vendored-sources"
|
||||
|
||||
[source.vendored-sources]
|
||||
directory = "vendor"
|
||||
EOF
|
||||
%generate_buildrequires
|
||||
%cargo_generate_buildrequires -a
|
||||
%endif
|
||||
|
||||
%build
|
||||
%cargo_build \
|
||||
-F openssl-kdf/deny_custom
|
||||
|
||||
%{?cargo_license_summary}
|
||||
%{?cargo_license} > LICENSE.dependencies
|
||||
%if 0%{?rhel} >= 10
|
||||
%cargo_vendor_manifest
|
||||
%endif
|
||||
|
||||
%install
|
||||
install -D -m 0755 -t %{buildroot}%{_libexecdir}/fdo target/release/fdo-client-linuxapp
|
||||
install -D -m 0755 -t %{buildroot}%{_libexecdir}/fdo target/release/fdo-manufacturing-client
|
||||
@ -86,14 +71,37 @@ install -D -m 0755 -t %{buildroot}%{_libexecdir}/fdo target/release/fdo-manufact
|
||||
install -D -m 0755 -t %{buildroot}%{_libexecdir}/fdo target/release/fdo-owner-onboarding-server
|
||||
install -D -m 0755 -t %{buildroot}%{_libexecdir}/fdo target/release/fdo-rendezvous-server
|
||||
install -D -m 0755 -t %{buildroot}%{_libexecdir}/fdo target/release/fdo-serviceinfo-api-server
|
||||
# duplicates as needed by AIO command
|
||||
install -D -m 0755 -t %{buildroot}%{_libexecdir}/fdo target/release/fdo-owner-tool
|
||||
install -D -m 0755 -t %{buildroot}%{_libexecdir}/fdo target/release/fdo-admin-tool
|
||||
install -D -m 0755 -t %{buildroot}%{_bindir} target/release/fdo-owner-tool
|
||||
install -D -m 0755 -t %{buildroot}%{_bindir} target/release/fdo-admin-tool
|
||||
install -D -m 0644 -t %{buildroot}%{_unitdir} examples/systemd/*
|
||||
install -D -m 0644 -t %{buildroot}%{_docdir}/fdo examples/config/*
|
||||
# db sql files
|
||||
install -D -m 0644 -t %{buildroot}%{_docdir}/fdo/migrations/migrations_manufacturing_server_postgres migrations/migrations_manufacturing_server_postgres/2023-10-03-152801_create_db/*
|
||||
install -D -m 0644 -t %{buildroot}%{_docdir}/fdo/migrations/migrations_manufacturing_server_sqlite migrations/migrations_manufacturing_server_sqlite/2023-10-03-152801_create_db/*
|
||||
install -D -m 0644 -t %{buildroot}%{_docdir}/fdo/migrations/migrations_owner_onboarding_server_postgres migrations/migrations_owner_onboarding_server_postgres/2023-10-03-152801_create_db/*
|
||||
install -D -m 0644 -t %{buildroot}%{_docdir}/fdo/migrations/migrations_owner_onboarding_server_sqlite migrations/migrations_owner_onboarding_server_sqlite/2023-10-03-152801_create_db/*
|
||||
install -D -m 0644 -t %{buildroot}%{_docdir}/fdo/migrations/migrations_rendezvous_server_postgres migrations/migrations_rendezvous_server_postgres/2023-10-03-152801_create_db/*
|
||||
install -D -m 0644 -t %{buildroot}%{_docdir}/fdo/migrations/migrations_rendezvous_server_sqlite migrations/migrations_rendezvous_server_sqlite/2023-10-03-152801_create_db/*
|
||||
# duplicates as needed by AIO command so link them
|
||||
mkdir -p %{buildroot}%{_bindir}
|
||||
ln -sr %{buildroot}%{_bindir}/fdo-owner-tool %{buildroot}%{_libexecdir}/fdo/fdo-owner-tool
|
||||
ln -sr %{buildroot}%{_bindir}/fdo-admin-tool %{buildroot}%{_libexecdir}/fdo/fdo-admin-tool
|
||||
# Create directories needed by the various services so we own them
|
||||
mkdir -p %{buildroot}%{_sysconfdir}/fdo
|
||||
mkdir -p %{buildroot}%{_sysconfdir}/fdo/keys
|
||||
mkdir -p %{buildroot}%{_sysconfdir}/fdo/stores
|
||||
mkdir -p %{buildroot}%{_sysconfdir}/fdo/stores/manufacturer_keys
|
||||
mkdir -p %{buildroot}%{_sysconfdir}/fdo/stores/manufacturing_sessions
|
||||
mkdir -p %{buildroot}%{_sysconfdir}/fdo/stores/owner_onboarding_sessions
|
||||
mkdir -p %{buildroot}%{_sysconfdir}/fdo/stores/owner_vouchers
|
||||
mkdir -p %{buildroot}%{_sysconfdir}/fdo/stores/rendezvous_registered
|
||||
mkdir -p %{buildroot}%{_sysconfdir}/fdo/stores/rendezvous_sessions
|
||||
mkdir -p %{buildroot}%{_sysconfdir}/fdo/stores/serviceinfo_api_devices
|
||||
mkdir -p %{buildroot}%{_sysconfdir}/fdo/manufacturing-server.conf.d
|
||||
mkdir -p %{buildroot}%{_sysconfdir}/fdo/owner-onboarding-server.conf.d
|
||||
mkdir -p %{buildroot}%{_sysconfdir}/fdo/rendezvous-server.conf.d
|
||||
mkdir -p %{buildroot}%{_sysconfdir}/fdo/serviceinfo-api-server.conf.d
|
||||
mkdir -p %{buildroot}%{_localstatedir}/lib/fdo
|
||||
# Dracut manufacturing service
|
||||
install -D -m 0755 -t %{buildroot}%{dracutlibdir}/modules.d/52fdo dracut/52fdo/module-setup.sh
|
||||
install -D -m 0755 -t %{buildroot}%{dracutlibdir}/modules.d/52fdo dracut/52fdo/manufacturing-client-generator
|
||||
@ -102,28 +110,50 @@ install -D -m 0755 -t %{buildroot}%{dracutlibdir}/modules.d/52fdo dracut/52fdo/m
|
||||
|
||||
%package -n fdo-init
|
||||
Summary: dracut module for device initialization
|
||||
License: %combined_license
|
||||
Requires: openssl-libs >= 3.0.1-12
|
||||
Requires: dracut
|
||||
%description -n fdo-init
|
||||
%{summary}
|
||||
|
||||
%files -n fdo-init
|
||||
%license LICENSE
|
||||
%{dracutlibdir}/modules.d/52fdo/*
|
||||
%license LICENSE LICENSE.dependencies
|
||||
%if 0%{?rhel} >= 10
|
||||
%license cargo-vendor.txt
|
||||
%endif
|
||||
%{dracutlibdir}/modules.d/52fdo/
|
||||
%{_libexecdir}/fdo/fdo-manufacturing-client
|
||||
|
||||
%package -n fdo-owner-onboarding-server
|
||||
Summary: FDO Owner Onboarding Server implementation
|
||||
License: %combined_license
|
||||
Requires: openssl-libs >= 3.0.1-12
|
||||
%description -n fdo-owner-onboarding-server
|
||||
%{summary}
|
||||
|
||||
%files -n fdo-owner-onboarding-server
|
||||
%license LICENSE
|
||||
%license LICENSE LICENSE.dependencies
|
||||
%if 0%{?rhel} >= 10
|
||||
%license cargo-vendor.txt
|
||||
%endif
|
||||
%dir %{_sysconfdir}/fdo
|
||||
%dir %{_sysconfdir}/fdo/keys
|
||||
%dir %{_sysconfdir}/fdo/owner-onboarding-server.conf.d
|
||||
%dir %{_sysconfdir}/fdo/serviceinfo-api-server.conf.d
|
||||
%dir %{_sysconfdir}/fdo/stores
|
||||
%dir %{_sysconfdir}/fdo/stores/owner_onboarding_sessions
|
||||
%dir %{_sysconfdir}/fdo/stores/owner_vouchers
|
||||
%dir %{_sysconfdir}/fdo/stores/serviceinfo_api_devices
|
||||
%{_libexecdir}/fdo/fdo-owner-onboarding-server
|
||||
%{_libexecdir}/fdo/fdo-serviceinfo-api-server
|
||||
%dir %{_localstatedir}/lib/fdo
|
||||
%dir %{_docdir}/fdo
|
||||
%{_docdir}/fdo/device_specific_serviceinfo.yml
|
||||
%{_docdir}/fdo/serviceinfo-api-server.yml
|
||||
%{_unitdir}/fdo-serviceinfo-api-server.service
|
||||
%{_docdir}/fdo/owner-onboarding-server.yml
|
||||
%{_docdir}/fdo/migrations/migrations_owner_onboarding_server_postgres/*
|
||||
%{_docdir}/fdo/migrations/migrations_owner_onboarding_server_sqlite/*
|
||||
%{_unitdir}/fdo-serviceinfo-api-server.service
|
||||
%{_unitdir}/fdo-owner-onboarding-server.service
|
||||
|
||||
%post -n fdo-owner-onboarding-server
|
||||
@ -140,13 +170,27 @@ Requires: openssl-libs >= 3.0.1-12
|
||||
|
||||
%package -n fdo-rendezvous-server
|
||||
Summary: FDO Rendezvous Server implementation
|
||||
License: %combined_license
|
||||
%description -n fdo-rendezvous-server
|
||||
%{summary}
|
||||
|
||||
%files -n fdo-rendezvous-server
|
||||
%license LICENSE
|
||||
%license LICENSE LICENSE.dependencies
|
||||
%if 0%{?rhel} >= 10
|
||||
%license cargo-vendor.txt
|
||||
%endif
|
||||
%dir %{_sysconfdir}/fdo
|
||||
%dir %{_sysconfdir}/fdo/keys
|
||||
%dir %{_sysconfdir}/fdo/rendezvous-server.conf.d
|
||||
%dir %{_sysconfdir}/fdo/stores
|
||||
%dir %{_sysconfdir}/fdo/stores/rendezvous_registered
|
||||
%dir %{_sysconfdir}/fdo/stores/rendezvous_sessions
|
||||
%{_libexecdir}/fdo/fdo-rendezvous-server
|
||||
%dir %{_localstatedir}/lib/fdo
|
||||
%dir %{_docdir}/fdo
|
||||
%{_docdir}/fdo/rendezvous-*.yml
|
||||
%{_docdir}/fdo/migrations/migrations_rendezvous_server_postgres/*
|
||||
%{_docdir}/fdo/migrations/migrations_rendezvous_server_sqlite/*
|
||||
%{_unitdir}/fdo-rendezvous-server.service
|
||||
|
||||
%post -n fdo-rendezvous-server
|
||||
@ -160,14 +204,29 @@ Summary: FDO Rendezvous Server implementation
|
||||
|
||||
%package -n fdo-manufacturing-server
|
||||
Summary: FDO Manufacturing Server implementation
|
||||
License: %combined_license
|
||||
Requires: openssl-libs >= 3.0.1-12
|
||||
%description -n fdo-manufacturing-server
|
||||
%{summary}
|
||||
|
||||
%files -n fdo-manufacturing-server
|
||||
%license LICENSE
|
||||
%license LICENSE LICENSE.dependencies
|
||||
%if 0%{?rhel} >= 10
|
||||
%license cargo-vendor.txt
|
||||
%endif
|
||||
%dir %{_sysconfdir}/fdo
|
||||
%dir %{_sysconfdir}/fdo/keys
|
||||
%dir %{_sysconfdir}/fdo/manufacturing-server.conf.d
|
||||
%dir %{_sysconfdir}/fdo/stores
|
||||
%dir %{_sysconfdir}/fdo/stores/manufacturer_keys
|
||||
%dir %{_sysconfdir}/fdo/stores/manufacturing_sessions
|
||||
%dir %{_sysconfdir}/fdo/stores/owner_vouchers
|
||||
%{_libexecdir}/fdo/fdo-manufacturing-server
|
||||
%dir %{_localstatedir}/lib/fdo
|
||||
%dir %{_docdir}/fdo
|
||||
%{_docdir}/fdo/manufacturing-server.yml
|
||||
%{_docdir}/fdo/migrations/migrations_manufacturing_server_postgres/*
|
||||
%{_docdir}/fdo/migrations/migrations_manufacturing_server_sqlite/*
|
||||
%{_unitdir}/fdo-manufacturing-server.service
|
||||
|
||||
%post -n fdo-manufacturing-server
|
||||
@ -181,15 +240,20 @@ Requires: openssl-libs >= 3.0.1-12
|
||||
|
||||
%package -n fdo-client
|
||||
Summary: FDO Client implementation
|
||||
License: %combined_license
|
||||
Requires: openssl-libs >= 3.0.1-12
|
||||
Requires: clevis
|
||||
Requires: clevis-luks
|
||||
Requires: clevis-pin-tpm2
|
||||
Requires: cryptsetup
|
||||
%description -n fdo-client
|
||||
%{summary}
|
||||
|
||||
%files -n fdo-client
|
||||
%license LICENSE
|
||||
%if 0%{?rhel} >= 10
|
||||
%license cargo-vendor.txt
|
||||
%endif
|
||||
%license LICENSE LICENSE.dependencies
|
||||
%{_libexecdir}/fdo/fdo-client-linuxapp
|
||||
%{_unitdir}/fdo-client-linuxapp.service
|
||||
|
||||
@ -204,31 +268,40 @@ Requires: cryptsetup
|
||||
|
||||
%package -n fdo-owner-cli
|
||||
Summary: FDO Owner tools implementation
|
||||
License: %combined_license
|
||||
%description -n fdo-owner-cli
|
||||
%{summary}
|
||||
|
||||
%files -n fdo-owner-cli
|
||||
%license LICENSE
|
||||
%if 0%{?rhel} >= 10
|
||||
%license cargo-vendor.txt
|
||||
%endif
|
||||
%license LICENSE LICENSE.dependencies
|
||||
%{_bindir}/fdo-owner-tool
|
||||
%{_libexecdir}/fdo/fdo-owner-tool
|
||||
|
||||
%package -n fdo-admin-cli
|
||||
Summary: FDO admin tools implementation
|
||||
Requires: fdo-manufacturing-server
|
||||
Requires: fdo-init
|
||||
Requires: fdo-client
|
||||
Requires: fdo-rendezvous-server
|
||||
Requires: fdo-owner-onboarding-server
|
||||
Requires: fdo-owner-cli
|
||||
License: %combined_license
|
||||
Requires: fdo-manufacturing-server = %{version}-%{release}
|
||||
Requires: fdo-rendezvous-server = %{version}-%{release}
|
||||
Requires: fdo-owner-onboarding-server = %{version}-%{release}
|
||||
Requires: fdo-owner-cli = %{version}-%{release}
|
||||
Requires: fdo-client = %{version}-%{release}
|
||||
Requires: fdo-init = %{version}-%{release}
|
||||
%description -n fdo-admin-cli
|
||||
%{summary}
|
||||
|
||||
%files -n fdo-admin-cli
|
||||
%license LICENSE
|
||||
%if 0%{?rhel} >= 10
|
||||
%license cargo-vendor.txt
|
||||
%endif
|
||||
%license LICENSE LICENSE.dependencies
|
||||
%dir %{_sysconfdir}/fdo
|
||||
%dir %{_sysconfdir}/fdo/keys
|
||||
%{_bindir}/fdo-admin-tool
|
||||
%{_libexecdir}/fdo/fdo-admin-tool
|
||||
%{_unitdir}/fdo-aio.service
|
||||
%dir %{_sysconfdir}/fdo
|
||||
|
||||
%post -n fdo-admin-cli
|
||||
%systemd_post fdo-aio.service
|
||||
@ -240,6 +313,94 @@ Requires: fdo-owner-cli
|
||||
%systemd_postun_with_restart fdo-aio.service
|
||||
|
||||
%changelog
|
||||
* Tue Nov 26 2024 Antonio Murdaca <amurdaca@redhat.com> - 0.5.1-1
|
||||
## What's Changed
|
||||
* chore: update patch for new release by @nullr0ute in https://github.com/fdo-rs/fido-device-onboard-rs/pull/625
|
||||
* chore: fix require error with commitlint by @miabbott in https://github.com/fdo-rs/fido-device-onboard-rs/pull/636
|
||||
* fix(license): replace space with - in Apache 2.0 by @7flying in https://github.com/fdo-rs/fido-device-onboard-rs/pull/632
|
||||
* fix(data-formats): use serde_tuple serializer for error messages by @mmartinv in https://github.com/fdo-rs/fido-device-onboard-rs/pull/629
|
||||
* fix: cargo test for non-root users by @mmartinv in https://github.com/fdo-rs/fido-device-onboard-rs/pull/635
|
||||
* fix(get_current_user_name): remove trailing whitespaces. by @mmartinv in https://github.com/fdo-rs/fido-device-onboard-rs/pull/638
|
||||
* chore: bump mio from 0.8.10 to 0.8.11 by @dependabot in https://github.com/fdo-rs/fido-device-onboard-rs/pull/640
|
||||
* fix: vendored tarfile creation by @mmartinv in https://github.com/fdo-rs/fido-device-onboard-rs/pull/634
|
||||
* fix: static-mut-refs warning by @7flying in https://github.com/fdo-rs/fido-device-onboard-rs/pull/651
|
||||
* Enable CentOS 9 builds and add Testing Farm e2e tests by @mmartinv in https://github.com/fdo-rs/fido-device-onboard-rs/pull/650
|
||||
* Add an OV re-registration window option when using DB storage by @7flying in https://github.com/fdo-rs/fido-device-onboard-rs/pull/643
|
||||
* chore: bump pem from 2.0.1 to 3.0.3 by @dependabot in https://github.com/fdo-rs/fido-device-onboard-rs/pull/639
|
||||
* chore: bump h2 from 0.3.25 to 0.3.26 by @dependabot in https://github.com/fdo-rs/fido-device-onboard-rs/pull/659
|
||||
* feat: verify trusted manufacturers by @mmartinv in https://github.com/fdo-rs/fido-device-onboard-rs/pull/656
|
||||
* database enhancements by @runcom in https://github.com/fdo-rs/fido-device-onboard-rs/pull/666
|
||||
* chore: bump openssl to 0.10.66 by @7flying in https://github.com/fdo-rs/fido-device-onboard-rs/pull/664
|
||||
* chore(store): make the store OVs agnostic by @runcom in https://github.com/fdo-rs/fido-device-onboard-rs/pull/671
|
||||
* feat(manufacturing-server): implement an export OVs endpoint by @runcom in https://github.com/fdo-rs/fido-device-onboard-rs/pull/673
|
||||
* fix(systemd-units): run before powering off the system by @mmartinv in https://github.com/fdo-rs/fido-device-onboard-rs/pull/676
|
||||
* fix(dracut): use isolate on error in the manufacturing-client service by @mmartinv in https://github.com/fdo-rs/fido-device-onboard-rs/pull/678
|
||||
* fix(systemd-generator): write configuration to '/run' by @mmartinv in https://github.com/fdo-rs/fido-device-onboard-rs/pull/677
|
||||
* fix(owner-tool): use the new API to export ovs by @runcom in https://github.com/fdo-rs/fido-device-onboard-rs/pull/675
|
||||
* chore: update diesel to 2.2.3 by @7flying in https://github.com/fdo-rs/fido-device-onboard-rs/pull/669
|
||||
* chore: bump reqwest from 0.11.27 to 0.12.7 by @dependabot in https://github.com/fdo-rs/fido-device-onboard-rs/pull/683
|
||||
* fix: use centos-stream-9 target instead of epel-9 by @mmartinv in https://github.com/fdo-rs/fido-device-onboard-rs/pull/687
|
||||
* enhance onboarding testing by @mmartinv in https://github.com/fdo-rs/fido-device-onboard-rs/pull/681
|
||||
* ci: add konflux test cases by @yih-redhat in https://github.com/fdo-rs/fido-device-onboard-rs/pull/688
|
||||
* fix(make-vendored-tarfile.sh): exclude idna tests with unicode points by @runcom in https://github.com/fdo-rs/fido-device-onboard-rs/pull/692
|
||||
* chore: bump for 0.5.1 by @runcom in https://github.com/fdo-rs/fido-device-onboard-rs/pull/693
|
||||
|
||||
## New Contributors
|
||||
* @miabbott made their first contribution in https://github.com/fdo-rs/fido-device-onboard-rs/pull/636
|
||||
* @yih-redhat made their first contribution in https://github.com/fdo-rs/fido-device-onboard-rs/pull/688
|
||||
|
||||
**Full Changelog**: https://github.com/fdo-rs/fido-device-onboard-rs/compare/v0.5.0...v0.5.1
|
||||
|
||||
* Thu Oct 03 2024 Miguel Martín <mmartinv@redhat.com> - 0.5.0-4
|
||||
- Apply all the patches in the spec
|
||||
|
||||
* Wed Oct 02 2024 Miguel Martín <mmartinv@redhat.com> - 0.5.0-3
|
||||
- Backport https://github.com/fdo-rs/fido-device-onboard-rs/pull/676
|
||||
|
||||
* Wed Feb 28 2024 Irene Diez <idiez@redhat.com> - 0.5.0-2
|
||||
- Update license
|
||||
|
||||
* Thu Feb 22 2024 Irene Diez <idiez@redhat.com> - 0.5.0-1
|
||||
- New version 0.5.0, adds database support
|
||||
- Remove unused patches
|
||||
|
||||
* Wed Aug 23 2023 Peter Robinson <pbrobinson@fedoraproject.org> - 0.4.12-4
|
||||
- Ensure client service fix is applied
|
||||
|
||||
* Tue Aug 22 2023 Peter Robinson <pbrobinson@fedoraproject.org> - 0.4.12-3
|
||||
- Own var/lib/fdo, SELinux fixes
|
||||
|
||||
* Thu Aug 17 2023 Peter Robinson <pbrobinson@fedoraproject.org> - 0.4.12-2
|
||||
- Add client/init deps to fdo-admin-cli
|
||||
|
||||
* Thu Jul 27 2023 Peter Robinson <pbrobinson@fedoraproject.org> - 0.4.12-1
|
||||
- Update to 0.4.12
|
||||
|
||||
* Wed Jul 19 2023 Fedora Release Engineering <releng@fedoraproject.org> - 0.4.10-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_39_Mass_Rebuild
|
||||
|
||||
* Mon Jul 03 2023 Peter Robinson <pbrobinson@fedoraproject.org> - 0.4.10-2
|
||||
- Updates for eln/c9s building
|
||||
|
||||
* Fri Jun 23 2023 Peter Robinson <pbrobinson@fedoraproject.org> - 0.4.10-1
|
||||
- Update to 0.4.10
|
||||
|
||||
* Wed Jun 14 2023 Peter Robinson <pbrobinson@fedoraproject.org> - 0.4.9-5
|
||||
- More spec updates
|
||||
|
||||
* Wed Jun 14 2023 Peter Robinson <pbrobinson@fedoraproject.org> - 0.4.9-4
|
||||
- Add patch for libcryptsetup-rs 0.8 API changes
|
||||
|
||||
* Tue Jun 13 2023 Peter Robinson <pbrobinson@fedoraproject.org> - 0.4.9-3
|
||||
- Updates for licenses
|
||||
|
||||
* Tue May 30 2023 Peter Robinson <pbrobinson@fedoraproject.org> - 0.4.9-2
|
||||
- Review feedback
|
||||
- Patch for libcryptsetup-rs 0.7
|
||||
|
||||
* Thu May 11 2023 Peter Robinson <pbrobinson@fedoraproject.org> - 0.4.9-1
|
||||
- Update to 0.4.9
|
||||
|
||||
* Mon Feb 20 2023 Peter Robinson <pbrobinson@fedoraproject.org> - 0.4.7-3
|
||||
- Fix services start
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user