import fido-device-onboard-0.4.7-3.el9
This commit is contained in:
parent
56e453eaea
commit
b7653d7dad
@ -1,2 +1,2 @@
|
|||||||
f89779ff4421530aa4f51ebe1eaa81858ec4b1f5 SOURCES/fido-device-onboard-rs-0.4.5-vendor-patched.tar.gz
|
46520f8fc83e17f4f308e56e464413df14b0a30e SOURCES/fido-device-onboard-rs-0.4.7-vendor-patched.tar.xz
|
||||||
2bccb11a53358c1464e00d9a2b41251d793651d0 SOURCES/fido-device-onboard-rs-0.4.5.tar.gz
|
7a56d23875101202a44ad2a35d928be29263cf4d SOURCES/fido-device-onboard-rs-0.4.7.tar.gz
|
||||||
|
4
.gitignore
vendored
4
.gitignore
vendored
@ -1,2 +1,2 @@
|
|||||||
SOURCES/fido-device-onboard-rs-0.4.5-vendor-patched.tar.gz
|
SOURCES/fido-device-onboard-rs-0.4.7-vendor-patched.tar.xz
|
||||||
SOURCES/fido-device-onboard-rs-0.4.5.tar.gz
|
SOURCES/fido-device-onboard-rs-0.4.7.tar.gz
|
||||||
|
@ -1,10 +0,0 @@
|
|||||||
diff --color -ru fido-device-onboard-rs-b52cd2912bc646779e290300fc27fa59f3264535-orig/Cargo.toml fido-device-onboard-rs-b52cd2912bc646779e290300fc27fa59f3264535/Cargo.toml
|
|
||||||
--- fido-device-onboard-rs-b52cd2912bc646779e290300fc27fa59f3264535-orig/Cargo.toml 2022-03-17 16:38:49.000000000 +0100
|
|
||||||
+++ fido-device-onboard-rs-b52cd2912bc646779e290300fc27fa59f3264535/Cargo.toml 2022-03-28 12:03:59.101029855 +0200
|
|
||||||
@@ -17,3 +17,6 @@
|
|
||||||
|
|
||||||
"integration-tests",
|
|
||||||
]
|
|
||||||
+
|
|
||||||
+[profile.release]
|
|
||||||
+debug = true
|
|
14
SOURCES/make-vendored-tarfile.sh
Normal file
14
SOURCES/make-vendored-tarfile.sh
Normal file
@ -0,0 +1,14 @@
|
|||||||
|
#/bin/bash
|
||||||
|
set -x
|
||||||
|
ver=$1
|
||||||
|
cargo vendor
|
||||||
|
# Various vendor cleanups
|
||||||
|
pushd vendor
|
||||||
|
# cleanup windows files
|
||||||
|
rm -rf winapi/src/*
|
||||||
|
touch winapi/src/lib.rs
|
||||||
|
rm -rf winapi-x86_64-pc-windows-gnu/lib/*
|
||||||
|
rm -rf winapi-i686-pc-windows-gnu/lib/*
|
||||||
|
rm -rf vcpkg/test-data
|
||||||
|
popd #vendor
|
||||||
|
tar cjf fido-device-onboard-rs-$ver-vendor-patched.tar.xz vendor/
|
@ -1,30 +1,48 @@
|
|||||||
|
%global debug_package %{nil}
|
||||||
%define dracutlibdir %{_prefix}/lib/dracut
|
%define dracutlibdir %{_prefix}/lib/dracut
|
||||||
%bcond_without check
|
%bcond_without check
|
||||||
%global __cargo_skip_build 0
|
|
||||||
%global __cargo_is_lib() false
|
|
||||||
%global forgeurl https://github.com/fedora-iot/fido-device-onboard-rs
|
%global forgeurl https://github.com/fedora-iot/fido-device-onboard-rs
|
||||||
|
|
||||||
Version: 0.4.5
|
Version: 0.4.7
|
||||||
|
|
||||||
%forgemeta
|
%forgemeta
|
||||||
|
|
||||||
Name: fido-device-onboard
|
Name: fido-device-onboard
|
||||||
Release: 1%{?dist}
|
Release: 3%{?dist}
|
||||||
Summary: An implementation of the FIDO Device Onboard Specification written in rust
|
Summary: A rust implementation of the FIDO Device Onboard Specification
|
||||||
|
|
||||||
License: BSD
|
# Apache-2.0
|
||||||
|
# Apache-2.0 OR BSL-1.0
|
||||||
|
# Apache-2.0 OR ISC OR MIT
|
||||||
|
# Apache-2.0 OR MIT
|
||||||
|
# (Apache-2.0 OR MIT) AND BSD-3-Clause
|
||||||
|
# Apache-2.0 WITH LLVM-exception OR Apache-2.0 OR MIT
|
||||||
|
# BSD-2-Clause
|
||||||
|
# BSD-3-Clause
|
||||||
|
# CC0-1.0
|
||||||
|
# CC0-1.0 OR Apache-2.0
|
||||||
|
# ISC
|
||||||
|
# MIT
|
||||||
|
# MIT OR Apache-2.0
|
||||||
|
# MIT OR Apache-2.0 OR Zlib
|
||||||
|
# MPL-2.0
|
||||||
|
# Unlicense OR MIT
|
||||||
|
# Zlib OR Apache-2.0 OR MIT
|
||||||
|
|
||||||
|
License: Apache-2.0 and BSD and MIT
|
||||||
URL: %{forgeurl}
|
URL: %{forgeurl}
|
||||||
Source: %{forgesource}
|
|
||||||
|
Source0: %{forgesource}
|
||||||
|
# this is a basic script to generate the vendor tarfile.
|
||||||
|
Source1: make-vendored-tarfile.sh
|
||||||
%if "%{?commit}" != ""
|
%if "%{?commit}" != ""
|
||||||
Source1: %{name}-rs-%{commit}-vendor-patched.tar.gz
|
Source2: %{name}-rs-%{commit}-vendor-patched.tar.xz
|
||||||
%else
|
%else
|
||||||
Source1: %{name}-rs-%{version}-vendor-patched.tar.gz
|
Source2: %{name}-rs-%{version}-vendor-patched.tar.xz
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
Patch0: debug-profile.patch
|
|
||||||
|
|
||||||
ExclusiveArch: %{rust_arches}
|
ExclusiveArch: %{rust_arches}
|
||||||
# RHBZ 1869980
|
# Needs, at least, tss bindings regen
|
||||||
ExcludeArch: s390x i686 %{power64}
|
ExcludeArch: s390x i686 %{power64}
|
||||||
|
|
||||||
%if 0%{?rhel} && !0%{?eln}
|
%if 0%{?rhel} && !0%{?eln}
|
||||||
@ -32,22 +50,22 @@ BuildRequires: rust-toolset
|
|||||||
%else
|
%else
|
||||||
BuildRequires: rust-packaging
|
BuildRequires: rust-packaging
|
||||||
%endif
|
%endif
|
||||||
BuildRequires: systemd-rpm-macros
|
BuildRequires: clang-devel
|
||||||
BuildRequires: openssl-devel >= 3.0.1-12
|
BuildRequires: cryptsetup-devel
|
||||||
BuildRequires: golang
|
BuildRequires: golang
|
||||||
BuildRequires: tpm2-tss-devel
|
BuildRequires: openssl-devel >= 3.0.1-12
|
||||||
BuildRequires: cryptsetup-devel
|
BuildRequires: systemd-rpm-macros
|
||||||
BuildRequires: clang-devel
|
BuildRequires: tpm2-tss-devel
|
||||||
|
|
||||||
%description
|
%description
|
||||||
%{summary}.
|
%{summary}.
|
||||||
|
|
||||||
%prep
|
%prep
|
||||||
%forgesetup
|
%forgesetup
|
||||||
%patch0 -p1
|
|
||||||
%cargo_prep
|
%cargo_prep
|
||||||
%if 0%{?rhel} && !0%{?eln}
|
|
||||||
tar xvf %{SOURCE1}
|
# Vendored crates
|
||||||
|
tar xf %{SOURCE2}
|
||||||
mkdir -p .cargo
|
mkdir -p .cargo
|
||||||
cat >.cargo/config << EOF
|
cat >.cargo/config << EOF
|
||||||
[source.crates-io]
|
[source.crates-io]
|
||||||
@ -56,10 +74,10 @@ replace-with = "vendored-sources"
|
|||||||
[source.vendored-sources]
|
[source.vendored-sources]
|
||||||
directory = "vendor"
|
directory = "vendor"
|
||||||
EOF
|
EOF
|
||||||
%endif
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%{__cargo} build --release --features openssl-kdf/deny_custom
|
%cargo_build \
|
||||||
|
-F openssl-kdf/deny_custom
|
||||||
|
|
||||||
%install
|
%install
|
||||||
install -D -m 0755 -t %{buildroot}%{_libexecdir}/fdo target/release/fdo-client-linuxapp
|
install -D -m 0755 -t %{buildroot}%{_libexecdir}/fdo target/release/fdo-client-linuxapp
|
||||||
@ -76,7 +94,7 @@ install -D -m 0755 -t %{buildroot}%{_bindir} target/release/fdo-admin-tool
|
|||||||
install -D -m 0644 -t %{buildroot}%{_unitdir} examples/systemd/*
|
install -D -m 0644 -t %{buildroot}%{_unitdir} examples/systemd/*
|
||||||
install -D -m 0644 -t %{buildroot}%{_docdir}/fdo examples/config/*
|
install -D -m 0644 -t %{buildroot}%{_docdir}/fdo examples/config/*
|
||||||
mkdir -p %{buildroot}%{_sysconfdir}/fdo
|
mkdir -p %{buildroot}%{_sysconfdir}/fdo
|
||||||
# 52fdo
|
# Dracut manufacturing service
|
||||||
install -D -m 0755 -t %{buildroot}%{dracutlibdir}/modules.d/52fdo dracut/52fdo/module-setup.sh
|
install -D -m 0755 -t %{buildroot}%{dracutlibdir}/modules.d/52fdo dracut/52fdo/module-setup.sh
|
||||||
install -D -m 0755 -t %{buildroot}%{dracutlibdir}/modules.d/52fdo dracut/52fdo/manufacturing-client-generator
|
install -D -m 0755 -t %{buildroot}%{dracutlibdir}/modules.d/52fdo dracut/52fdo/manufacturing-client-generator
|
||||||
install -D -m 0755 -t %{buildroot}%{dracutlibdir}/modules.d/52fdo dracut/52fdo/manufacturing-client-service
|
install -D -m 0755 -t %{buildroot}%{dracutlibdir}/modules.d/52fdo dracut/52fdo/manufacturing-client-service
|
||||||
@ -128,7 +146,7 @@ Summary: FDO Rendezvous Server implementation
|
|||||||
%files -n fdo-rendezvous-server
|
%files -n fdo-rendezvous-server
|
||||||
%license LICENSE
|
%license LICENSE
|
||||||
%{_libexecdir}/fdo/fdo-rendezvous-server
|
%{_libexecdir}/fdo/fdo-rendezvous-server
|
||||||
%{_docdir}/fdo/rendezvous-server.yml
|
%{_docdir}/fdo/rendezvous-*.yml
|
||||||
%{_unitdir}/fdo-rendezvous-server.service
|
%{_unitdir}/fdo-rendezvous-server.service
|
||||||
|
|
||||||
%post -n fdo-rendezvous-server
|
%post -n fdo-rendezvous-server
|
||||||
@ -222,6 +240,16 @@ Requires: fdo-owner-cli
|
|||||||
%systemd_postun_with_restart fdo-aio.service
|
%systemd_postun_with_restart fdo-aio.service
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Feb 20 2023 Peter Robinson <pbrobinson@fedoraproject.org> - 0.4.7-3
|
||||||
|
- Fix services start
|
||||||
|
|
||||||
|
* Wed Feb 15 2023 Peter Robinson <pbrobinson@fedoraproject.org> - 0.4.7-2
|
||||||
|
- Upstream fix for rhbz#2168089
|
||||||
|
|
||||||
|
* Wed Nov 30 2022 Peter Robinson <pbrobinson@fedoraproject.org> - 0.4.7-1
|
||||||
|
- Update to 0.4.7
|
||||||
|
- Package updates and cleanup
|
||||||
|
|
||||||
* Tue Mar 29 2022 Antonio Murdaca <runcom@linux.com> - 0.4.5-1
|
* Tue Mar 29 2022 Antonio Murdaca <runcom@linux.com> - 0.4.5-1
|
||||||
- bump to 0.4.5
|
- bump to 0.4.5
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user