import fido-device-onboard-0.4.0-1.el9
This commit is contained in:
parent
353c8f682b
commit
93ccfb5ee5
@ -1,2 +1,2 @@
|
|||||||
35944215160d00af8d8553bd85bd9bf7c6129e8b SOURCES/fido-device-onboard-rs-0.3.0-vendor-patched.tar.gz
|
49d6a159dc3e0b2369ffb6ac11bcf41a2c773ac9 SOURCES/fido-device-onboard-rs-0.4.0-vendor-patched.tar.gz
|
||||||
a1e98d6d0b85fd3f2ab81d9c6179e2cfc5e30d4f SOURCES/fido-device-onboard-rs-0.3.0.tar.gz
|
a8e4a64065bf7ae103a6bb903c6884a01f07bffb SOURCES/fido-device-onboard-rs-0.4.0.tar.gz
|
||||||
|
4
.gitignore
vendored
4
.gitignore
vendored
@ -1,2 +1,2 @@
|
|||||||
SOURCES/fido-device-onboard-rs-0.3.0-vendor-patched.tar.gz
|
SOURCES/fido-device-onboard-rs-0.4.0-vendor-patched.tar.gz
|
||||||
SOURCES/fido-device-onboard-rs-0.3.0.tar.gz
|
SOURCES/fido-device-onboard-rs-0.4.0.tar.gz
|
||||||
|
10
SOURCES/debug-profile.patch
Normal file
10
SOURCES/debug-profile.patch
Normal file
@ -0,0 +1,10 @@
|
|||||||
|
diff --color -ru fido-device-onboard-rs-0.4.0-orig/Cargo.toml fido-device-onboard-rs-0.4.0/Cargo.toml
|
||||||
|
--- fido-device-onboard-rs-0.4.0-orig/Cargo.toml 2022-02-24 20:44:38.000000000 +0100
|
||||||
|
+++ fido-device-onboard-rs-0.4.0/Cargo.toml 2022-02-24 21:53:32.785864178 +0100
|
||||||
|
@@ -17,3 +17,6 @@
|
||||||
|
"serviceinfo-api-dev-server",
|
||||||
|
"integration-tests",
|
||||||
|
]
|
||||||
|
+
|
||||||
|
+[profile.release]
|
||||||
|
+debug = true
|
@ -1,37 +0,0 @@
|
|||||||
diff --color -urN fido-device-onboard-rs-0.3.0-orig/Cargo.toml fido-device-onboard-rs-0.3.0/Cargo.toml
|
|
||||||
--- fido-device-onboard-rs-0.3.0-orig/Cargo.toml 2022-02-01 14:59:46.000000000 +0100
|
|
||||||
+++ fido-device-onboard-rs-0.3.0/Cargo.toml 2022-02-01 18:17:45.773515653 +0100
|
|
||||||
@@ -15,3 +15,7 @@
|
|
||||||
|
|
||||||
"integration-tests",
|
|
||||||
]
|
|
||||||
+
|
|
||||||
+[profile.release]
|
|
||||||
+debug = true
|
|
||||||
+
|
|
||||||
diff --color -urN fido-device-onboard-rs-0.3.0-orig/examples/systemd/fdo-client-linuxapp.service fido-device-onboard-rs-0.3.0/examples/systemd/fdo-client-linuxapp.service
|
|
||||||
--- fido-device-onboard-rs-0.3.0-orig/examples/systemd/fdo-client-linuxapp.service 2022-02-01 14:59:46.000000000 +0100
|
|
||||||
+++ fido-device-onboard-rs-0.3.0/examples/systemd/fdo-client-linuxapp.service 2022-02-01 17:06:50.581272078 +0100
|
|
||||||
@@ -5,6 +5,7 @@
|
|
||||||
[Service]
|
|
||||||
Type=oneshot
|
|
||||||
EnvironmentFile=-/boot/fdo-client-env
|
|
||||||
+Environment=ALLOW_NONINTEROPERABLE_KDF=1
|
|
||||||
Environment=LOG_LEVEL=info
|
|
||||||
ExecStart=/usr/libexec/fdo/fdo-client-linuxapp
|
|
||||||
ExecStartPost=-/usr/bin/mv /boot/device-credentials /etc/device-credentials
|
|
||||||
diff --color -urN fido-device-onboard-rs-0.3.0-orig/examples/systemd/fdo-owner-onboarding-server.service fido-device-onboard-rs-0.3.0/examples/systemd/fdo-owner-onboarding-server.service
|
|
||||||
--- fido-device-onboard-rs-0.3.0-orig/examples/systemd/fdo-owner-onboarding-server.service 2022-02-01 14:59:46.000000000 +0100
|
|
||||||
+++ fido-device-onboard-rs-0.3.0/examples/systemd/fdo-owner-onboarding-server.service 2022-02-01 17:06:42.983274923 +0100
|
|
||||||
@@ -4,8 +4,9 @@
|
|
||||||
|
|
||||||
[Service]
|
|
||||||
Environment=LOG_LEVEL=info
|
|
||||||
+Environment=ALLOW_NONINTEROPERABLE_KDF=1
|
|
||||||
ExecStart=/usr/libexec/fdo/fdo-owner-onboarding-server
|
|
||||||
# restart and failure condition
|
|
||||||
|
|
||||||
[Install]
|
|
||||||
-WantedBy=multi-user.target
|
|
||||||
\ No newline at end of file
|
|
||||||
+WantedBy=multi-user.target
|
|
@ -4,7 +4,7 @@
|
|||||||
%global __cargo_is_lib() false
|
%global __cargo_is_lib() false
|
||||||
%global forgeurl https://github.com/fedora-iot/fido-device-onboard-rs
|
%global forgeurl https://github.com/fedora-iot/fido-device-onboard-rs
|
||||||
|
|
||||||
Version: 0.3.0
|
Version: 0.4.0
|
||||||
|
|
||||||
%forgemeta
|
%forgemeta
|
||||||
|
|
||||||
@ -21,7 +21,7 @@ Source1: %{name}-rs-%{commit}-vendor-patched.tar.gz
|
|||||||
Source1: %{name}-rs-%{version}-vendor-patched.tar.gz
|
Source1: %{name}-rs-%{version}-vendor-patched.tar.gz
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
Patch0: kdf.patch
|
Patch0: debug-profile.patch
|
||||||
|
|
||||||
ExclusiveArch: %{rust_arches}
|
ExclusiveArch: %{rust_arches}
|
||||||
# RHBZ 1869980
|
# RHBZ 1869980
|
||||||
@ -35,6 +35,7 @@ BuildRequires: rust-packaging
|
|||||||
BuildRequires: systemd-rpm-macros
|
BuildRequires: systemd-rpm-macros
|
||||||
BuildRequires: openssl-devel
|
BuildRequires: openssl-devel
|
||||||
BuildRequires: golang
|
BuildRequires: golang
|
||||||
|
BuildRequires: tpm2-tss-devel
|
||||||
|
|
||||||
%description
|
%description
|
||||||
%{summary}.
|
%{summary}.
|
||||||
@ -56,7 +57,7 @@ EOF
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%{__cargo} build --release --features openssl-kdf/deny_custom,fdo-data-formats/use_noninteroperable_kdf
|
%{__cargo} build --release --features openssl-kdf/deny_custom
|
||||||
|
|
||||||
%install
|
%install
|
||||||
install -D -m 0755 -t %{buildroot}%{_libexecdir}/fdo target/release/fdo-client-linuxapp
|
install -D -m 0755 -t %{buildroot}%{_libexecdir}/fdo target/release/fdo-client-linuxapp
|
||||||
@ -65,6 +66,7 @@ install -D -m 0755 -t %{buildroot}%{_libexecdir}/fdo target/release/fdo-manufact
|
|||||||
install -D -m 0755 -t %{buildroot}%{_libexecdir}/fdo target/release/fdo-owner-onboarding-server
|
install -D -m 0755 -t %{buildroot}%{_libexecdir}/fdo target/release/fdo-owner-onboarding-server
|
||||||
install -D -m 0755 -t %{buildroot}%{_libexecdir}/fdo target/release/fdo-rendezvous-server
|
install -D -m 0755 -t %{buildroot}%{_libexecdir}/fdo target/release/fdo-rendezvous-server
|
||||||
install -D -m 0755 -t %{buildroot}%{_bindir} target/release/fdo-owner-tool
|
install -D -m 0755 -t %{buildroot}%{_bindir} target/release/fdo-owner-tool
|
||||||
|
install -D -m 0755 -t %{buildroot}%{_bindir} target/release/fdo-admin-tool
|
||||||
install -D -m 0644 -t %{buildroot}%{_unitdir} examples/systemd/*
|
install -D -m 0644 -t %{buildroot}%{_unitdir} examples/systemd/*
|
||||||
install -D -m 0644 -t %{buildroot}%{_docdir}/fdo examples/config/*
|
install -D -m 0644 -t %{buildroot}%{_docdir}/fdo examples/config/*
|
||||||
# 52fdo
|
# 52fdo
|
||||||
@ -75,6 +77,7 @@ install -D -m 0755 -t %{buildroot}%{dracutlibdir}/modules.d/52fdo dracut/52fdo/m
|
|||||||
|
|
||||||
%package -n fdo-init
|
%package -n fdo-init
|
||||||
Summary: dracut module for device initialization
|
Summary: dracut module for device initialization
|
||||||
|
Requires: openssl-devel >= 3.0.1-12
|
||||||
%description -n fdo-init
|
%description -n fdo-init
|
||||||
%{summary}
|
%{summary}
|
||||||
|
|
||||||
@ -85,6 +88,7 @@ Summary: dracut module for device initialization
|
|||||||
|
|
||||||
%package -n fdo-owner-onboarding-server
|
%package -n fdo-owner-onboarding-server
|
||||||
Summary: FDO Owner Onboarding Server implementation
|
Summary: FDO Owner Onboarding Server implementation
|
||||||
|
Requires: openssl-devel >= 3.0.1-12
|
||||||
%description -n fdo-owner-onboarding-server
|
%description -n fdo-owner-onboarding-server
|
||||||
%{summary}
|
%{summary}
|
||||||
|
|
||||||
@ -125,6 +129,7 @@ Summary: FDO Rendezvous Server implementation
|
|||||||
|
|
||||||
%package -n fdo-manufacturing-server
|
%package -n fdo-manufacturing-server
|
||||||
Summary: FDO Manufacturing Server implementation
|
Summary: FDO Manufacturing Server implementation
|
||||||
|
Requires: openssl-devel >= 3.0.1-12
|
||||||
%description -n fdo-manufacturing-server
|
%description -n fdo-manufacturing-server
|
||||||
%{summary}
|
%{summary}
|
||||||
|
|
||||||
@ -132,7 +137,6 @@ Summary: FDO Manufacturing Server implementation
|
|||||||
%license LICENSE
|
%license LICENSE
|
||||||
%{_libexecdir}/fdo/fdo-manufacturing-server
|
%{_libexecdir}/fdo/fdo-manufacturing-server
|
||||||
%{_docdir}/fdo/manufacturing-server.yml
|
%{_docdir}/fdo/manufacturing-server.yml
|
||||||
%{_docdir}/fdo/rendezvous-info.yml
|
|
||||||
%{_unitdir}/fdo-manufacturing-server.service
|
%{_unitdir}/fdo-manufacturing-server.service
|
||||||
|
|
||||||
%post -n fdo-manufacturing-server
|
%post -n fdo-manufacturing-server
|
||||||
@ -146,6 +150,7 @@ Summary: FDO Manufacturing Server implementation
|
|||||||
|
|
||||||
%package -n fdo-client
|
%package -n fdo-client
|
||||||
Summary: FDO Client implementation
|
Summary: FDO Client implementation
|
||||||
|
Requires: openssl-devel >= 3.0.1-12
|
||||||
%description -n fdo-client
|
%description -n fdo-client
|
||||||
%{summary}
|
%{summary}
|
||||||
|
|
||||||
@ -165,15 +170,27 @@ Summary: FDO Client implementation
|
|||||||
|
|
||||||
%package -n fdo-owner-cli
|
%package -n fdo-owner-cli
|
||||||
Summary: FDO Owner tools implementation
|
Summary: FDO Owner tools implementation
|
||||||
|
Requires: openssl-devel >= 3.0.1-12
|
||||||
%description -n fdo-owner-cli
|
%description -n fdo-owner-cli
|
||||||
%{summary}
|
%{summary}
|
||||||
|
|
||||||
%files -n fdo-owner-cli
|
%files -n fdo-owner-cli
|
||||||
%license LICENSE
|
%license LICENSE
|
||||||
%{_bindir}/fdo-owner-tool
|
%{_bindir}/fdo-owner-tool
|
||||||
%{_docdir}/fdo/owner-addresses.yml
|
|
||||||
|
%package -n fdo-admin-cli
|
||||||
|
Summary: FDO admin tools implementation
|
||||||
|
%description -n fdo-admin-cli
|
||||||
|
%{summary}
|
||||||
|
|
||||||
|
%files -n fdo-admin-cli
|
||||||
|
%license LICENSE
|
||||||
|
%{_bindir}/fdo-admin-tool
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Feb 24 2022 Antonio Murdaca <runcom@linux.com> - 0.4.0-1
|
||||||
|
- upgrade to 0.4.0
|
||||||
|
|
||||||
* Tue Feb 01 2022 Antonio Murdaca <runcom@linux.com> - 0.3.0-1
|
* Tue Feb 01 2022 Antonio Murdaca <runcom@linux.com> - 0.3.0-1
|
||||||
- bump to 0.3.0
|
- bump to 0.3.0
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user