import fido-device-onboard-0.4.5-1.el9_0
This commit is contained in:
parent
93ccfb5ee5
commit
899af0feea
@ -1,2 +1,2 @@
|
|||||||
49d6a159dc3e0b2369ffb6ac11bcf41a2c773ac9 SOURCES/fido-device-onboard-rs-0.4.0-vendor-patched.tar.gz
|
f89779ff4421530aa4f51ebe1eaa81858ec4b1f5 SOURCES/fido-device-onboard-rs-0.4.5-vendor-patched.tar.gz
|
||||||
a8e4a64065bf7ae103a6bb903c6884a01f07bffb SOURCES/fido-device-onboard-rs-0.4.0.tar.gz
|
2bccb11a53358c1464e00d9a2b41251d793651d0 SOURCES/fido-device-onboard-rs-0.4.5.tar.gz
|
||||||
|
4
.gitignore
vendored
4
.gitignore
vendored
@ -1,2 +1,2 @@
|
|||||||
SOURCES/fido-device-onboard-rs-0.4.0-vendor-patched.tar.gz
|
SOURCES/fido-device-onboard-rs-0.4.5-vendor-patched.tar.gz
|
||||||
SOURCES/fido-device-onboard-rs-0.4.0.tar.gz
|
SOURCES/fido-device-onboard-rs-0.4.5.tar.gz
|
||||||
|
@ -1,8 +1,8 @@
|
|||||||
diff --color -ru fido-device-onboard-rs-0.4.0-orig/Cargo.toml fido-device-onboard-rs-0.4.0/Cargo.toml
|
diff --color -ru fido-device-onboard-rs-b52cd2912bc646779e290300fc27fa59f3264535-orig/Cargo.toml fido-device-onboard-rs-b52cd2912bc646779e290300fc27fa59f3264535/Cargo.toml
|
||||||
--- fido-device-onboard-rs-0.4.0-orig/Cargo.toml 2022-02-24 20:44:38.000000000 +0100
|
--- fido-device-onboard-rs-b52cd2912bc646779e290300fc27fa59f3264535-orig/Cargo.toml 2022-03-17 16:38:49.000000000 +0100
|
||||||
+++ fido-device-onboard-rs-0.4.0/Cargo.toml 2022-02-24 21:53:32.785864178 +0100
|
+++ fido-device-onboard-rs-b52cd2912bc646779e290300fc27fa59f3264535/Cargo.toml 2022-03-28 12:03:59.101029855 +0200
|
||||||
@@ -17,3 +17,6 @@
|
@@ -17,3 +17,6 @@
|
||||||
"serviceinfo-api-dev-server",
|
|
||||||
"integration-tests",
|
"integration-tests",
|
||||||
]
|
]
|
||||||
+
|
+
|
||||||
|
@ -4,7 +4,7 @@
|
|||||||
%global __cargo_is_lib() false
|
%global __cargo_is_lib() false
|
||||||
%global forgeurl https://github.com/fedora-iot/fido-device-onboard-rs
|
%global forgeurl https://github.com/fedora-iot/fido-device-onboard-rs
|
||||||
|
|
||||||
Version: 0.4.0
|
Version: 0.4.5
|
||||||
|
|
||||||
%forgemeta
|
%forgemeta
|
||||||
|
|
||||||
@ -33,9 +33,11 @@ BuildRequires: rust-toolset
|
|||||||
BuildRequires: rust-packaging
|
BuildRequires: rust-packaging
|
||||||
%endif
|
%endif
|
||||||
BuildRequires: systemd-rpm-macros
|
BuildRequires: systemd-rpm-macros
|
||||||
BuildRequires: openssl-devel
|
BuildRequires: openssl-devel >= 3.0.1-12
|
||||||
BuildRequires: golang
|
BuildRequires: golang
|
||||||
BuildRequires: tpm2-tss-devel
|
BuildRequires: tpm2-tss-devel
|
||||||
|
BuildRequires: cryptsetup-devel
|
||||||
|
BuildRequires: clang-devel
|
||||||
|
|
||||||
%description
|
%description
|
||||||
%{summary}.
|
%{summary}.
|
||||||
@ -65,10 +67,15 @@ install -D -m 0755 -t %{buildroot}%{_libexecdir}/fdo target/release/fdo-manufact
|
|||||||
install -D -m 0755 -t %{buildroot}%{_libexecdir}/fdo target/release/fdo-manufacturing-server
|
install -D -m 0755 -t %{buildroot}%{_libexecdir}/fdo target/release/fdo-manufacturing-server
|
||||||
install -D -m 0755 -t %{buildroot}%{_libexecdir}/fdo target/release/fdo-owner-onboarding-server
|
install -D -m 0755 -t %{buildroot}%{_libexecdir}/fdo target/release/fdo-owner-onboarding-server
|
||||||
install -D -m 0755 -t %{buildroot}%{_libexecdir}/fdo target/release/fdo-rendezvous-server
|
install -D -m 0755 -t %{buildroot}%{_libexecdir}/fdo target/release/fdo-rendezvous-server
|
||||||
|
install -D -m 0755 -t %{buildroot}%{_libexecdir}/fdo target/release/fdo-serviceinfo-api-server
|
||||||
|
# duplicates as needed by AIO command
|
||||||
|
install -D -m 0755 -t %{buildroot}%{_libexecdir}/fdo target/release/fdo-owner-tool
|
||||||
|
install -D -m 0755 -t %{buildroot}%{_libexecdir}/fdo target/release/fdo-admin-tool
|
||||||
install -D -m 0755 -t %{buildroot}%{_bindir} target/release/fdo-owner-tool
|
install -D -m 0755 -t %{buildroot}%{_bindir} target/release/fdo-owner-tool
|
||||||
install -D -m 0755 -t %{buildroot}%{_bindir} target/release/fdo-admin-tool
|
install -D -m 0755 -t %{buildroot}%{_bindir} target/release/fdo-admin-tool
|
||||||
install -D -m 0644 -t %{buildroot}%{_unitdir} examples/systemd/*
|
install -D -m 0644 -t %{buildroot}%{_unitdir} examples/systemd/*
|
||||||
install -D -m 0644 -t %{buildroot}%{_docdir}/fdo examples/config/*
|
install -D -m 0644 -t %{buildroot}%{_docdir}/fdo examples/config/*
|
||||||
|
mkdir -p %{buildroot}%{_sysconfdir}/fdo
|
||||||
# 52fdo
|
# 52fdo
|
||||||
install -D -m 0755 -t %{buildroot}%{dracutlibdir}/modules.d/52fdo dracut/52fdo/module-setup.sh
|
install -D -m 0755 -t %{buildroot}%{dracutlibdir}/modules.d/52fdo dracut/52fdo/module-setup.sh
|
||||||
install -D -m 0755 -t %{buildroot}%{dracutlibdir}/modules.d/52fdo dracut/52fdo/manufacturing-client-generator
|
install -D -m 0755 -t %{buildroot}%{dracutlibdir}/modules.d/52fdo dracut/52fdo/manufacturing-client-generator
|
||||||
@ -77,7 +84,7 @@ install -D -m 0755 -t %{buildroot}%{dracutlibdir}/modules.d/52fdo dracut/52fdo/m
|
|||||||
|
|
||||||
%package -n fdo-init
|
%package -n fdo-init
|
||||||
Summary: dracut module for device initialization
|
Summary: dracut module for device initialization
|
||||||
Requires: openssl-devel >= 3.0.1-12
|
Requires: openssl-libs >= 3.0.1-12
|
||||||
%description -n fdo-init
|
%description -n fdo-init
|
||||||
%{summary}
|
%{summary}
|
||||||
|
|
||||||
@ -88,24 +95,30 @@ Requires: openssl-devel >= 3.0.1-12
|
|||||||
|
|
||||||
%package -n fdo-owner-onboarding-server
|
%package -n fdo-owner-onboarding-server
|
||||||
Summary: FDO Owner Onboarding Server implementation
|
Summary: FDO Owner Onboarding Server implementation
|
||||||
Requires: openssl-devel >= 3.0.1-12
|
Requires: openssl-libs >= 3.0.1-12
|
||||||
%description -n fdo-owner-onboarding-server
|
%description -n fdo-owner-onboarding-server
|
||||||
%{summary}
|
%{summary}
|
||||||
|
|
||||||
%files -n fdo-owner-onboarding-server
|
%files -n fdo-owner-onboarding-server
|
||||||
%license LICENSE
|
%license LICENSE
|
||||||
%{_libexecdir}/fdo/fdo-owner-onboarding-server
|
%{_libexecdir}/fdo/fdo-owner-onboarding-server
|
||||||
|
%{_libexecdir}/fdo/fdo-serviceinfo-api-server
|
||||||
|
%{_docdir}/fdo/serviceinfo-api-server.yml
|
||||||
|
%{_unitdir}/fdo-serviceinfo-api-server.service
|
||||||
%{_docdir}/fdo/owner-onboarding-server.yml
|
%{_docdir}/fdo/owner-onboarding-server.yml
|
||||||
%{_unitdir}/fdo-owner-onboarding-server.service
|
%{_unitdir}/fdo-owner-onboarding-server.service
|
||||||
|
|
||||||
%post -n fdo-owner-onboarding-server
|
%post -n fdo-owner-onboarding-server
|
||||||
%systemd_post fdo-owner-onboarding-server.service
|
%systemd_post fdo-owner-onboarding-server.service
|
||||||
|
%systemd_post fdo-serviceinfo-api-server.service
|
||||||
|
|
||||||
%preun -n fdo-owner-onboarding-server
|
%preun -n fdo-owner-onboarding-server
|
||||||
%systemd_preun fdo-owner-onboarding-server.service
|
%systemd_preun fdo-owner-onboarding-server.service
|
||||||
|
%systemd_post fdo-serviceinfo-api-server.service
|
||||||
|
|
||||||
%postun -n fdo-owner-onboarding-server
|
%postun -n fdo-owner-onboarding-server
|
||||||
%systemd_postun_with_restart fdo-owner-onboarding-server.service
|
%systemd_postun_with_restart fdo-owner-onboarding-server.service
|
||||||
|
%systemd_postun_with_restart fdo-serviceinfo-api-server.service
|
||||||
|
|
||||||
%package -n fdo-rendezvous-server
|
%package -n fdo-rendezvous-server
|
||||||
Summary: FDO Rendezvous Server implementation
|
Summary: FDO Rendezvous Server implementation
|
||||||
@ -129,7 +142,7 @@ Summary: FDO Rendezvous Server implementation
|
|||||||
|
|
||||||
%package -n fdo-manufacturing-server
|
%package -n fdo-manufacturing-server
|
||||||
Summary: FDO Manufacturing Server implementation
|
Summary: FDO Manufacturing Server implementation
|
||||||
Requires: openssl-devel >= 3.0.1-12
|
Requires: openssl-libs >= 3.0.1-12
|
||||||
%description -n fdo-manufacturing-server
|
%description -n fdo-manufacturing-server
|
||||||
%{summary}
|
%{summary}
|
||||||
|
|
||||||
@ -150,7 +163,10 @@ Requires: openssl-devel >= 3.0.1-12
|
|||||||
|
|
||||||
%package -n fdo-client
|
%package -n fdo-client
|
||||||
Summary: FDO Client implementation
|
Summary: FDO Client implementation
|
||||||
Requires: openssl-devel >= 3.0.1-12
|
Requires: openssl-libs >= 3.0.1-12
|
||||||
|
Requires: clevis
|
||||||
|
Requires: clevis-luks
|
||||||
|
Requires: cryptsetup
|
||||||
%description -n fdo-client
|
%description -n fdo-client
|
||||||
%{summary}
|
%{summary}
|
||||||
|
|
||||||
@ -166,28 +182,52 @@ Requires: openssl-devel >= 3.0.1-12
|
|||||||
%systemd_preun fdo-client-linuxapp.service
|
%systemd_preun fdo-client-linuxapp.service
|
||||||
|
|
||||||
%postun -n fdo-client
|
%postun -n fdo-client
|
||||||
%systemd_postun_with_restart fdo-client.linuxapp.service
|
%systemd_postun_with_restart fdo-client-linuxapp.service
|
||||||
|
|
||||||
%package -n fdo-owner-cli
|
%package -n fdo-owner-cli
|
||||||
Summary: FDO Owner tools implementation
|
Summary: FDO Owner tools implementation
|
||||||
Requires: openssl-devel >= 3.0.1-12
|
|
||||||
%description -n fdo-owner-cli
|
%description -n fdo-owner-cli
|
||||||
%{summary}
|
%{summary}
|
||||||
|
|
||||||
%files -n fdo-owner-cli
|
%files -n fdo-owner-cli
|
||||||
%license LICENSE
|
%license LICENSE
|
||||||
%{_bindir}/fdo-owner-tool
|
%{_bindir}/fdo-owner-tool
|
||||||
|
%{_libexecdir}/fdo/fdo-owner-tool
|
||||||
|
|
||||||
%package -n fdo-admin-cli
|
%package -n fdo-admin-cli
|
||||||
Summary: FDO admin tools implementation
|
Summary: FDO admin tools implementation
|
||||||
|
Requires: fdo-manufacturing-server
|
||||||
|
Requires: fdo-init
|
||||||
|
Requires: fdo-client
|
||||||
|
Requires: fdo-rendezvous-server
|
||||||
|
Requires: fdo-owner-onboarding-server
|
||||||
|
Requires: fdo-owner-cli
|
||||||
%description -n fdo-admin-cli
|
%description -n fdo-admin-cli
|
||||||
%{summary}
|
%{summary}
|
||||||
|
|
||||||
%files -n fdo-admin-cli
|
%files -n fdo-admin-cli
|
||||||
%license LICENSE
|
%license LICENSE
|
||||||
%{_bindir}/fdo-admin-tool
|
%{_bindir}/fdo-admin-tool
|
||||||
|
%{_libexecdir}/fdo/fdo-admin-tool
|
||||||
|
%{_unitdir}/fdo-aio.service
|
||||||
|
%dir %{_sysconfdir}/fdo
|
||||||
|
|
||||||
|
%post -n fdo-admin-cli
|
||||||
|
%systemd_post fdo-aio.service
|
||||||
|
|
||||||
|
%preun -n fdo-admin-cli
|
||||||
|
%systemd_preun fdo-aio.service
|
||||||
|
|
||||||
|
%postun -n fdo-admin-cli
|
||||||
|
%systemd_postun_with_restart fdo-aio.service
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Mar 29 2022 Antonio Murdaca <runcom@linux.com> - 0.4.5-1
|
||||||
|
- bump to 0.4.5
|
||||||
|
|
||||||
|
* Mon Feb 28 2022 Antonio Murdaca <runcom@linux.com> - 0.4.0-2
|
||||||
|
- fix runtime requirements to use openssl-libs and not -devel
|
||||||
|
|
||||||
* Thu Feb 24 2022 Antonio Murdaca <runcom@linux.com> - 0.4.0-1
|
* Thu Feb 24 2022 Antonio Murdaca <runcom@linux.com> - 0.4.0-1
|
||||||
- upgrade to 0.4.0
|
- upgrade to 0.4.0
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user