Update to 0.5.1
Resolves: RHEL-65521 Signed-off-by: Antonio Murdaca <amurdaca@redhat.com>
This commit is contained in:
parent
0b085d408e
commit
3eb02a3932
@ -0,0 +1,40 @@
|
||||
From f1b53d4bdac4ab889eb084111f395d418945ed07 Mon Sep 17 00:00:00 2001
|
||||
From: Antonio Murdaca <amurdaca@redhat.com>
|
||||
Date: Mon, 25 Nov 2024 12:30:52 +0100
|
||||
Subject: [PATCH] Revert "chore: use git fork for aws-nitro-enclaves-cose"
|
||||
|
||||
This reverts commit 1ea09e88baee3c47cdc76902f0034d553207d515.
|
||||
---
|
||||
data-formats/Cargo.toml | 2 +-
|
||||
http-wrapper/Cargo.toml | 2 +-
|
||||
2 files changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/data-formats/Cargo.toml b/data-formats/Cargo.toml
|
||||
index 83979e1..c8ae80f 100644
|
||||
--- a/data-formats/Cargo.toml
|
||||
+++ b/data-formats/Cargo.toml
|
||||
@@ -17,7 +17,7 @@ serde_cbor = "0.11"
|
||||
serde_repr = "0.1.6"
|
||||
serde_tuple = "0.5"
|
||||
thiserror = "1"
|
||||
-aws-nitro-enclaves-cose = { git = "https://github.com/nullr0ute/aws-nitro-enclaves-cose/", rev = "e3938e60d9051690569d1e4fcbe1c0c99d2fafa8" }
|
||||
+aws-nitro-enclaves-cose = "0.4.0"
|
||||
uuid = "1.3"
|
||||
num-traits = "0.2"
|
||||
num-derive = "0.3"
|
||||
diff --git a/http-wrapper/Cargo.toml b/http-wrapper/Cargo.toml
|
||||
index 0decb0c..70fcf41 100644
|
||||
--- a/http-wrapper/Cargo.toml
|
||||
+++ b/http-wrapper/Cargo.toml
|
||||
@@ -20,7 +20,7 @@ openssl = "0.10.66"
|
||||
|
||||
fdo-data-formats = { path = "../data-formats", version = "0.5.1" }
|
||||
fdo-store = { path = "../store", version = "0.5.1" }
|
||||
-aws-nitro-enclaves-cose = { git = "https://github.com/nullr0ute/aws-nitro-enclaves-cose/", rev = "e3938e60d9051690569d1e4fcbe1c0c99d2fafa8" }
|
||||
+aws-nitro-enclaves-cose = "0.4.0"
|
||||
|
||||
# Server-side
|
||||
uuid = { version = "1.3", features = ["v4"], optional = true }
|
||||
--
|
||||
2.47.0
|
||||
|
@ -1,30 +0,0 @@
|
||||
From 8899817ceff3371649ed87b700fb81490fb258c8 Mon Sep 17 00:00:00 2001
|
||||
From: Peter Robinson <pbrobinson@gmail.com>
|
||||
Date: Thu, 27 Jul 2023 10:36:58 +0100
|
||||
Subject: [PATCH] fix: drop unused sha-crypt dep
|
||||
|
||||
The use of sha-crypt was dropped with commit 8d1d1b2 but one of the
|
||||
Cargo.toml updates was missed so drop it there and update Cargo.lock
|
||||
to match.
|
||||
|
||||
Fixes: 8d1d1b2 ("chore: replace sha-crypt with openssl process calls")
|
||||
Signed-off-by: Peter Robinson <pbrobinson@gmail.com>
|
||||
---
|
||||
integration-tests/Cargo.toml | 3 +--
|
||||
2 files changed, 1 insertion(+), 21 deletions(-)
|
||||
|
||||
diff --git a/integration-tests/Cargo.toml b/integration-tests/Cargo.toml
|
||||
index 451bc3f..e3b87a9 100644
|
||||
--- a/integration-tests/Cargo.toml
|
||||
+++ b/integration-tests/Cargo.toml
|
||||
@@ -35,7 +35,6 @@
|
||||
passwd = "0.0.1"
|
||||
pem = "2.0"
|
||||
users = "0.11.0"
|
||||
-sha-crypt = "0.5.0"
|
||||
|
||||
fdo-data-formats = { path = "../data-formats" }
|
||||
fdo-util = { path = "../util" }
|
||||
--
|
||||
2.41.0
|
||||
|
@ -1,25 +0,0 @@
|
||||
From adb1d1055f85ae48b58252ca36ce00d861a27358 Mon Sep 17 00:00:00 2001
|
||||
From: Antonio Murdaca <antoniomurdaca@gmail.com>
|
||||
Date: Tue, 15 Aug 2023 16:29:53 +0200
|
||||
Subject: [PATCH] fix: relabel devcreds before onboarding
|
||||
|
||||
Signed-off-by: Antonio Murdaca <antoniomurdaca@gmail.com>
|
||||
---
|
||||
examples/systemd/fdo-client-linuxapp.service | 1 +
|
||||
1 file changed, 1 insertion(+)
|
||||
|
||||
diff --git a/examples/systemd/fdo-client-linuxapp.service b/examples/systemd/fdo-client-linuxapp.service
|
||||
index acfdc79..c0b3090 100644
|
||||
--- a/examples/systemd/fdo-client-linuxapp.service
|
||||
+++ b/examples/systemd/fdo-client-linuxapp.service
|
||||
@@ -6,6 +6,7 @@ After=network-online.target
|
||||
Type=oneshot
|
||||
EnvironmentFile=-/boot/fdo-client-env
|
||||
Environment=LOG_LEVEL=info
|
||||
+ExecStartPre=-/usr/sbin/restorecon /boot/device-credentials
|
||||
ExecStart=/usr/libexec/fdo/fdo-client-linuxapp
|
||||
ExecStartPost=-/usr/bin/mv /boot/device-credentials /etc/device-credentials
|
||||
|
||||
--
|
||||
2.41.0
|
||||
|
@ -1,68 +0,0 @@
|
||||
From 309c07aa5d43b3d126ccac640901f22afcc25b77 Mon Sep 17 00:00:00 2001
|
||||
From: Peter Robinson <pbrobinson@gmail.com>
|
||||
Date: Thu, 27 Jul 2023 10:21:26 +0100
|
||||
Subject: [PATCH] hack; drop shadow
|
||||
|
||||
Signed-off-by: Peter Robinson <pbrobinson@gmail.com>
|
||||
---
|
||||
integration-tests/Cargo.toml | 3 +--
|
||||
integration-tests/tests/e2e.rs | 7 -------
|
||||
integration-tests/tests/service_info.rs | 7 -------
|
||||
3 files changed, 1 insertion(+), 16 deletions(-)
|
||||
|
||||
diff --git a/integration-tests/Cargo.toml b/integration-tests/Cargo.toml
|
||||
index 451bc3f..3e19ebb 100644
|
||||
--- a/integration-tests/Cargo.toml
|
||||
+++ b/integration-tests/Cargo.toml
|
||||
@@ -33,10 +33,9 @@ serde_json = "1.0"
|
||||
pretty_assertions = "1.0.0"
|
||||
paste = "1.0"
|
||||
passwd = "0.0.1"
|
||||
-shadow = "0.0.1"
|
||||
pem = "2.0"
|
||||
users = "0.11.0"
|
||||
sha-crypt = "0.5.0"
|
||||
|
||||
fdo-data-formats = { path = "../data-formats" }
|
||||
-fdo-util = { path = "../util" }
|
||||
\ No newline at end of file
|
||||
+fdo-util = { path = "../util" }
|
||||
diff --git a/integration-tests/tests/e2e.rs b/integration-tests/tests/e2e.rs
|
||||
index 9857ce0..611fc84 100644
|
||||
--- a/integration-tests/tests/e2e.rs
|
||||
+++ b/integration-tests/tests/e2e.rs
|
||||
@@ -406,13 +406,6 @@ ssh-ed25519 sshkey_default user@example2.com
|
||||
"User: {} is not created during onboarding",
|
||||
&new_user
|
||||
);
|
||||
- if let Some(test_user) = shadow::Shadow::from_name(new_user) {
|
||||
- pretty_assertions::assert_eq!(
|
||||
- test_user.password.is_empty(),
|
||||
- false,
|
||||
- "Password not created during onboarding"
|
||||
- );
|
||||
- }
|
||||
} else {
|
||||
L.l("Skipped create initial user validation
|
||||
To validate set env variable FDO_PRIVILEGED and run test as superuser");
|
||||
diff --git a/integration-tests/tests/service_info.rs b/integration-tests/tests/service_info.rs
|
||||
index 8a346cc..4d05107 100644
|
||||
--- a/integration-tests/tests/service_info.rs
|
||||
+++ b/integration-tests/tests/service_info.rs
|
||||
@@ -285,13 +285,6 @@ ssh-ed25519 sshkey_default user@example2.com
|
||||
"User: {} is not created during onboarding",
|
||||
&new_user
|
||||
);
|
||||
- if let Some(test_user) = shadow::Shadow::from_name(new_user) {
|
||||
- pretty_assertions::assert_eq!(
|
||||
- test_user.password.is_empty(),
|
||||
- false,
|
||||
- "Password not created during onboarding"
|
||||
- );
|
||||
- }
|
||||
} else {
|
||||
L.l("Skipped create initial user validation
|
||||
To validate set env variable FDO_PRIVILEGED and run test as superuser");
|
||||
--
|
||||
2.41.0
|
||||
|
@ -1,46 +0,0 @@
|
||||
From 90bb88a24ddf9292150f7de6eeb2f93b0a793acf Mon Sep 17 00:00:00 2001
|
||||
From: "dependabot[bot]" <49699333+dependabot[bot]@users.noreply.github.com>
|
||||
Date: Fri, 27 Oct 2023 10:52:23 +0000
|
||||
Subject: [PATCH] chore: bump devicemapper from 0.33.5 to 0.34.0
|
||||
|
||||
Bumps [devicemapper](https://github.com/stratis-storage/devicemapper-rs) from 0.33.5 to 0.34.0.
|
||||
- [Release notes](https://github.com/stratis-storage/devicemapper-rs/releases)
|
||||
- [Changelog](https://github.com/stratis-storage/devicemapper-rs/blob/master/CHANGES.txt)
|
||||
- [Commits](https://github.com/stratis-storage/devicemapper-rs/compare/v0.33.5...devicemapper-v0.34.0)
|
||||
|
||||
---
|
||||
updated-dependencies:
|
||||
- dependency-name: devicemapper
|
||||
dependency-type: direct:production
|
||||
update-type: version-update:semver-minor
|
||||
...
|
||||
|
||||
Signed-off-by: dependabot[bot] <support@github.com>
|
||||
---
|
||||
client-linuxapp/Cargo.toml | 2 +-
|
||||
2 files changed, 48 insertions(+), 26 deletions(-)
|
||||
|
||||
diff --git a/client-linuxapp/Cargo.toml b/client-linuxapp/Cargo.toml
|
||||
index ee362913..9df5fe96 100644
|
||||
--- a/client-linuxapp/Cargo.toml
|
||||
+++ b/client-linuxapp/Cargo.toml
|
||||
@@ -18,7 +18,7 @@ uuid = "1.3"
|
||||
thiserror = "1"
|
||||
libcryptsetup-rs = { version = "0.8.0", features = ["mutex"] }
|
||||
secrecy = "0.8"
|
||||
-devicemapper = "0.33"
|
||||
+devicemapper = "0.34"
|
||||
openssl = "0.10.55"
|
||||
|
||||
fdo-data-formats = { path = "../data-formats", version = "0.4.12" }
|
||||
--- fido-device-onboard-rs-0.4.12/client-linuxapp/Cargo.toml.orig 2023-12-03 22:30:29.457047282 +0000
|
||||
+++ fido-device-onboard-rs-0.4.12/client-linuxapp/Cargo.toml 2023-12-03 22:30:36.901090510 +0000
|
||||
@@ -17,7 +17,7 @@
|
||||
nix = "0.26"
|
||||
uuid = "1.3"
|
||||
thiserror = "1"
|
||||
-libcryptsetup-rs = { version = "0.8.0", features = ["mutex"] }
|
||||
+libcryptsetup-rs = { version = "0.9.0", features = ["mutex"] }
|
||||
secrecy = "0.8"
|
||||
devicemapper = "0.34"
|
||||
openssl = "0.10.55"
|
@ -3,22 +3,16 @@
|
||||
%global combined_license Apache-2.0 AND (Apache-2.0 OR BSL-1.0) AND (Apache-2.0 OR ISC OR MIT) AND (Apache-2.0 OR MIT) AND ((Apache-2.0 OR MIT) AND BSD-3-Clause) AND (Apache-2.0 WITH LLVM-exception OR Apache-2.0 OR MIT) AND BSD-2-Clause AND BSD-3-Clause AND (CC0-1.0 OR Apache-2.0) AND (CC0-1.0 OR MIT-0 OR Apache-2.0) AND ISC AND MIT AND ((MIT OR Apache-2.0) AND Unicode-DFS-2016) AND (Apache-2.0 OR MIT OR Zlib) AND MPL-2.0 AND (Unlicense OR MIT)
|
||||
|
||||
Name: fido-device-onboard
|
||||
Version: 0.4.12
|
||||
Release: 14%{?dist}
|
||||
Version: 0.5.1
|
||||
Release: 1%{?dist}
|
||||
Summary: A rust implementation of the FIDO Device Onboard Specification
|
||||
License: BSD-3-Clause
|
||||
|
||||
URL: https://github.com/fedora-iot/fido-device-onboard-rs
|
||||
URL: https://github.com/fdo-rs/fido-device-onboard-rs
|
||||
Source0: %{url}/archive/v%{version}/%{name}-rs-%{version}.tar.gz
|
||||
# See make-vendored-tarfile.sh in upstream repo
|
||||
Source1: %{name}-rs-%{version}-vendor-patched.tar.xz
|
||||
Patch0: 0001-hack-drop-shadow.patch
|
||||
Patch1: 0001-fix-drop-unused-sha-crypt-dep.patch
|
||||
Patch3: 0001-fix-relabel-devcreds-before-onboarding.patch
|
||||
Patch4: fdo-bump-devicemapper-libcryptosetup.patch
|
||||
|
||||
# fixes for vendored dependencies
|
||||
Patch100: fix-aws-nitro-enclaves-cose.patch
|
||||
Patch1: 0001-Revert-chore-use-git-fork-for-aws-nitro-enclaves-cos.patch
|
||||
|
||||
# Because nobody cares
|
||||
ExcludeArch: %{ix86}
|
||||
@ -35,27 +29,26 @@ BuildRequires: golang
|
||||
BuildRequires: openssl-devel >= 3.0.1-12
|
||||
BuildRequires: systemd-rpm-macros
|
||||
BuildRequires: tpm2-tss-devel
|
||||
BuildRequires: sqlite-devel
|
||||
BuildRequires: libpq-devel
|
||||
|
||||
%description
|
||||
%{summary}.
|
||||
|
||||
%prep
|
||||
%setup -q -n %{name}-rs-%{version}
|
||||
%patch -P0 -p1
|
||||
%patch -P1 -p1
|
||||
%patch -P3 -p1
|
||||
%patch -P4 -p1
|
||||
|
||||
%if 0%{?rhel}
|
||||
%autosetup -p1 -a1 -n %{name}-rs-%{version}
|
||||
rm -f Cargo.lock
|
||||
%if 0%{?rhel} >= 10
|
||||
tar xf %{SOURCE1}
|
||||
%cargo_prep -v vendor
|
||||
%else
|
||||
%cargo_prep -V 1
|
||||
%endif
|
||||
# patch vendored dependencies
|
||||
%patch -P100 -p1
|
||||
%else
|
||||
%endif
|
||||
|
||||
%if 0%{?fedora}
|
||||
%autosetup -p1 -n %{name}-rs-%{version}
|
||||
%cargo_prep
|
||||
%generate_buildrequires
|
||||
%cargo_generate_buildrequires -a
|
||||
@ -82,9 +75,17 @@ install -D -m 0755 -t %{buildroot}%{_bindir} target/release/fdo-owner-tool
|
||||
install -D -m 0755 -t %{buildroot}%{_bindir} target/release/fdo-admin-tool
|
||||
install -D -m 0644 -t %{buildroot}%{_unitdir} examples/systemd/*
|
||||
install -D -m 0644 -t %{buildroot}%{_docdir}/fdo examples/config/*
|
||||
# db sql files
|
||||
install -D -m 0644 -t %{buildroot}%{_docdir}/fdo/migrations/migrations_manufacturing_server_postgres migrations/migrations_manufacturing_server_postgres/2023-10-03-152801_create_db/*
|
||||
install -D -m 0644 -t %{buildroot}%{_docdir}/fdo/migrations/migrations_manufacturing_server_sqlite migrations/migrations_manufacturing_server_sqlite/2023-10-03-152801_create_db/*
|
||||
install -D -m 0644 -t %{buildroot}%{_docdir}/fdo/migrations/migrations_owner_onboarding_server_postgres migrations/migrations_owner_onboarding_server_postgres/2023-10-03-152801_create_db/*
|
||||
install -D -m 0644 -t %{buildroot}%{_docdir}/fdo/migrations/migrations_owner_onboarding_server_sqlite migrations/migrations_owner_onboarding_server_sqlite/2023-10-03-152801_create_db/*
|
||||
install -D -m 0644 -t %{buildroot}%{_docdir}/fdo/migrations/migrations_rendezvous_server_postgres migrations/migrations_rendezvous_server_postgres/2023-10-03-152801_create_db/*
|
||||
install -D -m 0644 -t %{buildroot}%{_docdir}/fdo/migrations/migrations_rendezvous_server_sqlite migrations/migrations_rendezvous_server_sqlite/2023-10-03-152801_create_db/*
|
||||
# duplicates as needed by AIO command so link them
|
||||
ln -s %{_bindir}/fdo-owner-tool %{buildroot}%{_libexecdir}/fdo/fdo-owner-tool
|
||||
ln -s %{_bindir}/fdo-admin-tool %{buildroot}%{_libexecdir}/fdo/fdo-admin-tool
|
||||
mkdir -p %{buildroot}%{_bindir}
|
||||
ln -sr %{buildroot}%{_bindir}/fdo-owner-tool %{buildroot}%{_libexecdir}/fdo/fdo-owner-tool
|
||||
ln -sr %{buildroot}%{_bindir}/fdo-admin-tool %{buildroot}%{_libexecdir}/fdo/fdo-admin-tool
|
||||
# Create directories needed by the various services so we own them
|
||||
mkdir -p %{buildroot}%{_sysconfdir}/fdo
|
||||
mkdir -p %{buildroot}%{_sysconfdir}/fdo/keys
|
||||
@ -95,6 +96,7 @@ mkdir -p %{buildroot}%{_sysconfdir}/fdo/stores/owner_onboarding_sessions
|
||||
mkdir -p %{buildroot}%{_sysconfdir}/fdo/stores/owner_vouchers
|
||||
mkdir -p %{buildroot}%{_sysconfdir}/fdo/stores/rendezvous_registered
|
||||
mkdir -p %{buildroot}%{_sysconfdir}/fdo/stores/rendezvous_sessions
|
||||
mkdir -p %{buildroot}%{_sysconfdir}/fdo/stores/serviceinfo_api_devices
|
||||
mkdir -p %{buildroot}%{_sysconfdir}/fdo/manufacturing-server.conf.d
|
||||
mkdir -p %{buildroot}%{_sysconfdir}/fdo/owner-onboarding-server.conf.d
|
||||
mkdir -p %{buildroot}%{_sysconfdir}/fdo/rendezvous-server.conf.d
|
||||
@ -141,6 +143,7 @@ Requires: openssl-libs >= 3.0.1-12
|
||||
%dir %{_sysconfdir}/fdo/stores
|
||||
%dir %{_sysconfdir}/fdo/stores/owner_onboarding_sessions
|
||||
%dir %{_sysconfdir}/fdo/stores/owner_vouchers
|
||||
%dir %{_sysconfdir}/fdo/stores/serviceinfo_api_devices
|
||||
%{_libexecdir}/fdo/fdo-owner-onboarding-server
|
||||
%{_libexecdir}/fdo/fdo-serviceinfo-api-server
|
||||
%dir %{_localstatedir}/lib/fdo
|
||||
@ -148,6 +151,8 @@ Requires: openssl-libs >= 3.0.1-12
|
||||
%{_docdir}/fdo/device_specific_serviceinfo.yml
|
||||
%{_docdir}/fdo/serviceinfo-api-server.yml
|
||||
%{_docdir}/fdo/owner-onboarding-server.yml
|
||||
%{_docdir}/fdo/migrations/migrations_owner_onboarding_server_postgres/*
|
||||
%{_docdir}/fdo/migrations/migrations_owner_onboarding_server_sqlite/*
|
||||
%{_unitdir}/fdo-serviceinfo-api-server.service
|
||||
%{_unitdir}/fdo-owner-onboarding-server.service
|
||||
|
||||
@ -184,6 +189,8 @@ License: %combined_license
|
||||
%dir %{_localstatedir}/lib/fdo
|
||||
%dir %{_docdir}/fdo
|
||||
%{_docdir}/fdo/rendezvous-*.yml
|
||||
%{_docdir}/fdo/migrations/migrations_rendezvous_server_postgres/*
|
||||
%{_docdir}/fdo/migrations/migrations_rendezvous_server_sqlite/*
|
||||
%{_unitdir}/fdo-rendezvous-server.service
|
||||
|
||||
%post -n fdo-rendezvous-server
|
||||
@ -210,14 +217,16 @@ Requires: openssl-libs >= 3.0.1-12
|
||||
%dir %{_sysconfdir}/fdo
|
||||
%dir %{_sysconfdir}/fdo/keys
|
||||
%dir %{_sysconfdir}/fdo/manufacturing-server.conf.d
|
||||
%dir %{_sysconfdir}/fdo/keys
|
||||
%dir %{_sysconfdir}/fdo/stores
|
||||
%dir %{_sysconfdir}/fdo/stores/manufacturer_keys
|
||||
%dir %{_sysconfdir}/fdo/stores/manufacturing_sessions
|
||||
%dir %{_sysconfdir}/fdo/stores/owner_vouchers
|
||||
%{_libexecdir}/fdo/fdo-manufacturing-server
|
||||
%dir %{_localstatedir}/lib/fdo
|
||||
%dir %{_docdir}/fdo
|
||||
%{_docdir}/fdo/manufacturing-server.yml
|
||||
%{_docdir}/fdo/migrations/migrations_manufacturing_server_postgres/*
|
||||
%{_docdir}/fdo/migrations/migrations_manufacturing_server_sqlite/*
|
||||
%{_unitdir}/fdo-manufacturing-server.service
|
||||
|
||||
%post -n fdo-manufacturing-server
|
||||
@ -304,51 +313,20 @@ Requires: fdo-init = %{version}-%{release}
|
||||
%systemd_postun_with_restart fdo-aio.service
|
||||
|
||||
%changelog
|
||||
* Wed Nov 20 2024 Antonio Murdaca <amurdaca@redhat.com> - 0.4.12-14
|
||||
- rebuilt to fix rpminspect unicode points checks
|
||||
* Thu Nov 21 2024 Antonio Murdaca <amurdaca@redhat.com> - 0.5.1-1
|
||||
- Update to 0.5.1
|
||||
|
||||
* Wed Nov 20 2024 Antonio Murdaca <amurdaca@redhat.com> - 0.4.12-13
|
||||
- rebuilt to fix rpminspect license checks
|
||||
* Tue Feb 20 2024 Peter Robinson <pbrobinson@fedoraproject.org> - 0.5.0-1
|
||||
- Update to 0.5.0
|
||||
|
||||
* Tue Oct 29 2024 Troy Dawson <tdawson@redhat.com> - 0.4.12-12
|
||||
- Bump release for October 2024 mass rebuild:
|
||||
Resolves: RHEL-64018
|
||||
* Thu Jan 25 2024 Peter Robinson <pbrobinson@fedoraproject.org> - 0.4.13-1
|
||||
- Update to 0.4.13
|
||||
|
||||
* Mon Jun 24 2024 Troy Dawson <tdawson@redhat.com> - 0.4.12-11
|
||||
- Bump release for June 2024 mass rebuild
|
||||
|
||||
* Sun Feb 11 2024 Maxwell G <maxwell@gtmx.me> - 0.4.12-10
|
||||
- Rebuild for golang 1.22.0
|
||||
|
||||
* Sun Feb 04 2024 Yaakov Selkowitz <yselkowi@redhat.com> - 0.4.12-9
|
||||
- Update Rust macro usage
|
||||
|
||||
* Wed Jan 24 2024 Fedora Release Engineering <releng@fedoraproject.org> - 0.4.12-8
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_40_Mass_Rebuild
|
||||
|
||||
* Fri Jan 19 2024 Fedora Release Engineering <releng@fedoraproject.org> - 0.4.12-7
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_40_Mass_Rebuild
|
||||
|
||||
* Mon Jan 08 2024 Peter Robinson <pbrobinson@fedoraproject.org> - 0.4.12-6
|
||||
- Rebuild for fixed dependencies
|
||||
|
||||
* Fri Dec 01 2023 Fabio Valentini <decathorpe@gmail.com> - 0.4.12-5
|
||||
- Rebuild for openssl crate >= v0.10.60 (RUSTSEC-2023-0044, RUSTSEC-2023-0072)
|
||||
|
||||
* Wed Aug 23 2023 Peter Robinson <pbrobinson@fedoraproject.org> - 0.4.12-4
|
||||
- Ensure client service fix is applied
|
||||
|
||||
* Tue Aug 22 2023 Peter Robinson <pbrobinson@fedoraproject.org> - 0.4.12-3
|
||||
- Own var/lib/fdo, SELinux fixes
|
||||
|
||||
* Thu Aug 17 2023 Peter Robinson <pbrobinson@fedoraproject.org> - 0.4.12-2
|
||||
- Add client/init deps to fdo-admin-cli
|
||||
|
||||
* Thu Jul 27 2023 Peter Robinson <pbrobinson@fedoraproject.org> - 0.4.12-1
|
||||
* Wed Jul 26 2023 Peter Robinson <pbrobinson@fedoraproject.org> - 0.4.12-1
|
||||
- Update to 0.4.12
|
||||
|
||||
* Wed Jul 19 2023 Fedora Release Engineering <releng@fedoraproject.org> - 0.4.10-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_39_Mass_Rebuild
|
||||
* Mon Jul 03 2023 Peter Robinson <pbrobinson@fedoraproject.org> - 0.4.11-1
|
||||
- Update to 0.4.11
|
||||
|
||||
* Mon Jul 03 2023 Peter Robinson <pbrobinson@fedoraproject.org> - 0.4.10-2
|
||||
- Updates for eln/c9s building
|
||||
|
@ -1,25 +0,0 @@
|
||||
Backport of https://github.com/awslabs/aws-nitro-enclaves-cose/pull/66
|
||||
|
||||
diff --git a/vendor/aws-nitro-enclaves-cose/.cargo-checksum.json b/vendor/aws-nitro-enclaves-cose/.cargo-checksum.json
|
||||
index dd788a8..1035b7b 100644
|
||||
--- a/vendor/aws-nitro-enclaves-cose/.cargo-checksum.json
|
||||
+++ b/vendor/aws-nitro-enclaves-cose/.cargo-checksum.json
|
||||
@@ -1 +1 @@
|
||||
-{"files":{"CHANGELOG.md":"182c816f6cdcf13b370be9e712a0e7cf5b7c6b6612dc81c3b3d477abfca58e86","CODE_OF_CONDUCT.md":"34b6c98d5c23127ae6769e95e483e5bf6d3704ae1f0d3ae4e69d15f4ede118b6","CONTRIBUTING.md":"b050a75d5f6d2236ed40ad91dc53c4a4b30da184f9298f6f18507beae5fd7cb7","Cargo.toml":"d3ba98a34c9dcbff42da7e04d123b1687840738851e0630035e1f6e620a6fd98","LICENSE":"09e8a9bcec8067104652c168685ab0931e7868f9c8284b66f5ae6edae5f1130b","NOTICE":"d4290ed64c2edd0fce1d84e3f9dfb2881240fe534def76b8cd29ed6af683e287","README.md":"b16c142f4056384bb274fa7c9d0c2d73faf573cc2123a0bf4825970f88a67fc4","src/crypto/mod.rs":"a509e065cd0c3ed4c05484af9a7c45397ebf2a8b3f0d22578410f22484ffc33c","src/crypto/openssl_pkey.rs":"e9344a26ba101925a8e1c82960ff3d20a3df603be43132671bb15846ee96e829","src/crypto/tpm.rs":"2f8ec59523020319a4f63ca1e4bf3a4ae20c3acf8ca8ffd38e53ccd99611af3f","src/encrypt.rs":"ba89d5f221f0e4379d6f67dd946a00b183639b00bcf6918a4d3c441c4328894d","src/error.rs":"48fd4b84f9b4a7f5fc7ac52c2ce792d258c257908609270bf7751938082e19b7","src/header_map.rs":"88b3d7575ea4fd8eaaf4497a9d3c27ff43ec4da0213994aecf1ec9b5b89553c0","src/lib.rs":"8dbe7fe8206cfc76f46324c25418b37d0daf1ce23fc8b3219e1d89043c8e00de","src/sign.rs":"5a45658fa820ac9b5285c0987b66a58eb4f5b4373ab1aa07a73240848de098b2"},"package":"4e2fe3e862758ef5bb5d89868141ab28781d96347522b60eb6abeaf7f9acd4bc"}
|
||||
\ No newline at end of file
|
||||
+{"files":{},"package":"4e2fe3e862758ef5bb5d89868141ab28781d96347522b60eb6abeaf7f9acd4bc"}
|
||||
diff --git a/vendor/aws-nitro-enclaves-cose/src/sign.rs b/vendor/aws-nitro-enclaves-cose/src/sign.rs
|
||||
index 6426ac0..93f59ec 100644
|
||||
--- a/vendor/aws-nitro-enclaves-cose/src/sign.rs
|
||||
+++ b/vendor/aws-nitro-enclaves-cose/src/sign.rs
|
||||
@@ -135,8 +135,10 @@ pub struct SigStructure(
|
||||
#[serde(skip_serializing_if = "Option::is_none")]
|
||||
Option<ByteBuf>,
|
||||
/// external_aad : bstr,
|
||||
+ #[serde(default)]
|
||||
ByteBuf,
|
||||
/// payload : bstr
|
||||
+ #[serde(default)]
|
||||
ByteBuf,
|
||||
);
|
||||
|
4
sources
4
sources
@ -1,2 +1,2 @@
|
||||
SHA512 (fido-device-onboard-rs-0.4.12.tar.gz) = e1b5cfc2ed06977264526b67c8ae3bb8b38c557a0bbb5c9585fac5f334ee134ed921dd712678e842bc93340b8533c773902c27d354956ef169801c2260eddb4f
|
||||
SHA512 (fido-device-onboard-rs-0.4.12-vendor-patched.tar.xz) = 4cfb1ff883ee7f1a23316ca89e9272bedd4da20a8a05c90ef288d477f1c427b1bc8bfe660e5549da7b7dfd5571e76620d3cbda9b7da87e7303ac8a289d348222
|
||||
SHA512 (fido-device-onboard-rs-0.5.1-vendor-patched.tar.xz) = 5618890ff6839d2c3dcdcebfedcc3d76055a131b46eaf89d7d7ea6212c198c5a508687538c30b1cbb59a964053cf2df48f336b7ed45f370d2c158a47f54a4f6c
|
||||
SHA512 (fido-device-onboard-rs-0.5.1.tar.gz) = 6c8be6355cb8a4fc002ce3fcedda5b9337d384b70d966c85e7f6a111bf51445b2563190f747595c12ca1f46de3f56206fa4217ff6d1998b5540a35c3ddf374ea
|
||||
|
Loading…
Reference in New Issue
Block a user