import fido-device-onboard-0.3.0-1.el9
This commit is contained in:
parent
ffe46e28df
commit
353c8f682b
@ -1,2 +1,2 @@
|
|||||||
d87f6f6fe5179e4b756d48f5a4785f76efa44047 SOURCES/fido-device-onboard-rs-0.2.0-vendor-patched.tar.gz
|
35944215160d00af8d8553bd85bd9bf7c6129e8b SOURCES/fido-device-onboard-rs-0.3.0-vendor-patched.tar.gz
|
||||||
fd0c6fbe8f2ae8b411093ac8d6e1a7f96a1e082a SOURCES/fido-device-onboard-rs-0.2.0.tar.gz
|
a1e98d6d0b85fd3f2ab81d9c6179e2cfc5e30d4f SOURCES/fido-device-onboard-rs-0.3.0.tar.gz
|
||||||
|
4
.gitignore
vendored
4
.gitignore
vendored
@ -1,2 +1,2 @@
|
|||||||
SOURCES/fido-device-onboard-rs-0.2.0-vendor-patched.tar.gz
|
SOURCES/fido-device-onboard-rs-0.3.0-vendor-patched.tar.gz
|
||||||
SOURCES/fido-device-onboard-rs-0.2.0.tar.gz
|
SOURCES/fido-device-onboard-rs-0.3.0.tar.gz
|
||||||
|
37
SOURCES/kdf.patch
Normal file
37
SOURCES/kdf.patch
Normal file
@ -0,0 +1,37 @@
|
|||||||
|
diff --color -urN fido-device-onboard-rs-0.3.0-orig/Cargo.toml fido-device-onboard-rs-0.3.0/Cargo.toml
|
||||||
|
--- fido-device-onboard-rs-0.3.0-orig/Cargo.toml 2022-02-01 14:59:46.000000000 +0100
|
||||||
|
+++ fido-device-onboard-rs-0.3.0/Cargo.toml 2022-02-01 18:17:45.773515653 +0100
|
||||||
|
@@ -15,3 +15,7 @@
|
||||||
|
|
||||||
|
"integration-tests",
|
||||||
|
]
|
||||||
|
+
|
||||||
|
+[profile.release]
|
||||||
|
+debug = true
|
||||||
|
+
|
||||||
|
diff --color -urN fido-device-onboard-rs-0.3.0-orig/examples/systemd/fdo-client-linuxapp.service fido-device-onboard-rs-0.3.0/examples/systemd/fdo-client-linuxapp.service
|
||||||
|
--- fido-device-onboard-rs-0.3.0-orig/examples/systemd/fdo-client-linuxapp.service 2022-02-01 14:59:46.000000000 +0100
|
||||||
|
+++ fido-device-onboard-rs-0.3.0/examples/systemd/fdo-client-linuxapp.service 2022-02-01 17:06:50.581272078 +0100
|
||||||
|
@@ -5,6 +5,7 @@
|
||||||
|
[Service]
|
||||||
|
Type=oneshot
|
||||||
|
EnvironmentFile=-/boot/fdo-client-env
|
||||||
|
+Environment=ALLOW_NONINTEROPERABLE_KDF=1
|
||||||
|
Environment=LOG_LEVEL=info
|
||||||
|
ExecStart=/usr/libexec/fdo/fdo-client-linuxapp
|
||||||
|
ExecStartPost=-/usr/bin/mv /boot/device-credentials /etc/device-credentials
|
||||||
|
diff --color -urN fido-device-onboard-rs-0.3.0-orig/examples/systemd/fdo-owner-onboarding-server.service fido-device-onboard-rs-0.3.0/examples/systemd/fdo-owner-onboarding-server.service
|
||||||
|
--- fido-device-onboard-rs-0.3.0-orig/examples/systemd/fdo-owner-onboarding-server.service 2022-02-01 14:59:46.000000000 +0100
|
||||||
|
+++ fido-device-onboard-rs-0.3.0/examples/systemd/fdo-owner-onboarding-server.service 2022-02-01 17:06:42.983274923 +0100
|
||||||
|
@@ -4,8 +4,9 @@
|
||||||
|
|
||||||
|
[Service]
|
||||||
|
Environment=LOG_LEVEL=info
|
||||||
|
+Environment=ALLOW_NONINTEROPERABLE_KDF=1
|
||||||
|
ExecStart=/usr/libexec/fdo/fdo-owner-onboarding-server
|
||||||
|
# restart and failure condition
|
||||||
|
|
||||||
|
[Install]
|
||||||
|
-WantedBy=multi-user.target
|
||||||
|
\ No newline at end of file
|
||||||
|
+WantedBy=multi-user.target
|
@ -1,30 +0,0 @@
|
|||||||
--- fido-device-onboard-rs/Cargo.toml 2021-12-13 15:53:23.071283719 +0100
|
|
||||||
+++ fido-device-onboard-rs/Cargo.toml 2021-12-13 15:50:55.968837268 +0100
|
|
||||||
@@ -15,3 +15,6 @@
|
|
||||||
|
|
||||||
"integration-tests",
|
|
||||||
]
|
|
||||||
+
|
|
||||||
+[profile.release]
|
|
||||||
+debug = true
|
|
||||||
\ No newline at end of file
|
|
||||||
--- fido-device-onboard-rs/examples/systemd/fdo-client-linuxapp.service 2021-12-13 15:53:23.071283719 +0100
|
|
||||||
+++ fido-device-onboard-rs/examples/systemd/fdo-client-linuxapp.service 2021-12-13 15:51:01.323889924 +0100
|
|
||||||
@@ -7,6 +7,7 @@
|
|
||||||
Type=oneshot
|
|
||||||
Environment=DEVICE_CREDENTIAL=/boot/device-credentials
|
|
||||||
Environment=LOG_LEVEL=info
|
|
||||||
+Environment=ALLOW_NONINTEROPABLE_KDF=1
|
|
||||||
ExecStart=/usr/libexec/fdo/fdo-client-linuxapp
|
|
||||||
ExecStartPost=/usr/bin/mv /boot/device-credentials /etc/device-credentials
|
|
||||||
|
|
||||||
--- fido-device-onboard-rs/examples/systemd/fdo-owner-onboarding-server.service 2021-12-13 15:53:23.072283729 +0100
|
|
||||||
+++ fido-device-onboard-rs/examples/systemd/fdo-owner-onboarding-server.service 2021-12-13 15:51:04.354919728 +0100
|
|
||||||
@@ -4,6 +4,7 @@
|
|
||||||
|
|
||||||
[Service]
|
|
||||||
Environment=LOG_LEVEL=info
|
|
||||||
+Environment=ALLOW_NONINEROPABLE_KDF=1
|
|
||||||
ExecStart=/usr/libexec/fdo/fdo-owner-onboarding-server
|
|
||||||
# restart and failure condition
|
|
||||||
|
|
@ -4,12 +4,12 @@
|
|||||||
%global __cargo_is_lib() false
|
%global __cargo_is_lib() false
|
||||||
%global forgeurl https://github.com/fedora-iot/fido-device-onboard-rs
|
%global forgeurl https://github.com/fedora-iot/fido-device-onboard-rs
|
||||||
|
|
||||||
Version: 0.2.0
|
Version: 0.3.0
|
||||||
|
|
||||||
%forgemeta
|
%forgemeta
|
||||||
|
|
||||||
Name: fido-device-onboard
|
Name: fido-device-onboard
|
||||||
Release: 2%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: An implementation of the FIDO Device Onboard Specification written in rust
|
Summary: An implementation of the FIDO Device Onboard Specification written in rust
|
||||||
|
|
||||||
License: BSD
|
License: BSD
|
||||||
@ -20,7 +20,8 @@ Source1: %{name}-rs-%{commit}-vendor-patched.tar.gz
|
|||||||
%else
|
%else
|
||||||
Source1: %{name}-rs-%{version}-vendor-patched.tar.gz
|
Source1: %{name}-rs-%{version}-vendor-patched.tar.gz
|
||||||
%endif
|
%endif
|
||||||
Patch0: patch
|
|
||||||
|
Patch0: kdf.patch
|
||||||
|
|
||||||
ExclusiveArch: %{rust_arches}
|
ExclusiveArch: %{rust_arches}
|
||||||
# RHBZ 1869980
|
# RHBZ 1869980
|
||||||
@ -173,6 +174,9 @@ Summary: FDO Owner tools implementation
|
|||||||
%{_docdir}/fdo/owner-addresses.yml
|
%{_docdir}/fdo/owner-addresses.yml
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Feb 01 2022 Antonio Murdaca <runcom@linux.com> - 0.3.0-1
|
||||||
|
- bump to 0.3.0
|
||||||
|
|
||||||
* Tue Jan 11 2022 Antonio Murdaca <runcom@linux.com> - 0.2.0-2
|
* Tue Jan 11 2022 Antonio Murdaca <runcom@linux.com> - 0.2.0-2
|
||||||
- use patched vendor w/o win files and rename license
|
- use patched vendor w/o win files and rename license
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user