Link with -pie

Related: rhbz#2044857
This commit is contained in:
Matthias Clasen 2022-01-26 10:40:37 -05:00
parent d5d7282817
commit 498a7e7d5b
2 changed files with 26 additions and 1 deletions

20
festival-2.5.0-pie.patch Normal file
View File

@ -0,0 +1,20 @@
diff -up festival/src/main/Makefile.pie festival/src/main/Makefile
--- festival/src/main/Makefile.pie 2022-01-26 10:33:55.420688190 -0500
+++ festival/src/main/Makefile 2022-01-26 10:34:45.928050436 -0500
@@ -54,13 +54,13 @@ ifeq (SIOD_PYTHON, $(findstring SIOD_PYT
endif
festival: festival_main.o $(LIBDEPS)
- $(LINK_COMMAND) -o festival festival_main.o $(LIBS)
+ $(LINK_COMMAND) -o festival festival_main.o -Wp,-pie $(LIBS)
festival_client: festival_client.o $(REQUIRED_LIBDEPS)
- $(LINK_COMMAND) -o festival_client festival_client.o $(LIBS)
+ $(LINK_COMMAND) -o festival_client festival_client.o -Wp,-pie $(LIBS)
$(ETCDIR)/audsp: $(ETCDIR)/.made audsp.o $(LIBDEPS)
- $(LINK_COMMAND) -o $(ETCDIR)/audsp audsp.o $(LIBS)
+ $(LINK_COMMAND) -o $(ETCDIR)/audsp audsp.o -Wp,-pie $(LIBS)
# Can't just rely on the dir as it gets updated with new files
# check for the data of a file created in etcdir

View File

@ -1,7 +1,7 @@
Name: festival
Summary: Speech synthesis and text-to-speech system
Version: 2.5.0
Release: 16%{?dist}
Release: 17%{?dist}
URL: http://www.cstr.ed.ac.uk/projects/festival/
# The Emacs file is GPL+, there is one TCL-licensed source file, and
@ -56,6 +56,7 @@ Patch101: festival-2.5.0-use-system-speech-tools.patch
Patch102: festival-2.5.0-use-system-libs.patch
Patch103: festival-2.5.0-filesystem-standard.patch
Patch104: festival-2.5.0-siteinit.patch
Patch105: festival-2.5.0-pie.patch
BuildRequires: gcc
BuildRequires: gcc-c++
@ -298,6 +299,7 @@ you can also interface with Festival in via the shell or with BSD sockets.
%patch102 -p1 -b .use-system-libs
%patch103 -p1 -b .filesystem-standard
%patch104 -p1 -b .siteinit
%patch105 -p1 -b .pie
%build
@ -489,6 +491,9 @@ exit 0
%changelog
* Wed Jan 26 2022 Matthias Clasen <mclasen@redhat.com> - 2.5.0-17
- Link binaries with -pie. Related: rhbz:#2044857
* Mon Aug 09 2021 Mohan Boddu <mboddu@redhat.com> - 2.5.0-16
- Rebuilt for IMA sigs, glibc 2.34, aarch64 flags
Related: rhbz#1991688