22 lines
1.1 KiB
Diff
22 lines
1.1 KiB
Diff
diff -uNr a/fence/agents/lib/check_used_options.py b/fence/agents/lib/check_used_options.py
|
|
--- a/fence/agents/lib/check_used_options.py 2016-08-22 14:33:34.000000000 +0200
|
|
+++ b/fence/agents/lib/check_used_options.py 2016-12-23 10:58:41.653592220 +0100
|
|
@@ -1,5 +1,3 @@
|
|
-#!/usr/bin/python -tt
|
|
-
|
|
## Check if fence agent uses only options["--??"] which are defined in fencing library or
|
|
## fence agent itself
|
|
##
|
|
diff -uNr a/make/fencebuild.mk b/make/fencebuild.mk
|
|
--- a/make/fencebuild.mk 2016-08-22 14:33:36.000000000 +0200
|
|
+++ b/make/fencebuild.mk 2016-12-23 10:42:57.712668560 +0100
|
|
@@ -31,7 +31,7 @@
|
|
> $@
|
|
|
|
if [ 0 -eq `echo "$(@)" | grep fence_ &> /dev/null; echo $$?` ]; then \
|
|
- PYTHONPATH=$(abs_srcdir)/lib:$(abs_builddir)/lib $(top_srcdir)/fence/agents/lib/check_used_options.py $@; \
|
|
+ PYTHONPATH=$(abs_srcdir)/lib:$(abs_builddir)/lib $(PYTHON) $(top_srcdir)/fence/agents/lib/check_used_options.py $@; \
|
|
else true ; fi
|
|
|
|
for x in `PYTHONPATH=$(abs_srcdir)/lib:$(abs_builddir)/lib $(PYTHON) $(@) -o metadata | grep symlink | sed -e "s/.*\(fence.*\)\" .*/\1/g"`; do \
|