import fence-agents-4.2.1-96.el8
This commit is contained in:
parent
0b46bcfb97
commit
e085bae050
30
SOURCES/bz2072421-2-fence_zvmip-connect-error.patch
Normal file
30
SOURCES/bz2072421-2-fence_zvmip-connect-error.patch
Normal file
@ -0,0 +1,30 @@
|
||||
From 6430104318b4bf349425b08636183bf839812e04 Mon Sep 17 00:00:00 2001
|
||||
From: Oyvind Albrigtsen <oalbrigt@redhat.com>
|
||||
Date: Tue, 31 May 2022 08:55:25 +0200
|
||||
Subject: [PATCH] fence_zvmip: show unable to connect error instead of full
|
||||
stacktrace, e.g. when not using --ssl for SSL devices
|
||||
|
||||
---
|
||||
agents/zvm/fence_zvmip.py | 9 +++++++--
|
||||
1 file changed, 7 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/agents/zvm/fence_zvmip.py b/agents/zvm/fence_zvmip.py
|
||||
index 90ca95d45..4f538e10d 100644
|
||||
--- a/agents/zvm/fence_zvmip.py
|
||||
+++ b/agents/zvm/fence_zvmip.py
|
||||
@@ -127,8 +127,13 @@ def get_list_of_images(options, command, data_as_plug):
|
||||
|
||||
conn.send(packet)
|
||||
|
||||
- request_id = struct.unpack("!i", conn.recv(INT4))[0]
|
||||
- (output_len, request_id, return_code, reason_code) = struct.unpack("!iiii", conn.recv(INT4 * 4))
|
||||
+ try:
|
||||
+ request_id = struct.unpack("!i", conn.recv(INT4))[0]
|
||||
+ (output_len, request_id, return_code, reason_code) = struct.unpack("!iiii", conn.recv(INT4 * 4))
|
||||
+ except struct.error:
|
||||
+ logging.debug(sys.exc_info())
|
||||
+ fail_usage("Failed: Unable to connect to {} port: {} SSL: {} \n".format(options["--ip"], options["--ipport"], bool("--ssl" in options)))
|
||||
+
|
||||
images = set()
|
||||
|
||||
if output_len > 3*INT4:
|
@ -87,7 +87,7 @@
|
||||
Name: fence-agents
|
||||
Summary: Set of unified programs capable of host isolation ("fencing")
|
||||
Version: 4.2.1
|
||||
Release: 95%{?alphatag:.%{alphatag}}%{?dist}
|
||||
Release: 96%{?alphatag:.%{alphatag}}%{?dist}
|
||||
License: GPLv2+ and LGPLv2+
|
||||
Group: System Environment/Base
|
||||
URL: https://github.com/ClusterLabs/fence-agents
|
||||
@ -283,11 +283,12 @@ Patch108: bz2048857-fence_aws-botocore-bundled.patch
|
||||
Patch109: bz1886074-1-fencing-source_env.patch
|
||||
Patch110: bz1886074-2-fence_openstack.patch
|
||||
Patch111: bz1886074-3-fence_openstack-bundled.patch
|
||||
Patch112: bz2072421-all-agents-unify-ssl-parameters.patch
|
||||
Patch112: bz2072421-1-all-agents-unify-ssl-parameters.patch
|
||||
Patch113: bz2078244-fence_gce-update.patch
|
||||
Patch114: bz2080994-fence_ibm_vpc-fix-parameters.patch
|
||||
Patch115: bz2080729-1-fence_apc-fence_ilo_moonshot-import-logging.patch
|
||||
Patch116: bz2080729-2-fence_lpar-fix-import-fail_usage.patch
|
||||
Patch117: bz2072421-2-fence_zvmip-connect-error.patch
|
||||
|
||||
%if 0%{?fedora} || 0%{?rhel} > 7
|
||||
%global supportedagents amt_ws apc apc_snmp bladecenter brocade cisco_mds cisco_ucs compute drac5 eaton_snmp emerson eps evacuate hds_cb hpblade ibmblade ibm_powervs ibm_vpc ifmib ilo ilo_moonshot ilo_mp ilo_ssh intelmodular ipdu ipmilan kdump kubevirt lpar mpath redfish rhevm rsa rsb sbd scsi vmware_rest vmware_soap wti
|
||||
@ -482,6 +483,7 @@ BuildRequires: python3-google-api-client python3-pip python3-wheel python3-jinja
|
||||
%patch114 -p1
|
||||
%patch115 -p1
|
||||
%patch116 -p1
|
||||
%patch117 -p1
|
||||
|
||||
# prevent compilation of something that won't get used anyway
|
||||
sed -i.orig 's|FENCE_ZVM=1|FENCE_ZVM=0|' configure.ac
|
||||
@ -1506,6 +1508,11 @@ Fence agent for IBM z/VM over IP.
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Tue May 31 2022 Oyvind Albrigtsen <oalbrigt@redhat.com> - 4.2.1-96
|
||||
- all agents: unify ssl parameters to avoid having to use --ssl when
|
||||
using --ssl-secure/--ssl-insecure for some agents
|
||||
Resolves: rhbz#2072421
|
||||
|
||||
* Tue May 17 2022 Oyvind Albrigtsen <oalbrigt@redhat.com> - 4.2.1-95
|
||||
- fence_apc/fence_ilo_moonshot/fence_lpar: add missing "import logging"
|
||||
Resolves: rhbz#2080729
|
||||
@ -1516,9 +1523,6 @@ Fence agent for IBM z/VM over IP.
|
||||
Resolves: rhbz#2080994
|
||||
|
||||
* Thu Apr 28 2022 Oyvind Albrigtsen <oalbrigt@redhat.com> - 4.2.1-93
|
||||
- all agents: unify ssl parameters to avoid having to use --ssl when
|
||||
using --ssl-secure/--ssl-insecure for some agents
|
||||
Resolves: rhbz#2072421
|
||||
- fence_gce: update fence agent
|
||||
Resolves: rhbz#2078244
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user