Auto sync2gitlab import of fence-agents-4.2.1-110.el8.src.rpm
This commit is contained in:
parent
69dd85fe3f
commit
cc10e2594f
30
bz2160478-fence_scsi-fix-validate-all.patch
Normal file
30
bz2160478-fence_scsi-fix-validate-all.patch
Normal file
@ -0,0 +1,30 @@
|
|||||||
|
From a416a367a804f1e5abaf142c629fe6ab5572d3b6 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Oyvind Albrigtsen <oalbrigt@redhat.com>
|
||||||
|
Date: Thu, 12 Jan 2023 15:46:41 +0100
|
||||||
|
Subject: [PATCH] fence_scsi: skip key generation during validate-all action
|
||||||
|
|
||||||
|
---
|
||||||
|
agents/scsi/fence_scsi.py | 9 +++++----
|
||||||
|
1 file changed, 5 insertions(+), 4 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/agents/scsi/fence_scsi.py b/agents/scsi/fence_scsi.py
|
||||||
|
index e33339614..f9e6823b2 100644
|
||||||
|
--- a/agents/scsi/fence_scsi.py
|
||||||
|
+++ b/agents/scsi/fence_scsi.py
|
||||||
|
@@ -566,11 +566,12 @@ def main():
|
||||||
|
or ("--key" in options and options["--key"])):
|
||||||
|
fail_usage("Failed: nodename or key is required", stop_after_error)
|
||||||
|
|
||||||
|
- if not ("--key" in options and options["--key"]):
|
||||||
|
- options["--key"] = generate_key(options)
|
||||||
|
+ if options["--action"] != "validate-all":
|
||||||
|
+ if not ("--key" in options and options["--key"]):
|
||||||
|
+ options["--key"] = generate_key(options)
|
||||||
|
|
||||||
|
- if options["--key"] == "0" or not options["--key"]:
|
||||||
|
- fail_usage("Failed: key cannot be 0", stop_after_error)
|
||||||
|
+ if options["--key"] == "0" or not options["--key"]:
|
||||||
|
+ fail_usage("Failed: key cannot be 0", stop_after_error)
|
||||||
|
|
||||||
|
if "--key-value" in options\
|
||||||
|
and (options["--key-value"] != "id" and options["--key-value"] != "hash"):
|
@ -87,7 +87,7 @@
|
|||||||
Name: fence-agents
|
Name: fence-agents
|
||||||
Summary: Set of unified programs capable of host isolation ("fencing")
|
Summary: Set of unified programs capable of host isolation ("fencing")
|
||||||
Version: 4.2.1
|
Version: 4.2.1
|
||||||
Release: 109%{?alphatag:.%{alphatag}}%{?dist}
|
Release: 110%{?alphatag:.%{alphatag}}%{?dist}
|
||||||
License: GPLv2+ and LGPLv2+
|
License: GPLv2+ and LGPLv2+
|
||||||
Group: System Environment/Base
|
Group: System Environment/Base
|
||||||
URL: https://github.com/ClusterLabs/fence-agents
|
URL: https://github.com/ClusterLabs/fence-agents
|
||||||
@ -264,6 +264,7 @@ Patch121: bz1787178-2-fence_vmware_soap-login-timeout-50s.patch
|
|||||||
Patch122: bz2102024-fence_ibm_vpc-add-token-cache-support.patch
|
Patch122: bz2102024-fence_ibm_vpc-add-token-cache-support.patch
|
||||||
Patch123: bz2134017-fence_lpar-only-output-additional-info-on-debug.patch
|
Patch123: bz2134017-fence_lpar-only-output-additional-info-on-debug.patch
|
||||||
Patch124: bz2136076-fence_ibm_powervs-improve-defaults.patch
|
Patch124: bz2136076-fence_ibm_powervs-improve-defaults.patch
|
||||||
|
Patch125: bz2160478-fence_scsi-fix-validate-all.patch
|
||||||
|
|
||||||
%if 0%{?fedora} || 0%{?rhel} > 7
|
%if 0%{?fedora} || 0%{?rhel} > 7
|
||||||
%global supportedagents amt_ws apc apc_snmp bladecenter brocade cisco_mds cisco_ucs compute drac5 eaton_snmp emerson eps evacuate hds_cb hpblade ibmblade ibm_powervs ibm_vpc ifmib ilo ilo_moonshot ilo_mp ilo_ssh intelmodular ipdu ipmilan kdump kubevirt lpar mpath redfish rhevm rsa rsb sbd scsi vmware_rest vmware_soap wti
|
%global supportedagents amt_ws apc apc_snmp bladecenter brocade cisco_mds cisco_ucs compute drac5 eaton_snmp emerson eps evacuate hds_cb hpblade ibmblade ibm_powervs ibm_vpc ifmib ilo ilo_moonshot ilo_mp ilo_ssh intelmodular ipdu ipmilan kdump kubevirt lpar mpath redfish rhevm rsa rsb sbd scsi vmware_rest vmware_soap wti
|
||||||
@ -466,6 +467,7 @@ BuildRequires: python3-google-api-client python3-pip python3-wheel python3-jinja
|
|||||||
%patch122 -p1 -F2
|
%patch122 -p1 -F2
|
||||||
%patch123 -p1
|
%patch123 -p1
|
||||||
%patch124 -p1
|
%patch124 -p1
|
||||||
|
%patch125 -p1
|
||||||
|
|
||||||
# prevent compilation of something that won't get used anyway
|
# prevent compilation of something that won't get used anyway
|
||||||
sed -i.orig 's|FENCE_ZVM=1|FENCE_ZVM=0|' configure.ac
|
sed -i.orig 's|FENCE_ZVM=1|FENCE_ZVM=0|' configure.ac
|
||||||
@ -1463,6 +1465,10 @@ Fence agent for IBM z/VM over IP.
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Jan 13 2023 Oyvind Albrigtsen <oalbrigt@redhat.com> - 4.2.1-110
|
||||||
|
- fence_scsi: skip key generation during validate-all action
|
||||||
|
Resolves: rhbz#2160478
|
||||||
|
|
||||||
* Fri Nov 11 2022 Oyvind Albrigtsen <oalbrigt@redhat.com> - 4.2.1-109
|
* Fri Nov 11 2022 Oyvind Albrigtsen <oalbrigt@redhat.com> - 4.2.1-109
|
||||||
- fence_vmware_soap: set timeout, which should help cleanup tmp dirs
|
- fence_vmware_soap: set timeout, which should help cleanup tmp dirs
|
||||||
Resolves: rhbz#1787178
|
Resolves: rhbz#1787178
|
||||||
|
Loading…
Reference in New Issue
Block a user