- new upstream release

This commit is contained in:
Oyvind Albrigtsen 2016-08-26 12:42:07 +02:00
parent de86c1d3fa
commit c3cd18efd8
4 changed files with 19 additions and 72 deletions

1
.gitignore vendored
View File

@ -31,3 +31,4 @@ fence-agents-3.0.14.tar.bz2
/fence-agents-4.0.16.tar.xz /fence-agents-4.0.16.tar.xz
/fence-agents-4.0.20.tar.xz /fence-agents-4.0.20.tar.xz
/fence-agents-4.0.23.tar.xz /fence-agents-4.0.23.tar.xz
/fence-agents-4.0.24.tar.xz

View File

@ -1,57 +0,0 @@
From df5492f2dea1ff880308f6daf7043f3159aa4a89 Mon Sep 17 00:00:00 2001
From: Oyvind Albrigtsen <oalbrigt@redhat.com>
Date: Tue, 5 Jul 2016 14:33:43 +0200
Subject: [PATCH] Fix install issue for symlinked agents
---
make/fencebuild.mk | 25 +++++++++++++++++++++++++
1 file changed, 25 insertions(+)
diff --git a/make/fencebuild.mk b/make/fencebuild.mk
index 1d50398..f11aa8a 100644
--- a/make/fencebuild.mk
+++ b/make/fencebuild.mk
@@ -47,3 +47,28 @@ clean: clean-man
fi
clean-local: clean
+
+install-exec-hook: $(TARGET)
+ if [ -n "$(man8dir)" ]; then \
+ echo " $(MKDIR_P) '$(DESTDIR)$(man8dir)'"; \
+ $(MKDIR_P) "$(DESTDIR)$(man8dir)" || exit 1; \
+ fi
+ for p in $(TARGET); do \
+ dir=`dirname $$p`; \
+ for x in `PYTHONPATH=$(abs_srcdir)/lib:$(abs_builddir)/lib $(PYTHON) $$p -o metadata | grep symlink | sed -e "s/.*\(fence.*\)\" .*/\1/g"`; do \
+ echo " $(INSTALL_SCRIPT) $$dir/$$x '$(DESTDIR)$(sbindir)'"; \
+ $(INSTALL_SCRIPT) $$dir/$$x "$(DESTDIR)$(sbindir)" || exit $$?; \
+ echo " $(INSTALL_DATA) '$$dir/$$x.8' '$(DESTDIR)$(man8dir)'"; \
+ $(INSTALL_DATA) "$$dir/$$x.8" "$(DESTDIR)$(man8dir)" || exit $$?; \
+ done; \
+ done
+
+uninstall-hook: $(TARGET)
+ files=`for p in $(TARGET); do \
+ for x in \`PYTHONPATH=$(abs_srcdir)/lib:$(abs_builddir)/lib $(PYTHON) $$p -o metadata | grep symlink | sed -e "s/.*\(fence.*\)\" .*/\1/g"\`; do \
+ echo " rm -f '$(DESTDIR)$(sbindir)/$$x'"; \
+ rm -f "$(DESTDIR)$(sbindir)/$$x"; \
+ echo " rm -f '$(DESTDIR)$(man8dir)/$$x.8'"; \
+ rm -f "$(DESTDIR)$(man8dir)/$$x.8"; \
+ done; \
+ done`
--
2.7.4
diff -uNr a/fence/agents/Makefile.am b/fence/agents/Makefile.am
--- a/fence/agents/Makefile.am 2016-06-29 16:28:40.000000000 +0200
+++ b/fence/agents/Makefile.am 2016-07-13 12:51:34.950671572 +0200
@@ -31,7 +31,7 @@
scsidata_SCRIPTS = scsi/fence_scsi_check scsi/fence_scsi_check_hardreboot
zvm_fence_zvm_SOURCES = zvm/fence_zvm.c
-zvm_fence_zvm_CFLAGS = -D_GNU_SOURCE
+zvm_fence_zvm_CFLAGS = -D_GNU_SOURCE -Izvm
FENCE_TEST_ARGS = \
login=test\n\

View File

@ -15,13 +15,12 @@
Name: fence-agents Name: fence-agents
Summary: Fence Agents for Red Hat Cluster Summary: Fence Agents for Red Hat Cluster
Version: 4.0.23 Version: 4.0.24
Release: 2%{?alphatag:.%{alphatag}}%{?dist} Release: 1%{?alphatag:.%{alphatag}}%{?dist}
License: GPLv2+ and LGPLv2+ License: GPLv2+ and LGPLv2+
Group: System Environment/Base Group: System Environment/Base
URL: http://sourceware.org/cluster/wiki/ URL: http://sourceware.org/cluster/wiki/
Source0: https://fedorahosted.org/releases/f/e/fence-agents/%{name}-%{version}.tar.xz Source0: https://fedorahosted.org/releases/f/e/fence-agents/%{name}-%{version}.tar.xz
Patch1: 0001-Fix-install-issue-for-symlinked-agents.patch
%if 0%{?fedora} %if 0%{?fedora}
%global testagents zvm virsh raritan rcd_serial %global testagents zvm virsh raritan rcd_serial
@ -36,7 +35,7 @@ BuildRoot: %(mktemp -ud %{_tmppath}/%{name}-%{version}-%{release}-XXXXXX)
BuildRequires: glibc-devel BuildRequires: glibc-devel
BuildRequires: gnutls-utils BuildRequires: gnutls-utils
BuildRequires: libxslt BuildRequires: libxslt
BuildRequires: python-pexpect python-pycurl python-suds python-requests openwsman-python BuildRequires: python3-pexpect python3-pycurl python3-suds python3-requests openwsman-python3 python-pexpect python-pycurl
BuildRequires: autoconf automake libtool BuildRequires: autoconf automake libtool
%prep %prep
@ -45,7 +44,7 @@ BuildRequires: autoconf automake libtool
%build %build
./autogen.sh ./autogen.sh
%{configure} export PYTHON="/usr/bin/python3" %{configure}
CFLAGS="$(echo '%{optflags}')" make %{_smp_mflags} CFLAGS="$(echo '%{optflags}')" make %{_smp_mflags}
%install %install
@ -72,7 +71,7 @@ power management for several devices.
License: GPLv2+ and LGPLv2+ License: GPLv2+ and LGPLv2+
Group: System Environment/Base Group: System Environment/Base
Summary: Common utilities for fence agents Summary: Common utilities for fence agents
Requires: python-pexpect Requires: python3-pexpect
%description common %description common
Red Hat Fence Agents is a collection of scripts and libraries to handle remote power management for various devices. Red Hat Fence Agents is a collection of scripts and libraries to handle remote power management for various devices.
%files common %files common
@ -87,6 +86,7 @@ Red Hat Fence Agents is a collection of scripts and libraries to handle remote p
%exclude %{_sbindir}/fence_dummy %exclude %{_sbindir}/fence_dummy
%exclude %{_mandir}/man8/fence_dummy.8* %exclude %{_mandir}/man8/fence_dummy.8*
%exclude %{_sbindir}/fence_zvm %exclude %{_sbindir}/fence_zvm
%exclude %{_mandir}/man8/fence_zvm.8*
%package all %package all
@ -165,7 +165,7 @@ License: ASL 2.0
Group: System Environment/Base Group: System Environment/Base
Summary: Fence agent for Intel AMT (WS-Man) devices Summary: Fence agent for Intel AMT (WS-Man) devices
Requires: fence-agents-common >= %{version}-%{release} Requires: fence-agents-common >= %{version}-%{release}
Requires: openwsman-python Requires: openwsman-python3
Obsoletes: fence-agents Obsoletes: fence-agents
%description amt-ws %description amt-ws
The fence-agents-amt-ws package contains a fence agent for AMT (WS-Man) devices. The fence-agents-amt-ws package contains a fence agent for AMT (WS-Man) devices.
@ -220,7 +220,7 @@ The fence-agents-cisco-mds package contains a fence agent for Cisco MDS 9000 ser
License: GPLv2+ and LGPLv2+ License: GPLv2+ and LGPLv2+
Group: System Environment/Base Group: System Environment/Base
Summary: Fence agent for Cisco UCS series Summary: Fence agent for Cisco UCS series
Requires: python-pycurl Requires: python3-pycurl
Requires: fence-agents-common = %{version}-%{release} Requires: fence-agents-common = %{version}-%{release}
Obsoletes: fence-agents Obsoletes: fence-agents
%description cisco-ucs %description cisco-ucs
@ -248,7 +248,7 @@ The fence-agents-compute package contains a fence agent for Nova compute nodes.
License: GPLv2+ and LGPLv2+ License: GPLv2+ and LGPLv2+
Group: System Environment/Base Group: System Environment/Base
Summary: Fence agent for Docker Summary: Fence agent for Docker
Requires: python-pycurl Requires: python3-pycurl
Requires: fence-agents-common = %{version}-%{release} Requires: fence-agents-common = %{version}-%{release}
Obsoletes: fence-agents Obsoletes: fence-agents
%description docker %description docker
@ -580,7 +580,7 @@ The fence-agents-netio package contains a fence agent for Koukaam NETIO devices
License: GPLv2+ and LGPLv2+ License: GPLv2+ and LGPLv2+
Group: System Environment/Base Group: System Environment/Base
Summary: Fence agent for OVH provider Summary: Fence agent for OVH provider
Requires: python-suds Requires: python3-suds
Requires: fence-agents-common = %{version}-%{release} Requires: fence-agents-common = %{version}-%{release}
Obsoletes: fence-agents Obsoletes: fence-agents
%description ovh %description ovh
@ -596,7 +596,7 @@ Red Hat Fence Agent for OVH hosting provider
License: GPLv2+ and LGPLv2+ License: GPLv2+ and LGPLv2+
Group: System Environment/Base Group: System Environment/Base
Summary: Fence agent for OVH provider Summary: Fence agent for OVH provider
Requires: fence-agents-common python-suds Requires: fence-agents-common python3-suds
Obsoletes: fence-agents Obsoletes: fence-agents
%description pve %description pve
Red Hat Fence Agent for PVE Red Hat Fence Agent for PVE
@ -756,7 +756,7 @@ The fence-agents-virsh package contains a fence agent for virtual machines that
License: GPLv2+ and LGPLv2+ License: GPLv2+ and LGPLv2+
Group: System Environment/Base Group: System Environment/Base
Summary: Fence agent for VMWare with VI Perl Toolkit or vmrun Summary: Fence agent for VMWare with VI Perl Toolkit or vmrun
Requires: python-pexpect Requires: python3-pexpect
Requires: fence-agents-common = %{version}-%{release} Requires: fence-agents-common = %{version}-%{release}
Obsoletes: fence-agents Obsoletes: fence-agents
%description vmware %description vmware
@ -771,7 +771,7 @@ The fence-agents-vmware package contains a fence agent for VMWare accessed with
License: GPLv2+ and LGPLv2+ License: GPLv2+ and LGPLv2+
Group: System Environment/Base Group: System Environment/Base
Summary: Fence agent for VMWare with SOAP API v4.1+ Summary: Fence agent for VMWare with SOAP API v4.1+
Requires: python-suds Requires: python3-suds
Requires: fence-agents-common = %{version}-%{release} Requires: fence-agents-common = %{version}-%{release}
Obsoletes: fence-agents Obsoletes: fence-agents
%description vmware-soap %description vmware-soap
@ -800,7 +800,7 @@ The fence-agents-wti package contains a fence agent for WTI network power switch
License: GPLv2+ and LGPLv2+ License: GPLv2+ and LGPLv2+
Group: System Environment/Base Group: System Environment/Base
Summary: Fence agent for Citrix XenServer over XenAPI Summary: Fence agent for Citrix XenServer over XenAPI
Requires: python-pexpect Requires: python3-pexpect
Requires: fence-agents-common = %{version}-%{release} Requires: fence-agents-common = %{version}-%{release}
Obsoletes: fence-agents Obsoletes: fence-agents
%description xenapi %description xenapi
@ -825,6 +825,9 @@ The fence-agents-zvm package contains a fence agent for IBM z/VM over IP.
%{_mandir}/man8/fence_zvmip.8* %{_mandir}/man8/fence_zvmip.8*
%changelog %changelog
* Fri Aug 26 2016 Oyvind Albrigtsen <oalbrigt@redhat.com> - 4.0.24-1
- new upstream release
* Wed Jul 13 2016 Oyvind Albrigtsen <oalbrigt@redhat.com> - 4.0.23-2 * Wed Jul 13 2016 Oyvind Albrigtsen <oalbrigt@redhat.com> - 4.0.23-2
- fix build issue on s390 - fix build issue on s390

View File

@ -1 +1 @@
61122adef0d18fef9d41fd88512ed025 fence-agents-4.0.23.tar.xz 161195adb0c125bbbbc1440920a2ff28 fence-agents-4.0.24.tar.xz