import fence-agents-4.10.0-20.el9_0
This commit is contained in:
parent
164cdd65e3
commit
bfca8ba693
@ -1,139 +0,0 @@
|
||||
From e339f304d4423a0e661d915f72ba88553b21d74a Mon Sep 17 00:00:00 2001
|
||||
From: MSSedusch <sedusch@microsoft.com>
|
||||
Date: Tue, 28 Sep 2021 12:23:37 +0000
|
||||
Subject: [PATCH 1/2] add support for sovereign clouds and MSI
|
||||
|
||||
---
|
||||
lib/azure_fence.py.py | 14 ++++++++------
|
||||
1 file changed, 8 insertions(+), 6 deletions(-)
|
||||
|
||||
diff --git a/lib/azure_fence.py.py b/lib/azure_fence.py.py
|
||||
index 1f38bd4ea..75b63fdad 100644
|
||||
--- a/lib/azure_fence.py.py
|
||||
+++ b/lib/azure_fence.py.py
|
||||
@@ -286,11 +286,11 @@ def get_azure_credentials(config):
|
||||
credentials = None
|
||||
cloud_environment = get_azure_cloud_environment(config)
|
||||
if config.UseMSI and cloud_environment:
|
||||
- from msrestazure.azure_active_directory import MSIAuthentication
|
||||
- credentials = MSIAuthentication(cloud_environment=cloud_environment)
|
||||
+ from azure.identity import ManagedIdentityCredential
|
||||
+ credentials = ManagedIdentityCredential(cloud_environment=cloud_environment)
|
||||
elif config.UseMSI:
|
||||
- from msrestazure.azure_active_directory import MSIAuthentication
|
||||
- credentials = MSIAuthentication()
|
||||
+ from azure.identity import ManagedIdentityCredential
|
||||
+ credentials = ManagedIdentityCredential()
|
||||
elif cloud_environment:
|
||||
try:
|
||||
# try to use new libraries ClientSecretCredential (azure.identity, based on azure.core)
|
||||
@@ -340,7 +340,8 @@ def get_azure_compute_client(config):
|
||||
compute_client = ComputeManagementClient(
|
||||
credentials,
|
||||
config.SubscriptionId,
|
||||
- base_url=cloud_environment.endpoints.resource_manager
|
||||
+ base_url=cloud_environment.endpoints.resource_manager,
|
||||
+ credential_scopes=[cloud_environment.endpoints.resource_manager + "/.default"]
|
||||
)
|
||||
else:
|
||||
compute_client = ComputeManagementClient(
|
||||
@@ -359,7 +360,8 @@ def get_azure_network_client(config):
|
||||
network_client = NetworkManagementClient(
|
||||
credentials,
|
||||
config.SubscriptionId,
|
||||
- base_url=cloud_environment.endpoints.resource_manager
|
||||
+ base_url=cloud_environment.endpoints.resource_manager,
|
||||
+ credential_scopes=[cloud_environment.endpoints.resource_manager + "/.default"]
|
||||
)
|
||||
else:
|
||||
network_client = NetworkManagementClient(
|
||||
|
||||
From f08f02a7561e78dd9c95c66ccdcf6246c5ee7d6a Mon Sep 17 00:00:00 2001
|
||||
From: MSSedusch <sedusch@microsoft.com>
|
||||
Date: Fri, 1 Oct 2021 15:28:39 +0000
|
||||
Subject: [PATCH 2/2] compatiblity fix
|
||||
|
||||
---
|
||||
lib/azure_fence.py.py | 54 ++++++++++++++++++++++++++++++-------------
|
||||
1 file changed, 38 insertions(+), 16 deletions(-)
|
||||
|
||||
diff --git a/lib/azure_fence.py.py b/lib/azure_fence.py.py
|
||||
index 75b63fdad..5ca71eb42 100644
|
||||
--- a/lib/azure_fence.py.py
|
||||
+++ b/lib/azure_fence.py.py
|
||||
@@ -286,11 +286,19 @@ def get_azure_credentials(config):
|
||||
credentials = None
|
||||
cloud_environment = get_azure_cloud_environment(config)
|
||||
if config.UseMSI and cloud_environment:
|
||||
- from azure.identity import ManagedIdentityCredential
|
||||
- credentials = ManagedIdentityCredential(cloud_environment=cloud_environment)
|
||||
+ try:
|
||||
+ from azure.identity import ManagedIdentityCredential
|
||||
+ credentials = ManagedIdentityCredential(cloud_environment=cloud_environment)
|
||||
+ except ImportError:
|
||||
+ from msrestazure.azure_active_directory import MSIAuthentication
|
||||
+ credentials = MSIAuthentication(cloud_environment=cloud_environment)
|
||||
elif config.UseMSI:
|
||||
- from azure.identity import ManagedIdentityCredential
|
||||
- credentials = ManagedIdentityCredential()
|
||||
+ try:
|
||||
+ from azure.identity import ManagedIdentityCredential
|
||||
+ credentials = ManagedIdentityCredential()
|
||||
+ except ImportError:
|
||||
+ from msrestazure.azure_active_directory import MSIAuthentication
|
||||
+ credentials = MSIAuthentication()
|
||||
elif cloud_environment:
|
||||
try:
|
||||
# try to use new libraries ClientSecretCredential (azure.identity, based on azure.core)
|
||||
@@ -337,12 +345,19 @@ def get_azure_compute_client(config):
|
||||
credentials = get_azure_credentials(config)
|
||||
|
||||
if cloud_environment:
|
||||
- compute_client = ComputeManagementClient(
|
||||
- credentials,
|
||||
- config.SubscriptionId,
|
||||
- base_url=cloud_environment.endpoints.resource_manager,
|
||||
- credential_scopes=[cloud_environment.endpoints.resource_manager + "/.default"]
|
||||
- )
|
||||
+ try:
|
||||
+ compute_client = ComputeManagementClient(
|
||||
+ credentials,
|
||||
+ config.SubscriptionId,
|
||||
+ base_url=cloud_environment.endpoints.resource_manager,
|
||||
+ credential_scopes=[cloud_environment.endpoints.resource_manager + "/.default"]
|
||||
+ )
|
||||
+ except TypeError:
|
||||
+ compute_client = ComputeManagementClient(
|
||||
+ credentials,
|
||||
+ config.SubscriptionId,
|
||||
+ base_url=cloud_environment.endpoints.resource_manager
|
||||
+ )
|
||||
else:
|
||||
compute_client = ComputeManagementClient(
|
||||
credentials,
|
||||
@@ -357,12 +372,19 @@ def get_azure_network_client(config):
|
||||
credentials = get_azure_credentials(config)
|
||||
|
||||
if cloud_environment:
|
||||
- network_client = NetworkManagementClient(
|
||||
- credentials,
|
||||
- config.SubscriptionId,
|
||||
- base_url=cloud_environment.endpoints.resource_manager,
|
||||
- credential_scopes=[cloud_environment.endpoints.resource_manager + "/.default"]
|
||||
- )
|
||||
+ try:
|
||||
+ network_client = NetworkManagementClient(
|
||||
+ credentials,
|
||||
+ config.SubscriptionId,
|
||||
+ base_url=cloud_environment.endpoints.resource_manager,
|
||||
+ credential_scopes=[cloud_environment.endpoints.resource_manager + "/.default"]
|
||||
+ )
|
||||
+ except TypeError:
|
||||
+ network_client = NetworkManagementClient(
|
||||
+ credentials,
|
||||
+ config.SubscriptionId,
|
||||
+ base_url=cloud_environment.endpoints.resource_manager
|
||||
+ )
|
||||
else:
|
||||
network_client = NetworkManagementClient(
|
||||
credentials,
|
@ -59,7 +59,7 @@
|
||||
Name: fence-agents
|
||||
Summary: Set of unified programs capable of host isolation ("fencing")
|
||||
Version: 4.10.0
|
||||
Release: 18%{?alphatag:.%{alphatag}}%{?dist}
|
||||
Release: 20%{?alphatag:.%{alphatag}}%{?dist}
|
||||
License: GPLv2+ and LGPLv2+
|
||||
URL: https://github.com/ClusterLabs/fence-agents
|
||||
Source0: https://fedorahosted.org/releases/f/e/fence-agents/%{name}-%{version}.tar.gz
|
||||
@ -220,21 +220,20 @@ Patch3: ha-cloud-support-google.patch
|
||||
Patch4: ha-openstack-support.patch
|
||||
Patch5: bundled-pexpect.patch
|
||||
Patch6: bundled-suds.patch
|
||||
Patch7: bz2010652-fence_azure_arm-fix-sovereign-cloud-msi-support.patch
|
||||
Patch8: bz2010709-1-fence_amt_ws-fix-or-causing-dead-code.patch
|
||||
Patch9: bz2010709-2-fence_amt_ws-boot-option.patch
|
||||
Patch10: bz2000954-1-configure-fix-virt.patch
|
||||
Patch11: bz2000954-2-fence_kubevirt.patch
|
||||
Patch12: bz2022334-fence_zvmip-add-ssl-tls-support.patch
|
||||
Patch13: bz2029791-1-fence_openstack-add-ssl-insecure.patch
|
||||
Patch14: bz2029791-2-fence_openstack-cacert-default.patch
|
||||
Patch15: bz2000954-3-fence_kubevirt-get-namespace-from-context.patch
|
||||
Patch16: bz2041933-bz2041935-1-fence_openstack-clouds-openrc.patch
|
||||
Patch17: bz2041933-bz2041935-2-fence_openstack-clouds-openrc.patch
|
||||
Patch18: bz2042496-fence_ibm_vpc-fence_ibm_powervs.patch
|
||||
Patch19: bz2022334-fence_zvmip-add-disable-ssl.patch
|
||||
Patch7: bz2010709-1-fence_amt_ws-fix-or-causing-dead-code.patch
|
||||
Patch8: bz2010709-2-fence_amt_ws-boot-option.patch
|
||||
Patch9: bz2000954-1-configure-fix-virt.patch
|
||||
Patch10: bz2000954-2-fence_kubevirt.patch
|
||||
Patch11: bz2022334-fence_zvmip-add-ssl-tls-support.patch
|
||||
Patch12: bz2029791-1-fence_openstack-add-ssl-insecure.patch
|
||||
Patch13: bz2029791-2-fence_openstack-cacert-default.patch
|
||||
Patch14: bz2000954-3-fence_kubevirt-get-namespace-from-context.patch
|
||||
Patch15: bz2041933-bz2041935-1-fence_openstack-clouds-openrc.patch
|
||||
Patch16: bz2041933-bz2041935-2-fence_openstack-clouds-openrc.patch
|
||||
Patch17: bz2042496-fence_ibm_vpc-fence_ibm_powervs.patch
|
||||
Patch18: bz2022334-fence_zvmip-add-disable-ssl.patch
|
||||
|
||||
%global supportedagents amt_ws apc apc_snmp bladecenter brocade cisco_mds cisco_ucs compute drac5 eaton_snmp emerson eps evacuate hpblade ibmblade ibm_powervs ifmib ilo ilo_moonshot ilo_mp ilo_ssh intelmodular ipdu ipmilan kdump kubevirt lpar mpath redfish rhevm rsa rsb sbd scsi vmware_rest vmware_soap wti
|
||||
%global supportedagents amt_ws apc apc_snmp bladecenter brocade cisco_mds cisco_ucs compute drac5 eaton_snmp emerson eps evacuate hpblade ibmblade ibm_powervs ibm_vpc ifmib ilo ilo_moonshot ilo_mp ilo_ssh intelmodular ipdu ipmilan kdump kubevirt lpar mpath redfish rhevm rsa rsb sbd scsi vmware_rest vmware_soap wti
|
||||
%ifarch x86_64
|
||||
%global testagents virsh heuristics_ping aliyun aws azure_arm gce openstack virt
|
||||
%endif
|
||||
@ -357,12 +356,11 @@ BuildRequires: %{systemd_units}
|
||||
%patch11 -p1
|
||||
%patch12 -p1
|
||||
%patch13 -p1
|
||||
%patch14 -p1
|
||||
%patch15 -p1 -F2
|
||||
%patch16 -p1 -F1
|
||||
%patch14 -p1 -F2
|
||||
%patch15 -p1 -F1
|
||||
%patch16 -p1
|
||||
%patch17 -p1
|
||||
%patch18 -p1
|
||||
%patch19 -p1
|
||||
|
||||
# prevent compilation of something that won't get used anyway
|
||||
sed -i.orig 's|FENCE_ZVM=1|FENCE_ZVM=0|' configure.ac
|
||||
@ -962,6 +960,18 @@ Fence agent for IBM PowerVS that are accessed via REST API.
|
||||
%{_sbindir}/fence_ibm_powervs
|
||||
%{_mandir}/man8/fence_ibm_powervs.8*
|
||||
|
||||
%package ibm-vpc
|
||||
License: GPLv2+ and LGPLv2+
|
||||
Group: System Environment/Base
|
||||
Summary: Fence agent for IBM Cloud VPC
|
||||
Requires: fence-agents-common = %{version}-%{release}
|
||||
BuildArch: noarch
|
||||
%description ibm-vpc
|
||||
Fence agent for IBM Cloud VPC that are accessed via REST API.
|
||||
%files ibm-vpc
|
||||
%{_sbindir}/fence_ibm_vpc
|
||||
%{_mandir}/man8/fence_ibm_vpc.8*
|
||||
|
||||
%package ifmib
|
||||
License: GPLv2+ and LGPLv2+
|
||||
Summary: Fence agent for devices with IF-MIB interfaces
|
||||
@ -1442,6 +1452,10 @@ are located on corosync cluster nodes.
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Wed Mar 9 2022 Oyvind Albrigtsen <oalbrigt@redhat.com> - 4.10.0-20
|
||||
- fence_ibm_vpc: new fence agent
|
||||
Resolves: rhbz#2060562
|
||||
|
||||
* Fri Feb 11 2022 Oyvind Albrigtsen <oalbrigt@redhat.com> - 4.10.0-18
|
||||
- fence_zvmip: add SSL/TLS support
|
||||
Resolves: rhbz#2022334
|
||||
@ -1467,10 +1481,6 @@ are located on corosync cluster nodes.
|
||||
- fence_amt_ws: fix "or" causing dead code
|
||||
Resolves: rhbz#2010709
|
||||
|
||||
* Tue Oct 5 2021 Oyvind Albrigtsen <oalbrigt@redhat.com> - 4.10.0-10
|
||||
- fence_azure_arm: fix sovereign cloud and MSI support
|
||||
Resolves: rhbz#2010652
|
||||
|
||||
* Tue Aug 31 2021 Oyvind Albrigtsen <oalbrigt@redhat.com> - 4.10.0-9
|
||||
- Only build fence-virt subpackages for x86_64 arch
|
||||
Resolves: rhbz#1965988
|
||||
|
Loading…
Reference in New Issue
Block a user